The Apache service named reported the following error:
>>> (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address [::]:80 .

WAMPSERVER on windows 8 not starting

Okay, I figured out: my machine's port 80 was being used by IIS, not by Skype. Here is how I found that:

Left-click the WAMPManager icon to reveal the menu. Click Apache ► Service ► Test port 80. This will launch a command window and display some information about what, if anything is using port 80. You can find more details at http://forum.wampserver.com/read.php?2,122527.

Configure Apache to listen on different port
Since I wanted to keep running IIS on the port 80, I decided to run my WAMP Server on a different port. So here is how I did it.

I had to change http.conf file which in my case is in folder C:/WAMP/bin/apache/apache2.4.9/conf/. Open it (with Notepad for example) and search for 80. I had to change the following three lines on different places:

Listen 0.0.0.0:80         # Changed to Listen 0.0.0.0:81
Listen [::0]:80 # Changed to Listen [::0]:81
ServerName localhost:80 # Changed toServerName localhost:81

Now I have got the green icon of WAMP Server on Windows 8.

More details on http://forum.wampserver.com/read.php?2,13744.

C:\wamp64\bin\apache\apache2.4.39\conf\httpd.conf  修改这个文件中的配置。

http://localhost:81/index.php

http://localhost:81/adminer/adminer-4.7.1.php

http://localhost:81/phpmyadmin/

http://localhost:81/phpsysinfo/index.php?disp=bootstrap

Deploy and Run Your Web Apps using WAMP Server

  • Copy the project and paste it to C:\wamp64\www [If you have installed WAMP for 32 bit system, you need to copy the projects to C:\wamp32\www ].
  • Here my project folder name is sample. So I am copying folder ‘sample‘ to the www folder in WAMP installation directory.
  • Now open your browser. Type localhost/sample/ in the address bar to run the project [Replace sample with your project folder name ].

WAMPSERVER php的更多相关文章

  1. 安装wampserver时提示丢失MSVCR110.dll(在windows server上可用)

    对于32位系统,安装Wampserver 后启动的时候提示系统错误:MSVCR110.dll丢失. 于是卸载原来的WAMPSERVER .安装vcredist_x86.exe,重新安装WAMPSERV ...

  2. wampserver与 thinkphp 安装

    1.下载安装wampserver 2.设置phpmyadmin用户密码(首次密码是空的,所以需要重新设置) 设置密码 1.安装成功后,通过 phpmyadmin 进入mysql,点击上面的 [用户] ...

  3. 安装WampServer时出现的问题(丢失VCRUNTIME140.dll或MSVCR110.dll)以及解决办法

    今天,在安装WampServer时,刚开始提示了"丢失VCRUNTIME140.dll"的问题. 我就网上查了一下,结果大家说是没有安装VC++,然后我就按照网友们提供的网址去下载 ...

  4. 安装wampserver遇到,无法启动此程序,丢失MSVCR110.dll

    这个问题遇到多次了,根据网上的解决办法,下载这个动态链接库文件,安装到指定位置重启系统后还是解决不了,其实这个文件有时候是存在的也会出现这个问题.问题截图如下 其实这个我认为是系统缺少了相关组组件的安 ...

  5. wampserver解决“不能切换在线”及运行“404问题”

    初次安装使用wampserver2.2,由于各个电脑安装的应用或是电脑型号不一样会出现以下问题: 1.安装后,不能出切换“服务器在线”或是“服务器离线” 2.设置站点后,运行编写好的代码出现404错误 ...

  6. php安装的一点点事 ---wampserver

    安装wampserver后,需要配置一些文件 1. 首先修改httpd.conf <Directory /> Options FollowSymLinks AllowOverride No ...

  7. 跟我学PHP第二篇- 配置Mysql以及PHP WampServer篇(1)

    大家好,昨天我给大家介绍了如何去安装ZEND STUDIO,下面昨天文章的链接: http://www.cnblogs.com/kmsfan/p/zendStudio.html 本节为配置的第一部分, ...

  8. WAMPServer安装和配置

    1. 下载地址:  www.wampserver.com    www.php100.com 本机下载在 安装在 2. 自定义网站根目录 设置到这里 访问localhost就会访问到自定义的目录了假设 ...

  9. wampserver安装配置

    按步骤安装--选择指定浏览器-安装成功后显示绿色图标: 打开浏览器:将文件夹移入wampserver安装路径的www文件夹中:找到电脑IP 在手机端访问 IP/文件夹/demo.html即可

  10. WampServer 的phpmyadmin数据

    WampServer首次安装的时候phpmyadmin的密码是为空 设置密码 1.安装成功后,通过 phpmyadmin 进入mysql,点击上面的 [用户] 菜单,在用户[root]主机[local ...

随机推荐

  1. MySQL explain,type分析(转)

    问题:explain结果中的type字段代表什么意思? MySQL的官网解释非常简洁,只用了3个单词:连接类型(the join type).它描述了找到所需数据使用的扫描方式. 最为常见的扫描方式有 ...

  2. easyui 前端分页及前端查询

    1.静态分页核心方法 // 前端分页 -- 将datagrid的loadFilter属性设置为这个方法名即可 function partPurchasePagerFilter(data) { if ( ...

  3. Delphi XE2_XE3 Update

    Delphi 和 C++Builder XE2 更新摘要 XE2的关键特性如下: 1. FireMonkey Application Platform支持运行在Windows (32和64位),Mac ...

  4. C++的同名属性(没有虚拟属性)、同名普通函数、同名静态函数(没有虚拟静态函数),是否被覆盖

    例子1:属性的覆盖#include "stdafx.h" class A {public: int i; A() { i=1; }}; class B: public A {pub ...

  5. [IIS]修改MaxFieldLength与MaxRequestBytes彻底解决Request Too Long的问题

    当 IIS7/7.5 收到的请求头的长度超过16K(默认值),就会引发"Bad Request - Request Too Long. HTTP Error 400. The size of ...

  6. ln -在文件之间建立连接

    总览 ln [options] source [dest] ln [options] source...directory POSIX 选项: [-f] GNU 选项(缩写): [-bdfinsvF] ...

  7. 神经网络训练技巧:训练参数初始化、Drop out及Batch Normalization

    参数初始化: xavier初始化: https://blog.csdn.net/VictoriaW/article/details/73000632 条件:优秀的初始化应该使得各层的激活值和梯度的方差 ...

  8. 【串线篇】spring boot嵌入式Servlet容器启动原理;

    什么时候创建嵌入式的Servlet容器工厂?什么时候获取嵌入式的Servlet容器并启动Tomcat: 获取嵌入式的Servlet容器工厂: 1).SpringBoot应用启动运行run方法 2).r ...

  9. Eclipse Debug模式的开启与关闭问题简析_java - JAVA

    文章来源:嗨学网 敏而好学论坛www.piaodoo.com 欢迎大家相互学习 默认情况下,eclipse中右键debug,当运行到设置的断点时会自动跳到debug模式下.但由于我的eclipse环境 ...

  10. [原创]PHP代码修正之CodeSniffer

    目录 参考链接 介绍 安装 使用 命令行模式 PHPStorm 让编辑器使用PSR-2标准 集成phpcbf 参考链接 PHP开发规范之使用phpcbf脚本自动修正代码格式 在PhpStorm中使用P ...