Kylin安装,基于版本1.6.0,Kylin只有单机没有集群,

使用apache-kylin-1.6.0-hbase1.x-bin.tar.gz安装包。

1.安装规划

角色规划 IP/机器名 安装软件 运行进程
Kylin zdh-9 Kylin Kylin

2.安装依赖

Hadoop: 2.4+

Hive: 0.13+

HBase: 0.98+, 1.x

JDK: 1.7+

3.当前安装依赖的环境

Hadoop: hdfs/zdh1234 集群:zdh-7,zdh-9,zdh-11 版本:hadoop-2.7.1

Hive: hive/zdh1234 单机:zdh-9 版本:hive-2.1.0

Hbase: hbase/zdh1234 集群:zdh-7,zdh-9,zdh-11 版本:hbase-1.1.5

Jdk: root/zdh1234 单机:zdh-9 版本:jdk1.7.0_80

说明:Hive使用Mysql存放元数据

4.安装用户

kylin/zdh1234

useradd -g hadoop -s /bin/bash -md /home/kylin kylin

5.获取并且解压安装包

Kylin Download

tar -zxvf apache-kylin-1.6.0-hbase1.x-bin.tar.gz

6.设置Kylin的环境变量

export JAVA_HOME=/usr/java/jdk1.7.0_80
export PATH=$PATH:$JAVA_HOME/bin
export CLASSPATH=.:$JAVA_HOME/jre/lib/rt.jar:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar export KYLIN_HOME=/home/kylin/apache-kylin-1.6.0-hbase1.x-bin
export PATH=$PATH:$KYLIN_HOME/bin export HADOOP_HOME=/home/hdfs/hadoop-2.7.1
export PATH=$HADOOP_HOME/bin:$HADOOP_HOME/sbin:$PATH export HBASE_HOME=/home/hbase/hbase-1.1.5
export PATH=$PATH:$HBASE_HOME/bin export HIVE_HOME=/home/hive/apache-hive-2.1.0-bin
export HIVE_CONF=$HIVE_HOME/conf
export HCAT_HOME=$HIVE_HOME/hcatalog
export PATH=$PATH:$HIVE_HOME/bin

7.检查安装环境

执行如下命令,查看是否满足Kylin的安装依赖:

check-env.sh

kylin需要对hdfs,hbase,hive的执行权限,

如果没有,需要新增权限,包括下面的子目录:

chmod -R g+rwx hive/
drwx------. 4 kylin hadoop 4096 4月 12 15:03 kylin
drwxr-x---. 5 hbase hadoop 4096 4月 12 13:37 hbase
drwxr-x---. 9 hdfs hadoop 4096 4月 12 13:36 hdfs
drwxr-xr-x. 5 hive hadoop 4096 4月 12 14:51 hive

特别的,kylin对于hive目录还需要写权限。

8.启动Kylin

kylin.sh start

停止kylin

kylin.sh stop

9.登陆Kylin的Web页面

http://zdh-9:7070/kylin

用户名密码 ADMIN/KYLIN

10.使用Kylin自带cube示例验证

10.1

执行sample.sh,并且重启kylin。

10.2

登陆web页面,选中learn_kylin工程,

构建cube,选中Models的kylin_sales_cube, 点击Actions -> Build

在monitor页面下查看构建进度,达到100%即可。

10.3

在Insight页面下执行sql查询:

select part_dt, sum(price) as total_selled, count(distinct seller_id) as sellers from kylin_sales group by part_dt order by part_dt

可以在hive里面执行上面的sql,比较查询花费的时间。

11.问题解决

11.1.无法访问Hadoop JobHistory

java.io.IOException: java.net.ConnectException: Call From master/192.168.182.100 to 0.0.0.0:10020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see:  http://wiki.apache.org/hadoop/ConnectionRefused

在zdh-9上面的hdfs用户下配置Hadoop jobhistory启动即可

11.2.安全检查失败

org.apache.hadoop.hbase.DoNotRetryIOException: org.apache.hadoop.hbase.DoNotRetryIOException: java.net.UnknownHostException: gagcluster Set hbase.table.sanity.checks to false at conf or table descriptor if you want to bypass sanity checks

修改hbase-site.xml文件中的配置项

hbase.table.sanity.checks的值为false:

<property>
<name>hbase.table.sanity.checks</name>
<value>false</value>
</property>

将hadoop的配置文件core-site.xml和hdfs-site.xml拷贝到hbase的conf目录下启动正常

11.3.hbase拷贝报错

Caused by: java.lang.IllegalArgumentException: Wrong FS: hdfs://gagcluster/kylin/kylin_metadata/kylin-ec90975d-2af0-4d06-a8c5-8d31b80b77a9/kylin_sales_cube/hfile/F2/7c91c1e5e24547bcbe2a8791c7b96861, expected: hdfs://10.43.159.7:9000

修改hbase-site.xml的配置项如下:

<property>
<name>hbase.rootdir</name>
<value>hdfs://gagcluster/hbase</value>
</property>

11.4.Kylin无法启动

报错,一些表找不到

然后发现hbase启动异常

使用habse shell命令list表,失败

发现hbase有异常日志,有一个节点由于时间不同步无法启动,

把集群时间同步之后在重新启动即可。

12.参考文章

Kylin Installation Guide

Kylin安装Version1.6.0的更多相关文章

  1. Kafka集群安装Version1.0.1(自带Zookeeper)

    1.说明 Kafka集群安装,基于版本1.0.1, 使用kafka_2.12-1.0.1.tgz安装包, 其中2.12是编译工具Scala的版本. 而且不需要另外安装Zookeeper服务, 使用Ka ...

  2. Storm集群安装Version1.0.1开启Kerberos

    Storm集群安装,基于版本1.0.1, 同时开启Kerberos安全认证, 使用apache-storm-1.0.1.tar.gz安装包. 1.安装规划 角色规划 IP/机器名 安装软件 运行进程 ...

  3. 分布式大数据多维分析(OLAP)引擎Apache Kylin安装配置及使用示例【转】

    Kylin 麒麟官网:http://kylin.apache.org/cn/download/ 关键字:olap.Kylin Apache Kylin是一个开源的分布式分析引擎,提供Hadoop之上的 ...

  4. Apache Kylin安装部署

    0x01 Kylin安装环境 Kylin依赖于hadoop大数据平台,安装部署之前确认,大数据平台已经安装Hadoop, HBase, Hive. 1.1 了解kylin的两种二进制包 预打包的二进制 ...

  5. Hbase集群安装Version1.1.5

    Hbase集群安装,基于版本1.1.5, 使用hbase-1.1.5.tar.gz安装包. 1.安装说明 使用外部Zookeeper集群而非Hbase自带zookeeper, 使用Hadoop文件系统 ...

  6. CentOS 7.0编译安装Nginx1.6.0+MySQL5.6.19+PHP5.5.14

    准备篇: CentOS 7.0系统安装配置图解教程 http://www.osyunwei.com/archives/7829.html 一.配置防火墙,开启80端口.3306端口 CentOS 7. ...

  7. centos 7.0 编译安装php 7.0.3

    php下载页面 http://cn2.php.net/downloads.php 7.0.3多地区下载页面 http://cn2.php.net/get/php-7.0.3.tar.gz/from/a ...

  8. CentOS7 编译安装 nginx-1.10.0

    对于NGINX 支持epoll模型 epoll模型的优点 定义: epoll是Linux内核为处理大批句柄而作改进的poll,是Linux下多路复用IO接口select/poll的增强版本,它能显著的 ...

  9. 一、Ubuntu14.04下安装Hadoop2.4.0 (单机模式)

    一.在Ubuntu下创建hadoop组和hadoop用户 增加hadoop用户组,同时在该组里增加hadoop用户,后续在涉及到hadoop操作时,我们使用该用户. 1.创建hadoop用户组 2.创 ...

随机推荐

  1. Linux学习 - 权限管理命令

    一.chmod(change the permissions mode of a file) 1 功能 改变文件或目录权限 root 与 所有者 可进行此操作 2 语法 chmod  [(ugoa) ...

  2. When do we use Initializer List in C++?

    Initializer List is used to initialize data members of a class. The list of members to be initialize ...

  3. jQuery 的两种语法

    文档就绪事件(文档加载完成之后才执行jQuer代码): 第一种: $(document).ready(function() { // jQuery 代码.... }); 第二种: $(function ...

  4. Android系统编程入门系列之硬件交互——多媒体展示

    前两篇文章通过麦克风硬件和摄像头硬件分别采集音频和视频的多媒体数据,在得到的多媒体数据通常是以编码文件的格式存储,在用户需要展示时,可通过设备的内置扩音器或蓝牙耳机等硬件播放音频,通过设备的显示屏或外 ...

  5. [BUUCTF]REVERSE——[ACTF新生赛2020]Oruga

    [ACTF新生赛2020]Oruga 附件 步骤: 例行检查,64位程序,无壳 64位ida载入,检索字符串,根据提示来到关键函数 14行~18行就是让字符串的前5位是 actf{ ,sub_78A( ...

  6. Windows通过计划任务定时执行bat文件

    第一步 第二步 第三步 第四步 第五步 第六步

  7. 从K8S部署示例进一步理解容器化编排技术的强大

    概念 Kubernetes,也称为K8s,生产级别的容器编排系统,是一个用于自动化部署.扩展和管理容器化应用程序的开源系统.K8s是一个go语言开发,docker也是go语言开发,可见go语言的是未来 ...

  8. Java8 函数式接口 @FunctionalInterface以及常用Consumer<T>、Supplier<T>、Function<T, R>、Predicate<T>总结

    首先看看什么是Lambda 表达式 Lambda是一个匿名函数,我们可以把Lambda表达式理解为一段可以传递的代码(将代码像数据一样传递):最简单的Lambda表达式可由逗号分隔的参数列表.-> ...

  9. Vue2与Vue3的组件通讯对比

    Vue2 父传子 父传子比较简单, 主要通过以下步骤实现 父在template中为子绑定属性 <Child :childData='pMsg'/> <!-- 也可以写死 --> ...

  10. LuoguB2147 求 f(x,n) 题解

    Content 求给定 \(x,n\),求 \(f(x,n)=\sqrt{n+\sqrt{(n-1)+\sqrt{(n-2)+\sqrt{\dots+2+\sqrt{1+x}}}}}\) 的值. So ...