2011-01-05 12:44:42,144 ERROR org.apache.hadoop.mapred.TaskTracker: Can not start task tracker because java.lang.RuntimeException: Not a host:port pair: local

at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:136)

at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:123)

at org.apache.hadoop.mapred.JobTracker.getAddress(JobTracker.java:1807)

at org.apache.hadoop.mapred.TaskTracker.<init>(TaskTracker.java:905)

at org.apache.hadoop.mapred.TaskTracker.main(TaskTracker.java:2833)

需配置mapred.job.tracker属性,在hadoop-0.20.2\conf\ mapred-site.xml的configuration节点中配置(job-tracker host为jobTracker服务器的ip或域名)

<configuration>

<property>

                <name>mapred.job.tracker</name>

                <value>localhost:9101</value>

</property>

</configuration>

1、taskTracker和jobTracker 启动失败

2011-01-05 12:44:42,144 ERROR org.apache.hadoop.mapred.TaskTracker: Can not start task tracker because java.lang.RuntimeException: Not a host:port pair: local

at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:136)

at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:123)

at org.apache.hadoop.mapred.JobTracker.getAddress(JobTracker.java:1807)

at org.apache.hadoop.mapred.TaskTracker.<init>(TaskTracker.java:905)

at org.apache.hadoop.mapred.TaskTracker.main(TaskTracker.java:2833)

需配置mapred.job.tracker属性,在mapred-site.xml的configuration节点中配置(job-tracker host为jobTracker服务器的ip或域名)

<property>

<name>mapred.job.tracker</name>

<value>[job-tracker host]:9001</value>

</property>

2、namenode启动失败

STARTUP_MSG: build = https://svn.apache.org/repos/asf/hadoop/common/branches/branch-0.20 -r 911707; compiled by 'chrisdo' on Fri Feb 19 08:07:34 UTC 2010

************************************************************/

2011-02-28 15:54:29,719 ERROR org.apache.hadoop.hdfs.server.namenode.NameNode: java.lang.NullPointerException

at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:134)

at org.apache.hadoop.hdfs.server.namenode.NameNode.getAddress(NameNode.java:156)

at org.apache.hadoop.hdfs.server.namenode.NameNode.getAddress(NameNode.java:160)

at org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:175)

at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:279)

at org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:956)

at org.apache.hadoop.hdfs.server.namenode.NameNode.main(NameNode.java:965)

需配置fs.default.name属性,在core-site.xml的configuration节点中配置(namenode host为namenode服务器的ip或域名)

<property>

<name>fs.default.name</name>

<value>[namenode host]:9000</value>

</property>

3、hadoop运行需要地方存放一些临时文件,而数据量较大的时候,这些临时文件也会比较大,所以配置临时目录的时候要确定这些目录是否有足够的空间,如果没有指定目录,一般会放在/tmp这个目录下面。

一般需要指定的目录有:hadoop-env.sh里的export HADOOP_PID_DIR=;hdfs-site.xml里的dfs.name.dir和dfs.data.dir;core-site.xml里的hadoop.tmp.dir;mapred-site.xml里的mapred.system.dir、mapred.local.dir、mapred.tmp.dir。

4、分布式运行,查看日志是个非常郁闷的事情,一般的程序标准输出会放在与bin同级的logs目录下的userlogs下面,会有相当多的文件夹。可通过http://job-tracker host:port/jobdetails.jsp查看hadoop运行状况和日志,一般port为50030。

5、有时,当你申请到一个HOD集群后马上尝试上传文件到HDFS时,DFSClient会警告NotReplicatedYetException。通常会有一个如下报错信息。

org.apache.hadoop.ipc.RemoteException: java.io.IOException File /root/testdir/hadoop-default.xml could only be replicated to 0 nodes, instead of 1

at org.apache.hadoop.dfs.FSNamesystem.getAdditionalBlock(FSNamesystem.java:1123)

at org.apache.hadoop.dfs.NameNode.addBlock(NameNode.java:330)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

……

不幸的是我也遇到了这个报错,google了很久才找到一个解决方案:当你向一个DataNodes正在和NameNode联络的集群上传文件的时候,这种现象就会发生。在上传新文件到HDFS之前多等待一段时间就可以解决这个问题,因为这使得足够多的DataNode启动并且联络上了NameNode。

6、Error: Java heap space

mapred-site.xml中设置

<property>

<name>mapred.child.java.opts</name>

<value>-Xmx512m</value>

</property>

调整这个数字。

7、 Namenode in safe mode

解决方法

bin/hadoop dfsadmin -safemode leave

taskTracker和jobTracker 启动失败的更多相关文章

  1. JobTracker启动流程源码级分析

    org.apache.hadoop.mapred.JobTracker类是个独立的进程,有自己的main函数.JobTracker是在网络环境中提交及运行MR任务的核心位置. main方法主要代码有两 ...

  2. windows service 1053错误 启动失败

    做项目移植的时候发现一个项目的window service启动失败,最后试出来是启动时间超时 解决办法是给window service设置一个长一点的等待时间,步骤如下: 启动,输入regedit启动 ...

  3. 玩转Windows服务系列——无COM接口Windows服务启动失败原因及解决方案

    将VS创建的Windows服务项目编译生成的程序,通过命令行 “服务.exe -Service”注册为Windows服务后,就可以通过服务管理器进行管理了. 问题 通过服务管理器进行启动的时候,发现服 ...

  4. ubuntu升级内核后vmware-player启动失败

    在虚拟机软件中,vmware player是对硬件支持很好的,通过它可以很方便的使用网银.单片机开发等等工作.但是最近ubuntu每次升级内核后,vmware都会启动失败,提示:Before you ...

  5. CentOS 7下MySQL服务启动失败的解决思路

    今天,启动MySQL服务器失败,如下所示: [root@spark01 ~]# /etc/init.d/mysqld start Starting mysqld (via systemctl): Jo ...

  6. 服务器重启后SQL Server Agent由于"The EventLog service has not been started" 启动失败

    案例环境: 操作系统   : Microsoft Windows Server 2003 Standard Edtion SP2 数据库版本 : SQL Server 2005 Standard Ed ...

  7. db2start启动失败

    db2start启动失败 [db2inst1@localhost ~]$ db2start db2start: error while loading shared libraries: libaio ...

  8. PHP5.6启动失败

    PHP编译安装完毕,启动失败,提示 1 [23-Jun-2014 12:27:02] ERROR: failed to open configuration file '/usr/local/php/ ...

  9. IIs管理服务一直启动失败的原因之一

    首先eventlog里面的日志: 万维网发布服务(WWW 服务)没有为站点 1 注册 URL 前缀 https://*:8172/.该站点已被禁用.数据字段包含错误号. IISWMSVC_STARTU ...

随机推荐

  1. JavaScript CSS 等前端推荐

    推荐两个网站,JAVASCRIPT与前端相关,两边都可以玩,蛮方便的,然后全通后你拿个全英文版本的证书提升逼格. https://www.freecodecamp.org/ https://www.f ...

  2. noi.ac NOIP2018 全国热身赛 第四场 T2 sort

    [题解] 跟51nod 1105差不多. 二分答案求出第L个数和第R个数,check的时候再套一个二分或者用two pointers. 最后枚举ai在b里面二分,找到所有范围内的数,排序后输出. 注意 ...

  3. centos7 ftp 500 OOPS: cannot change directory:/var/ftp/xutong/

    在设置多用户登录的时候 该指定的用户xutong对于上级目录/var/ftp 没有访问权限 修改一下上级目录的权限 chmod /var/ftp 对于ftp多用户访问的配置修改也做一个记录 以是设置F ...

  4. 优化子查询sql语句为内连接

    背景: 希望提高查询的效率,从sql语句中频繁出现的子查询入手. 数据表如下:Student表中的CityCode对应于City表中的Code. Student表:                   ...

  5. UVALive 2957 Bring Them There

    Bring Them There Time Limit: 3000ms Memory Limit: 131072KB This problem will be judged on UVALive. O ...

  6. POJ-1067取石子游戏,威佐夫博弈范例题/NYOJ-161,主要在于这个黄金公式~~

    取石子游戏 Time Limit: 1000MS   Memory Limit: 10000K              Description 有两堆石子,数量任意,可以不同.游戏开始由两个人轮流取 ...

  7. 哀悼改变全站颜色为灰色CSS代码收藏

    <style type="text/css">   *{       filter:progid:DXImageTransform.Microsoft.BasicIma ...

  8. SQL SERVER 2012 第三章 使用INSERT语句添加数据

    INSERT [TOP (<expression>) [PERCENT] [INTO] <tabular object>[(column list)][OUTPUT <o ...

  9. zoj4028 LIS

    差分约束瞎搞一下,话说这个数据不知道怎么回事,我的图按道理而言最多只有4n条边,开5n还不够??必须6n?? 约束条件首先根据f函数可建立两点之间的约束,不妨设d[i]为i到0的距离,则对于f[i] ...

  10. PostgreSQL 9.3.1 中文手册(解决关键词报错的问题)

    http://www.postgres.cn/docs/9.3/sql-keywords-appendix.html