近日,给一台Windows 2016上的vCenter打补丁,系统重启后,发现vmware的很多服务无法启动了。这是一台老版本的vcenter,虽然已经2021年了,但是它还管理着一些很老的ESX,比如ESX5.5的系统。所以,还是需要6.0的vCenter。

发现VMware Component Manager反复再启动,然后失败。检查了vmware服务的依赖关系,很多服务都是最终依赖于VMware Component Manager服务的,必须它先启动,其它服务才能启动。因为更新了 Windows补丁,SQL server补丁。还是感觉补丁不太可能造成这些问题的。因为vmware其实是运行在自己的python环境和java环境里的,Windows系统日志确实也看不出什么有用的信息,只是告诉你有个服务没有能在超时时间内启动。

在网上查了一些文章,其中有一篇提到,可以用certificate-manager命令重新生成全部证书,certificate-manager的位置在vcenter的安装路径下的vmcad目录里。

D:\Program Files\VMware\vCenter Server\vmcad

选择4,重新生成证书并替换所有证书。但是结果是失败,提示查看日志文件获取更多信息。日志文件位置在D:\ProgramData\VMware\vCenterServer\logs\vmca\certificate-manager.log

最后部分的内容如下:

2021-04-20T05:17:11.105Z INFO certificate-manager Command output :- 
 Entry with alias [vpxd-extension] in store [vpxd-extension] was created successfully

https://www.cnblogs.com/qishine/p/14721100.html

2021-04-20T05:17:11.105Z INFO certificate-manager Command executed successfully
2021-04-20T05:17:11.105Z INFO certificate-manager Running command : ['D:\\Program Files\\VMware\\vCenter Server\\python\\python.exe', 'D:\\Program Files\\VMware\\vCenter Server\\vpxd\\scripts\\updateExtensionCertInVC.py', '-e', 'com.vmware.vim.eam', '-c', 'D:\\ProgramData\\VMware\\vCenterServer\\data\\certmanager\\rollback\\vpxd-extension_bkp.crt', '-k', 'D:\\ProgramData\\VMware\\vCenterServer\\data\\certmanager\\rollback\\vpxd-extension_bkp.priv', '-u', 'administrator@vsphere.local', '-p', '*****']
2021-04-20T05:17:14.269Z INFO certificate-manager Command output :- 
 2021-04-20T05:17:11.717Z   Updating certificate for "com.vmware.vim.eam" extension

2021-04-20T05:17:14.275Z ERROR certificate-manager 2021-04-20T05:17:11.717Z   Updating certificate for "com.vmware.vim.eam" extension

2021-04-20T05:17:14.278Z INFO certificate-manager Error while reverting certificate for store : vpxd-extension
2021-04-20T05:17:14.279Z ERROR certificate-manager Error while reverting certificate for store : vpxd-extension
2021-04-20T05:17:14.280Z ERROR certificate-manager please see D:\ProgramData\VMware\vCenterServer\logs\vmca\certificate-manager.log for more information.

可以看到在处理vpxd-extension证书的时候遇到了问题。

经过查看,发现是服务器证书过期了,将服务器时间改到证书失效前,然后再通过 certificate-manager生成证书并替换(选择4或者8),

全部成功后,发现服务可以启动,vsphere client可以连接。但是发现提示Update Manager报错,还是证书相关。可能要换Update Manager的证书。

但是在Update Manager的证书路径下D:\Program Files (x86)\VMware\Infrastructure\Update Manager\SSL查看rui.crt发现证书有效期是10年的,并没有过期。将服务器时间改到当前,发现vsphere client无法登录,提示用户名密码错误。

经过查找,发现是STS的证书过期,可以重新生成一下。

vmware官方给出了重新生成证书的步骤,

https://docs.vmware.com/en/VMware-vSphere/6.0/com.vmware.vsphere.security.doc/GUID-F9A0CA06-8875-4A66-BBBA-DB0C0143B5AE.html

D:\ProgramData\VMware\vCenterServer\cfg\sso\keys

按照步骤重新生成了证书,但是更新STS证书的时候还是失败了

检查日志

D:\ProgramData\VMware\vCenterServer\runtime\VMwareSTSService\logs\ssoAdminServer.log

但是无法找到更多的解决方案了。无奈,重装一台VCSA的版本。只是VCSA需要另外配合Windows版本的Update Manager.

VMware Component Manager服务无法启动的更多相关文章

  1. 解决VMWARE NAT SERVICE服务无法启动或服务消失的问题

    解决VMWARE NAT SERVICE服务无法启动或服务消失的问题 2016-02-02 11:18 2012人阅读 评论(2) 收藏 举报  分类: 网络通信(3)  今日使用VMware中的Wi ...

  2. VMware DHCP Service服务无法启动问题的解决

    我的电脑出现VMware DHCP Service和VMware NAT Service两个服务无法启动的问题: 打开VMware主界面,菜单->编辑->虚拟网络编辑器: 勾选上“将主机虚 ...

  3. arcgis license manager 10.2服务无法启动

    (步骤)1. 用cmd切换到 license manager 安装目录,如 C:\Program Files (x86)\ArcGIS\License10.2\bin,输入: Lmgrd -z -c ...

  4. VMware Host Agent服务不能正常启动

    VMware Host Agent服务不能正常启动 原因及解决方法 一直都在用VMWare Server 2.0,其他都还好,就是隔三差五的会有些小问题,比如VMware Host Agent服务不能 ...

  5. Windows无法启动 VMware Workstation server服务解决方法

    Windows无法启动VMware Workstation server服务, 可以通过删除datastores.xml文件来解决. 具体操作步骤如下: 1.在系统盘目录下,找到C:\ProgramD ...

  6. vmware无法安装vmware authorization&windows无法启动VMware Authorization Service服务

    在vmware安装过程中或更新时,时常遇到vmware无法安装vmware authorization&windows无法启动VMware Authorization Service服务的情况 ...

  7. windows 本地链接 VMware虚拟机 redis服务

    使用本地Windows链接 VMware虚拟机 redis服务 我用的虚拟机系统是:windows Server 2012 先把Redis服务器拷贝到服务器并解压,目录如下 这里仅仅作为演示,所以就不 ...

  8. zookeeper源码分析之一服务端启动过程

    zookeeper简介 zookeeper是为分布式应用提供分布式协作服务的开源软件.它提供了一组简单的原子操作,分布式应用可以基于这些原子操作来实现更高层次的同步服务,配置维护,组管理和命名.zoo ...

  9. MSSQLSERVER服务无法启动的解决方案

    MSSQLSERVER服务无法启动的解决方案 有时候sqlserver无法启动了,原因是mssqlserver服务没有启动,当你手动启动时,又出现服务无法响应的可恶错误提示... 笔者“有幸”遇到了, ...

随机推荐

  1. Spring Boot:整合Swagger

    1.先创建一个SpringBoot项目 其中application.properties文件中是创建项目时自动添加的配置. 2.添加相关maven依赖 <!--swagger--> < ...

  2. Netty 如何高效接收网络数据?一文聊透 ByteBuffer 动态自适应扩缩容机制

    本系列Netty源码解析文章基于 4.1.56.Final版本,公众号:bin的技术小屋 前文回顾 在前边的系列文章中,我们从内核如何收发网络数据开始以一个C10K的问题作为主线详细从内核角度阐述了网 ...

  3. Node.js精进(9)——性能监控(上)

    市面上成熟的 Node.js 性能监控系统,监控的指标有很多. 以开源的 Easy-Monitor 为例,在系统监控一栏中,指标包括内存.CPU.GC.进程.磁盘等. 这些系统能全方位的监控着应用的一 ...

  4. 常用Linux音译

    su:Swith user 切换用户,切换到root用户 cat: Concatenate 串联 uname: Unix name 系统名称 df: Disk free 空余硬盘 du: Disk u ...

  5. Hash 哈希表和算法思路详解

    概述 哈希表是一种可以满足快速查找数据结构,时间复杂度接近O(1). 哈希函数是无限集到有限集的映射. 处理数据量大,查找效率要求高时推荐使用hash容器. 问题: 什么情况下考虑使用哈希容器? 常用 ...

  6. MQ系列2:消息中间件的技术选型

    1 背景 在高并发.高消息吞吐的互联网场景中,我们经常会使用消息队列(Message Queue)作为基础设施,在服务端架构中担当消息中转.消息削峰.事务异步处理 等职能. 对于那些不需要实时响应的的 ...

  7. element多重校验报please transfer a valid prop path to form item

  8. 一步一步在angular11中添加多语言支持

    1.新建angular 2.添加@angular/localize ng add @angular/localize 3.设置默认locale_id,在app.module.ts中 import { ...

  9. CF Round #805 (Div. 3) 题解

    A 直接模拟即可,注意 \(10^k\) 的情况(罚时!罚时!罚时!). A Code using namespace std; typedef long long ll; typedef pair& ...

  10. 使用flex弹性布局代替传统浮动布局来为微信小程序写自适应页面

    原文转载自「刘悦的技术博客」https://v3u.cn/a_id_109 我们知道,写习惯了前端的人,一般切图后布局页面的话,上手最习惯的是基于盒子模型的浮动布局,依赖 display 属性 + p ...