atitit.故障排除--- 当前命令发生了严重错误。应放弃任何可能产生的结果sql server 2008

1. 现象 1

2. 原因:::sql server的bug 或者限制,查询的时候儿使用资源太多超过操作系统/防火墙/安全软件的限制...
2

2.1. 防火墙/安全软件的原因:自动关闭了长时连接and 资源多的连接.. 2

2.2. 并发连接数超过了其承载量,服务器会将其中一些连接Down掉;
2

3. 解决之道:: 2

3.1. 打补丁sp 2

3.2. 使用top n /where 减少查询数量(attialx验证ok)
2

3.3. 提升电脑配置(推荐,,验证ok)
2

3.4. 查询字段添加索引 2

3.5. 减少select 大的字段查询..只select 小的字段
2

3.6. 修改某一字段的长度,或许是这个造成的.. 3

3.7. strSql和Param太多了,导致错误。
3

3.8. 在调用存储过程中未指明详细的数据类型.(据google结果说打了sp4才出现的,这就不知道了)
3

4. 参考 3

1. 现象

执行一个sql 语句的时候儿这个错误..代码韩式管理器黑头都是中个..

解决“当前命令发生了严重错误。应放弃任何可能产生的结果。”的问题

在从服务器接收结果时发生传输级错误。 (provider: 命名管道提供程序, error: 0 - 管道的另一端上无任何进程。)

当前命令发生了严重错误。应放弃任何可能产生的结果

常常还有conn 自动关闭的事情....socket close..

org.springframework.transaction.TransactionSystemException: Could not roll back Hibernate transaction; nested exception is org.hibernate.TransactionException: rollback failed

org.springframework.transaction.CannotCreateTransactionException: Could not open Hibernate Session for transaction; nested exception is org.hibernate.service.UnknownServiceException: Unknown service requested [org.hibernate.service.jdbc.connections.spi.ConnectionProvider]

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Connection reset by peer: socket write error

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: 该连接已关闭。

org.springframework.transaction.TransactionSystemException: Could not commit Hibernate transaction; nested exception is org.hibernate.TransactionException: commit failed

作者:: 老哇的爪子 Attilax 艾龙,  EMAIL:1466519819@qq.com

转载请注明来源: http://blog.csdn.net/attilax

2.  原因:::sql server的bug 或者限制,查询的时候儿使用资源太多超过操作系统/防火墙/安全软件的限制...

数据只有75w,查询的时候儿也这个错误.....

大概查询的时候儿内存使用太多...

但是mysql 相同的电脑上 相同的数据数量就没问题..

2.1. 防火墙/安全软件的原因:自动关闭了长时连接and 资源多的连接..

2.2. 并发连接数超过了其承载量,服务器会将其中一些连接Down掉;

3. 解决之道::

3.1. 打补丁sp

3.2. 使用top n /where 减少查询数量(attialx验证ok)

3.3. 提升电脑配置(推荐,,验证ok)

3.4. 查询字段添加索引

3.5. 减少select 大的字段查询..只select 小的字段

3.6. 修改某一字段的长度,或许是这个造成的..

估计是文章的长度太长导致的,于是查找到代码 db.AddInParameter(dbCommand, "Content", DbType.AnsiString, model.Content);

将其改为

db.AddInParameter(dbCommand, "Content", DbType.String, model.Content);

3.7. strSql和Param太多了,导致错误。

param for循环51 次即 2092 个就报错。

3.8. 在调用存储过程中未指明详细的数据类型.(据google结果说打了sp4才出现的,这就不知道了)

4. 参考

2014/11/25  11:23            22,212 异常请教:当前命令发生了严重错误。应放弃任何可能产生的结果.htm

2014/11/25  11:20           113,357 当前命令发生了严重错误。应放弃任何可能产生的结果.htm

2014/11/25  11:23            12,669 解决“当前命令发生了严重错误。应放弃任何可能产生的结果。”的问题 - Sam Lin - 博客园.htm

2014/11/25  11:20            42,875 解决问题 当前命令发生了严重错误。应放弃任何可能产生的结果 - wthorse的专栏 - 博客频道 - CSDN.NET.htm

atitit.故障排除--- 当前命令发生了严重错误。应放弃任何可能产生的结果sql server 2008的更多相关文章

  1. SqlException 当前命令发生了严重错误 应放弃任何可能产生的结果

    今天在信息发布功能时出现了一个怪异的错误(时而出错,时而不会): System.Data.SqlClient.SqlException: 当前命令发生了严重错误.应放弃任何可能产生的结果. >& ...

  2. atitit.故障排除------有时会错误com.microsoft.sqlserver.jdbc.SQLServerException: Connection reset by peer: soc

    atitit.故障排除------有时会错误com.microsoft.sqlserver.jdbc.SQLServerException: Connection reset by peer: soc ...

  3. Atitit.故障排除系列---php 程序网站数据库错误排除流程

    Atitit.故障排除系列---php 程序网站数据库错误排除流程 Php页面报告的错误不能定位到myusql的db配置上...字说是db conn err Mysql 接入错误...大概查看哈能不能 ...

  4. Atitit.故障排除系列---NoClassDefFoundError NoClassDefFoundError

    Atitit.故障排除系列---NoClassDefFoundError  NoClassDefFoundError java.lang.ClassNotFoundException找不到类异常.当应 ...

  5. Atitit.故障排除系列-----apache 不能启动的排除

    Atitit.故障排除系列-----apache 不能启动的排除 能直接使用cli启动httpd   ,,详细打印出信息.. C:\Users\ASIMO>"C:\wamp\apach ...

  6. Atitit.故障排除系列---NoClassDefFoundError  NoClassDefFoundError ClassNotFoundException

    Atitit.故障排除系列---NoClassDefFoundError  NoClassDefFoundError ClassNotFoundException 1. java.lang.Class ...

  7. Atitit.故障排除系列---php 计划网站数据库错误排除过程

    Atitit.故障排除系列---php 计划网站数据库错误排除过程 Php页面报告的错误不能定位到myusql的db配置上...字说是db conn err Mysql 接入错误...大概查看哈能不能 ...

  8. 利用Ring Buffer在SQL Server 2008中进行连接故障排除

    原文:利用Ring Buffer在SQL Server 2008中进行连接故障排除 出自:http://blogs.msdn.com/b/apgcdsd/archive/2011/11/21/ring ...

  9. SQL Server 2008性能故障排查(二)——CPU

    原文:SQL Server 2008性能故障排查(二)--CPU 承接上一篇:SQL Server 2008性能故障排查(一)--概论 说明一下,CSDN的博客编辑非常不人性化,我在word里面都排好 ...

随机推荐

  1. linux下批量添加新用户

    作为一个系统管理员,可能要经常的为机器添加用户,可能是在一台机器上添加很多用户,也有可能是在很多机器上要添加同一个用户. 基本上,批量添加用户有两种方式,一是用useradd + passwd命令配合 ...

  2. koa2搭建服务器+使用mongoose链接mangodb

    使用node搭建服务器,用到了现在比较流行的框架koa. 1.初始化package.json npm init -y 2.安装koa2 npm i koa --save 3.搭建服务器 const K ...

  3. OpenShift负载分区策略(Router Shading)

    在很多场景下,单靠几个在Infra节点上的Router进行服务请求的转发是不够的,项目中很多时候都有流量隔离的需求,主要场景在于: 一个集群中的不同的环境的流量隔离需求,比如开发走几个Router,生 ...

  4. 如何把rc.local里执行的shell脚本的日志内容放到其他位置

    rc.local的日志内容默认是/var/log/boot.log /etc/rc.d/rc.local文件的文件头是#!/bin/sh ,我们把这修改成#!/bin/sh -x,这样系统启动后就会把 ...

  5. OpenCV学习(14) 细化算法(2)

          前面一篇教程中,我们实现了Zhang的快速并行细化算法,从算法原理上,我们可以知道,算法是基于像素8邻域的形状来决定是否删除当前像素.还有很多与此算法相似的细化算法,只是判断的条件不一样. ...

  6. 关于OGRE与OSG的简单比较【转】

    关于OGRE与OSG的简单比较 林乃养 lnychina{at}gmail.com 浙江大学CAD&CG实验室 2010年3月27日 1 前言 我曾经细致阅读过OGRE和OSG官方提供的文档, ...

  7. 如何在Windows Server 2012 R2上安装SharePoint 2013

    笔者原以为是个挺容易个事儿, 毕竟是微软自家的产品安装在自家的操作系统上, 没想到还是让我费了半天劲.   写在这里吧, 方便其他的朋友.   具体步骤 ======================= ...

  8. 如何高效的将excel导入sqlserver?

    大部分人都知道用oledb来读取数据到dataset,但是读取之后怎么处理dataset就千奇百怪了.很多人通过循环来拼接sql,这样做不但容易出错而且效率低下,System.Data.SqlClie ...

  9. [ES6] 04. The let keyword -- 2 Fiald case

    Fiald case 1: let can work in it's block { let a = 10; var b = 1; } a // ReferenceError: a is not de ...

  10. linux查看CPU性能及工作状态的指令mpstat,vmstat,iostat,sar,top

    转载:http://www.cnblogs.com/xianghang123/archive/2011/08/25/2153591.html 衡量CPU性能的指标: 1,用户使用CPU的情况:CPU运 ...