rndc—使用说明

       rndc设置(本地)

产生/etc/rndc.key


    执行”rndc-confgen -a”指令后,会在/etc目录下产生rndc.key文件,

而所产生的文件内容如下图所示:

“algorithm hmac-md5”表示我们是使用”hmac-md5”算法來产生

”secret”每次执行都会产生不一样的”secret”。

产生/etc/rndc.conf文件

    

1.          执行上图指令后会在/etc目录下产生rndc.conf文件,将文件中secret置换成rndc.key的secret。置换后的文件内容如下:


  修改/etc/named.conf
  如rndc.conf文件后面的注解所示,在/etc/named.conf文件中加入


  检查 /var/log/messages
  重新启动Bind后,若在/var/log/messages中发现

则表示设定成功。

测试
  即表示之后便可以在本机端利用”rndc”command来控制管理Bind。例如: 
  

rndc后面接status参数可以展示出目前DNS server的相关信息,可以接的参数  可以由只输入”rndc”后面不加任何参数,执行后便会列出所有可以接的参数为何。

   rndc设置(远端)

   远端控制管理Bind的意思是在其他的电脑上通过 ”rndc” command 的方式来对远端的DNS server(Bind)做设定或是管理的动作,由于透过rndc的方式,所以能增加资料传送的安全性。

   在设定local端时,我们已产生rndc.key及rndc.conf,所以就继续沿用此2个文件。

修改/etc/named.conf
 在named.conf文件中加入
 

  allow{ any; }表示允許任何电脑连接到此电脑,inet 后面则接DNS server IP address。

检查 /var/log/messages
重新启动Bind后,若在/var/log/messages中发现

  即表示之后便可以在远端电脑利用”rndc”command来控制Bind。

 设定远端电脑的rndc.key及rndc.conf

将远端电脑中的rndc.key及rndc.conf文件中的secret设成与欲控制的 DNS server 中rndc.key之secret相同,如此才能控制远端DNS server。

测试


rndc –s 后面接DNS server IP address(domain name亦可)。执行后可列出远端DNS server相关信息。

BIND rndc—使用说明的更多相关文章

  1. std::bind 的使用说明

    转自: https://www.cnblogs.com/cmranger/p/4743926.html ///////////////////// std::bind bind是对C++98标准中函数 ...

  2. 第7章 DNS & bind从基础到深入

    本文目录: 7.1 DNS必懂基础 7.1.1 域的分类 7.1.2 主机名.域名.FQDN 7.1.3 域的分层授权 7.1.4 DNS解析流程 7.2 DNS术语 7.2.1 递归查询和迭代查询 ...

  3. Centos7 DNS神奇的配置

    文件 [root@iff etc]# cat /etc/named.conf // // named.conf // // Provided by Red Hat bind package to co ...

  4. linux-dns-11

    1网卡设置配置文件里面DNS服务器地址设置,2.系统默认DNS服务器地址设置.3,hosts文件指定 生效顺序是: 1 hosts文件 ---- 2 网卡配置文件DNS服务地址 ---3 /etc/r ...

  5. DNS BIND之rndc介绍及使用

    rndc(Remote Name Domain Controllerr)是一个远程管理bind的工具,通过这个工具可以在本地或者远程了解当前服务器的运行状况,也可以对服务器进行关闭.重载.刷新缓存.增 ...

  6. 使用BIND安装智能DNS服务器(二)---配置rndc远程控制

    首先两个BIND DNS服务器要正常运行.       主DNS服务器IP:192.168.1.100 客户机DNS服务器IP:192.168.1.101 1 主DNS端配置: cd /etc/ 生成 ...

  7. Bind 远程连接出现rndc: connect failed: 192.168.1.66#953: connection refused

    远程连接IP地址为192.168.1.66的BIND DNS服务器,出现 rndc: connect failed: 192.168.1.66#953: connection refused 原因:1 ...

  8. Bind 远程连接DNS服务器时出现 rndc: connection to remote host closed

    使用命令:rndc -s 192.168.1.2 status 连接远程的bind 搭建的DNS服务器时出现下面的错误:   rndc: connection to remote host close ...

  9. [系统开发] Python 实现的 Bind 智能 DNS Web 管理系统

    在公司的运营中,DNS还是很重要的,不仅名称解析需要DNS,一些重要的服务,比如负载均衡.HTTP 虚拟主机也会用到它.Bind 手工管理方式有一定的危险性,一旦写错格式就会造成 DNS 服务瘫痪. ...

随机推荐

  1. Linux服务器rsync自动备份

    一.在 server 端配置 1. 编辑配置文件 #vi /etc/rsyncd.conf 添加下面的配置参数: uid = nobody # 该选项指定当该模块传输文件时守护进程应该具有的uid.默 ...

  2. noip2015Day2T1-跳石头

    题目描述 Description 一年一度的“跳石头”比赛又要开始了! 这项比赛将在一条笔直的河道中进行,河道中分布着一些巨大岩石.组委会已经选择好了两块岩石作为比赛起点和终点.在起点和终点之间,有N ...

  3. 第八十六节,html5+css3pc端固定布局,网站结构,CSS选择器,完成导航

    html5+css3pc端固定布局,网站结构,CSS选择器,完成导航 页面采用1280的最低宽度设计,去掉滚动条为1263像素. 项目是PC端的固定布局,会采用像素(px)单位. 网站结构语义 在没有 ...

  4. UITableView简单使用

    在iOS开发中UITableView可以说是使用最广泛的控件,我们平时使用的软件中到处都可以看到它的影子,类似于微信.QQ.新浪微博等软件基本上随处都是UITableView.当然它的广泛使用自然离不 ...

  5. MongoDB聚合管道(Aggregation Pipeline)

    参考聚合管道简介 聚合管道 聚合管道是基于数据处理管道模型的数据聚合框架.文档进入一个拥有多阶段(multi-stage)的管道,并被管道转换成一个聚合结果.最基本的管道阶段提供了跟查询操作类似的过滤 ...

  6. [SOJ] connect components in undirected graph

    题目描述: 输入一个简单无向图,求出图中连通块的数目 输入: 输入的第一行包含两个整数n和m,n是图的顶点数,m是边数.1<=n<=1000,0<=m<=10000. 以下m行 ...

  7. 正规消息发送器-- ESFramework 4.0 进阶(06)

    在ESFramework 4.0 进阶(04)-- 驱动力:通信引擎(下)一文末尾我们已经将通信引擎以及整个消息骨架流程组装起来了,只要通信引擎一接收到消息,框架就会按照规定的流程进行运转.到这里,自 ...

  8. 有关app的一些小知识

    META相关 1. 添加到主屏后的标题(IOS)<meta name="apple-mobile-web-app-title" content="标题"& ...

  9. phpstudy 相关配置

    在/etc/my.cnf中 添加 expire_logs_days=5 phpstudy add   list    del

  10. 第二次冲刺spring会议(第三次会议)

    [例会时间]2014/5/6 21:15 [例会地点]9#446 [例会形式]轮流发言 [例会主持]马翔 [例会记录]兰梦 小组成员:兰梦 ,马翔,李金吉,赵天,胡佳奇