问题

linux创建文件夹文件。补全,启动服务均报错,具体报错信息如下

[root@localhost log]# mkdir /log/mysql -p
mkdir: 无法创建目录"/log": 设备上没有空间
[root@localhost log]# rm -rf ma-bash: 无法为立即文档创建临时文件: 设备上没有空间
-bash: 无法为立即文档创建临时文件: 设备上没有空间

[root@localhost ~]# systemctl restart nginx
Job for nginx.service failed because a configured resource limit was exceeded. See "systemctl status nginx.service" and "journalctl -xe" for details.
[root@localhost ~]# systemctl status nginx.service
● nginx.service - The nginx HTTP and reverse proxy server
Loaded: loaded (/usr/lib/systemd/system/nginx.service; disabled; vendor preset: disabled)
Active: failed (Result: resources)

7月 30 10:42:48 localhost.localdomain systemd[1]: nginx.service failed to run 'start-pre' task: No space left on device
7月 30 10:42:48 localhost.localdomain systemd[1]: Failed to start The nginx HTTP and reverse proxy server.
7月 30 10:42:48 localhost.localdomain systemd[1]: Unit nginx.service entered failed state.
7月 30 10:42:48 localhost.localdomain systemd[1]: nginx.service failed.
7月 30 10:42:48 localhost.localdomain systemd[1]: Starting The nginx HTTP and reverse proxy server...

解决流程

1.1.1 查看磁盘空间以及inode的数量

[root@localhost lib]# df -h
文件系统 容量 已用 可用 已用% 挂载点
/dev/sda3 99G 16G 78G % /
devtmpfs .8G .8G % /dev
tmpfs .8G .8G % /dev/shm
tmpfs .8G 9.1M .8G % /run
tmpfs .8G .8G % /sys/fs/cgroup
/dev/sda2 988M 121M 800M % /boot
/dev/sda5 418G 200G 197G % /opt
tmpfs .6G .6G % /run/user/
tmpfs .6G .6G % /run/user/ [root@localhost /]# df -i
文件系统 Inode 已用(I) 可用(I) 已用(I)% 挂载点
/dev/sda3 % /
devtmpfs % /dev
tmpfs % /dev/shm
tmpfs % /run
tmpfs % /sys/fs/cgroup
/dev/sda2 % /boot
/dev/sda5 % /opt
tmpfs % /run/user/
tmpfs % /run/user/

由此可见磁盘空间正常但是inode已经爆满

1.1.2什么是磁盘inode

一、inode是什么?

理解inode,要从文件储存说起。
文件储存在硬盘上,硬盘的最小存储单位叫做"扇区"(Sector)。每个扇区储存512字节(相当于0.5KB)。
操作系统读取硬盘的时候,不会一个个扇区地读取,这样效率太低,而是一次性连续读取多个扇区,即一次性读取一个"块"(block)。这种由多个扇区组成的"块",是文件存取的最小单位。"块"的大小,最常见的是4KB,即连续八个 sector组成一个 block。
文件数据都储存在"块"中,那么很显然,我们还必须找到一个地方储存文件的元信息,比如文件的创建者、文件的创建日期、文件的大小等等。这种储存文件元信息的区域就叫做inode,中文译名为"索引节点"。
文章原文地址:https://www.cnblogs.com/itech/archive/2012/05/15/2502284.html
1.1.3解决inode爆满问题
      解决思路:查找inode数量大的文件夹,确定文件夹后跟开发沟通,确定无误删除重启机器。
[root@localhost /]# for i in /*; do echo $i; find $i |wc -l|sort -nr; done
.....
部分省略
.....
/run
733
/sbin
1
/srv
1
/sys
31369
/tmp
12
/tools
181
/uploads
42
/usr
248909
/var
6308823

从根部开始查找由此可见/var文件夹竟然有600w+一定是有问题了继续查找

[root@localhost lib]# for i in /var/*; do echo $i; find $i |wc -l|sort -nr; done

找到/var/lib文件夹继续查找

[root@localhost lib]# for i in /var/lib/*; do echo $i; find $i |wc -l|sort -nr; done
```
部分省略
```
/var/lib/pear
37
/var/lib/php
6292685
[root@localhost lib]# cd php
[root@localhost php]# ls
session

由此查找到/var/lib/php/session目录确定可以删除就直接删除

查一下容量

[root@localhost lib]# du -sh * | sort -n 

690M php

删除

cd /var/lib/php
rm -rf *

再次查看inode

[root@localhost php]# df -i
文件系统 Inode 已用(I) 可用(I) 已用(I)% 挂载点
/dev/sda3 % / #没有删除完查看一下已经变小
devtmpfs % /dev
tmpfs % /dev/shm
tmpfs % /run
tmpfs % /sys/fs/cgroup
/dev/sda2 % /boot
/dev/sda5 % /opt
tmpfs % /run/user/
tmpfs % /run/user/
[root@localhost php]# df -i
文件系统 Inode 已用(I) 可用(I) 已用(I)% 挂载点
/dev/sda3 % /
devtmpfs % /dev
tmpfs % /dev/shm
tmpfs % /run
tmpfs % /sys/fs/cgroup
/dev/sda2 % /boot
/dev/sda5 % /opt
tmpfs % /run/user/
tmpfs % /run/user/
您在 /var/spool/mail/root 中有邮件

到此结束问题解决

Linux设备空间存储满问题的更多相关文章

  1. Linux inode空间占满 “no space left on device”

    Linux inode空间占满 提示 “no space left on device” 中文环境:“无法创建XXX目录,设备没有空间” Linux系统iNode耗尽硬盘无法写入文件怎么办?df -h ...

  2. linux磁盘空间用满的处理方法

    linux下空间满可能有两种情况 可以通过命令 df -h  查看磁盘空间占用,实际上是查看磁盘块占用的文件(block) df -i  查看索引节点的占用(Inodes) 磁盘块和索引节点其中之一满 ...

  3. linux磁盘空间占满问题快速定位并解决

    经常会遇到这样的场景:测试环境磁盘跑满了,导致系统不能正常运行!此时就需要查看是哪个目录或者文件占用了空间.常使用如下几个命令进行排查:df, lsof,du. 通常的解决步骤如下:1. df -h ...

  4. Linux磁盘空间占满问题快速定位

    1.df -h命令查看系统盘与各个磁盘的占用空间比率 [tidb@:vg_adn_tidbCkhsTest:172.31.30.62 /dev]$df -Th Filesystem Type Size ...

  5. linux磁盘空间使用问题

    linux磁盘空间用满的处理方法 linux下空间满可能有两种情况 可以通过命令 df -h  查看磁盘空间占用,实际上是查看磁盘块占用的文件(block) df -i  查看索引节点的占用(Inod ...

  6. linux 磁盘空间被占满但找不到目标文件的问题处理 lsof命令

    lsof简介 在终端下输入lsof即可显示系统打开的文件,因为 lsof 需要访问核心内存和各种文件,所以必须以 root 用户的身份运行它才能够充分地发挥其功能. 直接输入lsof部分输出为: 每行 ...

  7. Linux FC/iSCSI存储设备管理系列(一):Linux系统设备驱动入门

    Linux FC/iSCSI存储设备管理系列(一):Linux系统设备驱动入门 转载请在文首保留原文出处:EMC中文支持论坛 - https://community.emc.com/go/chines ...

  8. Linux设备模型(9)_device resource management ---devm申请空间【转】

    转自:http://www.wowotech.net/linux_kenrel/device_resource_management.html . 前言 蜗蜗建议,每一个Linux驱动工程师,都能瞄一 ...

  9. (转)Linux服务器磁盘空间占满问题

    转自:https://www.cnblogs.com/cindy-cindy/p/6796684.html 下面我们一起来看一篇关于Linux服务器磁盘占满问题解决(/dev/sda3 满了),希望碰 ...

随机推荐

  1. 963B:Destruction of a Tree

    You are given a tree (a graph with n vertices and n - 1 edges in which it's possible to reach any ve ...

  2. Linux 桌面的 Dock 类程序

    1.Cairo-Dock是一个Dock类软件,它支持OpenGL.提供动画及视觉效果的插件.新的Applet.重写配置面板.新增主题等功能. 2.Docky是从GNOME Do项目剥离出来的一个Doc ...

  3. 电脑无法上网,DHCP客户端不能正确获取IP地址

    问题特征:DHCP服务器更新[保留]配置信息后,给一客户端绑定了新的IP地址;但客户端IP地址并未正确更新; 处理: 一.检查DHCP服务器配置; 1.MAC地址.IP地址均正确;并已“添加到筛选器” ...

  4. react-native flatlist setState修改数据视图不刷新解决方案

    给flatlist添加属性:handleMethod = {({viewableItems}) => this.handleViewableItemsChanged(viewableItems) ...

  5. 【Linux下安装配置Jupyter】

    """ 第一步 安装 """ pip3 install -i https://pypi.douban.com/simple jupyter ...

  6. Tomcat线程池与NIO配置

    每个web客户端请求对于服务器端来说就一个单独的线程,客户端的请求数量增多将会导致线程数就上去了,CPU就忙着跟线程切换. 而NIO则是使用单线程(单个CPU)或者只使用少量的多线程(多CPU)来接受 ...

  7. 高速改动android系统默认日期方法

    高速改动android系统默认日期方法 在android系统的设备上,都有一个默认的開始日期,看过非常多设备,有些设备在没有联网的时候没有同步到系统时间的时候,竟然默认的还是1970年的日期.也见过有 ...

  8. OpenCASCADE7.3.0 is available for download

    OpenCASCADE7.3.0 is available for download OPEN CASCADE is pleased to announce a new public release ...

  9. 操作excel脚本练习

    # -*- coding: utf-8 -*- import xlrd import xlwt import sys from xlwt import * from xlrd import open_ ...

  10. u盘安装14.04ubuntu系统

    最近在安装ubuntu 14.04系统,总结了下安装的方法,记录如下 1.下载ubuntu 14.04 iso文件,下载地址 http://www.ubuntu.com/download/deskto ...