一、创建sftp服务数据目录及相关测试用户

[root@localhost ~]# mkdir -pv /data/sftp/                #sftp数据目录
[root@localhost ~]# chown root:root -R /data/sftp/ #一定要是root用户,否则无法chroot
[root@localhost ~]# chmod -R /data/sftp/ #权限最低需要保证普通用户可以进入
[root@localhost ~]# groupadd sftp #sftp服务组,sftp服务可以设置匹配组或单个用户来设置,如果是单个用户可以忽略
[root@localhost ~]# useradd -d /data/sftp/user1 -m -g sftp -s /sbin/nologin user1
[root@localhost ~]# id user1
[root@localhost ~]# echo "" |passwd --stdin user1 #添加密码。测试环境从简,生产不建议此密码,可以通过网页 https://suijimimashengcheng.51240.com/ 或mkpasswd命令生产(需要安装expect软件包)

二、修改sshd服务配置文件,以组的方式管理sftp用户权限

修改前配置

修改后:

配置解释:

Subsystem sftp internal-sftp     #使用sftp服务使用系统自带的internal-sftp
Match Group sftp #匹配sftp组的用户,如果要匹配多个组,多个组之间用逗号分割
ChrootDirectory /data/sftp/%u #用chroot将用户的根目录指定到/data/sftp/%u,%u代表用户名,这样用户就只能在/data/sftp/%u下活动
ForceCommand internal-sftp #强制执行内部sftp,并忽略任何~/.ssh/rc文件中的命令
AllowTcpForwarding no #不允许转发TCP协议,默认是yes,如果用户可以shell访问则建议为yes
X11Forwarding no #是否允许进行 X11 转发。默认值是"no",设为"yes"表示允许。如果允许X11转发并且sshd()代理的显示区被配置为在含有通配符的地址(X11UseLocalhost)上监听。那么将可能有额外的信息被泄漏。由于使用X11转发的可能带来的风险,此指令默认值为"no"。需要注意的是,禁止X11转发并不能禁止用户转发X11通信,因为用户可以安装他们自己的转发器。如果启用了 UseLogin ,那么X11转发将被自动禁止。

重启服务,可能出现的错误:

[root@localhost ~]# systemctl restart sshd   #重启服务
Job for sshd.service failed because the control process exited with error code. See "systemctl status sshd.service" and "journalctl -xe" for details.
[root@localhost ~]# tail /var/log/messages
Jul :: localhost systemd: Starting Session of user root.
Jul :: localhost systemd: Stopping OpenSSH server daemon...
Jul :: localhost systemd: Starting OpenSSH server daemon...
Jul :: localhost sshd: /etc/ssh/sshd_config line : Directive 'UseDNS' is not allowed within a Match block #报错信息
Jul :: localhost systemd: sshd.service: main process exited, code=exited, status=/n/a
Jul :: localhost systemd: Failed to start OpenSSH server daemon.
Jul :: localhost systemd: Unit sshd.service entered failed state.
Jul :: localhost systemd: sshd.service failed.
Jul :: localhost systemd: Started Session of user root.
Jul :: localhost systemd: Starting Session of user root.

这是因为UseDNS 在我们的sftp设置块下方,按我上面的配置就没有此问题了。

三、客户端连接测试

1.服务端为该用户目录授权

[root@localhost ~]# cd /data/sftp/
[root@localhost sftp]# ll
总用量
drwx------ user1 sftp -- : user1
[root@localhost sftp]# chown root:root user1
[root@localhost sftp]# chmod user1/
[root@localhost sftp]# cd user1/
[root@localhost user1]# mkdir upload
[root@localhost user1]# chown user1:sftp upload/

2.客户端测试连接

[root@localhost ~]# sftp user1@172.16.150.135  #注意连接的用户名
user1@172.16.150.135's password:
Connected to 172.16.150.135.
sftp> ls
upload
sftp> cd upload/
sftp> mkdir test
sftp> rmdir test
sftp> help #查看命令帮助
Available commands:
bye Quit sftp
cd path Change remote directory to 'path'
chgrp grp path Change group of file 'path' to 'grp'
chmod mode path Change permissions of file 'path' to 'mode'
chown own path Change owner of file 'path' to 'own'
df [-hi] [path] Display statistics for current directory or
filesystem containing 'path'

可能出现的报错:

packet_write_wait: Connection to 172.16.150.135 port : Broken pipe
Couldn't read packet: Connection reset by peer

出现以上报错,通常是因为用户的目录权限有问题,这也是sftp服务最容易出现问题的地方。我们只要抓住以下两个要点(原则)

由ChrootDirectory指定的目录开始一直往上到系统根目录为止的目录拥有者都只能是root
由ChrootDirectory指定的目录开始一直往上到系统根目录为止都不可以具有群组写入权限

四、根据单个用户配置(其他参照组配置即可)

Match User zara_sftp   #使用User关键字  后面接用户名
ChrootDirectory /data/sftp/zara_sftp #用户数据目录,注意权限
X11Forwarding no
AllowTcpForwarding no
ForceCommand internal-sftp

centos安装sftp服务的更多相关文章

  1. centos 安装sftp服务

    打开命令终端窗口,按以下步骤操作. 0.查看openssh的版本 ssh -V 使用ssh -V 命令来查看openssh的版本,版本必须大于4.8p1,低于的这个版本需要升级.  1.创建sftp组 ...

  2. Centos7.3安装sftp服务和ssh

    Centos安装SFTP 安装SFTP服务         1. 查看openssh版本             ssh -V             openssh版本必须大于4.8p1       ...

  3. centos 安装memcache服务后memcahce本机连接Permission

    自己手动在虚拟机下装了下memcache,整个过程真是充满波折,本身用php5.3安装memcache扩展就麻烦很多,无法通过yum直接安装,安装方法详见http://chenwei.me/blog/ ...

  4. Centos安装vncserver服务

    vnc是一款Windows远程桌面软件,其优点是支持跨操作系统的远程图形化控制.下面开始记录第一次安装vnc服务的过程. 1.先检查系统是否有安装VNC服务 [root@localhost ~]# [ ...

  5. centos安装openoffice服务

    第一步:yum install openoffice.org-brand openoffice.org-core openoffice.org-java-common xvfb openoffice. ...

  6. CentOS 安装nginx服务

    安装nginx服务 sudo yum install nginx 启动nginx systemctl start nginx 加入启动项 systemctl enable nginx 测试nginx服 ...

  7. CentOS安装FTP服务

    最近公司有一个内部比赛(黑客马拉松),报名参加了这么一个赛事,在准备参赛作品的同时(参赛服务器需要自己搭建),借着这个机会,决定把tomcat部署相关的知识从0到1重新捋一遍.就当备忘录了. FTP服 ...

  8. CentOS安装Openfire服务

    原文::http://xiao987334176.blog.51cto.com/2202382/979677 系统是全新新安装的系统.版本号是Centos 5.6 x86 同步北京时间 # ntpda ...

  9. Centos安装vsftp服务

    1.安装vsftp yum install vsftpd 2.开启vsftp服务,设置开机自启 service vsftpd restart chkconfig vsftpd on 停止vsftpd: ...

随机推荐

  1. EntityFrameworkCore(efcore)在与 MySQL 连接使用中的问题

    请直接使用第三方驱动: Pomelo.EntityFrameworkCore.MySql(https://github.com/PomeloFoundation/Pomelo.EntityFramew ...

  2. Java foreach循环

    foreach循环:增强性的for循环应用: 在for语句中,需要使用索引来进行操作具体的数组或集合内容操作:而foreach可以取消索引的操作细节: for ( 类型 变量 : 数组 | 集合 ) ...

  3. Qt背景不显示问题

    背景不显示的只有主窗口会发生,原因是主窗口使用的QWidget类 解决办法 重构paintEvent事件,添加即可 void LoginWidget::paintEvent(QPaintEvent * ...

  4. 【Git版本控制】Idea中设置Git忽略对某些文件的版本追踪

    在Idea中有些本地文件无需与远程库同步,仅是本地使用.此时就需要将这些文件加入到Git的版本忽略中来. 设置步骤 1.搜索插件 .ignore,并安装 2.增加.gitignore文件 3.配置相应 ...

  5. tornado 之 RequestHandler(请求)

    RequestHandler from tornado.web import ReuqestHandler 一.利用HTTP协议想服务器传递参数 提取url的特定部分 http://127.0.0.1 ...

  6. C语言的10大基础算法

    C语言的10大基础算法 算法是一个程序和软件的灵魂,作为一名优秀的程序员,只有对一些基础的算法有着全面的掌握,才会在设计程序和编写代码的过程中显得得心应手.本文包括了经典的Fibonacci数列.简易 ...

  7. ASIO库使用注意事项

    1. 使用 io_service::work 实现 io_service 无任务时不退出 正常情况下向io_service抛任务,它执行完成后就会自动退出,而要实现那种chromium那种的循环队列, ...

  8. lf 前后端分离 (4) 价格策略

    一.价格策略 价格策略就是通过前端发送要购买的课程以及价格策略来找出表关联的字段返回客户端 通过contenttype 属性 找到课程所有的价格策略 for prcie_policy in cours ...

  9. seq命令的使用

    标题:seq命令的使用 作用:seq命令用于以指定增量从首数开始打印数字到尾数,即产生从某个数到另外一个数之间的所有整数,并且可以对整数的格式.宽度.分割符号进行控制 语法: [1] seq [选项] ...

  10. 201777010217-金云馨《面向对象程序设计(java)》第十六周学习总结

    项目 内容 这个作业属于哪个课程 https://www.cnblogs.com/nwnu-daizh/ 这个作业的要求在哪里 https://www.cnblogs.com/nwnu-daizh/p ...