Zabbix故障总结(持续更新)
Zabbix housekeeper processes more than 75% busy
问题原因
为了防止数据库持续增大,zabbix有个自动删除历史数据的机制,就是housekeeper,而mysql数据库删数据的时候,性能会降低,就会报这个错
解决方案
调整HousekeepingFrequency参数,我这里设置为12小时执行一次
HousekeepingFrequency=12 #时间间隔
MaxHousekeeperDelete=1000000 #最大删除量
Zabbix discoverer processes more than 75% busy
问题原因
配置了自动发现的任务。每个自动发现的任务都会在一定时间内占用一个自动发现的进程。而默认配置项为1,所以报警
解决方案
修改配置文件的StartDiscoverers选项
[root@zabbix-master ~]# grep 'StartDiscoverers' /etc/zabbix/zabbix_server.conf
### Option: StartDiscoverers
StartDiscoverers=10
Zabbix poller processes more than 75% busy
问题原因
翻译过来是轮询的负载量高,网上大多数说法是增加启动的StartPollers进程数,但就我遇到的情况,无法解决。查了很多文档,发现可能是我大批量更改模板导致。
这边有一个交换机模板,应用了百台交换机,后来对这个模板的自动发现进行了调整。交换机发现了新的监控项,而老的监控项默认保留40天,造成监控项爆炸了。个人理解,不一定对。
解决方案 : 调整StartPollers数量
[root@zabbix-master ~]# grep 'StartPollers' /etc/zabbix/zabbix_server.conf
### Option: StartPollers
StartPollers=100
### Option: StartPollersUnreachable
StartPollersUnreachable=80
修改模板自动发现规则的保留失去的资源期间
Zabbix alerter processes more than 75% busy
问题原因
zabbix服务器邮件进程繁忙导致的,一般是因为在设置动作的时候,间隔太短,在一些特殊情况下,产生大量告警,例如几万封邮件,服务器发邮件,邮件进程发挂了。
解决方案
网上有牛逼的人删数据库解决,风险较大,建议通过导流解决。改发邮件的脚本,将邮件的动作改为打印时间,如下,待邮件都释放完了,再改回来。
[root@zabbix-master ~]# cat /usr/lib/zabbix/alertscripts/sms
#!/bin/bash
echo `date` >> /tmp/sms.txt
Too many processes on zabbix server
zabbix服务器进程太多报警,默认超过300个进程就报警。感觉默认值太小了,zabbix配置调优后,进程就500多个了,所以我把触发值改为600.

Zabbix preprocessing manager processes more than 75%
随着3.4版本的发布,出现了一大波新功能,后续会陆续推出3.4版本新功能介绍及实践.本次说一下3.4新增的Preprocessing这个功能.(3.4中文翻译好像有点问题把Preprocessing翻译为进程,翻译有点错误)Preprocessing为预处理,预加工(google翻译^_^)使用这个功能可以对item收到的数据行处理,处理之后再存入数据库或展示出来.
preprocessing功能非常实用,如某些品牌的网络设备,使用snmp方式监控并收集回来的数据,由于厂商预先进行了处理,导致网络流量的值为4.5MB或者56KB等形式,人性化的表现形式,而对于3.4以前的zabbix来说,整数或浮点数后面多一两个字符,这整串数据就不能以整数值或者浮点数配置监控项的数据库收集类型,必须使用文本字符串类型,而文本和字符串类型监控项触发器不能使用数值监控类型的判断并触发流量报警。要变成数字类型,唯一的方式是使用外部检查预先编写字符串处理脚本,但增加的配置监控项的繁琐程度,且外部检查降低了zabbix的性能,3.4的preprocessing功能使得问题解决,并更加灵活的处理监控数据。
Zabbix故障总结(持续更新)的更多相关文章
- zabbix常见问题整理 持续更新……
[toc] 1.zabbix仪表板错误 问题: zabbix server is not running: the information displayed may not be current 解 ...
- 消息队列面试题、RabbitMQ面试题、Kafka面试题、RocketMQ面试题 (史上最全、持续更新、吐血推荐)
文章很长,建议收藏起来,慢慢读! 疯狂创客圈为小伙伴奉上以下珍贵的学习资源: 疯狂创客圈 经典图书 : <Netty Zookeeper Redis 高并发实战> 面试必备 + 大厂必备 ...
- [读书]10g/11g编程艺术深入体现结构学习笔记(持续更新...)
持续更新...) 第8章 1.在过程性循环中提交更新容易产生ora-01555:snapshot too old错误.P257 (这种情况我觉得应该是在高并发的情况下才会产生) 假设的一个场景是系统一 ...
- PTA|团体程序设计天梯赛-练习题目题解锦集(C/C++)(持续更新中……)
PTA|团体程序设计天梯赛-练习题目题解锦集(持续更新中) 实现语言:C/C++: 欢迎各位看官交流讨论.指导题解错误:或者分享更快的方法!! 题目链接:https://pintia.cn/ ...
- 史上最全的spark面试题——持续更新中
史上最全的spark面试题——持续更新中 2018年09月09日 16:34:10 为了九亿少女的期待 阅读数 13696更多 分类专栏: Spark 面试题 版权声明:本文为博主原创文章,遵循C ...
- 4W字的后端面试知识点总结(持续更新)
点赞再看,养成习惯,微信搜索[三太子敖丙]关注这个互联网苟且偷生的工具人. 本文 GitHub https://github.com/JavaFamily 已收录,有一线大厂面试完整考点.资料以及我的 ...
- JUC并发包与容器类 - 面试题(一网打净,持续更新)
文章很长,建议收藏起来,慢慢读! 疯狂创客圈为小伙伴奉上以下珍贵的学习资源: 疯狂创客圈 经典图书 : <Netty Zookeeper Redis 高并发实战> 面试必备 + 大厂必备 ...
- Redis 面试题 - 收藏版 (持续更新、吐血推荐)
文章很长,建议收藏起来,慢慢读! 疯狂创客圈为小伙伴奉上以下珍贵的学习资源: 疯狂创客圈 经典图书 : <Netty Zookeeper Redis 高并发实战> 面试必备 + 大厂必备 ...
- Zookeeper 面试题(持续更新、吐血推荐)
文章很长,建议收藏起来,慢慢读! 疯狂创客圈为小伙伴奉上以下珍贵的学习资源: 疯狂创客圈 经典图书 : <Netty Zookeeper Redis 高并发实战> 面试必备 + 大厂必备 ...
随机推荐
- WebService 学习记录
-------------------------------------------PS:这个WebService 服务必须一直开着,关闭就没法访问了 Web Service 教程 一.webser ...
- MACOS-Can't-connect-to-local-MySQL-server-through-socket-'/tmp/mysql.sock'
mac os start mysql fail by "brew services start mysql"you can try : mysql.server start
- 使用kolla安装的openstack mariadb为集群所有节点无法启动
当在做测试时,把所有的openstack节点都关机,再开启做测试时,发现mariadb galera集群启不来,相当于所有的mariadb集群都停止了(跟所有节点断电情况相似),这时候怎么办呢,重新建 ...
- irc使用教程
下面介绍几个IRC名词:NICKNAME (或nick) 昵称.在命令中可以表示你本人或者其他聊天客.#CHANNEL (或#chan) 频道.聊天室房间名字.房间名字前面一定要加 # 符号.服务器机 ...
- Visual Studio 2010 出现关于ActivityLog.xml错误的解决方案
在用VS编写程序是第一次会跳出“Visual Studio has encountered an exception.This may be caused by an extension. You c ...
- 排序算法<No.6>【插入排序】
算法,我在路上,将自己了解的算法内容全部梳理一遍! 今天介绍简单点的,插入排序. 首先,什么是插入排序,这个维基百科上有.个人的理解,就是将一个数插入到一个已经排好序的数列当中某个合适的位置,使得增加 ...
- 编写dll时的内存分配策略
前一篇文章介绍了为何要共用内存管理器,有人要问可不可以在编写dll时更通用一些,可以兼顾其它编译器(如果是其它编译器的话,Delphi写的dll不能与其它语言共用内存管理器),采用一定的策略来避免在d ...
- WCF 基础连接已经关闭: 服务器关闭了本应保持活动状态的连接。
详细错误信息: System.ServiceModel.CommunicationException: 接收对 http://localhost:48655/XXXXXX.svc 的 HTTP 响应时 ...
- Docker+Nginx部署Angular
在部署Angular生产环境之前,需要电脑已经安装docker. 添加Dockerfile在已经完成的Angular项目的项目根目录下添加Dockerfile文件. Dockerfile文件内容: F ...
- 【优化】自定义抛出throw 对象练习
package ltb6w; import java.util.*; public class Bank { private boolean bool=true; private String sel ...