这里只做记录说明

Redis的主从配置网上很多文章,百度一大堆,安装流程应该都可以配置通。我使用的这篇文章

https://blog.csdn.net/u010648555/article/details/79427606

配置完成主从后,继续哨兵的配置,同样网上很多文章,我参考

https://blog.csdn.net/u010648555/article/details/79430105

在配置哨兵的过程中遇到问题,哨兵搭建都成功,相互之间也知道对方的存在,就是无法通信,无法启动故障迁移。

原因主要是因为 sentinel.conf 配置确实一个配置,不过添加那一句貌似就裸奔了,要完善处理,可以参考这骗文章:

https://www.cnblogs.com/zhoujinyi/p/5585723.html

我测试时添加了

protected-mode no

  正式环境建议研究配置,都给密码,改端口

如下时我的 sentinel.conf 完整配置

# 这个是Redis6379配置内容,其他文件同理新增然后改一下端口即可,,和 。

#当前Sentinel服务运行的端口
port protected-mode no
# 哨兵监听的主服务器
sentinel monitor mymaster 127.0.0.1
# 3s内mymaster无响应,则认为mymaster宕机了
sentinel down-after-milliseconds mymaster
#如果10秒后,mysater仍没启动过来,则启动failover
sentinel failover-timeout mymaster
# 执行故障转移时, 最多有1个从服务器同时对新的主服务器进行同步
sentinel parallel-syncs mymaster

修改后即可测试成功自动迁移。

下面就是把Redis和Sentinel都弄成Windows 的服务运行。

将Redis做成服务运行,这篇文章也说得清楚,

https://www.cnblogs.com/zoro-zero/p/6437519.html

不过没有说将哨兵做成服务。下面是我自己测试成功,可以将哨兵做成服务的脚本

(在redis目录下执行,管理员执行)

//删除服务,默认的Redis
redis-server --service-uninstall
//删除服务,指定的服务名称
redis-server --service-uninstall --service-name RedisService1 //安装redis
redis-server --service-install redis.windows.conf --loglevel verbose //安装其他名称的服务
redis-server --service-install --service-name redisService1 --port //将Sentinel安装为Windows服务
redis-server --service-install sentinel.conf --sentinel --service-name RedisSentinel --port

另外,测试哨兵的时候,这个命令也很好用,比 shutdown 方便。

测试利器,  debug sleep 0.1就相当于执行了一条开销为100ms的命令

127.0.0.1:6379> debug sleep 1
OK
(1.00s)

  

debug error

测试利器, debug error,redis直接会返回一个错误应答

127.0.0.1:6379> debug error "test"
(error) test

  

Redis 安装成windows服务- 一主二从三哨兵,sentinel安装为Windows服务的更多相关文章

  1. springboot 集成Redis一主二从三哨兵

    1.Centos7 Redis一主二从三哨兵配置 Redis一主二从三哨兵环境搭建 2.接入过程 与集成redis单机不同的是jedis相关的配置做了修改,JedisPool换成了JedisSenti ...

  2. redis环境搭建及一主二从三哨兵模式配置

    一.单机redis环境搭建 1.安装: OS:linux redhat6.5 下载redis 官网下载链接:https://redis.io/download 把安装包上传到服务器,进行解压 [roo ...

  3. docker-compose一键部署redis一主二从三哨兵模式(含密码,数据持久化)

    本篇基于centos7服务器进行部署开发 一.拉取redis镜像,使用如下命令 docker pull redis 1.查看镜像是否拉取成功,使用如下命令 docker images 显示如下则证明拉 ...

  4. redis 一主二从三哨兵

    总体部署 一主二从三哨兵 ip地址分配分别为 主 127.0.0.1:6379 从 127.0.0.1:6389 从 127.0.0.1:6399 哨兵 127.0.0.1:26379 哨兵 127. ...

  5. redis一主二从三哨兵

    redis做集群的时候有很多种配置方法,一主二从三哨兵这种模式是官网推荐的.,写配置文件链接的时候,写的是哨兵地址,不是IP,用户名,密码之类的. 一主二从很好理解,一个主的redis,实时备份到两个 ...

  6. docker compose搭建redis7.0.4高可用一主二从三哨兵集群并整合SpringBoot【图文完整版】

    一.前言 redis在我们企业级开发中是很常见的,但是单个redis不能保证我们的稳定使用,所以我们要建立一个集群. redis有两种高可用的方案: High availability with Re ...

  7. Redis安装部署(一主二从三哨兵)

    需求:根据当前客户的生产环境,模拟安装部署Redis的测试环境,方便后续的功能测试. 1.准备工作 2.安装编译Redis 3.Redis运行环境配置 4.Redis启动和关闭 1.准备工作 Redi ...

  8. Docker Compose搭建Redis一主二从三哨兵高可用集群

    一.Docker Compose介绍 https://docs.docker.com/compose/ Docker官方的网站是这样介绍Docker Compose的: Compose是用于定义和运行 ...

  9. linux 下Redis 5.0主从复制(一主二从)哨兵模式的搭建

    文档结构如下: 一.环境说明: 作用 IP地址 端口 操作系统版本 安装目录 哨兵文件 主库 172.16.10.80 6379 Redhat 6.7 /redis5.0/redis-5.0.0 Se ...

随机推荐

  1. WebLogic Server 多租户资源管理(resource consume manager)

    WebLogic Server基于分区管理heap Size,CPU利用率等,具体的设置如下, 首先需要在setDomainEnv.cmd文件中java_option中加入如下字段 -XX:+Unlo ...

  2. linux使用其它用户 su - op -c

    su - op -c "whoami"

  3. 科研不是比赛,而是一种对未知和完美的自我追求——跟邢波(Eric Xing)面对面聊科研

    编者按:6月26日,2014年国际机器学习大会(ICML)在北京国际会议中心完美落幕.作为机器学习领域两大顶尖年会之一,这是 ICML大会30多年来首次来到中国和远东,在国内的机器学习界震动不小.身为 ...

  4. JS中event.preventDefault()取消默认事件能否还原?

    参考知乎讨论:https://www.zhihu.com/question/21891734

  5. install libiconv libraries

    #下载地址: https://ftp.gnu.org/pub/gnu/libiconv/ #编译安装 ./configure --prefix=/usr/local make make install ...

  6. javascript快速入门16--表格

    表格的层次结构 <table border="1"> <caption>表格标题</caption> <thead> <tr& ...

  7. [Python爬虫] 之二十一:Selenium +phantomjs 利用 pyquery抓取36氪网站数据

    一.介绍 本例子用Selenium +phantomjs爬取36氪网站(http://36kr.com/search/articles/电视?page=1)的资讯信息,输入给定关键字抓取资讯信息. 给 ...

  8. MongoDB集群设置集合分片生效及查看集合分片情况

    #连接mongos /opt/mongodb/mongodb-linux-x86_64-2.4.8/bin/mongo  127.0.0.1:27017   #使用admin数据库 use admin ...

  9. CMA连续物理内存用户空间映射---(二)

    摘要: 相对于上一篇測试程序CMA连续物理内存用户空间映射---(一) 添加功能: 1.分配和映射统一放在IOCTL,一次完毕,能够连续多次分配并映射到用户空间,提高操作性: 2.驱动添加链表,使分配 ...

  10. 菜鸟调错(五)——jetty执行时无法保存文件

    背景交代: 上一篇博客写的是用jetty和Maven做开发.測试.在使用的过程中遇到一个小问题.就是在jetty启动以后,改动了jsp.xml等文件无法保存. 错误信息: 解决方式: 到Maven库( ...