今天继续SharePoint 2013 的探索之旅,之前几篇文章分析了SharePoint 2013的物理拓扑结构,安装,以及逻辑体系结构。在这篇文章中,我将继续Step By Step形式演示如何在SharePoint 2013中创建Web Application。

预准备工作

1.在SharePoint 2013 Central Administration中创建Web Application,前提条件是必须登录的账号是在SharePoint Group "Farm Administrators"的成员。

SharePoint Farm Administrator

默认情况下,在SharePoint 2013 产品配置向导安装结束后,SharePoint Farm Administration组包含3种类型账号:SharePoint 安装账号,SharePoint Farm 账号以及BUILTIN\Administrators 组(AD组)。

2.根据Least Privilege原则,专门为Web Application Pool 创建Managed Service Account(SP_Pool),如下图所示。SP_Pool其实就是应用程序池标识(Application Pool Identity),比如你创建了一个Web Application并为它创建了一个Pool,你可以选择此账户。一个Application Pool包含了一个或多个Worker Process(w3wp.exe)。当Application Pool启动时会将其身份(应用程序池标识)赋予给Worker Process。

3.在DNS中,需要为Web Application新增主机名(A记录),并将其指向SharePoint Server。打开DNS 管理器,在Forward Lookup Zones(正向查找区域)创建"A 记录"并将Intranet作为Host Name(主机名),然后将IP地址指向我们的SharePoint 2013 Server,如下图所示。

创建Web Application

  • 在完成预准备工作后,进入SharePoint Central Administration,在Dashboard中选择 Manage Web Application。

  • 在顶部Ribbon菜单,点击New。

  • 端口,只需在DNS中加入A记录并指向SharePoint Server即可),Host Name,Path,如下图所示。

  • 接着选择新建Web Application Pool,并为其选择SP_Pool作为应用程序池标志。对于URL和ZONE使用默认即可。

  • 接着选择DB Server和内容数据库,默认的内容数据库是以GUID命名,当然你也可以自定义一个容易辨识的名字。

  • 最后,在Service Application Connections选择默认即可。

我想指出的是,Service Application Proxy是Web Application与Service Application的中间件。通过Proxy,Web Application才能访问和使用Service Application。

小结

Web Application中值得探索的东西还是很多,我将在下篇文章继续分享我对SharePoint 2013的理解。

Have a nice weekend.

SharePoint 2013 创建Web Application的更多相关文章

  1. SharePoint 2013 创建web应用程序报错"This page can’t be displayed"

    错误描述 This page can’t be displayed •Make sure the web address http://centeradmin is correct. •Look fo ...

  2. SharePoint 2013 创建web应用程序报错"This page can’t be displayed"

    错误描写叙述 This page can't be displayed •Make sure the web address http://centeradmin is correct. •Look ...

  3. SharePoint创建web application出现“The password supplied with the username was not correct”错误的解决方法

    平台环境 Windows Server 2012 R2 Standard, SharePoint Server 2010, Microsoft SQL Server 2012 (SP1) 问题描述 在 ...

  4. SharePoint 2013创建WCF REST Service

    SharePoint 2013为开发者提供了丰富的REST API,方便了我们在客户端操作List中的数据.当然我们也可以在SharePoint 2013中创建自定义的REST Service,比如通 ...

  5. 小议:怎样解决创建Web Application失败问题?

    我们都知道微软建议部署SharePoint2013环境的内存至少是12GB.可是有些小型企业在部署On Premise的环境时因为预算有限,仅仅能使用内存是8GB的环境来部署SharePoint201 ...

  6. 解决SharePoint密码更新后,创建Web Application 失败

    问题在sharepoint central administration中通过Configuration Wizards来创建一个web application,出现如下错误: The passwor ...

  7. SharePoint 2013 创建 Site Collection

    在之前的文章中,通过SharePoint Central Administration 创建了Web Application.在这篇文章中将继续SharePoint 2013之旅——还是以Step B ...

  8. SharePoint 2013创建应用程序时IIS端口文件夹下没文件

    最近SharePoint 2007迁移到2013的时候,碰到创建应用程序时IIS端口文件夹下没文件的问题,网上找了大把的原因,终于在这里找到了解决方案: Fix: 1. Open IIS on the ...

  9. SharePoint 2013 创建搜索中心及搜索设置

    本文没有太多深奥的东西,只是简单的搜索配置,如果你已经掌握请略过本文. 好了,进入内容简介,众所周知,搜索是SharePoint一大特性,下面,我们简单介绍下搜索中心的创建. 1.创建Search子网 ...

随机推荐

  1. 命令行能运行,但是在crontab不能正常运行的问题

    今天配置了一个crontab,但是怎么也不能执行,原因是环境变量的问题,记录一下. 解决问题的办法,在shell脚本添加: ################## . /etc/profile . ~/ ...

  2. linux CPU占用率高(转)

    来自:http://www.cnitblog.com/houcy/archive/2012/11/28/86801.html 1.用top命令查看哪个进程占用CPU高 gateway网关进程14094 ...

  3. percona-Toolkit

    1:下载最新安装包 wget https://www.percona.com/downloads/percona-toolkit/2.1.1/percona-toolkit-2.1.1.tar.gz ...

  4. Android ——VideoView禁止"无法播放该视频"弹窗

    我们在使用videoView播放视频时,如果获取内容失败.网址不对.或者视频格式不对等,会弹出“无法播放该视频”的弹窗,阻塞用户使用. 这种情况,如果在一些自助服务类场合下,弹窗会造成十分不友好的用户 ...

  5. recordMyDesktop的安装与使用

    今天给大家推荐一款能让桌面录像更简单的屏幕录像的工具:  RecordMyDesktop 安装 RecordMyDesktop RecordMyDesktop 的核心是一系列命令工具,不过 Gnome ...

  6. java json与map互相转换(一)

      java json与map互相转换(一) CreationTime--2018年7月16日 Author:Marydon 1.准备工作 所需jar包:json-20180130.jar impor ...

  7. find -size 查出指定文件大小的命令

    find -size n [c] 查找n值大小的文件,默认单位是块(1块=512字节) 1. 查找大于1500字节的文件 find ~ -size +1500c 2. 查找等于1500字节的文件 fi ...

  8. nginx常用超时设置

    客户度连接nginx超时, 建议5s内 接收客户端header超时, 默认60s, 如果60s内没有收到完整的http包头, 返回408 Syntax: client_header_timeout t ...

  9. Dubbo OPS工具——dubbo-admin & dubbo-monitor

    1. 前言 今年八月份的时候,查看github仓库,Dubbo OPS还提供了三种工具用于Dubbo的监控运维: 九月份,伴随着Dubbo的全面快速的升级,现在仓库里Dubbo OPS下这三个工具已经 ...

  10. 请问实现MVC的框架有哪些,实现持久化操作的框架有哪些,还有类似于spring整合的框架又有哪些

    2011-04-10 我知道MVC框架有struts.webWork; 持久化的有hibernate.ibatis,而进行整合的我只知道spring了 ------------------- 表示层框 ...