一、配置etcd数据库
etcd服务作为Kubernetes集群的主数据库,在安装Kubernetes各服务之前需要首先安装和启动。
1. 安装etcd
yum -y install etcd
2. 修改etcd配置文件
vim /etc/etcd/etcd.conf
ETCD_NAME=etcd-node1 #定义节点名称
ETCD_DATA_DIR="/var/lib/etcd/default.etcd" #定义数据存放位置
#[cluster]
ETCD_INITIAL_ADVERTISE_PEER_URLS=http://192.168.1.1:2380 #通知其他etcd实例地址
ETCD_INITIAL_CLUSTER="etcd-node1=http://192.168.1.1:2380,etcd-node2=http://192.168.1.2:2380,etcd-node3=http://192.168.1.3:2380" #定义etcd集群节点
ETCD_INITIAL_CLUSTER_STATE=new #初始化集群状态,new表示新建
ETCD_INITIAL_CLUSTER_TOKEN=etcd-k8s-cluster #初始化集群token,token一致则可以进入同一集群
ETCD_LISTEN_PEER_URLS=http://0.0.0.0:2380 #监听etcd实例的地址
ETCD_ADVERTISE_CLIENT_URLS=http://192.168.1.1:2379 #通知客户端地址
ETCD_LISTEN_CLIENT_URLS="http://0.0.0.0:2379" #监听客户端地址
#[proxy]
ETCD_PROXY="off"
#[security]
etcd数据库安装时要安装为奇数节点(与zookeeper类似),最少为3台,否则选举Leader会失败,启动其他节点时直接修改以上配置文件的本地ip为当前服务器ip即可。
3. 启动etcd数据库并查询当前状态
3.1 启动etcd数据库
systemctl start etcd
3.2 查询etcd集群成员
etcdctl member list
3.3 查询etcd集群健康状态
etcdctl cluster-health
etcd集群启动完成后可以开始部署Kubernetes master节点。如果遇到etcd节点启动失败,报错为该节点已经加入其它集群的提示,可以尝试在其他节点上执行etcdctl member remove node-name将节点剔除集群,或者换一个新的集群认证token加入新的集群即可。
一、配置etcd数据库的更多相关文章
- k8s集群部署之环境介绍与etcd数据库集群部署
角色 IP 组件 配置 master-1 192.168.10.11 kube-apiserver kube-controller-manager kube-scheduler etcd 2c 2g ...
- XData -–无需开发、基于配置的数据库RESTful服务,可作为移动App和ExtJS、WPF/Silverlight、Ajax等应用的服务端
XData -–无需开发.基于配置的数据库RESTful服务,可作为移动App和ExtJS.WPF/Silverlight.Ajax等应用的服务端 源起一个App项目,Web服务器就一台,已经装了 ...
- 配置MySQL数据库
一.配置MySQL数据库 1.解压绿色版mysql,如下图 二.安装服务 1.运行cmd(管理员版本,否则没有权限),如下图 2.运行命令mysqld –install安装服务,如下图: 如果不需要m ...
- CAS 4.0.0RC 配置通过数据库认证用户登录
配置通过数据库认证用户登录 打开webapp\WEB-INF目录下的deployerConfigContext.xml,替换 <bean id="primaryAuthenticati ...
- 【转载】CentOS6.5_X64下安装配置MongoDB数据库
[转载]CentOS6.5_X64下安装配置MongoDB数据库 2014-05-16 10:07:09| 分类: 默认分类|举报|字号 订阅 下载LOFTER客户端 本文转载自zhm&l ...
- CentOS 7.0下配置MariaDB数据库
刚刚配置了下CentOS 7.0版本的服务器,配置数据库时发现# mysql_secure_installation命令用不了,之后网上查了一下发现CentOS 7.0版本用MariaDB替换了mys ...
- 如何利用tomcat和cas实现单点登录(2):配置cas数据库验证和cas客户端配置
接(1),上一篇主要讲述了tomcat和cas server端的部署. 接下来主要还有两个步骤. 注意:为了开启两个tomcat,要把直接配置的tomcat的环境变量取消!!!!!!!!!! 客户端配 ...
- 迅美VPS安装和配置MySQL数据库教程
MySQL相关教程与知识: 迅美VPS安装和配置MySQL数据库教程 navicat8管理MySQL教程-创建数据库和导入数据 navicat8管理MySQL教程-管理建立用户和分配 ...
- 原创教程:SpagoBI4.2汉化及配置Mysql数据库教程
SpagoBI4.2汉化及配置Mysql数据库教程 商务智能套件SpagoBI提供一个基于J2EE的框架用于管理BI对象如报表.OLAP分析.仪表盘.记分卡以及数据挖掘模型等的开源BI产品.它提供的B ...
随机推荐
- 兼容当前五大浏览器的渐变颜色背景gradient的写法
<style type="text/css" media="screen"> #gradient { width: 200px; height: 2 ...
- sass使用指南
[sass使用指南] http://www.ruanyifeng.com/blog/2012/06/sass.html
- Labyrinth(记忆化BFS)
Labyrinth http://codeforces.com/problemset/problem/1064/D time limit per test 2 seconds memory limit ...
- Asp.net中操作Excel的代码解析
一 . 使用Excel对象模型创建Excel文档: 1.创建简单的文档 try { 3 //创建Excel程序对象 Microsoft.Office.Interop.Excel.Application ...
- 查看CPU序列号以及系统信息
CPU序列号 wmic cpu get processorid 现在也不唯一,比如联想同款机器,因为CPU批量生产,id也是一样 操作系统信息 systeminfo 查看硬件信息 dxdi ...
- Spring框架的事务管理之编程式的事务管理(了解)
1. 说明:Spring为了简化事务管理的代码:提供了模板类 TransactionTemplate,所以手动编程的方式来管理事务,只需要使用该模板类即可!!2.手动编程方式的具体步骤如下: 1.步骤 ...
- css水波动画效果
代码来源:http://www.jq22.com/code1526 HTML: <div class="waves"></div> css: html, b ...
- .net core webapi 部署windows server 2008 r2 笔记
WebAPI部署文档 安装dotnet-dev-win-x64.1.0.4 安装DotNetCore.1.1.0-WindowsHosting 安装vc_redist.x64 安装Windows6.1 ...
- vmware fusion 10序列号
vmware fusion pro 10序列号 亲测可用激活 FG3TU-DDX1M-084CY-MFYQX-QC0RD
- 记录java版本不兼容的坑,(kafka运行报错)
启动kafka报错 错误原因是: 由较高版本的jdk编译的java class文件 试图在较低版本的jvm上运行的报错 解决办法是: 查看java版本 C:\Users\Administrator&g ...