这里只说明安装和注意事项,更具体的配置如端口号、cnf文件配置等就不写了。

阿里云开源镜像站资源目录 (aliyun.com)

我用的是基础版本。

基础版本镜像是默认不联网的,可以用下面的命令ping一下本机和百度。

ping 127.0.0.1

ping www.baidu.com

这时候要修改网络配置。

sudo vi /etc/sysconfig/network-scripts/ifcfg-ens33
// 修改配置ONBOOT=no----->ONBOOT=yes
// wq保存退出
service network restart //重启网络服务

此外最好就是两种方式都关闭防火墙和SELinux。

rpm方式

1.   安装wget

yum -y install wget

2.   在CentOS中将防火墙和SELinux临时关闭。

systemctl disable firewalld
setenforce 0
systemctl status firewalld

正常状态下Active会显示绿色激活状态,关掉就是如图所示。

3.   安装yum-utils

yum install yum-utils

4.   去官网复制下载链接,下载MySQL

点进去选个版本就好。

wget https://dev.mysql.com/get/mysql80-community-release-el7-5.noarch.rpm

注意上面写的是el7-5,而不是e17-5。。打错会报404的。

yum localinstall mysql80-community-release-el7-1.noarch.rpm

5. 禁用Mysql8.0版本,启用MySQL5.7版本

yum-config-manager --disable mysql80-community

yum-config-manager --enable mysql57-community

6.   安装mysql

 // 查看mysql的repo,确认是不是5.7版本
yum repolist enabled | grep mysql yum install -y mysql-community-server

7.   启动MySQL服务与查看状态

systemctl start mysqld.service

systemctl status mysqld.service

ss -natl | grep 3306

可以看到MySQL服务已经启动成功,默认是3306端口。

Mysql安装完成后会自动生成一个随机密码,使用随机密码即可登录或者修改密码。随机密码可以在MySQL的错误日志中找到。

grep 'temporary password' /var/log/mysqld.log

8.   登录Mysql

9. 设置密码(必须重新设置密码,不然用不了其它功能)

10. 创建数据库账号,并赋予权限

@左边是账号,右边是%(代表任意ip都可以使用的账号,也可以设置成localhost),

identified by 密码。

授予权限可以设置grant all on *.*,就是授予用户所有库表操作权限。

关闭MySQL

查看MySQL状态

找到mysqladmin文件

正常关闭MySQL,查看状态

源码编译方式(这个好麻烦,踩了很多坑,这里简化了)

1. 安装依赖包

rpm -e --nodeps mariadb-libs
yum -y install gcc gcc-c++ ncurses ncurses-devel cmake bison

2. 安装wget

和上面同理。

3. 去官网找源码包下载链接

这回选的是Mysql Community Server

https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.37.tar.gz

4.   用wget下载源码包、boost依赖包、openSSL包

wget https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.37.tar.gz
yum install openssl-devel
wget http://downloads.sourceforge.net/project/boost/boost/1.59.0/boost_1_59_0.tar.gz
// boost下载可能会比较慢

5. 创建用户与授权

useradd -M -s /sbin/nologin mysql
mkdir -p /mysql/data mkdir -p /usr/local/mysql
chown -R mysql:mysql /usr/local/mysql
chown -R mysql.mysql /mysql/data
chown 750 /mysql/data

6. 解压

tar xzf boost_1_59_0.tar.gz
tar xzf mysql-5.7.37.tar.gz

7. 预编译

cd mysql-5.7.37

cmake . -DCMAKE_INSTALL_PREFIX=/usr/local/mysql \
-DMYSQL_DATADIR=/mysql/data \
-DWITH_BOOST=../boost_1_59_0 \
-DSYSCONFDIR=/etc \
-DENABLED_LOCAL_INFILE=1 \
-DENABLE_DTRACE=0 \
-DDEFAULT_CHARSET=utf8mb4 \
-DDEFAULT_COLLATION=utf8mb4_general_ci \
-DWITH_EMBEDDED_SERVER=1

8. 编译安装与添加环境变量

make -j $(grep processor /proc/cpuinfo | wc -l) //耐心等待

make install

echo -e '\n\nexport PATH=/usr/local/mysql/bin:$PATH\n' >> /etc/profile && source /etc/profice

这两条命令执行都要相当久,如果vmware显示有问题了(比如黑屏、文字显示不正常)的时候可以按一下回车。

9. 添加MySQL服务到systemed。复制可执行文件到指定的目录下,并修改名字为mysqld,授予权限,设置开机自启

cp /usr/local/mysql/support-files/mysql.server /etc/init.d/mysqld

chmod +x /etc/init.d/mysqld
systemctl enable mysqld
systemctl start mysqld

可以看到最后一句启动MySQL报错了,

Failed to start LSB: start and stop MySQL.

查看日志:

cd到/etc/init.d去启动服务,报错发现有个err文件。

直接说解决方法:

vi /etc/my.cnf
// 添加如下内容
[mysqld]
skip-grant-table

ERROR! The server quit without updating PID file (/data/mysql/mysql.pid)_Hot Cocoa的博客-CSDN博客

10. 查看端口状态

systemctl status mysqld.service

ss -natl | grep 3306

==================================================================================================

网络报错解决方法:

// 停掉NetworkManager
service NetworkManager stop
chkconfig NetworkManager off

用阿里云镜像Centos7通过rpm和源码编译方式安装MySQL5版本的更多相关文章

  1. centos7下源码编译方式安装httpd

    前言 Apache至少需要apr.apr-util.pcre组件的支持. APR(Apache portable Run-time libraries,Apache可移植运行库)的目的如其名称一样,主 ...

  2. 使用阿里云镜像站NTP服务搭建NTP服务器(基于CentOS 7系统)

    镜像下载.域名解析.时间同步请点击 阿里云开源镜像站 一.NTP服务器介绍 网络时间协议(Network Time Protocol,NTP)服务器,也就是日常所说的NTP服务器,用来提供同步时间服务 ...

  3. 在阿里云ECS CentOS7上部署基于MongoDB+Node.js的博客

    前言:这是一篇教你如何在阿里云的ECS CentOS 7服务器上搭建一个个人博客的教程,教程比较基础,笔者尽可能比较详细的把每一步都罗列下来,包括所需软件的下载安装和域名的绑定,笔者在此之前对Linu ...

  4. (二)初探Maven之设置代理和阿里云镜像

    引言:           在许多公司,可能因为安全性的要求配置了代理服务器,用户无法直接访问外网,所以在项目中使用Maven必须设置好代理才能下载依赖.           并且直接从中央仓库下载依 ...

  5. contos 7创建阿里云镜像源

    今天在ESC上安装mariaDB,发现centOS 7默认的yum源上的mariaDB版本过低,然后又镜像到网易上,发现网易源上没有mariaDB,几经折腾才发现阿里镜像上mariaDB版本较新.更改 ...

  6. ubuntu 软件包(package)更换源(source)为阿里云镜像 update&upgrade

    在ubuntu下用apt-get install安装软件时,发现package list中没有所需的软件, 估计可能是package list太旧了,于是需要apt-get update & ...

  7. 阿里云服务器centos7环境下安装xampp后,mysql有进程,但是却没有监听3306端口

    配置阿里云服务器centos7中xampp环境时出现了一种情况: 在centos中可以使用命令进入mysql 修改后也可以远程用phpmyadmin连接mysql 但是用navicat却无法连接 先修 ...

  8. CentOS8 使用 aliyun 阿里云 镜像站点的方法

    CentOS8现已可使用国内的aliyun阿里云镜像站,方法如下: 用cd命令切换到yum.repos目录,备份原始的3个repo文件:cd /etc/yum.repos.d/sudo cp Cent ...

  9. 阿里云ECS(Centos7.2 64bit)安装Docker

    购买了阿里云的ECS服务器后,一直在尝试安装Docker,使用过Ubuntu和CentOS系统,也一直在查找文档,但都是Docker安装完成后却无法访问,一直在ECS上不停的更换系统盘 再次按官方文档 ...

  10. 阿里云ECS 固定带宽变为按量付费的方式

    阿里云ECS 固定带宽变为按量付费的方式 阿里云控制台 2.升降配置-降低配置-降低至最低配置 3.为按量带宽设置一个峰值,例如100M. 4.过几分钟,就自动变为按量付费的带宽了.

随机推荐

  1. Blazor前后端框架Known功能介绍:系统安装激活及自定义

    本章介绍系统安装与激活及其自定义功能. 概述 框架内置简单的系统安装功能. 录入企业编码.名称.系统名称.产品密钥.管理员密码信息完成安装. 可自定义高级安装功能,如安装数据库等您产品所需的安装信息. ...

  2. java端口被占用解决办法

  3. 多app应用(推荐方式)

    多app应用目录结构 项目单独一个app结构: 多个app: 多个app放在一个apps文件夹中, 在根目录下创建apps的文件夹 操作: 没勾选template,那么项目根目录就没有template ...

  4. [SDOI2008] 仪仗队【题解】

    题目描述 作为体育委员,C 君负责这次运动会仪仗队的训练.仪仗队是由学生组成的 \(N \times N\) 的方阵,为了保证队伍在行进中整齐划一,C 君会跟在仪仗队的左后方,根据其视线所及的学生人数 ...

  5. 避坑 | OI排雷新生态

    可持久化线段树 query 的时候两结点的 sz 相减的时候一定是左儿子相减. 可持久化线段树建新点要将原来的不更改的节点连接上. 动态规划也可以倒着考虑. P3957的单调队列是先加入后删除,否则加 ...

  6. Vue3 中 keepAlive 如何搭配 VueRouter 来更自由的控制页面的状态缓存?

    在 vue 中,默认情况下,一个组件实例在被替换掉后会被销毁.这会导致它丢失其中所有已变化的状态--当这个组件再一次被显示时,会创建一个只带有初始状态的新实例.但是 vue 提供了 keep-aliv ...

  7. 【路由器】OpenWrt 简介和安装

    目录 简介 来源 介绍 安装 一般安装流程 固件搜索下载 参考资料 简介 来源 2002 年底 Linksys 公司推出 WRT-54G,采用了 Linux 取代了原来的 vXworks 系统.迫于 ...

  8. sql-labs--Less-1--Error based-Single quotes

    sql="SELECT * FROM users WHERE id='id' LIMIT 0,1"; 打开第一关,我们看到如下界面,上面写着Please input the ID ...

  9. 弹性数据库连接池探活策略调研(一)——HikariCP

    调研背景: 数据库连接建立是比较昂贵的操作(至少对于 OLTP),不仅要建立 TCP 连接外还需要进行连接鉴权操作,所以客户端通常会把数据库连接保存到连接池中进行复用.连接池维护到弹性数据库(JED) ...

  10. [EasyExcel] 导出合并单元格

    前言 使用spring boot 对excel 进行操作在平时项目中要经常使用.常见通过jxl和poi 的方式进行操作.但他们都存在一个严重的问题就是非常的耗内存.这里介绍一种 Easy Excel ...