zabbix snmp 协议监控 dell iRDAC
转摘:http://blog.csdn.net/wanglei_storage/article/details/52789921
http://blog.csdn.net/wanglei_storage/article/details/52794459
Dell iDRAC
iDRAC又称为Integrated Dell Remote Access Controller,也就是集成戴尔远程控制卡,这是戴尔服务器的独有功能,iDRAC卡相当于是附加在服务器上的一计算机,可以实现一对一的服务器远程管理与监控,通过与服务器主板上的管理芯片BMC进行通信,监控与管理服务器的硬件状态信息。它拥有自己的系统和IP地址,与服务器上的OS无关。是管理员进行远程访问和管理的利器,戴尔服务器集成了iDRAC控制卡,我们就可以扔掉价格昂贵的KVM设备了。在戴尔第12代服务器中,iDRAC的版本升级到了iDRAC 7
首先,我们需要在BIOS中启用iDRAC功能
一、启动Dell服务器,按F2 System Setup,打开BIOS界面,选择iDRAC Settings
二、在IDRAC Settings界面中选择Network
三、在Network界面中 Enable NIC,并且选择NIC接口,我这边为LOM1
四、设置iDRAC IPV4地址
也可以通过服务器显示窗口设置
五、设置完成之后即可通过web页面进行管理
初此打开该页面后需要修改默认密码
账户:root 密码:calvin
六、现在即可通过iDRAC的web页面进行管理
实验目的:
该篇文章主要是通过zabbix snmp协议来监控dell服务器的硬件信息(需要启用并且配置iRDAC功能)
先简单了解下SNMP协议:
简单网络管理协议(SNMP),由一组网络管理的标准组成,包含一个应用层协议(application layer protocol)、数据库模型(database schema)和一组资源对象。该协议能够支持网络管理系统,用以监测连接到网络上的设备是否有任何引起管理上关注的情况。该协议是互联网工程工作小组(IETF,Internet Engineering Task Force)定义的internet协议簇的一部分。SNMP的目标是管理互联网Internet上众多厂家生产的软硬件平台,因此SNMP受Internet标准网络管理框架的影响也很大。SNMP已经出到第三个版本的协议,其功能较以前已经大大地加强和改进了。
Dell服务器启用iDRAC功能可以参考我上一篇博文:
http://blog.csdn.net/wanglei_storage/article/details/52789921
在这之前,需要有两个操作,如果你已经完成下列两项,则直接开始监控操作即可
- 安装zabbix server
- 在dell服务器BIOS中开启iDRAC功能
一、iDRAC开启SNMP服务
1、打开iDRAC web页面,输入账户密码
2、启用SNMP协议
登录之后单击 —> iDRAC设置 —> 网络 —> 服务 —> SNMP代理
下列几点需要注意(待会zabbix中会用到):
已启用 √
SNMP团体名称 xkeshi
SNMP协议 所有(SNMP v1/2/3)
SNMP查找端口号 161
3、zabbix 服务端通过snmp验证
[root@dev70 ~]# snmpget -v 2c -c <Community> <iDRAC IP> .1.3.6.1.4.1.674.10892.2.1.1.2.0
[root@dev70 ~]# snmpget -v 2c -c xkeshi 192.168.184.200 .1.3.6.1.4.1.674.10892.2.1.1.2.0
SNMPv2-SMI::enterprises.674.10892.2.1.1.2.0 = STRING: "iDRAC8"
二、配置zabbix
1、创建值映射
zabbix web界面 —> 管理 —> 一般 —> 值映射
将根据下列名称进行值映射
- DellDracDiskState
1 -> Unknown
2 -> Ready
3 -> Online
4 -> Foreign
5 -> Offline
6 -> Blocked
7 -> Failed
8 -> Non-RAID
9 -> Removed
- Dell iDRAC Network Device Connection Status
1 -> Connected
2 -> Disconnected
- Dell Open Manage System Status
1 -> Other
2 -> Unknown
3 -> OK
4 -> NonCritical
5 -> Critical
6 -> NonRecoverable
- DellPowerState
1 -> Other
2 -> Unknown
3 -> Off
4 -> On
- Dell PSU State Settings
1 -> Unknown
2 -> Online (state disabled)
4 -> not Ready
8 -> Fan Failure
10 -> Online and Fan Failure
16 -> On
242 -> Online and OK
- DellRaidLevel
1 -> Unknown
2 -> RAID-0
3 -> RAID-1
4 -> RAID-5
5 -> RAID-6
6 -> RAID-10
7 -> RAID-50
8 -> RAID-60
9 -> Concatenated RAID 1
10 -> Concatenated RAID 5
- DellRaidVolumeState
1 -> Unknown
2 -> Online
3 -> Failed
4 -> Degraded
- Dell_PSU_SensorState
1 -> Presence Detected
2 -> PS Failure
4 -> Predictuve Failure
8 -> PS AC lost
16 -> AC lost or out of range
32 -> AC out of range but still present
2、配置全局变量{$SNMP_COMMUNITY_IDRAC}
zabbix web界面 —> 管理 —> 一般 —> 宏
3、导入模板
模板下载地址:https://github.com/endersonmaia/zabbix-templates/tree/master/dell/idrac
zabbix web界面 —> 配置 —> 模板 —> 导入
Template_Dell_iDRAC_SNMPv2.zbx.xml
4、创建主机
zabbix web界面 —> 配置 —> 主机 —> 创建主机
输入主机地址及SNMP地址和端口,保存
5、查看监控状态
至此,所有操作步骤已经完成,你可以定义不同的图形将所有的监控项进行整合,例如:
zabbix snmp 协议监控 dell iRDAC的更多相关文章
- 在ZABBIX平台上通过SNMP协议监控网络设备
在ZABBIX平台上通过SNMP协议监控网络设备 方法一:自动发现监控项 ZABBIX自带模板Template SNMP Interfaces中有"自动发现规则"这一选项,在主机选 ...
- zabbix基于SNMP 协议监控路由器
zabbix基于SNMP 协议监控路由器 步骤 步骤超级方便. 1. 路由器上开启snmp 2. 确保外网能訪问到 3. 用snmpwalk測试 4. 加入zabbix主机,SNMP interfac ...
- Zabbix通过SNMPv2监控DELL服务器的硬件信息
(一)zabbix监控DELL服务器 (1)简述:监控DELL服务器硬件一般有两种途径:1.操作系统上安装OMSA,编写脚本调用omreport命令进行监控(需要在操作系统上安装比较麻烦):2.使用i ...
- zabbix企业应用:通过SNMP和iDRAC监控DELL服务器硬件
原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 .作者信息和本声明.否则将追究法律责任.http://qicheng0211.blog.51cto.com/3958621/174998 ...
- zabbix企业级监控dell硬件服务状态
监控dell服务的硬件状态,一般有两种方式 第一,在操作熊上安装OMSA,编写脚本调用omreport命令进行监控 第二.使用IDRAC,只需开启在IARAC上的SNMP,zabbix通过snmp进行 ...
- zabbix监控DELL服务器硬件状态
zabbix监控DELL服务器硬件状态 登录dell服务的管理页面 默认用户名:root 密码:calvin 服务器开放snmp信息,开启完应用 Zabbix服务器导入dell监控硬件模板 验证 sn ...
- (37)zabbix snmp类型 无需安装agent也能监控
概述 如果我们需要监控打印机.路由器.UPS等设备,肯定不能使用zabbix agentd,因为他们不能安装软件的,还好他们一般都支持SNMP协议,这样我可以使用SNMP来监控他们.如果你希望使用SN ...
- zabbix snmp监控与主被模式
1.snmp基础介绍 snmp全称是简单网络管理协议 为什么要用? 路由器交换机无法安装agent程序,但是都提供snmp服务端, 我们可以使用zabbix的snmp方式监控snmp服务端的数据 2. ...
- centos7之zabbix监控DELL磁盘阵列
本篇我们介绍戴尔服务器R730.R720.R710等服务器下挂在的MD1200磁盘阵列柜监控方式 一.使用场景 在生产环境中存储肯定是离不开的,服务器自带的硬盘卡槽有限,所以一般需要存储的量大的话,都 ...
随机推荐
- 一块网卡多个IP实现
////////////////////////////写在前面//////////////////////////////////////////// 需要注意,这里我们是一块网卡多个IP,而并非是 ...
- Java class、Object、Class 的区别
Java的对象模型中: 所有的类都是Class类的实例,Object是类,那么Object也是Class类的一个实例. 所有的类都最终继承自Object类,Class是类,那么Class也继承自Obj ...
- Django开发点菜系统学习笔记
1.使用django-simple-captcha包的时候,会调用到: register_form = RegisterForm(request.POST) 但是这个时候captcha不进行错误检验, ...
- zend studio 添加xdebug调试php代码
1.Eclipse下对于大部分语言都提供了调试器接口,自然的对于PHP,Zend已经集成了XDebug调试器,找到Zend中的Preferences->PHP->Debug, 将调试器设置 ...
- Linux下Python安装(脚本全)
在linux下安装Python: # 下载最新版本 cd /usr/local/src/ sudo wget http://www.python.org/ftp/python/3.3.2/Python ...
- python面向对象( item系列,__enter__ 和__exit__,__call__方法,元类)
python面向对象进阶(下) item系列 __slots__方法 __next__ 和 __iter__实现迭代器 析构函数 上下文管理协议 元类一.item系列 把对象操作属性模拟成字典的 ...
- msbuild编译
@echo offcd /d %~dp0 if exist output.log del /q /f output.logif exist success.txt del /q /f success. ...
- Activiti 教程
Activiti入门教程:http://blog.csdn.net/column/details/activitizhou.html Activiti 5.15 用户手册:http://www.cnb ...
- week05《Java程序设计》第五次学习总结
week05<Java程序设计>第五次学习总结 1. 本周学习总结 1.1 写出你认为本周学习中比较重要的知识点关键词 答:关键词:接口,inteface关键词,implement关键词, ...
- 关于SQL Sever连接问题
错误: 与 SQL Server 建立连接时出现与网络相关的或特定于实例的错误.未找到或无法访问服务器.请验证实例名称是否正确并且 SQL Server 已配置为允许远程连接. (provider: ...