compute节点上开启服务openstack-nova-compute.service时,无法启动的解决方法
本文前一部分为本人解决问题的过程,但最终没有解决;无奈在网上找方法时,看到有网友评论说:修改controller上的guest账号密码,再重启openstack-nova-compute.service就可正常重启,结果一试,问题解决,感谢大神。
1. 在compute节点上开启服务openstack-nova-compute.service时,无法启动,命令一直卡着不动,如下:

2.查看日志,在/var/log/nova-compute.log中看到在controller上的5672端口不可达:

3. 在controller节点上放通防火墙5672端口:
[root@controller ~]# firewall-cmd --zone=public --add-port=5672/tcp --permanent //放通5672端口
Warning: ALREADY_ENABLED: 5672:tcp
success
[root@controller ~]# systemctl restart firewalld //重启防火墙
[root@controller ~]# firewall-cmd --zone=public --query-port=5672/tcp //查看5672端口是否放通
yes
4. 在compute节点上,重启libvirtd.service,openstack-nova-compute.service。发现libvirtd.service正常启动,openstack-nova-compute.service仍然无法启动。
[root@compute1 ~]# systemctl start libvirtd.service
[root@compute1 ~]# systemctl start openstack-nova-compute.service
Job for openstack-nova-compute.service failed because the control process exited with error code. See "systemctl status openstack-nova-compute.service" and "journalctl -xe" for details.

5. 查看journalctl -xe报错,仅仅只能看到服务启动失败,仍然没有有效信息。

6. 同时,查看compute节点上的nova-compute.log日志文件,发现身份验证机制AMQPLAIN拒绝登录。

7. 返回到controller节点,核查rabbitmq服务是否开启,5672端口是否打开,结果显示都是正常打开。
[root@controller ~]# ps -ef|grep rabbitmq
rabbitmq 1345 1 0 02:14 ? 00:00:25 /usr/lib64/erlang/erts-7.3.1.2/bin/beam -W w -A 64 -P 1048576 -t 5000000 -stbt db -K true -- -root /usr/lib64/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.6.5/ebin -noshell -noinput -s rabbit boot -sname rabbit@controller -boot start_sasl -config /etc/rabbitmq/rabbitmq -kernel inet_default_connect_options [{nodelay,true}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@controller.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@controller-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.6.5/plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@controller-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@controller" -kernel inet_dist_listen_min 25672 -kernel inet_dist_listen_max 25672
rabbitmq 2254 1345 0 02:14 ? 00:00:00 inet_gethost 4
rabbitmq 2255 2254 0 02:14 ? 00:00:00 inet_gethost 4
root 25827 15202 0 10:40 pts/3 00:00:00 grep --color=auto mq
You have mail in /var/spool/mail/root
[root@controller ~]# netstat -na|grep 5672
tcp 0 0 0.0.0.0:25672 0.0.0.0:* LISTEN
tcp6 0 0 :::5672 :::* LISTEN
8. 于是又看了下rabbitmq日志(/var/log/rabbitmq/rabbit\@controller.log-20190725),结果显示用户openstack拥有无效凭证,如下:

9. 心想重新给用户openstack赋予权限试下:
[root@controller rabbitmq]# rabbitmqctl list_users
Listing users ...
openstack []
guest [administrator]
[root@controller rabbitmq]# rabbitmqctl set_permissions -p / openstack '.*' '.*' '.*'
Setting permissions for user "openstack" in vhost "/" ...
[root@controller rabbitmq]# systemctl restart rabbitmq_server.service
10. 结果仍然提示相同的错误,于是在网上查看网友的解决方法,就看到一个网友说自己修改了用户guest的密码后,恢复正常;尝试后故障恢复。
[root@controller rabbitmq]# rabbitmqctl change_password guest shroot123
Changing password for user "guest" ...
[root@controller rabbitmq]# systemctl restart rabbit_server.service //修改完后重启会有以下报错,等会再重启就可以正常
Failed to restart rabbit_server.service: Unit not found.
[root@controller rabbitmq]# systemctl restart rabbitmq-server.service
[root@controller rabbitmq]# systemctl status rabbitmq-server.service
● rabbitmq-server.service - RabbitMQ broker
Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled; vendor preset: disabl
Active: active (running) since Thu 2019-07-25 11:24:37 CST; 5s ago
Process: 31959 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
Main PID: 32075 (beam)
Status: "Initialized"
CGroup: /system.slice/rabbitmq-server.service
├─32075 /usr/lib64/erlang/erts-7.3.1.2/bin/beam -W w -A 64 -P 1048576 -t 5000000 -stbt
├─32271 inet_gethost 4
└─32272 inet_gethost 4
Jul 25 11:24:35 controller systemd[1]: Starting RabbitMQ broker...
Jul 25 11:24:36 controller rabbitmq-server[32075]: RabbitMQ 3.6.5. Copyright (C) 2007-2016 Pivotal
Jul 25 11:24:36 controller rabbitmq-server[32075]: ## ## Licensed under the MPL. See http:/
Jul 25 11:24:36 controller rabbitmq-server[32075]: ## ##
Jul 25 11:24:36 controller rabbitmq-server[32075]: ########## Logs: /var/log/rabbitmq/rabbit@cont
Jul 25 11:24:36 controller rabbitmq-server[32075]: ###### ## /var/log/rabbitmq/rabbit@cont
Jul 25 11:24:36 controller rabbitmq-server[32075]: ##########
Jul 25 11:24:36 controller rabbitmq-server[32075]: Starting broker...
Jul 25 11:24:37 controller systemd[1]: Started RabbitMQ broker.
Jul 25 11:24:37 controller rabbitmq-server[32075]: completed with 0 plugins.
再返回compute节点重启openstack-nova-compute.service,正常。
[root@compute1 ~]# systemctl restart openstack-nova-compute.service
[root@compute1 ~]# systemctl status openstack-nova-compute.service
● openstack-nova-compute.service - OpenStack Nova Compute Server
Loaded: loaded (/usr/lib/systemd/system/openstack-nova-compute.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2019-07-25 12:18:40 CST; 6s ago
Main PID: 12552 (nova-compute)
Tasks: 22
CGroup: /system.slice/openstack-nova-compute.service
└─12552 /usr/bin/python2 /usr/bin/nova-compute
Jul 25 12:18:34 compute1 systemd[1]: Stopped OpenStack Nova Compute Server.
Jul 25 12:18:34 compute1 systemd[1]: Starting OpenStack Nova Compute Server...
Jul 25 12:18:40 compute1 systemd[1]: Started OpenStack Nova Compute Server.
Jul 25 12:18:40 compute1 nova-compute[12552]: /usr/lib/python2.7/site-packages/oslo_messaging/...
Jul 25 12:18:40 compute1 nova-compute[12552]: access_policy)
Hint: Some lines were ellipsized, use -l to show in full.
虽然问题解决了,但仍然一头雾水,不明原因,不过问题解决也挺开心,因此也将自己解决的这个过程分享出来,希望对大家有帮助,也希望有哪位网友分析出原因,请在评论区回复,谢谢。
compute节点上开启服务openstack-nova-compute.service时,无法启动的解决方法的更多相关文章
- Windows 10+Ubuntu 16.04在MBR分区上安装双系统之后没有Windows 10的启动菜单解决方法
背景: 硬盘分区方式:MBR 硬盘容量256,Windows 100,Ubuntu 156,其中主分区安装的是Windows,Ubuntu安装在逻辑分区上,文件系统为Ext4,整个Ubuntu就挂载在 ...
- Docker安装、命令详情、层级架构、docker服务启动失败解决方法
容器背景: 层级架构: 容器对比传统化虚拟机: 可以把docker理解成是一款自带软件(比如:nignx.tomcat.....)的镜像操作系统(首先是要下载镜像) 以下是Windows环境安装Do ...
- Apache服务无法启动的解决方法
apache服务无法启动的解决方法 在配置apache的时候,把apache安装为服务myweb,用apacheMonitor启动myweb发现无法启动,提示:the requested operat ...
- linux上备份Oracle时EXP-00091的错误解决方法
unix/linux上备份Oracle时EXP-00091的错误解决方法 unix/linux上备份数据时的错误解决方法 EXP-00091: Exporting questionable stati ...
- MySQL 1053错误 服务无法正常启动的解决方法
MySQL 1053错误 服务无法正常启动的解决方法 1.右键我的电脑,管理,进入服务 2.右键单击Mysql8 属性,选择登陆 选择此账号 登陆管理员账号
- 【FAQ】华为帐号服务报错 907135701的常见原因总结和解决方法
很多开发者在接入华为帐号服务时,经常会出现907135701的报错.根据官网文档说明,错误码907135701表示: 这个错误码在安卓和鸿蒙上都会出现,导致该报错的原因有很多,开发者可以按照下面几点进 ...
- 在Dell R720服务器上安装ESXI5.5时会出现卡在LSI_MR3.V00的解决方法
接近年底,公司各种活动,各种加班,导致没有太多时间写博客,今抽了点时间将前几天搭建虚拟化服务时所出现的一个问题描述下: 服务器配置:CUP E5-2609 内存32G 硬盘5 ...
- 使用wamp扩展php时出现服务未启动的解决方法
今天在使用wamp扩展php的插件时,出现了如下图所示的错误提示 网上查了查,都说是端口原因,修改Apache的 80端口,但是并没有解决问题. 最后我终于找到了解决方法,步骤很简单,如下: 首先,在 ...
- jenkins在windows服务器上执行含git push命令的脚本权限不足的解决方法
错误摘要 默认情况下执行脚本是没问题的,但是脚本中含有git push命令就无法执行了 用jenkins部署hexo博客时候遇到的,执行hexo d -g一直阻塞至Build was aborted, ...
随机推荐
- 学习Java,容易被你忽略的小细节(3)
在<学习Java,容易被你忽略的小细节(2)>中我们已经深入讨论过String类中equals()方法的使用,在本文中我们将进一步讨论equals()方法在其他境况下的使用方法. 首先,我 ...
- 如何理解<T extends Comparable<? super T>>
在看java容器类的时候经常可以看到<T extends Comparable<? super T>>,感觉十分不解? 我们觉得<T extends Comparable ...
- openstack namespace 的应用
查看虚拟机网络连通性 1.neutron port-list | grep IP 2.neutron port-show ID 查看subnet 3.neutron subnet-show ID 查看 ...
- MCtalk对话尚德机构:AI讲师,假套路还是真功夫?
一间容纳百人的被挤得满满的教室,老师讲.学生听.线下课堂曾是职业教育最普遍的形式.随着移动互联网的普及,大量的学习行为逐渐转化到线上进行,传统教育机构如何抓住这轮技术转型的契机,而不是被它吞噬? 近日 ...
- js获取radio选中索引值
<form name="form1" onsubmit="return foo()"> <input type="radio&quo ...
- Git及基础命令的介绍以及如何向本地仓库添加文件
在介绍Git的使用之前,我们得要先来了解一下Git.那么什么是Git? Git是一个版本管理工具(VCS),具有以下的特点: 分布式版本控制: 多个开发人员协调工作: 有效监听谁做的修改: 本地及远程 ...
- Git项目迁移
代码项目迁移步骤 1.将原有项目重命名,old 2.新建一个项目,名字为原本的项目名称,new 3.使用特殊方式克隆代码 # old.git为原项目重命名后的git链接 git clone --mir ...
- CentOS 7 时区设置 timedatectl
[root@testandy ~]# timedatectl --help timedatectl [OPTIONS...] COMMAND ... Query or change system ti ...
- Linux实例/etc/fstab文件配置错误导致系统启动异常
Centos 7.3系统 问题现象: 阿里云ECS升级配置后重启,SSH连接不上.登录控制台远程连接ECS,出现以下界面. 提交工单阿里云反馈:https://help.aliyun.com/kno ...
- Atlassian In Action-Jira之指导思想(一)
太上,不知有之:其次,亲而誉之:其次,畏之:其次,侮之.信不足焉,有不信焉.悠兮,其贵言.功成事遂,百姓皆谓"我自然". --<道德经> 研发管理或者系统工具的指导思想 ...