Linux格式化分区报错Could not start /dev/sda No such file or directory 解决办法
Linux查看已经分好的区
[root@linuxidc ~]# fdisk -l /dev/sda
Disk /dev/sda: 21.5 GB, 21474836480 bytes
255 heads, 63 sectors/track, 2610 cylinders
Units = cylinders of 16065 * 512 = 8225280bytes
Sector size (logical/physical): 512 bytes /512 bytes
I/O size (minimum/optimal): 512 bytes / 512bytes
Disk identifier: 0x7d57cb1f
Device Boot Start End Blocks Id System
/dev/sda1 1 2610 20964793+ 5 Extended
/dev/sda5 1 128 1028097 83 Linux
/dev/sda6 129 256 1028128+ 83 Linux
/dev/sda7 257 384 1028128+ 83 Linux
格式化新分区的时候,报错,提示下面的错误,没有这个文件或目录。
Could not stat /dev/sda7 --- No such fileor directory
The device apparently does not exist; didyou specify it correctly?
[root@linuxidc ~]# mke2fs -t ext4 /dev/sda7
mke2fs 1.41.12 (17-May-2010)
Could not stat /dev/sda7 --- No such fileor directory
The device apparently does not exist; didyou specify it correctly?
解决方法:执行partprobe 命令
partprobe包含在parted的rpm软件包中。
partprobe可以修改kernel中分区表,使kernel重新读取分区表。
因此,使用该命令就可以创建分区并且在不重新启动机器的情况下系统能够识别这些分区。
查看是否安装过该命令:
[root@linuxidc~]# rpm -q parted
packageparted is not installed
提示没有安装过,则需要安装parted
安装命令:#yum install parted #前提是保证你的虚拟机可以上网,要从网络下载安装包
[root@linuxidc~]# yum install parted
Loadedplugins: fastestmirror
1234567 Loadingmirror speeds from cached hostfile
* base: mirrors.skyshe.cn
* extras: mirrors.skyshe.cn
* updates: mirrors.skyshe.cn
base | 3.7 kB 00:00
extras |3.3 kB 00:00
updates | 3.4 kB 00:00
Settingup Install Process
ResolvingDependencies
-->Running transaction check
--->Package parted.i686 0:2.1-25.el6 will be installed
-->Finished Dependency Resolution
DependenciesResolved
=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
parted i686 2.1-25.el6 base 595 k
TransactionSummary
=============================================================================
Install 1 Package(s)
Totaldownload size: 595 k
Installedsize: 2.1 M
Isthis ok [y/N]: y
DownloadingPackages:
parted-2.1-25.el6.i686.rpm | 595 kB 00:16
Runningrpm_check_debug
RunningTransaction Test
TransactionTest Succeeded
RunningTransaction
Installing : parted-2.1-25.el6.i686 1/1
Verifying : parted-2.1-25.el6.i686 1/1
Installed:
parted.i686 0:2.1-25.el6
Complete!
安装完成后,再进行查询一次,已经安装成功。
[root@linuxidc~]# rpm -q parted
parted-2.1-25.el6.i686
执行一下该命令:
[root@linuxidc~]# partprobe
Warning:WARNING: the kernel failed to re-read the partition table on /dev/sda (Deviceor resource busy). As a result, it maynot reflect all of your changes until after reboot.
Warning:WARNING: the kernel failed to re-read the partition table on /dev/sdb (Deviceor resource busy). As a result, it maynot reflect all of your changes until after reboot.
Warning:Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0 has been opened read-only.
Warning:Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0 has been opened read-only.
Error:Invalid partition table - recursive partition on /dev/sr0.
然后执行格式化,就OK了,如果还提示出错,重启之后再执行格式化就可以了。
[root@linuxidc~]# mkfs -t ext4 /dev/sda7
mke2fs1.41.12 (17-May-2010)
Filesystemlabel=
OStype: Linux
Blocksize=4096 (log=2)
Fragmentsize=4096 (log=2)
Stride=0blocks, Stripe width=0 blocks
64384inodes, 257032 blocks
12851blocks (5.00%) reserved for the super user
Firstdata block=0
Maximumfilesystem blocks=264241152
8block groups
32768blocks per group, 32768 fragments per group
8048inodes per group
Superblockbackups stored on blocks:
32768, 98304, 163840, 229376
Writinginode tables: done
Creatingjournal (4096 blocks): done
Writingsuperblocks and filesystem accounting information: done
Thisfilesystem will be automatically checked every 35 mounts or
180days, whichever comes first. Use tune2fs-c or -i to override.
Linux格式化分区报错Could not start /dev/sda No such file or directory 解决办法的更多相关文章
- Linux 格式化分区 报错Could not stat --- No such file or directory 和 partprobe 命令
分区的过程正常: [root@db1 /]# fdisk -l Disk /dev/sda: 21.4 GB, 21474836480 bytes 255 heads, 63 sectors/tr ...
- ././include/linux/kconfig.h:4:32: fatal error: generated/autoconf.h: No such file or directory 解决办法
我在编写内核驱动模块的时候报了一个非常奇怪的错误,如下图: 在目录下看了一下确实没有发现这个文件,感觉很奇怪,因为我记得之前编译模块是没有错误的,所以不可能是我代码写的有问题. 查阅了资料很多说要清除 ...
- (转)启动网卡报错(Failed to start LSB: Bring up/down networking )解决办法总结
启动网卡报错(Failed to start LSB: Bring up/down networking )解决办法总结 原文:http://blog.51cto.com/11863547/19059 ...
- 搭建elsticsearch集群 报错with the same id but is a different node instance解决办法
搭建elsticsearch集群 报错with the same id but is a different node instance解决办法 学习了:https://blog.csdn.net/q ...
- MySQL8.0报错Can't connect to MySQL server on 'localhost' (10061)的解决办法
MySQL8.0报错Can't connect to MySQL server on 'localhost' (10061)的解决办法 事情的起因 今天课堂上要展示小组项目,需要用一个软件叫W ...
- nginx 启动报错“var/run/nginx/nginx.pid" no such file or directory
nginx 启动报错“var/run/nginx/nginx.pid" no such file or directory 今天刚搭建的nginx服务器启动时,报错“var/run/ngin ...
- shell 报错 /bin/bash^M: bad interpreter: No such file or directory
shell 执行报错: ./test.sh: /bin/bash^M: bad interpreter: No such file or directory 原因:window和linux 的文件格式 ...
- 升级openssh编译报错“configure: error: *** working libcrypto not found, check config.log”的解决办法
问题描述 在linux上,欲将OpenSSH_6.4p1编译升级到OpenSSH_8.0p1时,执行了./configure --prefix=/usr --sysconfdir=/etc/ssh - ...
- CURL命令报错:dyld: lazy symbol binding failed: Symbol not found: _SSL_load_error_strings解决办法
Mac OS X 10.11.6, curl 命令报错,错误如下: dyld: lazy symbol binding failed: Symbol not found: _SSL_load_erro ...
随机推荐
- Java学习日记-2.5 关于0和无穷
1. 无穷 Java中将无穷定义为浮点数,分为正负无穷,分别为POSITIVE_INFINITY和NEGATIVE_INFINITY 2. null null在java中可以理解为一个特殊的引用类型, ...
- L - Kakuro Extension - HDU 3338 - (最大流)
题意:有一个填数字的游戏,需要你为白色的块内填一些值,不过不能随意填的,是有一些规则的(废话),在空白的上方和作方给出一些值,如果左下角有值说明下面列的和等于这个值,右上角的值等于这行后面的数的和,如 ...
- CSS里的 no-repeat 是什么意思
CSS里的 no-repeat是针对背景图片来说的.当你设置了no-repeat这个属性后,你的背景图片将不会被重复,再换一种说法,你在网站上所看到的背景图片就是你所添加的图片, 不会出现平铺或者重复 ...
- WPF: How to use DatePicker in XAML-DataGrid
https://msdn.microsoft.com/en-us/library/system.windows.controls.datagridtemplatecolumn(v=VS.100).as ...
- Apache服务器 配置多个网站解决方案
2016.5.28 今周六 下午 阴 无风 周末接了个小单,弄一个企业站,用php语言:于是又要拿起好久没动的php啦! 关键第一步是搭建Apache环境,在这里本人用的是wamp ...
- 利用Jenkins自动部署工具间接构建kettle的调度平台
关于Jenkins的介绍我就不说了,自己百度,因为这个工具调用脚本只是他的功能的冰山一角,其他功能我也不能理解,因为不是那个领域. 下面我就介绍一下为什么我们需要一个调度平台,以及学习完 ...
- 1001 Sum Problem [ACM刷题]
这一段时间一直都在刷OJ,这里建一个博客合集,用以记录和分享算法学习的进程. github传送门:https://github.com/haoyuanliu/Online_Judge/tree/mas ...
- BitmapFactory.decodeByteArray() 返回null,分析与解决
问题描述:用android自带的Camera获取图片,上传至远程数据库中(mysql),以BLOB格式存储, 但在提取图片时,始终无法在android界面显示,示例代码如下: ..... .... ...
- HDU 2639 Bone Collector II(01背包变型)
此题就是在01背包问题的基础上求所能获得的第K大的价值. 详细做法是加一维去推当前背包容量第0到K个价值,而这些价值则是由dp[j-w[ i ] ][0到k]和dp[ j ][0到k]得到的,事实上就 ...
- js判断访问者是否来自移动端代码
<script type="text/javascript"> function is_mobile() { var regex_match = /(nokia|iph ...