apache启动报错(98)Address already in use: make_sock: could not bind to address [::]:80
说明80端口被用
终端: ps -ef|grep httpd察看占用的进程或者用netstat -lnp|grep 80
找到后kill掉,如果都不行那么再试试以下方法(试过可以)
终端输入:
find / -name ports.conf
/etc/apache2/ports.conf
输入:
vim '/etc/apache2/ports.conf'
键入‘i’即可修改,
将listen 80 这一句注释掉
按‘Esc’退出编辑状态
按‘:wq’,保存并退出(‘:q’不保存退出,‘:q!’不保存强制退出,‘:wq!’强制保存退出)
输入:
sudo /etc/init.d/apache2 start 即可。
当httpd.conf和ports.conf中都有listen 80时可能有效,加载时会冲突。
其实出现这种情况原因不定,如果同一个监听端口添加多次在运行前几次时没问题,多次运行时也会出现问题。有时侯你弄了一番,当你觉得不可能弄好的时候,它可能就好了。个人愚见,不喜勿喷。
(本文复制自http://blog.csdn.net/individualing/article/details/7884110)
apache启动报错(98)Address already in use: make_sock: could not bind to address [::]:80的更多相关文章
- apache启动报错(98)Address already in use: make_sock: could not bind to...
# /etc/init.d/httpd startStarting httpd: (98)Address already in use: make_sock: could not bind to ad ...
- 转 : Apache启动报错:could not bind to address [::]:443 解决办法
转:Apache启动报错:could not bind to address [::]:443 解决办法 安装Apache服务器的时候,报如下错误: Installing the 'apache' s ...
- Apache启动报错Address already in use: make_sock: could not bind to...
Apache启动时报错:(98)Address already in use: make_sock: could not bind to... # /etc/init.d/httpd start St ...
- Tomcat启动报错:StandardServer.await: create[8005] java.net.BindException: Cannot assign requested address
Tomcat启动报错:StandardServer.await: create[8005] java.net.BindException: Cannot assign requested addres ...
- (98)Address already in use: make_sock: could not bind to address 80 [resolved] (2012-10-11 09:04)
以前遇到一个问题: sudo /etc/init.d/apache2 start * Starting web server apache2 apache2: Could not reliably d ...
- Address already in use: make_sock: could not bind to address [::]:80
**********************************************************处理办法:# ps -aux | grep httpWarning: bad syn ...
- 【elaseticsearch】elaseticsearch启动报错Caused by: org.elasticsearch.transport.BindTransportException: Failed to bind to [9300-9400]
elaseticsearch启动报错 [es1] uncaught exception in thread [main] org.elasticsearch.bootstrap.StartupExce ...
- apache启动报错:Cannot load php5apache2_2.dll into server
错误信息: httpd.exe: Syntax error on line 178 of D:/Program Files/httpd-2.4.20-x64-vc14-r2 /Apache24/con ...
- windows apache启动报错
Windows启动Apache时报错 he requested operation has failed 有可能80端口被占或者项目路径不存在等 首先找到问题原因 cmd--命令端--切换到apach ...
随机推荐
- Java并发编程中的相关注解
引自:http://www.cnblogs.com/phoebus0501/archive/2011/02/21/1960077.html Java并发编程中,用到了一些专门为并发编程准备的 Anno ...
- linux中的IP地址的修改
一,图形界面,setup 二,修改文件 1,修改主机名字 vi /etc/sysconfig/network NETWORKING=yes #HOSTNAME=localhost.localdomai ...
- tornado-cookies+pycket 验证
1.pip install pycket pip install redis 2.config settings = dict( debug=True, template_path='template ...
- Oracle exp/imp 导出/导入
set NLS_LANG=AMERICAN_AMERICA.AL32UTF8 exp jjhd_test/11111111@a_syj file="d:\jjhd_test.dmp" ...
- Maven运行的方式
1.运行父工程(父工程将各个子模块聚合到一起) 2.直接运行子模块(Web工程)
- python中的jion
on将列表或元组中的每个元素连接起来,举个例子: 1 a = ["hello", "world", "dlrb"] 2 a1 = " ...
- <转载> bat 脚本基本语法 http://blog.csdn.net/bluedusk/article/details/1500629
bat 脚本基本语法 2007-01-25 10:31 常用命令 echo.@.call.pause.rem(小技巧:用::代替rem)是批处理文件最常用的几个命令,我们就从他们开始学起. = ...
- Flex学习笔记--多层菜单按钮
<?xml version="1.0" encoding="utf-8"?> <s:Application xmlns:fx="ht ...
- Linux 创建用户并赋予 Sudo 权限
01,创建账号 => useradd admin 02,赋予密码 => passwd admin 03,修改 sudo 权限文件,使得该用户可以使用 sudo 命令 vim /etc/su ...
- Git安装和基本使用(1)
参考廖雪峰GIt教程 https://www.liaoxuefeng.com/wiki/0013739516305929606dd18361248578c67b8067c8c017b000/00137 ...