最近在从活动数据库进行异机克隆时碰到了ORA-17629,ORA-17627,ORA-12154的错误,起初以为是一个Bug呢。Oracle Bug着实太多了,已经成了习惯性思维了。汗!错误提示是无法连接到连接到远程数据库,连接字符串无法解析。咦,配置了从auxiliary DB到target DB的tnsnames,且都是连通的阿......

1、故障现象
    --下面的操作在auxiliary DB所在的机器上完成
    [oracle@linux4 ~]$ export ORACLE_SID=sybo3
    [oracle@linux4 ~]$ sqlplus / as sysdba
    SQL> startup nomount;
    [oracle@linux4 ~]$ rman target sys/oracle@TAR auxiliary sys/oracle@AUX

Recovery Manager: Release 11.2.0.1.0 - Production on Wed Jul 31 16:00:59 2013

Copyright (c) 1982, 2009, Oracle and/or its affiliates.  All rights reserved.

connected to target database: SYBO3 (DBID=2347733014)
    connected to auxiliary database: SYBO3 (not mounted)

RMAN> duplicate database to sybo3 from active database spfile nofilenamecheck;

Starting Duplicate Db at 31-JUL-13
    using target database control file instead of recovery catalog
    allocated channel: ORA_AUX_DISK_1
    channel ORA_AUX_DISK_1: SID=125 device type=DISK

contents of Memory Script:
    {
       backup as copy reuse
       targetfile  '/u01/oracle/db_1/dbs/spfilesybo3.ora' auxiliary format 
     '/u01/oracle/db_1/dbs/spfilesybo3.ora'   ;
       sql clone "alter system set spfile= ''/u01/oracle/db_1/dbs/spfilesybo3.ora''";
    }
    executing Memory Script

Starting backup at 31-JUL-13
    allocated channel: ORA_DISK_1
    channel ORA_DISK_1: SID=23 device type=DISK
    RMAN-00571: ===========================================================
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ===========================================================
    RMAN-03002: failure of Duplicate Db command at 07/31/2013 16:01:07
    RMAN-03015: error occurred in stored script Memory Script
    RMAN-03009: failure of backup command on ORA_DISK_1 channel at 07/31/2013 16:01:07
    ORA-17629: Cannot connect to the remote database server                        
    ORA-17627: ORA-12154: TNS:could not resolve the connect identifier specified
    ORA-17629: Cannot connect to the remote database server

2、故障分析与解决
    上面是一堆的RMAN与ORA相关错误号了
    在执行脚本backup as copy reuse时出现了错误,也就是说备份的时候出现错误RMAN-03009
    其次是ORA-17629,不能连接到远程数据库服务器,ORA-17627后跟着ORA-12154,说明是由于无法解析字符串
    下面来看看ORA-17629到底是什么问题
    [oracle@linux4 ~]$ oerr ora 17629
    17629, 00000, "Cannot connect to the remote database server"
    // *Cause:  Connecting to the remote server specified by database connect 
    //          string for netowrk file transfer failed.
    // *Action: Check additional error messages

重要的提示信息:for netowrk file transfer failed,网络文件传输失败。
    由于我们使用的是从活动数据库进行克隆,因此活动数据库的数据文件等等应当会通过网络复制到辅助数据库,更确切地是说是通过Oracle Net。
    也就是说尽管我们在辅助数据库端配置了到target DB以及到Auxiliary DB的tnsnames的连接是不够的,target DB端也要连接到Auxiliary DB传送文件。
    上面只是一个初步的推测,从Oracle Metalink找到了关于这个问题的描述。就是需要在两个服务器之间都配置到target DB与Auxiliary DB的tnsnames。

检查一下两个主机的tnsnames.ora的配置
    [oracle@linux3 admin]$ more tnsnames.ora 
    # tnsnames.ora Network Configuration File: /u01/oracle/db_1/network/admin/tnsnames.ora
    # Generated by Oracle configuration tools.

TAR =                               #Target Server只有到Target DB的tnsnames.ora
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.7.25)(PORT = 1531))
        )
        (CONNECT_DATA =
          (SERVICE_NAME = SYBO3.ORASRV.COM)
        )
      )
  
    [oracle@linux4 admin]$ more tnsnames.ora  #Auxiliary Server有到Target DB和Auxiliary DB的tnsnames.ora
    TAR =
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.7.25)(PORT = 1531))
        )
        (CONNECT_DATA =
          (SERVICE_NAME = SYBO3.ORASRV.COM)
        )
      )

AUX =
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.7.26)(PORT = 1531))
        )
        (CONNECT_DATA =
          (SERVICE_NAME = SYBO3.ORASRV.COM)
        )
      )

-- Author : Robinson Cheng
    -- Blog   : http://blog.csdn.net/robinson_0612

解决方案
        在Target Server端添加到Auxiliary DB的tnsnames.ora,即与Auxiliary server端使用相同的tnsnames entry

下面测试tnsnames的连通性
    [oracle@linux3 admin]$ tnsping aux  
    [oracle@linux3 admin]$ tnsping tar
    [oracle@linux4 admin]$ tnsping aux
    [oracle@linux4 admin]$ tnsping tar

再次duplicate时,成功鸟,喝茶哟!

3、MetaLink的描述(Doc ID 1144273.1)
    Applies to: 
    Oracle Database - Enterprise Edition - Version 11.2.0.1 and later
    Information in this document applies to any platform.

Symptoms

The duplicate database from active failed with the following errors :

ORA-17629: Cannot connect to the remote database server
    ORA-17627: ORA-12154: TNS:could not resolve the connect identifier specified
    ORA-17629: Cannot connect to the remote database server

Cause
        Cause 1:

For Active Duplication you need to connect to the target and Auxiliary DB using net service name ,even if you are running RMAN at the Auxiliary DB.
        The net service name to connect to the Auxiliary DB should also be configured at the target Database.
  
        In the tnsnames.ora on the machine of the TARGET database, there are 2 services created to connect to auxiliary database that have the same "service name" but "different" configuration.

Possible Cause 2:
  
        Mismatch of Parameters DEFAULT_DOMAIN and DB_DOMAIN
  
        db_domain=PROD.world         # init.ora
        default_domain=PROD.WORLD    # sqlnet.ora
  
        # DEFAULT_DOMAIN defined on sqlnet.ora is 'case' sensitive and when defined must match 
           DB_DOMAIN initialization parameter

Solution

1. To be sure that the tnsnames.ora file of each machine (machine where is the source database and machine where is the auxiliary  database) has the service name to connect to auxiliary database.
  
        2. Verify that there are not duplicate service_name with different configuration in the tnsnames.ora file.
  
        As per the Step 2 of the below RMAN doc :
       http://download.oracle.com/docs/cd/B28359_01/backup.111/b28270/rcmdupdb.htm#i1008564
  
          Step 2: Establish Oracle Net Connectivity to the Auxiliary Instance
  
        When duplicating from an active database, you must first have connected as SYSDBA to the auxiliary instance by means of a net service name. This net service name must also be available on the source database instance.
        The source database instance, to which RMAN is connected as TARGET, uses this net service name to connect directly to the auxiliary database instance.

Double check using the following commands on the TARGET and AUXILIARY

% tnsping <target_db>
        % tnsping <auxiliary_db>
      Once this is executed for the TARGET and AUXILIARY, it should return the same 'connect' information.

Additional Note:

If the listener is started from a different environment to rman client 
        Then server processes will try to resolve the AUXILIARY service name using $TNS_ADMIN/tnsnames.ora where the value of TNS_ADMIN is as set in the 'listener runtime environment'.

RMAN duplicate from active遇到ora-17167,ora-12154的更多相关文章

  1. 使用RMAN DUPLICATE...FROM ACTIVE DATABASE创建物理standby database

    Applies to: Oracle Server - Enterprise Edition - Version 11.1.0.6 to 11.2.0.4 [Release 11.1 to 11.2] ...

  2. 基于RMAN从活动数据库异机克隆(rman duplicate from active DB)

    Oracle 11g RMAN能够实现基于活动数据库进行异机克隆,从而省去需要先备份再ftp到辅助服务器的过程.这一切可以全部交给Oracle来搞定.在克隆期间,Oracle会读取Target DB的 ...

  3. RMAN 'Duplicate From Active Database' Feature in Oracle11g (Doc ID 452868.1)

    RMAN 'Duplicate From Active Database' Feature in Oracle11g (Doc ID 452868.1) APPLIES TO: Oracle Data ...

  4. 关于 rman duplicate from active database 搭建dataguard--系列一

    关于 rman duplicate from active database.详细操作实际为backup as copy .会拷贝非常多空块.对于那些数据库数据文件超过100G的都不是非常建议用:在非 ...

  5. RMAN duplicate from active 时遭遇 ORA-17627 ORA-12154

    最近在从活动数据库进行异机克隆时碰到了ORA-17629,ORA-17627,ORA-12154的错误,起初以为是一个Bug呢.Oracle Bug着实太多了,已经成了习惯性思维了.汗!错误提示是无法 ...

  6. RMAN duplicate from active database

    在Oracle 11G有二种方法实现duplicate: 1.Active database duplication 2.Backup-based duplication Active databas ...

  7. Creating Physical Standby Using RMAN DUPLICATE...FROM ACTIVE DATABASE执行结果

    > run { > allocate channel prmy1 type disk; > allocate channel prmy2 type disk; > alloca ...

  8. 使用 rman duplicate from active database 搭建dataguard 手记--系列二

    run { allocate channel prmy1 type disk; allocate channel prmy2 type disk; allocate channel prmy3 typ ...

  9. Oracle 11gR2使用RMAN duplicate复制数据库

    11g的RMAN duplicate 个人感觉比10g的先进了很多,10g需在rman备份的基础上进行复制,使用RMAN duplicate创建一个数据完全相同但DBID不同的数据库.而11g的RMA ...

随机推荐

  1. $headers = $this->input->request_headers();返回请求头(header)数组

    请查看:CI中的输入类部分 建议用第一个 $headers = $this->input->request_headers() $this->input->request_he ...

  2. Good Bye 2015 A. New Year and Days 签到

    A. New Year and Days   Today is Wednesday, the third day of the week. What's more interesting is tha ...

  3. HDU5596/BestCoder Round #66 (div.2) 二分BIT/贪心

    GTW likes gt    Memory Limit: 131072/131072 K (Java/Others) 问题描述 从前,有nn只萌萌的GT,他们分成了两组在一起玩游戏.他们会排列成一排 ...

  4. 浅说Java中的反射机制(二)

    写过一篇Java中的反射机制,不算是写,应该是抄了,因为那是别人写的,这一篇也是别人写的,摘抄如下: 引自于Java基础--反射机制的知识点梳理,作者醉眼识朦胧.(()为我手记) 什么是反射? 正常编 ...

  5. jd-gui 反编译后去除注释

    默认情况下,使用jd-gui反编译时会有注释. 行号注释 /* 521:502 */ 元信息 /* Location:           D:\core-1.0.0.jar * Qualified ...

  6. jsp中的out对象 和 servlet中的response.getOutputStream()

    web容器生成的servlet代码中有out.write(””),这个和JSP中调用的response.getOutputStream()产生冲突. 即Servlet规范说明,不能既调用 respon ...

  7. LaTeX新人教程,30分钟从完全陌生到基本入门

    by Nan 对于真心渴望迅速上手LaTeX的人,前言部分可以跳过不看. 本教程面向对LaTeX完全无认知无基础的新人.旨在让新人能够用最简单快捷的方式,轻松入门,能够迅速使用LaTeX完成基本的文本 ...

  8. Sql case when用法

    说明,sql中的if和else 是不能在select 语句中使用的.只能用来控制sql程序的流程.只能用case when. CREATE TABLE USER(NAME VARCHAR(20) NO ...

  9. Backbone seajs demo2

    <!doctype html> <html lang="en"> <head> <meta charset="UTF-8&quo ...

  10. spring各个包之间的依赖关系

    从图中可以看到: 1.spring core,spring beans被其他较多包依赖,spring aop,spring context,spring expression分别被两个包依赖,而spr ...