1.一般是权限问题,把用户和组改为mysql就可以了。

chown -R mysql:mysql  /var/lib/mysql

2.在启动mysql时报下列错误

[root@mysqld2 ~]# service mysql.server start
Starting MySQL......................................The server quit without updating PID file (/var/lib/mysql/mysqld2.clvn.com.cn.pid).                       [失败]

解决方法

查看日志文件

[root@mysqld1 mysql]# tail /var/log/mysqld.log 
2014-05-09 22:08:10 3483 [Note] NDB: Changed global value of binlog_format from STATEMENT to MIXED
2014-05-09 22:08:46 3483 [Warning] NDB: server id set to zero - changes logged to bin log with server id zero will be logged with another server id by slave mysqlds
2014-05-09 22:08:46 3483 [Note] Starting Cluster Binlog Thread
2014-05-09 22:08:46 3483 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 6f59371c-d783-11e3-ac36-000c2971b28f.
2014-05-09 22:08:46 3483 [Note] Server hostname (bind-address): '*'; port: 3306
2014-05-09 22:08:46 3483 [Note] IPv6 is available.
2014-05-09 22:08:46 3483 [Note]   - '::' resolves to '::';
2014-05-09 22:08:46 3483 [Note] Server socket created on IP: '::'.
2014-05-09 22:08:46 3483 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
140509 22:08:46 mysqld_safe mysqld from pid file /var/lib/mysql/mysqld1.clvn.com.cn.pid ended

解决方法

[root@mysqld1 mysql]# scripts/mysql_install_db --user=mysql
Installing MySQL system tables...2014-05-09 22:51:12 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2014-05-09 22:51:12 3564 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-05-09 22:51:12 3564 [Note] InnoDB: The InnoDB memory heap is disabled
2014-05-09 22:51:12 3564 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2014-05-09 22:51:12 3564 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-05-09 22:51:12 3564 [Note] InnoDB: Using Linux native AIO
2014-05-09 22:51:12 3564 [Note] InnoDB: Using CPU crc32 instructions
2014-05-09 22:51:12 3564 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2014-05-09 22:51:12 3564 [Note] InnoDB: Completed initialization of buffer pool
2014-05-09 22:51:12 3564 [Note] InnoDB: Highest supported file format is Barracuda.
2014-05-09 22:51:12 3564 [Note] InnoDB: 128 rollback segment(s) are active.
2014-05-09 22:51:12 3564 [Note] InnoDB: Waiting for purge to start
2014-05-09 22:51:13 3564 [Note] InnoDB: 5.6.17 started; log sequence number 1626007
2014-05-09 22:51:13 3564 [Note] Binlog end
2014-05-09 22:51:13 3564 [Note] InnoDB: FTS optimize thread exiting.
2014-05-09 22:51:13 3564 [Note] InnoDB: Starting shutdown...
2014-05-09 22:51:14 3564 [Note] InnoDB: Shutdown completed; log sequence number 1626017
OK

Filling help tables...2014-05-09 22:51:14 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2014-05-09 22:51:14 3588 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-05-09 22:51:14 3588 [Note] InnoDB: The InnoDB memory heap is disabled
2014-05-09 22:51:14 3588 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2014-05-09 22:51:14 3588 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-05-09 22:51:14 3588 [Note] InnoDB: Using Linux native AIO
2014-05-09 22:51:14 3588 [Note] InnoDB: Using CPU crc32 instructions
2014-05-09 22:51:14 3588 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2014-05-09 22:51:14 3588 [Note] InnoDB: Completed initialization of buffer pool
2014-05-09 22:51:14 3588 [Note] InnoDB: Highest supported file format is Barracuda.
2014-05-09 22:51:14 3588 [Note] InnoDB: 128 rollback segment(s) are active.
2014-05-09 22:51:15 3588 [Note] InnoDB: Waiting for purge to start
2014-05-09 22:51:15 3588 [Note] InnoDB: 5.6.17 started; log sequence number 1626017
2014-05-09 22:51:15 3588 [Note] Binlog end
2014-05-09 22:51:15 3588 [Note] InnoDB: FTS optimize thread exiting.
2014-05-09 22:51:15 3588 [Note] InnoDB: Starting shutdown...
2014-05-09 22:51:16 3588 [Note] InnoDB: Shutdown completed; log sequence number 1626027
OK

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:

./bin/mysqladmin -u root password 'new-password'
  ./bin/mysqladmin -u root -h mysqld1.clvn.com.cn password 'new-password'

Alternatively you can run:

./bin/mysql_secure_installation

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the manual for more instructions.

You can start the MySQL daemon with:

cd . ; ./bin/mysqld_safe &

You can test the MySQL daemon with mysql-test-run.pl

cd mysql-test ; perl mysql-test-run.pl

Please report any problems at http://bugs.mysql.com/

The latest information about MySQL is available on the web at

http://www.mysql.com

Support MySQL by buying support/licenses at http://shop.mysql.com

WARNING: Found existing config file ./my.cnf on the system.
Because this file might be in use, it was not replaced,
but was used in bootstrap (unless you used --defaults-file)
and when you later start the server.
The new default config file was created as ./my-new.cnf,
please compare it with your file and take the changes you need.

[root@mysqld1 mysql]# ./bin/mysqld_safe &
[1] 3612
[root@mysqld1 mysql]# 140509 22:51:29 mysqld_safe Logging to '/usr/local/mysql/data/mysqld1.clvn.com.cn.err'.
140509 22:51:29 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data

查看mysql.server的状态信息

[root@mysqld1 ~]# service mysql.server start
Starting MySQL.                                            [确定]

参考:http://ovcer.blog.51cto.com/1145188/1409059

解决mysql启动时报The server quit without updating PID file 的错误(转)的更多相关文章

  1. 深度解析MySQL启动时报“The server quit without updating PID file”错误的原因

    很多童鞋在启动mysql的时候,碰到过这个错误, 首先,澄清一点,出现这个错误的前提是:通过服务脚本来启动mysql.通过mysqld_safe或mysqld启动mysql实例并不会报这个错误. 那么 ...

  2. Mysql 启动遇到 The server quit without updating PID file (/[FAILED]l/mysql/data/021rjsh216086s.pid)和Attempted to open a previously opened tablespace

    今天在测试服务器做调试的时候,遇到Mysql的启动问题,好像是PID文件找不到了. 不科学啊,前几天还好好的呀,我也没怎么乱搞啊,然后一通百度,找到了几个解决办法. 1.有可能是已经存在mysql进程 ...

  3. MySQL启动出现The server quit without updating PID file错误解决办法

    启动mysql服务的时候报下面这个错: 之间网上搜了各种办法,有重新初始化的(这怎么可能,里面还有数据...),有修改启动脚本的等等,但是都没用. 其实解决办法非常简单粗暴,那就是把/etc/my.c ...

  4. MySql启动提示:The server quit without updating PID file(…)失败

    在网上找了很多 1.可能是/usr/local/mysql/data/rekfan.pid文件没有写的权限解决方法 :给予权限,执行 “chown -R mysql:mysql /var/data”  ...

  5. lnmp下启动mysql报错 The server quit without updating PID file

    启动时候错误代码:Starting MySQL[FAIL.] The server quit without updating PID file (/var/run/mysqld/mysqld.pid ...

  6. mac mysql start ERROR! The server quit without updating PID file

    在mac下安装完mysql,启动时出现error: ERROR! The server quit without updating PID file (/usr/local/var/mysql/nal ...

  7. MySQL数据库出现The server quit without updating PID file.

    一.服务器环境 操作系统:CentOS-6.4 服务器环境:集成环境LNMP1.0 二.步骤重现 1.安装LNMP1.0,具体操作方法见这里,安装成功: 2.因个人需求,现将MySQL数据库存放在/d ...

  8. Starting MySQL....The server quit without updating PID file错误解决办法

    出现错误:Starting MySQL....The server quit without updating PID file 检查错误文件: /var/lib/mysql/xxxx.err,根据其 ...

  9. mysql启动时报错:Starting MySQL... ERROR! The server quit without updating PID file (/opt/mysql/data/mysql.pid)

    mysql启动报错Starting MySQL... ERROR! The server quit without updating PID file (/opt/mysql/data/mysql.p ...

随机推荐

  1. C# 6 与 .NET Core 1.0 高级编程 - 38 章 实体框架核心(上)

    译文,个人原创,转载请注明出处(C# 6 与 .NET Core 1.0 高级编程 - 38 章 实体框架核心(上)),不对的地方欢迎指出与交流. 章节出自<Professional C# 6 ...

  2. 5. UITest测试总结

    1. 什么是Mock 当我们在做单元测试的过程中,为了保持测试又短又快和测试的隔离性,希望尽可能少地去实例化一些具体的组件.在现在面向对象的系统中,被测试的对象很可能会依赖于几个其他的对象,这时候我们 ...

  3. Qt之hello world

    本人使用的是Qt5.7版本的,请读者自主下载安装. 今天首先来进行Qt入门的第一个程序,也是很经典的一个例子.这是在很多的变成语言中都会用到的例子,就是输出helloworld这个信息.Qt中使用的变 ...

  4. 中国大学MOOC中的后台文件传输

    早期版本的中国大学MOOC一旦被挂起后,应用在完成当前下载任务后无法继续添加新任务,当然也无法将缓存状态写入数据库.这个问题能否顺利解决直接关系到用户体验. 顺便吐槽下,凡是使用了后台文件传输还提示你 ...

  5. linux php安装memcached扩展

    memcached的安装包括:1.服务端的安装:2.客户端的安装 一.服务器端安装 方法一: memcached 依赖于libevent 库,因此我们需要先安装libevent. 假设将源码放在/us ...

  6. Java排序小算法(冒泡和选择)

    package MyTest; import java.util.Scanner; public class BubbleSort { public void Init(int array[]) { ...

  7. [Hadoop] - SSH免密码登录

    在安装hadoop之前需要进行ssh免密码登录,ssh 无密码登录要使用公钥与私钥.linux下可以用用ssh-keygen生成公钥/私钥对,下面我以Redhat为例. 我这里只采用一台机器A(10. ...

  8. Linux系统(一)文件系统、压缩、打包操作总结

    序言 当前的形势,.Net已经开源,.Net Core 正在跨平台,可见微软巨人在努力,在改变,在进步,在走向春天.从前被微软供作上帝的.Net从业者,如果不打开心扉面向开源,改变自己,那么很可能在不 ...

  9. BZOJ 1096: [ZJOI2007]仓库建设(动态规划+斜率优化)

    第一次写斜率优化,发现其实也没啥难的,没打过就随便找了一份代码借(chao)鉴(xi)下,不要介意= = 题解实在是懒得写了,贴代码吧= = CODE: #include<cstdio># ...

  10. jQuery中.bind() .live() .delegate() .on()的区别 和 三种方式写光棒事件 动画

    地狱的镰刀 bind(type,[data],fn) 为每个匹配元素的特定事件绑定事件处理函数. $("a").bind("click",function(){ ...