案例说明:
    域名:
        www.tianyik.com  /var/html/www
        blog.tianyik.com  /var/html/blog
        bbs.tianyik.com  /var/html/bbs
    主机ip:192.168.31.36    
    创建站点目录:mkdir /var/html/{www,blog,bbs}
    创建首页文件:
        touch /var/html/{www,blog,bbs}/index.html  或者
        for name in www blog bbs;do echo "http://$name.tainyik.com" >/var/html/$name/index.html;done
    检查创建情况:for name in www blog bbs;do cat /var/html/$name/index.html;done
    修改虚拟主机配置文件
        vim httpd-vhost.conf  修改如下:
            NameVirtualHost *:80
            <VirtualHost *:80>
                ServerAdmin tan.tianyik.com
                DocumentRoot "/var/html/www"
                ServerName www.tianyik.com
                ServerAlias tianyik.com
                ErrorLog "logs/dummy-host.example.com-error_log"
                ErrorLog "logs/www-error_log"
                CustomLog "logs/www-access_log" common
            </VirtualHost>
            <VirtualHost *:80>
                ServerAdmin tan.tianyik.com
                DocumentRoot "/var/html/blog"
                ServerName blog.tianyik.com
                ErrorLog "logs/blog-error_log"
                CustomLog "logs/blog-access_log" common
            </VirtualHost>
            <VirtualHost *:80>
                ServerAdmin tan.tianyik.com
                DocumentRoot "/var/html/bbs"
                ServerName bbs.tianyik.com
                ErrorLog "logs/bbs-error_log"
                CustomLog "logs/bbs-access_log" common
            </VirtualHost>
                注意:原来的<>需要删掉
    修改主配置文件
        去掉注释:Include conf/extra/httpd-vhosts.conf
        找到下面一段(段中有#的注释行已删除)
            <Directory "/application/apache2.2.31/htdocs">  
                Options Indexes FollowSymLinks  
                AllowOverride None
                Order allow,deny
                Allow from all
            </Directory>
        修改为下面的一段:
            <Directory "/var/html">  //不改会报403错误
                Options FollowSymLinks  //去掉Indexes,为安全
                AllowOverride None
                Order allow,deny
                Allow from all
            </Directory>
        修改:ServerName localhost:80  
            不改可能会报错如下:
            httpd: apr_sockaddr_info_get() failed for min
            httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    检查语法:/application/apache/bin/apachectl -t
    平滑重启:/application/apache/bin/apachectl graceful
    在本地做解析:修改hosts文件
        添加:192.168.31.36  tianyik.com  www.tianyik.com  blog.tianyik.com  bbs.tianyik.com
        检查修改情况 ping
    尝试访问:成功!

apache下配置虚拟主机案例详解的更多相关文章

  1. wampserver下配置虚拟主机 实现多站点支持

    wampserver下配置虚拟主机 实现多站点支持 wampserver是由德国人开发,在windows环境下实现apache+php+mysql的一款集成环境软件,wampserver自带SQLit ...

  2. (转)CentOS 6下配置软RAID图文详解

    CentOS 6下配置软RAID图文详解 原文:http://blog.51cto.com/hujiangtao/1929620 一.RAID 简介 RAID 是英文Redundant Array o ...

  3. nginx下配置虚拟主机

    linux 虚拟机下配置虚拟主机 nginx.conf 文件不动, 在 conf.d 或者 conf 目录下 新建项目.conf server { listen 80; server_name loc ...

  4. linux环境下配置虚拟主机域名

    linux环境下面配置虚拟主机域名 第一步:在root目录下面(即根目录)ls(查看文件)cd进入etc目录find hosts文件vi hosts 打开hosts文件并进行编辑在打开的文件最下面添加 ...

  5. Nginx下配置虚拟主机的三种方法

    Nginx下,一个server标签就是一个虚拟主机. 1.基于域名的虚拟主机,通过域名来区分虚拟主机——应用:外部网站 2.基于端口的虚拟主机,通过端口来区分虚拟主机——应用:公司内部网站,外部网站的 ...

  6. Nginx负载均衡的详细配置及使用案例详解.

    感谢看过这一些列博文和评论的小伙伴, 我把自己所看到的学到的拿到这里来分享是想和大家一起学习进步, 想听听园友给出的意见, 也是对自己学习过程的一个总结. 技术无止境, 我们仍需努力! 1,话不多说, ...

  7. [项目构建 十三]babasport Nginx负载均衡的详细配置及使用案例详解.

    在这里再次说明下, 这个项目是从网上 找到的一套学习资料, 自己在 空闲时间学习了这些东西. 这里面的code当然会有很多不完善的地方, 但是确实也能学到很多新东西.感谢看过这一些列博文和评论的小伙伴 ...

  8. lnmp下配置虚拟主机

    一:首先熟悉几个命令 which php      --->  which是通过 PATH环境变量到该路径内查找可执行文件,所以基本的功能是寻找可执行文件 whereis php   ----& ...

  9. Mac环境下配置tomcat的步骤详解

    前言 相信对Java Web稍微知道一点,一般对Tomcat都不会陌生,Apache是普通服务器,本身只支持html即普通网页,可以通过插件支持PHP,还可以与Tomcat连通(单向Apache连接T ...

随机推荐

  1. 【BZOJ 2820】 YY的GCD (莫比乌斯+分块)

    YY的GCD   Description 神犇YY虐完数论后给傻×kAc出了一题 给定N, M,求1<=x<=N, 1<=y<=M且gcd(x, y)为质数的(x, y)有多少 ...

  2. SPRING IN ACTION 第4版笔记-第二章WIRING BEANS-008-在XML配置文件中引入JAVA配置文件 <import> 、<bean>

    一.在xml中引入xml,用<import> <?xml version="1.0" encoding="UTF-8"?> <be ...

  3. Altium Designer10 如何导出Gerber文件

    版本:AD10.818 目的:Gerber文件导出备忘 http://blog.sina.com.cn/s/blog_9b9a51990100zyyv.html 目录: Step1:设置原点 Step ...

  4. 【Xamarin开发 Android 系列 3】循序渐进的学习顺序

    原文:[Xamarin开发 Android 系列 3]循序渐进的学习顺序 指定合理的学习步骤,将各个技术点进行强化.慢慢 的就从点到线 到面的飞跃,一切仅仅是时间问题,开始前,请记住,学习是最佳的投资 ...

  5. [OJ] Insert Interval

    LintCode #30. Insert Interval (Easy) LeetCode #57. Insert Interval (Hard) class Solution { public: v ...

  6. 17.1.1.2 Setting the Replication Slave Configuration

    17.1.1.2 Setting the Replication Slave Configuration 在一个复制slave, 你必须创建一个唯一的server ID,如果这个没有做,slave设置 ...

  7. 转载:浅谈Java多线程的同步问题【很好我就留下来,多分共享】

    转载:http://www.cnblogs.com/phinecos/archive/2010/03/13/1684877.html#undefined 多线程的同步依靠的是对象锁机制,synchro ...

  8. C#面向对象——方法的重载及构造函数、静态对象。

    namespace nameclass2 { class Class2 //方法的重载 { public void Function( string s) { Console.WriteLine(s) ...

  9. 织梦内容管理系统(DedeCms) 小说模块insert注入漏洞

    漏洞版本: Dedecms 漏洞描述: DedeCms是免费的PHP网站内容管理系统. 织梦内容管理系统(DedeCms) 以简单.实用.开源而闻名,是国内最知名的PHP开源网站管理系统,也是使用用户 ...

  10. access 导数据到sql server 2008

    使用sp_configure启用'Ad Hoc Distributed Queries'解决 1.启用Ad Hoc Distributed Queries:exec sp_configure 'sho ...