1、下载源码包

curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.2.12.tgz

2、解压 放到 /usr/local/ 目录下

tar -zxvf mongodb-linux-x86_64-3.2.12.tgz
mv  mongodb-linux-x86_64-3.2.12/ /usr/local/mongodb

3、切换目录

cd /usr/local/mongodb

4、在当前路径【/usr/local/mongodb】下创建文件夹

mkdir -p ./data/db

mkdir ./logs

5、进入/usr/local/mongodb/bin 目录下,创建配置文件

vi mongodb.conf

写入一下配置字段

 
dbpath = /usr/local/mongodb/data/db #数据文件存放目录

logpath = /usr/local/mongodb/logs/mongodb.log #日志文件存放目录
port = 27017  #端口
fork = true  #以守护程序的方式启用,即在后台运行
nohttpinterface = true
auth=true #【建议练习条件下为false 认证字段】
bind_ip=0.0.0.0
 

mongodb.conf 参数解释:

--dbpath 数据库路径(数据文件)

--logpath 日志文件路径

--master 指定为主机器

--slave 指定为从机器

--source 指定主机器的IP地址

--pologSize 指定日志文件大小不超过64M.因为resync是非常操作量大且耗时,最好通过设置一个足够大的oplogSize来避免resync(默认的 oplog大小是空闲磁盘大小的5%)。

--logappend 日志文件末尾添加,即使用追加的方式写日志

--journal 启用日志

--port 启用端口号

--fork 在后台运行

--only 指定只复制哪一个数据库

--slavedelay 指从复制检测的时间间隔

--auth 是否需要验证权限登录(用户名和密码)

--syncdelay 数据写入硬盘的时间(秒),0是不等待,直接写入

--notablescan 不允许表扫描

--maxConns 最大的并发连接数,默认2000 

--pidfilepath 指定进程文件,不指定则不产生进程文件

--bind_ip 绑定IP,绑定后只能绑定的IP访问服务

  

6、进行环境变量配置, 打开配置文件 /etc/profile

vi /etc/profile

在后面添加一条语句

添加这条语句:export PATH=$PATH:/usr/local/mongodb/bin

7、配置文件生效

source /etc/profile

8、服务启动语句 : 以自定义的 mongodb 配置文件方式启动

mongod -f /usr/local/mongodb/bin/mongodb.conf

以修复模式启动 mongodb:

./mongod --repair -f mongodb.conf

 

以参数式启动:

./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork

  

如果报如下错误:

ERROR: child process failed, exited with error number 1

很可能是 mongodb.conf 中配置的路径不一致问题;

如果报如下错误:

ERROR: child process failed, exited with error number 100

很可能是没有正常关闭导致的,那么可以删除 mongod.lock 文件

如果出现如下情况

warning: Failed to connect to 127.0.0.1:27017, reason: errno:111 Connection refused

可以采用如下两种方式解决:

若数据库出现如上不能连接的原因,可能是data目录下的mongod.lock文件问题,可以用如下命令修复:

./bin/mongod --repair

或者直接删除mongod.lock

rm -f /usr/local/mongodb/data/db/mongod.lock

然后再启动 mongodb 服务:

./mongod --config mongodb.conf

如果以上两部依然解决不掉,则是路径文件,我们可以删除 /usr/local/mongodb/mongodb3.2.4/bin/data 目录及其子目录,并采用绝对路径的方式:

./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork

 

9、服务关闭语句

mongod -f /usr/local/mongodb/bin/mongodb.conf --shutdown  

检查端口是否已被启动:

netstat -lanp | grep 27017

查看 mongodb 进程:

ps aux |grep mongodb

10、进入客户端界面的命令

mongo

11、设置自启动步骤

将 mongodb 服务加入到自启动文件中:

vi /etc/rc.local

在文件末尾追加如下命令:

/usr/local/mongodb/mongodb3.2.4/bin/mongod --config mongodb.conf

客户端常用命令:

db.version(); # 查看 mongodb 的版本

use test; # 进入到指定的数据中,这里是 test 数据库

在浏览器中输入 IP:27017,如:

http://101.201.212.129:27017/

可以查看 MongoDB 的版本信息;

查看所有开机启动的服务

systemctl list-units --type=service

  

centos7 源码安装 MongoDb的更多相关文章

  1. centos7源码安装Python3的前提条件

    centos7源码安装Python3的前提条件: # yum -y install openssl-devel bzip2-devel expat-devel gdbm-devel readline- ...

  2. 搭建LNAMP环境(六)- PHP7源码安装MongoDB和MongoDB拓展

    上一篇:搭建LNAMP环境(五)- PHP7源码安装Redis和Redis拓展 一.安装MongoDB 1.创建mongodb用户组和用户 groupadd mongodb useradd -r -g ...

  3. centos7源码安装mysql5.7.19

    centos7源码包安装mysql5.7 5.7.20安装方法和5.7.19的一样. 1.安装前准备 清空环境.安装相应的软件包 1>关闭防火墙和SELinux 2>配置yum源(阿里云, ...

  4. Centos7源码安装mysql及读写分离,互为主从

       Linux服务器 -源码安装mysql 及读写分离,互为主从   一.环境介绍: Linux版本: CentOS 7 64位 mysq版本: mysql-5.6.26 这是我安装时所使用的版本, ...

  5. CentOS7源码安装qbittorrent最新版本

    CentOS的软件 yum 里 yum search qbittorrent yum info qbittorrent 找到的是3.37版本 官网最新的是4.12版本.但需要源码安装: 官网下载最新版 ...

  6. CentOS7源码安装Redis5.0.4非关系型数据库

    源码安装redis-5.0.4 一. 下载redis 1. 需要连接网络 二. 案例(另一种安装方法) [root@localhost ~]# wget http://download.redis.i ...

  7. CentOS7 源码安装 PostgreSQL 12

    PostgreSQL 12 源码安装 Table of Contents 1. 下载 2. 准备环境 3. 编译安装 4. 设置环境变量 5. 初始化数据库 6. 配置参数文件 6.1. postgr ...

  8. Centos7源码安装Apache和PHP

    源码安装Apache 安装需要的依赖 yum -y install gcc autoconf automake make pcre pcre-devel openssl openssl-devel​# ...

  9. centos7源码安装Apache及Tomcat

    源码安装Apache (1) 一.通过 https://apr.apache.org/  下载 APR 和 APR-util 通过 http://httpd.apache.org/download.c ...

随机推荐

  1. map,实现技巧,id

    cf #include<iostream> #include<cstdio> #include<algorithm> #include<vector> ...

  2. word2vec原理与代码

    目录 前言 CBOW模型与Skip-gram模型 基于Hierarchical Softmax框架的CBOW模型 基于Negative Sampling框架的CBOW模型 负采样算法 结巴分词 wor ...

  3. arcgis python desc.dataType

    desc = arcpy.Describe(r"C:\Users\dell\Documents\ArcGIS\ddd.shp") 是ShapeFile desc = arcpy.D ...

  4. 使用redis防止重复提交

    使用redis防止重复提交   其实主要思路是他的https://blog.csdn.net/u013378306/article/details/52944780 主要目前我的情况是,前后端分离的, ...

  5. Selenium 2自动化测试实战33(带unittest的脚本分析)

    带unittest的脚本分析 #test.py #coding:utf-8 from selenium import webdriver from selenium.webdriver.common. ...

  6. [Kaggle] How to handle big data?

    上一篇,[Kaggle] How to kaggle?[方法导论] 这里再做一点进阶学习. 写在前面 "行业特征" 的重要性 Ref: Kaggle2017—1百万美金的肺癌检测竞 ...

  7. 搭建Kubernetes容器集群管理系统

    1.Kubernetes 概述 Kubernetes 是 Google 开源的容器集群管理系统,基于 Docker 构建一个容器的调度服务,提供资源调度.均衡容灾.服务注册.劢态扩缩容等功能套件. 基 ...

  8. Linux 查看Tomcat版本信息

    Linux 查看Tomcat版本信息 如果我们想运行在 Linux 下的 Tomcat 版本信息,只需要在 Tomcat 的 bin/ 目录下,运行 version.sh 脚本即可. 1.使用如下命令 ...

  9. Linux开机启动过程分析

    开机过程指的是从打开计算机电源直到LINUX显示用户登录画面的全过程.分析LINUX开机过程也是深入了解LINUX核心工作原理的一个很好的途径. 启动第一步--加载BIOS 当 你打开计算机电源,计算 ...

  10. Delphi 字符串加密与解密函数

    EncdDecd 单元: EncodeString.DecodeString.EncodeBase64.DecodeBase64 uses EncdDecd; const str = '万一的 Del ...