创业阶段,进一步实践了Linux环境搭建和维护,以下是一些经常使用软件的搭建步骤和參考资料,仅供自己和诸位參考。

我个人还是比較倾向“一站式Web开发”的。自己想做点事。须要太多的技能。

非商业软件项目,自己全盘负责比較灵活和高效。

1.mysql(关键是创建mysql用户,并用mysql用户运行安装程序)
  參考资料 http://www.cnblogs.com/xiaoluo501395377/archive/2013/04/07/3003278.html
  rpm -qa | grep mysql  // 这个命令就会查看该操作系统上是否已经安装了mysql数据库
  
  Mysql下载地址
  http://dev.mysql.com/downloads/file.php?id=451491
  
  http://blog.sina.com.cn/s/blog_694ac4520100zbbd.html
  
  ----------------------
  ./mysqld_safe --user=mysql &
  
  不能直接使用mysqld。以root用户的身份运行(--user=mysql。能够解决问题)
  2014-04-24 09:19:50 8011 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!
  
  ./bin/mysqld --user=mysql &
  不要使用root用户。使用mysql用户
  
  mysql启动 
  http://swordshadow.iteye.com/blog/1921814
  
  //这样的方式,有时候,不起作用,直接按Enter,mysql就被杀死了
  ./mysqld --user=mysql &
  
  能够使用nohup命令启动
  nohup /usr/bin/mysql --user=mysql &
------------------------
  启动报错
  
2014-04-24 09:25:09 8276 [Note] InnoDB: 128 rollback segment(s) are active.
InnoDB: Error: pthread_create returned 11

暂时解决方法:

# ulimit -s unlimited

./mysqld_safe: line 166:  8796 Killed                 
 nohup /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=/usr/local/mysql/data/AY1404221737304200fcZ.err --pid-file=/usr/local/mysql/data/AY1404221737304200fcZ.pid < /dev/null >> /usr/local/mysql/data/AY1404221737304200fcZ.err 2>&1
140424 09:35:47 mysqld_safe Number of processes running now: 0

mysqld --basedir=/usr/local/mysql --datadir=/var/lib/mysql --user=mysql &

该方法在系统重新启动,或者又一次登录后将失效。

第二种方法:

改动/etc/profile文件,加入

ulimit -s unlimited
---------------卸载自带的mysql---------------
  rpm -qa |grep mysql
  卸载centos自带的mysql,rpm -e --nodeps mysql-libs-5.1.61-4.el6.x86_64
  
------------------------------------

2014-04-24 11:17:25 14210 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

--------------------------------------------------------------------------
Can't find messagefile '/usr/share/mysql/errmsg.sys'
将源代码包里面的sql/share/english/errmsg.sys拷贝到/usr/share/mysql/errmsg.sys 
----------------------------------------------------------------------------

[mysqld]
datadir=/home/mysql/mysql/data
basedir=/home/mysql/mysql
socket=/home/mysql/mysql/run/mysql.sock
log-error=/home/mysql/mysql/log/error.log
user=mysql
innodb_buffer_pool_size=100M
key_buffer_size=50M
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

[mysqld_safe]
log-error=/home/mysql/log/mysqld.log
pid-file=/home/mysql/mysqld.pid

[client]
socket=/home/mysql/mysql/run/mysql.sock

grant all privileges on *.* to root@"%" identified by "lw198962" with grant option;  flush privileges;

./constraints_parser -5 -D -f pages-1400495572/FIL_PAGE_INDEX/0-161 >/tmp/t_bibasic_salessend.sql

#生成数据文件
./constraints_parser -5 -f pages-1400495572/FIL_PAGE_INDEX/4294967295-0 >/tmp/xiaolei_.sql

#生成load-data语句
./constraints_parser -5 -D -f pages-1400495572/FIL_PAGE_INDEX/4294967295-0

2.Redis配置
  http://hi.baidu.com/cxc0378/item/40f4b70e7fda603af3eafcbb
  
3.Mongodb
  /usr/local/mongodb/start-mongo

4.node
  下载二进制安装包。解压就可以 
    
  export NODE_HOME=/usr/local/node/
  export PATH=$NODE_HOME/bin:$PATH 
  
  Linux下运行,
  ./node 
  
  //使用绝对路径
  forever start /var/www/trunk/bootstrap.js &
  forever stop /var/www/trunk/bootstrap.js &
  
  forever start -l /var/www/snsforever.log -o /var/www/snsout.log -e /var/www/snserr.log /var/www/sns/bootstrap.js   
  forever stop /var/www/sns/bootstrap.js   
 -------------------------------------------------------------------------
 关键:使用mysql用户
[mysql@itfriend mysql]$ scripts/mysql_install_db --user=mysql --basedir=/home/mysql/mysql --datadir=/home/mysql/mysql/data

server内存太小,没有交换区,手动改动
http://www.prowebdev.us/2012/05/amazon-ec2-linux-micro-swap-space.html

Run dd if=/dev/zero of=/swapfile bs=1M count=1024 
Run mkswap /swapfile 
Run swapon /swapfile 
Add this line /swapfile swap swap defaults 0 0 to /etc/fstab

5.Nginx
 下载地址 http://nginx.org/download/,都是源代码包,没有二进制安装包
 
 安装过程
 wget  http://nginx.org/packages/centos/6/noarch/RPMS/nginx-release-centos-6-0.el6.ngx.noarch.rpm
 yum install nginx-release...
 yum install nginx
 
 [root@itfriend bin]# find / -name nginx
/var/cache/yum/x86_64/6/nginx
/var/cache/nginx
/var/log/nginx
/var/lib/yum/repos/x86_64/6/nginx
/usr/share/nginx
/usr/sbin/nginx
/etc/sysconfig/nginx
/etc/logrotate.d/nginx
/etc/rc.d/init.d/nginx
/etc/nginx

启动 nginx

又一次载入
nginx -s reload

停止1
nginx -s quit

停止2
ps -ef|grep enigx,找到master的进程号
kill -QUIT 24346
 
 静态资源被Ngnix拦截,直接响应浏览器
 http://114.215.191.169/images/fans123/photos/44813db99c67489523bd7edfb14e1bed7b7553a8.gif

參考资料:
http://nginx.org/en/linux_packages.html
http://www.nginx.cn/
 
6.Linux命令
  改动密码: passwd root,输入2次密码
  
   /usr/local/mysql/bin/mysqld_safe --user=mysql
   cat /var/log/mysqld.log
   
   mysqladmin -u root password "11"
   
   /usr/local/mysql/bin/mysqladmin -u root password 11
   
   source/etc/profile是让/etc/profile文件改动后马上生效
   
   :tar zxvf 
 
 7.crontab
   crontab -e
   编辑自己这个用户的定时文件
   
   */1 * * * * /var/www/autobackup-mysql.sh
   每分钟运行一次
 
8.安装JDK
  查看可安装的java包yum list java*  
  yum install java-1.7.0-openjdk* -y

參考资料:http://blog.csdn.net/renfufei/article/details/9733367
 
9.安装Tomcat
  复制安装包。改动权限 chmod a+x *
  

ITFriend创业阶段的server环境搭建手冊的更多相关文章

  1. ITFriend创业阶段的服务器环境搭建手册

    创业阶段,进一步实践了Linux环境搭建和维护,下面是一些常用软件的搭建步骤和参考资料,仅供自己和诸位参考. 我个人还是比较倾向"一站式Web开发"的,自己想做点事,需要太多的技能 ...

  2. CentOS下安装和配置MySQL-JDK-Tomcat-Nginx(个人官网环境搭建手冊)

    今天,又一次弄我的个人云主机的环境.准备运营自己用Java写的个人官网等站点. 服务器环境:阿里云CentOS 6.4位 包含以下脚本在内的绝大部分命令和脚本,都是我亲自运行过,靠谱的. 完整的&qu ...

  3. 使用cordova+Ionic+AngularJs进行Hybird App开发的环境搭建手冊

    一.所需工具 1,JDK:生成 2.安卓SDK开发环境 3,NodeJs:主要使用的还是npm 4,Python开发环境 5.VS 2012(2008,2015也能够,已亲測):安装这个主要是须要一些 ...

  4. [ArcGIS]ArcGIS Server环境搭建,发布服务,以及使用ArcGIS API for JavaScript

    环境搭建 安装Web服务器 IIS 控制面板-程序-程序和功能-启用或关闭Windows功能,勾选以下 安装VisualStudio,选择包括ASP.NET模块 安装ArcGIS服务器 ArcGIS ...

  5. Linux应用server搭建手冊—Weblogic服务域的创建与部署

         前一篇谈到了Weblogic的安装,接下来整理weblogic服务域的创建及项目的部署      一.webLogic服务域创建          使用root用户登录后使用命令:#su W ...

  6. SVN server环境搭建

    VisualSVN server搭建: 1. 下载VisualSVN server for Windows安装包:https://www.visualsvn.com/ 2. 安装过程,基本就是下一步一 ...

  7. sprigcloud Eureka Server环境搭建

    1.搭建springcloud的Erueka组件,现在搭建这些套件已经变的很方便了,进入https://start.spring.io/页面,如下图: 2.选择好Eureka Server,点击Gen ...

  8. Nginx + FastCgi + Spawn-fcgi + C 架构的server环境搭建

    1.Nginx 1.1.安装 Nginx 的中文维基 http://wiki.codemongers.com/NginxChs 下载 Nginx 0.6.26(开发版)(请下载最新版本号) tar z ...

  9. 使用DataSnap Server环境搭建注意的问题。

    1.Data exploer 的MYSQL文件(Libmysql.dll)放到系统的system32目录即可

随机推荐

  1. Linux命令之nice和renice

    (1).nice命令 nice [选项] [命令 [参数]] 在执行程序之前,改变优先级.以调整过的优先级运行命令.如果没有给出命令,就显示当前的优先级.优先级范围从-20到19,越小优先级越高,默认 ...

  2. 【图论】Popular Cows

    [POJ2186]Popular Cows Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 34752   Accepted: ...

  3. 【可持久化数组】【rope】bzoj3673 bzoj3674 可持久化并查集 by zky

    rope教程:http://blog.csdn.net/iamzky/article/details/38348653 Code(bzoj3673): #include<cstdio> # ...

  4. [PKUSC2018]真实排名

    [PKUSC2018]真实排名 题目大意: 有\(n(n\le10^5)\)个人,每个人有一个成绩\(A_i(0\le A_i\le10^9)\).定义一个人的排名为\(n\)个人中成绩不小于他的总人 ...

  5. openstack-cinder-netapp

    https://communities.netapp.com/docs/DOC-31749 http://docs.openstack.org/havana/config-reference/cont ...

  6. mysql 按年月查询

    查询2017的数据:select * from table where year(column)='2017';查找月份为12的数据:select * from table where month(c ...

  7. Nand Flash与Nor

    转:http://www.360doc.com/content/11/1215/15/1299815_172458274.shtml Flash经常在一些地方被提到,一直没认真去理解它们的区别,因此, ...

  8. TJSONTableObject跨平台解析JSON

    TJSONTableObject跨平台解析JSON USES SynCrossPlatformJSON TSQLRecordPeoplePersistent = class(TPersistent) ...

  9. C/C++控制台输出时设置字体及背景颜色

    1.改变整个控制台的颜色用 system("color 0A"); 其中color后面的0是背景色代号,A是前景色代号.各颜色代码如下: 0=黑色 1=蓝色 2=绿色 3=湖蓝色  ...

  10. jquery一键控制checkbox全选,反选,全不选。

    jquery attr()方法获取标签的 checked 会有问题,所以用了 prop() 方法. Hml的checkbox没有加name,只用了 div 嵌套. 如有更好的方法,望指点!! //全选 ...