Oracle 11g R2(11.2.0.4) RAC 数据文件路径错误解决--ORA-01157 ORA-01110: 数据文件
Oracle 11g R2(11.2.0.1) RAC 数据文件路径错误解决--ORA-01157 ORA-01110: 数据文件
oracle 11g R2(11.2.0.4) rac
--scan ip
select file_name,tablespace_name from dba_data_files;
+DATA/bol/datafile/system.259.990861405 SYSTEM
+DATA/bol/datafile/sysaux.260.990861407 SYSAUX
+DATA/bol/datafile/undotbs1.261.990861409 UNDOTBS1
+DATA/bol/datafile/undotbs2.263.990861413 UNDOTBS2
+DATA/bol/datafile/users.264.990861413 USERS
+DATA/bol/datafile/test01.dbf TEST
+DATA/bol/datafile/sde_tbs.dbf SDE_TBS
+DATA/bol/datafile/sde_tbs02.dbf SDE_TBS
select name,file#,bytes/1024/1024 MB,status from v$datafile;
+DATA/bol/datafile/system.259.990861405 1 770 SYSTEM
+DATA/bol/datafile/sysaux.260.990861407 2 850 ONLINE
+DATA/bol/datafile/undotbs1.261.990861409 3 1125 ONLINE
+DATA/bol/datafile/undotbs2.263.990861413 4 200 ONLINE
+DATA/bol/datafile/users.264.990861413 5 500 ONLINE
+DATA/bol/datafile/test01.dbf 6 50 ONLINE
+DATA/bol/datafile/sde_tbs.dbf 7 500 ONLINE
+DATA/bol/datafile/sde_tbs02.dbf 8 200 ONLINE
[root@rac2 ~]# su - oracle
[oracle@rac2 ~]$ cd /u01/app/oracle/product/11.2.0/db_1/dbs/
[oracle@rac2 dbs]$ ll
total 16
-rw-rw---- 1 oracle asmadmin 1544 Nov 21 07:39 hc_bol2.dat
-rw-r----- 1 oracle oinstall 33 Oct 30 07:36 initbol2.ora
-rw-r--r-- 1 oracle oinstall 2851 Oct 30 07:01 init.ora
-rw-r----- 1 oracle oinstall 1536 Oct 30 07:40 orapwbol2
创建错误的表空间,用户,权限以及插入数据
通过scan_ip连接,是rac2节点,归档模式
SQL> archive log list;
Database log mode Archive Mode
Automatic archival Enabled
Archive destination +FRA/bol/arch
Oldest online log sequence 54
Next log sequence to archive 55
Current log sequence 55
SQL> CREATE TABLESPACE EXAMPLE DATAFILE
'/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' SIZE 100M AUTOEXTEND ON NEXT 640K MAXSIZE 32767M
NOLOGGING
ONLINE
EXTENT MANAGEMENT LOCAL AUTOALLOCATE
BLOCKSIZE 8K
SEGMENT SPACE MANAGEMENT AUTO
FLASHBACK ON;
SQL> CREATE USER hr
IDENTIFIED BY "hr"
DEFAULT TABLESPACE EXAMPLE
TEMPORARY TABLESPACE TEMP
PROFILE DEFAULT
ACCOUNT UNLOCK;
GRANT RESOURCE TO HR;
ALTER USER HR DEFAULT ROLE ALL;
-- 7 System Privileges for HR
GRANT ALTER SESSION TO HR;
GRANT CREATE DATABASE LINK TO HR;
GRANT CREATE SEQUENCE TO HR;
GRANT CREATE SESSION TO HR;
GRANT CREATE SYNONYM TO HR;
GRANT CREATE VIEW TO HR;
GRANT UNLIMITED TABLESPACE TO HR;
SQL> create table t (id int);
SQL> insert into t select level id from dual connect by level <100000;
SQL> commit;
SQL> select count(*) from t;
SQL> select count(*) from hr.t;
再次查看表空间,数据文件等
SQL> select file_name,tablespace_name from dba_data_files;
/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF EXAMPLE
SQL> select name,file#,bytes/1024/1024 MB,status from v$datafile;
/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF 9 100 ONLINE
登录rac1节点查看
SQL> select file_name,tablespace_name from dba_data_files;--直接报错
ORA-01157: 无法标识/锁定数据文件 9 - 请参阅 DBWR 跟踪文件
ORA-01110: 数据文件 9: '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF'
SQL> select group_number , name , state, type from v$asm_diskgroup; --查看asm磁盘组信息,返回正常
1 DATA CONNECTED EXTERN
2 FRA CONNECTED EXTERN
3 OCR MOUNTED EXTERN
登录rac2节点
SQL> alter database datafile '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' offline;
SQL> select name,file#,bytes/1024/1024 MB,status from v$datafile;
/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF 9 100 RECOVER
使用rman在rac2节点上登录
[oracle@rac2 dbs]$ rman target /
Recovery Manager: Release 11.2.0.4.0 - Production on Wed Nov 21 08:14:47 2018
Copyright (c) 1982, 2011, Oracle and/or its affiliates. All rights reserved.
connected to target database: BOL (DBID=4213574617)
RMAN> copy datafile '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' to '+DATA/bol/datafile/EXAMPLE01.DBF';
Starting backup at 21-NOV-18
using target database control file instead of recovery catalog
allocated channel: ORA_DISK_1
channel ORA_DISK_1: SID=32 instance=bol2 device type=DISK
channel ORA_DISK_1: starting datafile copy
input datafile file number=00009 name=/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF
output file name=+DATA/bol/datafile/example01.dbf tag=TAG20181121T081627 RECID=1 STAMP=992765787
channel ORA_DISK_1: datafile copy complete, elapsed time: 00:00:01
Finished backup at 21-NOV-18
[oracle@rac2 dbs]$ sqlplus / as sysdba
SQL> alter database rename file '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' to '+DATA/bol/datafile/EXAMPLE01.DBF';
Database altered.
SQL> recover datafile '+DATA/bol/datafile/EXAMPLE01.DBF';
ORA-00279: change 2845533 generated at 11/21/2018 07:39:35 needed for thread 1
ORA-00289: suggestion : +FRA/bol/arch/110_1_990861401.log
ORA-00280: change 2845533 for thread 1 is in sequence #110
Specify log: {<RET>=suggested | filename | AUTO | CANCEL}
Log applied.
Media recovery complete.
SQL> alter database datafile '+DATA/bol/datafile/EXAMPLE01.DBF' online;
Database altered.
在节点2上查询
SQL> select file_name,tablespace_name from dba_data_files; --显示路径正常
+DATA/bol/datafile/example01.dbf EXAMPLE
SQL> select name,file#,bytes/1024/1024 MB,status from v$datafile;
+DATA/bol/datafile/example01.dbf 9 100 ONLINE
在节点1上进行查询,也正常,并查询hr.t的数据
SQL> select file_name,tablespace_name from dba_data_files;
+DATA/bol/datafile/example01.dbf EXAMPLE
SQL> select count(*) from hr.t;--返回正常
[root@rac1 ~]# su - oracle
[oracle@rac1 ~]$ sqlplus / as sysdba
SQL> select count(*) from hr.t;
COUNT(*)
----------
99999
---在非归档模式下进行
SQL> alter database datafile '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' offline;
ORA-01145: offline immediate disallowed unless media recovery enabled
以上操作需要在归档模式下才可以
非归档模式下
SQL> alter tablespace EXAMPLE offline;
Tablespace altered.
SQL> alter database datafile '/u01/app/oracle/product/11.2.0/db_1/dbs/C:APPADMINISTRATORORADATABOLEXAMPLE01.DBF' offline;
Database altered.
Oracle 11g R2(11.2.0.4) RAC 数据文件路径错误解决--ORA-01157 ORA-01110: 数据文件的更多相关文章
- Oracle Linux 6.3下安装Oracle 11g R2(11.2.0.3)
本文主要描写叙述了在Oracle Linux 6.3下安装Oracle 11gR2(11.2.0.3).从Oracle 11g開始,Oracle官方站点不再提供其Patch的下载链接,须要使用Meat ...
- CentOS6.9 安装Oracle 11G 版本11.2.0.1.0
安装实例与数据库 CentOS6.9 安装Oracle 11G 版本11.2.0.1.0 一.检查系统类别. 查看 系统的类别,这里是 64位系统:[root@localhost ~]# uname ...
- oracle 11g R2安装报错ORA-00604及ORA-06553的原因及解决方法
10月31日PO主打算装oracle 11g R2,于是通过QQ旋风离线下载功能从oracle官网的链接下载了win32_11gR2_database_1of2.zip和win32_11gR2_dat ...
- Missing artifact com.oracle:ojdbc6:jar:11.2.0.3 Maven中不能引入ojdbc解决方法,错误
今天从服务器检出Maven项目的时候,遇到了一个问题,就是在pom.xml中引入ojdbc的jar包的时候出错了,提示是Missing artifact com.oracle:ojdbc6:jar:1 ...
- oracle 11g r2 使用rman进行迁移rac到rac
源端服务器主机名 rac05 rac06公共IP地址(eth0) 10.15.8.15 10.15.8.16 虚拟IP地址(eth0) 10.15.8.17 10.15.8.18私有IP地址(eth1 ...
- CentOS7 安装oracle 11g (11.2.0.1.0)
1.安装依赖: #yum -y install binutils compat-libcap1 compat-libstdc++-33 gcc gcc-c++ glibc glibc-devel ks ...
- 关于 Oracle 11g r2 Enterprise Manager (EM) 在windows环境无法启动的解决办法
正确的解决办法是在安装的时候使用emca正确安装 如果已经安装过Enterprise Manager: 请用是如下命令卸载后重装 emca -deconfig dbcontrol db emca -r ...
- RHEL6.7 x64双节点安装Oracle 11g r2 RAC
基础环境 使用两台HP DL580服务器作为RAC节点,存储使用IBM V7000.具体环境如下: 设备 用途 IP地址 磁盘空间 HP DL580 RAC节点01 RAC01-pub:116.1.1 ...
- Oracle 11g R2 Backup Data Pump(数据泵)之expdp/impdp工具
Oracle Data Pump(以下简称数据泵)是Oracle 10g开始提供的一种数据迁移工具,同时也被广大DBA用来作为数据库的逻辑备份工具和体量较小的数据迁移工具.与传统的数据导出/导入工具, ...
随机推荐
- Myeclipse 快捷键使用
MyEclipse快捷键大全-------------------------------------MyEclipse 快捷键1(CTRL)----------------------------- ...
- each方法的简单使用
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/stric ...
- IDEA配置文件的保存目录
IntelliJ IDEA 的实时代码模板保存在 /templates 目录下,其他系统目录位置如下:(因为目录名在各个系统上是一致的,建议用硬盘搜索工具搜索即可) Windows: . Linux: ...
- [转载]spring security 的 logout 功能
原文地址:security 的 logout 功能">spring security 的 logout 功能作者:sumnny 转载自:http://lengyun3566.iteye ...
- tp3.2关联模型 BELONGS_TO
<?php namespace Home\Model; use Think\Model\RelationModel; class AttenModel extends RelationModel ...
- 最全面的linux信号量解析
信号量 一.什么是信号量 信号量的使用主要是用来保护共享资源,使得资源在一个时刻只有一个进程(线程) 所拥有. 信号量的值为正的时候,说明它空闲.所测试的线程可以锁定而使用它.若为0,说明 它被占用, ...
- vue组件 Prop传递数据
组件实例的作用域是孤立的.这意味着不能(也不应该)在子组件的模板内直接引用父组件的数据.要让子组件使用父组件的数据,我们需要通过子组件的props选项. prop 是单向绑定的:当父组件的属性变化时, ...
- ios 获取导航栏和状态栏高度,针对iPhoneX
因为iPhoneX的产生,原本的导航栏再也不是44了,那么会出现什么问题呢?在隐藏导航栏的页面,原本的高度要向上调整一个导航栏+状态栏的高度.那么iPhoneX的导航栏高度不是44了,我们需要手动获取 ...
- 解决Navicat连接mysql报错:1862 - Your password has expired. To log in you must change it using a client that supports expired passwords.
今天尝试用Navicat连接mysql时,发现一个1862的报错问题: 后来参照这篇文章https://blog.csdn.net/u010513756/article/details/5073501 ...
- 使用饿了么ui表单验证报错: [Element Warn][Form]model is required for validat
[Element Warn][Form]model is required for validat 如文末的完整例子: 该提示说的是 form表单需要一个绑定一个 对象(使用:model=" ...