初学者自编文档,如有错误,请指出,具体命令就不阐述了,不明白 度娘吧!

nginx我是编译安装在服务器上 和其他安装应该会有区别

  • 安装路径路径:/usr/local/
  • 安装包存放位置:/home/apps/web/
前期依赖包安装链接 http://www.cnblogs.com/nikolatesfei/p/5422678.html

1. 安装PHP

     cd  home/apps/web && mkdir php && cd php 进入安装包存放文件夹并创建php文件夹 并进入php安装文件夹

      A.下载  wget http://museum.php.net/php5/php-5.6.2.tar.gz

B.解压  tar xzf php-5.6.2.tar.gz

C.安装  ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc/ --with-mcrypt --with-zlib --with-curl --disable-debug --enable-fpm --enable-mbstring --enable-sockets --enable-zip --enable-xml --enable-pdo

安装注解: --width-xx 为需要编译安装的内容,请根据合适的方案来,我后面因为需要php支持jpeg的支持需要重新编译GD库导致无法安装,只能重新安装php,在此申明,未加上GD库

---------------------------------------------------------------------------------

我在这里安装出现了错误:

configure: error:mcrypt.h not found. Please reinstall libmcrypt.

百度资料,百度后 现整理如下

需安装libmcrypt

http://sourceforge.net/projects/mcrypt/files/Libmcrypt/2.5.8/

A. wget https://sourceforge.net/projects/mcrypt/files/Libmcrypt/2.5.8/libmcrypt-2.5.8.tar.gz

B. tar zxvf libmcrypt-2.5.8.tar.gz

C. cd libmcrypt-2.5.8

D.  ./configure --prefix=/usr/local

E. make

F. make instally

安装完毕,请重新执行上一部操作

-----------------------------------------------------------------------------------

D. make

E. make install

2.启动

/usr/local/php/sbin/php-fpm -y=/usr/local/php/etc/php-fpm.conf -c=/usr/local/php/etc/php.ini

-------------------------------------------------------------------------------------------------------------

这里出现了错误:

        [21-Apr-2016 16:08:27] ERROR: failed to open configuration file '/usr/local/php/etc/php-fpm.conf': No such file or directory (2)

    [21-Apr-2016 16:08:27] ERROR: failed to load configuration file '/usr/local/php/etc/php-fpm.conf'
    [21-Apr-2016 16:08:27] ERROR: FPM initialization failed

自查应该是缺少conf文件

1 .cd /usr/local/php/etc

2 .cp php-fpm.conf.default php-fpm.conf 复制一个文件 复制的文件名为php-fpm.conf

-------------------------------------------------------------------------------------------------------------------------------

----------------------------------

2.重启

/usr/local/php/sbin/php-fpm -y=/usr/local/php/etc/php-fpm.conf -c=/usr/local/php/etc/php.ini -t
killall php
/usr/local/php/sbin/php-fpm -y=/usr/local/php/etc/php-fpm.conf -c=/usr/local/php/etc/php.ini
----------------------------------------------------------------------------
这里重启一个错误:
ERROR: unable to bind listening socket for address ’127.0.0.1:9000′
解决方案:
netstat -lntup | grep 9000
killall php-fpm
-----------------------------------------------------------------------------------

3.配置

1.phpinfo() 中 Loaded Configuration File 值为none

直接把源码包中的php.ini-production拷贝到--with-config-file-path设置的路径,例:/usr/local/php/etc/php.ini

--with-config-file-path 为安装代码中的值 在安装代码中已经加上

cp php.ini-production /usr/local/php/etc/php.ini

2.日志文件

php.ini

error_log = /usr/local/php/log/error_log
error_reporting = E_ALL
改成 error_reporting = E_ALL | E_STRICT log_errors = On display_errors = off extension_dir="/usr/local/php/lib/php/extensions/"

php-fpm.conf

catch_workers_output = yes
error_log = /usr/local/php/log/error_log

www.conf

# 只有www.conf.default,那么复制一个www.conf

cd /usr/local/php/etc/php-fpm.d

cp www.conf.default www.conf

vi /usr/local/php/etc/php-fpm.d/www.conf

将 user = nobody group=nobody改成你系统运行的角色,如果你是root运行,忽略本次操作

3.环境变量

1.vi etc/profile

2.在最后追加

 PATH=$PATH:/usr/local/php/bin:$PATH

  export PATH

'user' directive is ignored when FPM is not running as root
用的非root用户运行的,sudo 运行命令即可

centos-php安装的更多相关文章

  1. NoSql1 在Linux(CentOS)上安装memcached及使用

    前言:       今天是初五,生活基本要从过年的节奏中回归到正常的生活了,所以想想也该想想与工作有关的事情了.我之前在工作中会经常使用memcached和redis,但是自己一直没有时间系统的好好看 ...

  2. 在Ubuntu|CentOS上安装Shutter截图工具及快捷键设置

    简介 Shutter前身叫GScrot,它是一款相当棒的截图软件. 通过Shutter,你可以截取包括选定区域.全屏幕.窗口.窗口内的控件甚至网页的图像.通过内置的强大插件机制,你可以在截图后,对图像 ...

  3. CentOS下安装hadoop

    CentOS下安装hadoop 用户配置 添加用户 adduser hadoop passwd hadoop 权限配置 chmod u+w /etc/sudoers vi /etc/sudoers 在 ...

  4. CentOS下安装使用start-stop-daemon

    CentOS下安装使用start-stop-daemon 在centos下下了个自启动的服务器脚本 执行的时候发现找不到start-stop-daemon命令 好吧 执行手动编译一下 加上这个命令 w ...

  5. CentOS 7 安装 Docker

    CentOS 7 安装 Docker 这里介绍 ContOS 7 的安装 docker V1.2+,包括阿里云加速 docker 镜像下载的设置,这对提升使用 docker 体验至关重要.其他系统安装 ...

  6. centos在线安装svn

    centos在线安装svn 用下列命令安装svn服务 yum install subversion 创建svn版本库目录 mkdir -p /var/svn/svnrepos 创建版本库 svnadm ...

  7. CentOS 7 安装 配置 MySQL

    第一部分:CentOS 7安装MySQL 5.7 1.下载YUM库 shell > wget http://dev.mysql.com/get/mysql57-community-release ...

  8. 从零开始学 Java - CentOS 下安装 Nginx

    早上下起了暴雨 闹钟还未响起就听到雨滴哗啦啦击打窗户的声音,被吵醒了.起床上班,在楼下的十字路口,暴雨大到完全看不清对面,两个穿着雨衣的交警站在路口中间指挥着过往的车辆,大家都慌慌张张.急急忙忙的打着 ...

  9. 从零开始学 Java - CentOS 下安装 Tomcat

    生活以痛吻我,我仍报之以歌 昨天晚上看到那个冯大辉老师的微信公众号,「小道消息」上的一篇文章,<生活以痛吻我,我仍报之以歌>.知乎一篇匿名回答,主题为<冯大辉到底是不是技术大牛,一个 ...

  10. Linux(Centos)之安装Redis及注意事项

    1.redis简单说明 a.在前面我简单的说过redis封装成共用类的实现,地址如下:http://www.cnblogs.com/hanyinglong/p/Redis.html. b.redis是 ...

随机推荐

  1. 核心C#

    核心C# 内容提要: 声明变量:变量的初始化和作用域:C#的预定义数据类型:在C#程序中使用条件语句.循环和跳转语句指定执行流:枚举:名称空间: Main()方法:基本命令行C#编译器选项:使用Sys ...

  2. 使用C++做算法时,对内存的管理的办法

    使用C++做算法时,对内存的管理的办法 最近老是在想C++的内存控制机制,查了一些资料所以有点想法,自己记录一下免得以后自己忘了. 1. 需求 在做线性代数的算法时,首要的就实现Matrix这个类.由 ...

  3. Centos 上使用mmsh协议听猫扑网络电台 VLC播放器

    Centos 上使用mmsh协议听猫扑网络电台 VLC播放器 安装CentOS已经有一段时间了,但是由于在Linux下除了学习,其他是事情都干不了.今天想闲来无事开了CentOS就想听一下歌,突然想起 ...

  4. asp.net MVC 路由机制

    1:ASP.NET的路由机制主要有两种用途: -->1:匹配请求的Url,将这些请求映射到控制器 -->2:选择一个匹配的路由,构造出一个Url 2:ASP.NET路由机制与URL重写的区 ...

  5. Android 短信模块分析(三) MMS入口分析

    MMS入口分析:      在Mms中最重要的两个Activity,一个是conversationList(短信列表) ,另一个就是ComposeMessageActivity(单个对话或者短信).每 ...

  6. TaintDroid:智能手机监控实时隐私信息流跟踪系统(三)

    4.3   原生代码标记传播 Native 代码是不受TaintDroid监控的.理想情况下,我们获得了相同的传播语义当使用相同的解释副本时.因此,为了精确的在Java层进行污点监控,我们定义了两个必 ...

  7. python自动化开发-1

    1.python简介 python是一门简明并且强大的面向对象的开发语言,已经在WEB开发,软件开发,科学计算,大数据分析,自动化运维等领域得到了广泛的应用. 注意:所有测试均已python3为主,与 ...

  8. 十件你需要知道的事,关于openstack-trove(翻译)

    开源数据库即服务OpenStack Trove应该知道的10件事情 作者:Ken Rugg,Tesora首席执行官 Ken Rugg是Tesora的创始人,CEO和董事会成员. Ken的大部分职业都是 ...

  9. Tip of the Day

    Did you know ... ? You can view all statements within the method where certain exceptions can be cau ...

  10. linux 查看磁盘占用情况

    查看"/usr/local/"路径下,所有文件大小总和.只列出总和,不显示该路径下各子文件的大小. du -sh /usr/local/ 结果显示如下图: 如果要详细显示出各子文件 ...