Oozie时bin/oozied.sh start或bin/oozied.sh run出现Bootstrap进程无法启动,http://bigdatamaster:11000/oozie界面也无法打开?E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.ser
不多说,直接上干货!
问题详情

[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$ bin/oozied.sh start Setting OOZIE_HOME: /home/hadoop/app/oozie-4.1.-cdh5.5.4
Setting OOZIE_CONFIG: /home/hadoop/app/oozie-4.1.-cdh5.5.4/conf
Sourcing: /home/hadoop/app/oozie-4.1.-cdh5.5.4/conf/oozie-env.sh
setting CATALINA_OPTS="$CATALINA_OPTS -Xmx1024m"
setting OOZIE_CONF=${OOZIE_HOME}/conf
setting OOZIE_DATA=${OOZIE_HOME}/data
setting OOZIE_LOG=${OOZIE_HOME}/logs
setting CATALINA_BASE=${OOZIE_HOME}/oozie-server
setting CATALINA_TMPDIR=${OOZIE_HOME}/oozie-server/temp
setting CATALINA_OUT=${OOZIE_LOG}/catalina.out
Setting OOZIE_CONFIG_FILE: oozie-site.xml
Using OOZIE_DATA: /home/hadoop/app/oozie-4.1.-cdh5.5.4/data
Using OOZIE_LOG: /home/hadoop/app/oozie-4.1.-cdh5.5.4/logs
Setting OOZIE_LOG4J_FILE: oozie-log4j.properties
Setting OOZIE_LOG4J_RELOAD:
Setting OOZIE_HTTP_HOSTNAME: bigdatamaster
Setting OOZIE_HTTP_PORT:
Setting OOZIE_ADMIN_PORT:
Setting OOZIE_HTTPS_PORT:
Setting OOZIE_BASE_URL: http://bigdatamaster:11000/oozie
Using CATALINA_BASE: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server
Setting OOZIE_HTTPS_KEYSTORE_FILE: /home/hadoop/.keystore
Setting OOZIE_HTTPS_KEYSTORE_PASS: password
Setting OOZIE_INSTANCE_ID: bigdatamaster
Using CATALINA_OUT: /home/hadoop/app/oozie-4.1.-cdh5.5.4/logs/catalina.out
Setting CATALINA_PID: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/temp/oozie.pid Using CATALINA_OPTS: -Xmx1024m -Dderby.stream.error.file=/home/hadoop/app/oozie-4.1.-cdh5.5.4/logs/derby.log
Adding to CATALINA_OPTS: -Doozie.home.dir=/home/hadoop/app/oozie-4.1.-cdh5.5.4 -Doozie.config.dir=/home/hadoop/app/oozie-4.1.-cdh5.5.4/conf -Doozie.log.dir=/home/hadoop/app/oozie-4.1.-cdh5.5.4/logs -Doozie.data.dir=/home/hadoop/app/oozie-4.1.-cdh5.5.4/data -Doozie.instance.id=bigdatamaster -Doozie.config.file=oozie-site.xml -Doozie.log4j.file=oozie-log4j.properties -Doozie.log4j.reload= -Doozie.http.hostname=bigdatamaster -Doozie.admin.port= -Doozie.http.port= -Doozie.https.port= -Doozie.base.url=http://bigdatamaster:11000/oozie -Doozie.https
.keystore.file=/home/hadoop/.keystore -Doozie.https.keystore.pass=password -Djava.library.path= Using CATALINA_BASE: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server
Using CATALINA_HOME: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server
Using CATALINA_TMPDIR: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/temp
Using JRE_HOME: /home/hadoop/app/jdk
Using CLASSPATH: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/bin/bootstrap.jar
Using CATALINA_PID: /home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/temp/oozie.pid
Existing PID file found during start.
Removing/clearing stale PID file.
[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$
查看日志


-- ::, INFO XLogService: - SERVER[bigdatamaster] Log4j configuration file [oozie-log4j.properties]
-- ::, INFO XLogService: - SERVER[bigdatamaster] Log4j configuration file loaded from [/home/hadoop/app/oozie-4.1.-cdh5.5.4/conf]
-- ::, INFO XLogService: - SERVER[bigdatamaster] Log4j reload interval [ sec]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Oozie home dir [/home/hadoop/app/oozie-4.1.-cdh5.5.4]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Oozie conf dir [/home/hadoop/app/oozie-4.1.-cdh5.5.4/conf]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Oozie conf file [oozie-site.xml]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Configuration change via System Property, [oozie.base.url]=[http://bigdatamaster:11000/oozie]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Configuration change via System Property, [oozie.http.hostname]=[bigdatamaster]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Configuration change via System Property, [oozie.http.port]=[]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Configuration change via System Property, [oozie.instance.id]=[bigdatamaster]
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] System property [oozie.https.keystore.pass] no defined in Oozie configuration, ignored
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] System property [oozie.admin.port] no defined in Oozie configuration, ignored
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] System property [oozie.https.port] no defined in Oozie configuration, ignored
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] System property [oozie.https.keystore.file] no defined in Oozie configuration, ignored
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.http.hostname], Value [bigdatamaster]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.instance.id], Value [bigdatamaster]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.http.port], Value []
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] Invalid configuration defined, [oozie.service.ProxyUserService.proxyuser.hadoop.hosts]
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] Invalid configuration defined, [oozie.service.ProxyUserService.proxyuser.hadoop.groups]
-- ::, WARN Services: - SERVER[bigdatamaster] System ID [oozie-hado] exceeds maximum length [], trimming
-- ::, INFO Services: - SERVER[bigdatamaster] Exiting null Entering NORMAL
-- ::, INFO Services: - SERVER[bigdatamaster] Initialized runtime directory [/home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/temp/oozie-hado4767423416871899036.dir]
-- ::, FATAL Services: - SERVER[bigdatamaster] Runtime Exception during Services Load. Check your list of 'oozie.services' or 'oozie.services.ext'
-- ::, FATAL Services: - SERVER[bigdatamaster] E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
org.apache.oozie.service.ServiceException: E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.oozie.service.Services.loadServices(Services.java:)
at org.apache.oozie.service.Services.init(Services.java:)
at org.apache.oozie.servlet.ServicesLoader.contextInitialized(ServicesLoader.java:)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:)
at org.apache.catalina.core.StandardService.start(StandardService.java:)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:)
at org.apache.catalina.startup.Catalina.start(Catalina.java:)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:)
at java.lang.reflect.Method.invoke(Method.java:)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:)
Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.hadoop.conf.Configuration.getClasses(Configuration.java:)
at org.apache.oozie.service.ConfigurationService$LogChangesConfiguration.getClasses(ConfigurationService.java:)
at org.apache.oozie.service.ConfigurationService.getClasses(ConfigurationService.java:)
at org.apache.oozie.service.Services.loadServices(Services.java:)
... more
Caused by: java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:)
at org.apache.oozie.util.XConfiguration.getClassByName(XConfiguration.java:)
at org.apache.hadoop.conf.Configuration.getClasses(Configuration.java:)
... more
[hadoop@bigdatamaster logs]$
解决办法
http://community.cloudera.com/t5/Cloudera-Manager-Installation/Oozie-startup-failure-ERROR-XSDB6/td-p/11584
查看

[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$ ps aux | grep oozie
hadoop 0.0 0.0 pts/ S+ : : grep oozie
[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$
[hadoop@bigdatamaster oozie-4.1.0-cdh5.5.4]$
然后
Its likely that another instance of Oozie may be running on the machine already thats causing this. You can first check for such an instance via a "ps aux | grep oozie" command perhaps, and kill it if one is indeed running.
If there's no other instance, then its likely that the OOME caused crash/kill has left the DB lock under the derby directory, causing the further startups to fail as it now thinks the DB is in use (Derby DB supports only 1 max. current user, which is why we strongly discourage its use in your clusters - consider moving off of Derby when you get a chance).
To resolve that, run: rm /var/lib/oozie/data/*.lck
After this, start up the Oozie server again, and it should come up now.
Once again: Consider changing the default DB of Oozie to MySQL/etc. instead of Derby. You'll avoid a lot of other pains that will come later if you continue to use it.

[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$ jps
Bootstrap
NameNode
SecondaryNameNode
Jps
QuorumPeerMain
ResourceManager
[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$

-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] System property [oozie.https.keystore.file] no defined in Oozie configuration, ignored
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.http.hostname], Value [bigdatamaster]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.instance.id], Value [bigdatamaster]
-- ::, INFO ConfigurationService: - SERVER[bigdatamaster] Overriding configuration with system property. Key [oozie.http.port], Value []
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] Invalid configuration defined, [oozie.use.system.libpath]
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] Invalid configuration defined, [oozie.service.ProxyUserService.proxyuser.hadoop.hosts]
-- ::, WARN ConfigurationService: - SERVER[bigdatamaster] Invalid configuration defined, [oozie.service.ProxyUserService.proxyuser.hadoop.groups]
-- ::, WARN Services: - SERVER[bigdatamaster] System ID [oozie-hado] exceeds maximum length [], trimming
-- ::, INFO Services: - SERVER[bigdatamaster] Exiting null Entering NORMAL
-- ::, INFO Services: - SERVER[bigdatamaster] Initialized runtime directory [/home/hadoop/app/oozie-4.1.-cdh5.5.4/oozie-server/temp/oozie-hado2668923471340073361.dir]
-- ::, FATAL Services: - SERVER[bigdatamaster] Runtime Exception during Services Load. Check your list of 'oozie.services' or 'oozie.services.ext'
-- ::, FATAL Services: - SERVER[bigdatamaster] E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
org.apache.oozie.service.ServiceException: E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.oozie.service.Services.loadServices(Services.java:)
at org.apache.oozie.service.Services.init(Services.java:)
at org.apache.oozie.servlet.ServicesLoader.contextInitialized(ServicesLoader.java:)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:) at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:)
Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.hadoop.conf.Configuration.getClasses(Configuration.java:)
at org.apache.oozie.service.ConfigurationService$LogChangesConfiguration.getClasses(ConfigurationService.java:)
at org.apache.oozie.service.ConfigurationService.getClasses(ConfigurationService.java:)
at org.apache.oozie.service.Services.loadServices(Services.java:)
... more
Caused by: java.lang.ClassNotFoundException: Class org.apache.oozie.service.CoordinatorStoreService not found
at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:)
at org.apache.oozie.util.XConfiguration.getClassByName(XConfiguration.java:)
at org.apache.hadoop.conf.Configuration.getClasses(Configuration.java:)
... more
[hadoop@bigdatamaster logs]$

[hadoop@bigdatamaster oozie-4.1.-cdh5.5.4]$ chmod oozie-server
然后,我又执行这条命令。
然后呢,大家也许还会出现如下问题:
Oozie安装时放置Mysql驱动包的总结(网上最全)
Oozie时出现org.apache.oozie.service.ServiceException: E0103: Could not load service classes, Cannot load JDBC driver class 'com.mysql.jdbc.Driver'
Oozie时bin/oozied.sh start或bin/oozied.sh run出现Bootstrap进程无法启动,http://bigdatamaster:11000/oozie界面也无法打开?E0103: Could not load service classes,
java.lang.ClassNotFoundException: Class org.apache.oozie.ser
Oozie时bin/oozied.sh start或bin/oozied.sh run出现Bootstrap进程无法启动,http://bigdatamaster:11000/oozie界面也无法打开?
Oozie时出现Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure?
Oozie时出现Exception in thread "main" java.lang.UnsupportedClassVersionError: com/mysql/jdbc/Driver : Unsupported major.minor version 52.0?
CDH版本的oozie安装执行bin/oozie-setup.sh prepare-war,没生成oozie.war?
Oozie时bin/oozied.sh start或bin/oozied.sh run出现Bootstrap进程无法启动,http://bigdatamaster:11000/oozie界面也无法打开?E0103: Could not load service classes, java.lang.ClassNotFoundException: Class org.apache.oozie.ser的更多相关文章
- Oozie时出现org.apache.oozie.service.ServiceException: E0103: Could not load service classes, Cannot load JDBC driver class 'com.mysql.jdbc.Driver'
不多说,直接上干货! 问题详情 查看你的$OOZIE_HOME/logs 我的是/home/hadoop/app/oozie-4.1.0-cdh5.5.4/logs/oozie.log文件 [hado ...
- Tomcat报java.lang.ClassNotFoundException: 1catalina.org.apache.juli.FileHandler
最近在生产环境部署Tomcat的时候,在启动的时候,在控制台报"java.lang.ClassNotFoundException: 1catalina.org.apache.juli.Fil ...
- 解决kylin sync table报错:MetaException(message:java.lang.ClassNotFoundException Class org.apache.hive.hcatalog.data.JsonSerDe not found
在kylin-gui中sync表default.customer_visit时报错: -- ::, ERROR [http-bio--exec-] controller.BasicController ...
- Tomcat报错java.lang.ClassNotFoundException: 2localhost.org.apache.juli.FileHandler
Can't load log handler "1catalina.org.apache.juli.FileHandler" java.lang.ClassNotFoundExce ...
- 一个解决过程:Servlet [某路径xxx] in web application [/项目xxx] threw load() exception和java.lang.ClassNotFoundException XXX
Servlet [某路径xxx] in web application [/项目xxx] threw load() exception和java.lang.ClassNotFoundException ...
- IDEA里运行代码时出现Caused by: java.lang.ClassNotFoundException: org.apache.log4j.Logger的解决办法(图文详解)
不多说,直接上干货! 问题详情 运行出现log4j的问题 -classpath "C:\Program Files\Java\jdk1.8.0_66\jre\lib\charsets.jar ...
- 在Eclipse IDE进行Struts开发时提示错误:java.lang.ClassNotFoundException: org.apache.struts2.dispatcher.FilterDispatcher的解决办法
If you have... included all necessary jars Configured build path correctly added them all in deploym ...
- json转换时 java.lang.ClassNotFoundException: org.apache.commons.lang.exception.NestableRuntimeException
java.lang.ClassNotFoundException: org.apache.commons.lang.exception.NestableRuntimeException 遇到这种问题是 ...
- java.lang.ClassNotFoundException: org.apache.juli.logging.LogFactory的解决办法
Tomcat7早就出来正式版,但是一直都没有用过,尤其是针对于我还一直在用Myeclipse6.5的人来说,它在配置tomcat的时候没有tomcat7的选项,所以就报了错误信息. java.lang ...
随机推荐
- JavaSE教程-03Java中分支语句与四种进制转换-思维导图
思维导图看不清楚时: 1)可以将图片另存为图片,保存在本地来查看 2)右击在新标签中打开放大查看 if语句 a) if语句 基本语法结构: if(关系表达式) { 基本语句体 } 执行流程: 首先判断 ...
- css块级元素居中
<!DOCTYPE html> <html> <head> <title>index</title> </head> <b ...
- Floyd判圈算法
Floyd判圈算法 leetcode 上 编号为202 的happy number 问题,有点意思.happy number 的定义为: A happy number is a number defi ...
- Coursera 机器学习笔记(一)
主要是第一二周内容 机器学习概要 机器学习是什么? 生活在信息时代的我们,其实时时刻刻都离不开机器学习算法.比如日常使用的搜索引擎就涉及到很多学习算法. Arthur Samuel 给出第一个定义.他 ...
- 【Spark2.0源码学习】-10.Task执行与回馈
通过上一节内容,DriverEndpoint最终生成多个可执行的TaskDescription对象,并向各个ExecutorEndpoint发送LaunchTask指令,本节内容将关注Exe ...
- python基础操作_字符串操作_列表操作list
#字符串可以通过下表取值,如下程序 names='java python' print(names[0],names[5]) #使用for循环轮询所有name值 ''' for name in nam ...
- oracle 体系结构简介
1.1.SGA(system global area) SGA是oracle Instance的基本组成部分,在示例启动是分配.是一组包含一个oracle实例的数据和控制信息的共享内存结构.主要用于存 ...
- linux exec操作文件描述符
linux每一个打开文件都会关联一个文件描述符,需要的时候我们可以使用exec命令指定一个大于3的数字作为文件 linux默认文件描述符 每打开一个shell就会打开默认的三个文件描述符描0,1,2, ...
- RabbitMQ安装与初始配置
[TOC] 本文只讨论linux下的Rabbitmq安装. Erlang安装 rabbitmq依赖于Erlang,需先安装,推荐安装rabbitmq/erlang-rpm: #clone源码 git ...
- 验证表格多行某一input是否为空
function checkTableKeyWordVal(tableId){ var result = true; $("#"+tableId+" tbody tr&q ...