转自:http://blog.51cto.com/jimshu/590411

 Windows 防火墙通过阻止未授权用户通过 Internet 或网络访问您的计算机来帮助保护计算机。

  Windows 2008 和 Windows Vista 及后续版本都修改了安全策略,防火墙默认阻止了未经允许的访问。

一、服务

1、查看服务

  打开“管理工具”--“服务”,可以找到名为“Windows Firewall”的服务。

  在Windows Server 2003操作系统中,如果停止这个服务,将允许所有的外部连接,即打开了所有的端口。但是,Windows Server 2008和Windows Vista及后续版本,颠覆了这一原则,即:如果停止这个服务,将拒绝所有的外部连接请求(关闭所有的端口)。

2、从控制面板打开防火墙管理界面

3、基本操作(不推荐)

  在这种“基本模式”下,如果需要允许某些程序通过防火墙,可以针对该应用程序开放其所需的端口。

4、高级安全Windows防火墙(推荐)

(1)如果是 Windows Server 2008 操作系统,直接在“管理工具”中打开“高级安全Windows防火墙”。

(2)如果是Windows 7 操作系统,默认情况下“管理工具”是隐藏的。可以通过“搜索程序和文件”(超级搜索)功能打开。

(3)通过控制面板也可以打开“高级安全Windows防火墙”。

二、关闭防火墙(不推荐)

  为了图省事,特别是在测试环境中,如果想关闭防火墙,应该按以下操作。(请勿停止Windows Firewall服务,不然会禁用所有的入站请求)

(1)模式一:基本模式下的操作

(2)模式二:高级安全 Windows 防火墙

三、为SQL Server 开放端口

1. 启用SQL Server默认实例所需的端口

  SQL Server服务器(默认实例)默认使用TCP1433端口为客户端建立连接,但是在安装SQL Server的过程中并不会自动打开这个端口。在安装时会有一个警告。

  为了开放端口,我们使用“高级安全 Windows 防火墙”。

  在左侧的列表中,选择“入站规则”,在最右侧的任务列表中选择“新建规则”。

  在“该规则应用于TCP还是UDP”中选择“TCP”,然后在“该规则应用于所有本地端口还是特定端口”中选择“特定本地端口”,然后输入端口号(数字)。

  在本例中,可以输入多个端口,中间用逗号隔开。Windows 7 和 Windows Server 2008 R2 还允许开放连续的端口,例如:5100-5200。

说明1:TCP5022端口用在SQL Server的镜像(MIRROR)技术中。此处仅为示例,如果未启用镜像功能,则无需打开TCP5022。

说明2:TCP5022端口也用在SQL Server 2012的“AlwaysOn可用性组”技术中。此处仅为示例,如果未启用“AlwaysOn可用性组”,则无需打开TCP5022。

2. 启用SQL Server Browser所需的端口

  当SQL Server 的实例使用了动态端口时,如果客户端应用程序不知道这个实例的端口,就需要查询实例所在的计算机上的“SQL Server Browser”服务。 SQL Server Browser这个侦听器只侦听UDP1434端口,因此需要添加相应的端口。

四、允许Ping的回显请求

  在日常使用时,我们经常使用Ping命令去查看网络上是否存在另一台计算机,或者检测网络是否通畅。

  ICMP是Internet Control Message Protocol,即Internet控制报文协议。它是TCP/IP协议族的一个子协议,用于在IP主机、路由器之间传递控制消息。控制消息是指网络通不通、主机是否可达、路由是否可用等网络本身的消息。Ping的过程实际上就是ICMP协议工作的过程。

  但是,Windows Server 2008 和 Windows 7 默认不开放此端口。一般情况下,仅在以下2种情形才会开放Ping所需的端口。

1. 此服务器为域控制器

  如果此服务器被提升为域控制器,Active Direcotry服务将强行打开一系列的端口,允许域的其它服务器和客户端进行连接,其中就包括了ICMPv4回显请求。

2. 手动添加入站规则,允许ICMPv4回显请求

  如果这台计算机不是域控制器(或者是Windows7),就需要手动添加入站规则,允许ICMPv4回显请求。

win7与win server 2008防火墙设置的更多相关文章

  1. 【win7 + win server 2008】设置定时任务,设置.bat 文件去执行php脚本 == 用来配合爬虫程序简直不要太爽

    Windows Server 2008中使用计划任务定时执行BAT bat进行PHP脚本的执行 一.首先进行任务管理器设置  每隔1分钟执行.BAT 文件配置 首先Windows Server 200 ...

  2. SQL server 2008 防火墙设置

    zh以前应为有特殊需求,需要在副武器外连接数据库,需要打开TCPIP服务. 但是因为有防火墙,经常连接不成功. 根据网上的资料总结,写了一个小的bat,来解决这个问题: @echo ========= ...

  3. win server 2008搭建域环境

    0x00 简介 1.域控:win server 2008 2.域内服务器:win server 2008.win server 2003 3.域内PC:win7 x64.win7 x32.win xp ...

  4. Windows Server 2008防火墙问题及Sql Server2005用户登录问题

    一.Windows Server 2008防火墙问题 1.  问题: 1.在 Windows 安全中心中单击“立即打开”以打开 Windows 防火墙时,会收到以下错误消息:安全中心无法打开 Wind ...

  5. Windows Server 2008 MetaFile设置占用内存限制

    最近遇到Windows Server 2008服务器内存持续飙升,48G内存用了99%,查看任务管理器的进程,也没发现具体哪个进程用的内存比较大? 于是,在网上找了了一个查看内存的工具RamMap,具 ...

  6. filebeat7.5.2 在 windows server 2008 R2 设置系统服务报错

    今天在windows server 2008 R2 设置filebeat为系统服务报错(在 windows 10 .windows server 2012.windows server 2019下安装 ...

  7. win server 2008 r2 sharepoint 域环境安装经历

    环境: 物理机:win7(x64,计算机名字:wyman-pc,ip:192.168.10.102)  / sql server 2008 r2(x64) /VM10 虚拟机:win svr 2008 ...

  8. 【关于服务器端SQL Server 2008的设置】 使其他客户端机可通过ODBC数据源可访问

    服务器系统:Server 2003 数据库:SQL Server 2005 服务器配置:开启服务:server.workstation(这两个服务对于提供局域网共享有很大作用) 关闭防火墙 开启gue ...

  9. 利用NSA的MS17-010漏洞利用工具实现Win 7和Win Server 2008系统入侵

    影子经纪人(Shadow Brokers)最近陆续曝光的NSA网络武器令人震惊,尽管这些工具是否出自国家级别黑客团队之手尚不清楚,但至少存在一个可以说明问题的事实:这些漏洞利用工具都能有效运行,且具有 ...

随机推荐

  1. Atitit.wrmi web rmi框架新特性

    Atitit.wrmi web rmi框架新特性 1. V1d  新特性1 1.1. 增加了精确参数1 1.2. 增加了req参数,命名参数模式..1 1.3. 增加了globale  传递隐含参数r ...

  2. Atitit..net clr il指令集 以及指令分类  与指令详细说明

    Atitit..net clr il指令集 以及指令分类  与指令详细说明 1.1. .NET CLR 和 Java VM 都是堆叠式虚拟机器(Stack-Based VM), 1 1.2. 查看工具 ...

  3. iptables修改

    https://fedoraproject.org/wiki/How_to_edit_iptables_rules?rd=User_talk:Rforlot Listing Rules Current ...

  4. 图像视频编码和FFmpeg(2)-----YUV格式介绍和应用

    本文不讲FFmpeg,而是讲YUV图像格式.因为摄像头拍摄出来的原始图像一般都是YUV格式.在FFmpeg中,视频是通过多张YUV图像而得到. YUV图像格式是什么,这个可以看一下维基百科.这个超链接 ...

  5. MAJOR-MINOR-MKDEV

    标记一下,容易忘,以免每次查代码. ./include/linux/types.h:21:typedef __u32 __kernel_dev_t; ./include/linux/types.h:2 ...

  6. gdb 详解

    环境:gcc (OpenWrt/Linaro GCC 4.8) 以如下的简单代码为例,说明gdb的使用. void func1(int a, int b) { int c; c = a + b; } ...

  7. 没有局域网环境,全是公网IP可以做LVS吗,该如何做了!请大家赐教!

    没有局域网环境,全是公网IP可以做LVS吗,该如何做了!请大家赐教! 由 wjjava 在 周四, -- : 提交 LVS集群 现在有3台服务器,各有一个公网IP地址.IP地址形式如下: IP1:12 ...

  8. ionic入坑记记录

    0.java1.8安装各种环境的配置 1.没有安装过npm 1.1 安装nodejs自带此物. 1.2 不希望npm install -g都在c盘.设置全局路径 path中是X:\某个文件夹\你的文件 ...

  9. CDH配置JAVA_HOME

    jdk成功安装 java -version 正确显示版本 echo $JAVA_HOME  正确输出路径 但CDH链接数据库还是报错: Error: JAVA_HOME is not set and ...

  10. flex初始化方法

    initalize是初始化,creationcomplete是创建完成,applicationComplete是应用程序中所有的实例都创建完成后才执行,三者的执行顺序是intalize creatio ...