1,报错截图

2,报错信息

五月 08, 2018 9:57:58 上午 org.apache.tomcat.util.digester.SetPropertiesRule begin
警告: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:MyCastBox' did not find a matching property.
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server version: Apache Tomcat/8.0.50
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server built: Feb 7 2018 20:06:05 UTC
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server number: 8.0.50.0
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Name: Windows 10
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Version: 10.0
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Architecture: amd64
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Java Home: C:\MyDev\Java\jdk1.8.0_131\jre
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Version: 1.8.0_131-b11
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Vendor: Oracle Corporation
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_BASE: C:\MyDev\Tomcat\apache-tomcat-8.0.50
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_HOME: C:\MyDev\Tomcat\apache-tomcat-8.0.50
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:56967
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dmaven.multiModuleProjectDirectory=$MAVEN_HOME
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.base=C:\MyDev\Tomcat\apache-tomcat-8.0.50
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.home=C:\MyDev\Tomcat\apache-tomcat-8.0.50
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dwtp.deploy=C:\MyDev\Tomcat\apache-tomcat-8.0.50\webapps
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Djava.endorsed.dirs=C:\MyDev\Tomcat\apache-tomcat-8.0.50\endorsed
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dfile.encoding=UTF-8
五月 08, 2018 9:57:58 上午 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
信息: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\MyDev\Java\jdk1.8.0_131\bin;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\MyDev\Java\jdk1.8.0_131\jre\bin;C:/MyDev/Java/jre1.8.0_131/bin/server;C:/MyDev/Java/jre1.8.0_131/bin;C:/MyDev/Java/jre1.8.0_131/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\windows\system32;C:\MyDev\Maven\apache-maven-3.5.2\bin;C:\MyDev\Java\jdk1.7.0_67\bin;C:\MyDev\Java\jdk1.7.0_67\jre\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\MyDev\Git\cmd;C:\MyDev\nodejs\;C:\MyDev\aspectj1.8\bin;C:\MyDev\MySQL5.6_RP_Green\bin;C:\Users\zjp\AppData\Local\Microsoft\WindowsApps;C:\Users\zjp\AppData\Roaming\n
pm;C:\MyDev\eclipse-jee-luna-SR2-win32-x86_64;;.
五月 08, 2018 9:57:58 上午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["http-nio-8080"]
五月 08, 2018 9:57:58 上午 org.apache.tomcat.util.net.NioSelectorPool getSharedSelector
信息: Using a shared selector for servlet write/read
五月 08, 2018 9:57:58 上午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["ajp-nio-8009"]
五月 08, 2018 9:57:58 上午 org.apache.tomcat.util.net.NioSelectorPool getSharedSelector
信息: Using a shared selector for servlet write/read
五月 08, 2018 9:57:58 上午 org.apache.catalina.startup.Catalina load
信息: Initialization processed in 1749 ms
五月 08, 2018 9:57:58 上午 org.apache.catalina.core.StandardService startInternal
信息: Starting service Catalina
五月 08, 2018 9:57:58 上午 org.apache.catalina.core.StandardEngine startInternal
信息: Starting Servlet Engine: Apache Tomcat/8.0.50
五月 08, 2018 9:58:07 上午 org.apache.jasper.servlet.TldScanner scanJars
信息: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
五月 08, 2018 9:58:08 上午 org.apache.catalina.core.ApplicationContext log
信息: No Spring WebApplicationInitializer types detected on classpath
五月 08, 2018 9:58:08 上午 org.apache.catalina.core.ApplicationContext log
信息: Initializing Spring root WebApplicationContext
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/C:/MyDev/Tomcat/apache-tomcat-8.0.50/webapps/MyCastBox/WEB-INF/lib/logback-classic-1.1.2.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/C:/MyDev/Tomcat/apache-tomcat-8.0.50/webapps/MyCastBox/WEB-INF/lib/slf4j-log4j12-1.7.7.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
2018-05-08 09:58:12,659 [localhost-startStop-1] INFO com.alibaba.druid.pool.DruidDataSource:928 - {dataSource-1} inited
五月 08, 2018 9:58:15 上午 org.apache.catalina.core.ApplicationContext log
信息: Set web app root system property: 'webapp.root' = [C:\MyDev\Tomcat\apache-tomcat-8.0.50\webapps\MyCastBox\]
五月 08, 2018 9:58:15 上午 org.apache.catalina.core.ApplicationContext log
信息: Initializing Logback from [classpath:logback.xml]
五月 08, 2018 9:58:15 上午 org.apache.catalina.core.ApplicationContext log
信息: JUL to SLF4J bridge is not available on the classpath
五月 08, 2018 9:58:15 上午 org.apache.catalina.core.ApplicationContext log
信息: Set web app root system property: 'webapp.root' = [C:\MyDev\Tomcat\apache-tomcat-8.0.50\webapps\MyCastBox\]
五月 08, 2018 9:58:15 上午 org.apache.catalina.core.ApplicationContext log
信息: Initializing log4j from [classpath:log4j.properties]
五月 08, 2018 9:58:17 上午 org.apache.catalina.core.ApplicationContext log
信息: Initializing Spring FrameworkServlet 'dispatcherServlet'
#
# There is insufficient memory for the Java Runtime Environment to continue.
# Native memory allocation (malloc) failed to allocate 1223856 bytes for Chunk::new
[thread 26196 also had an error]
# An error report file with more information is saved as:
# C:\MyDev\eclipse-jee-luna-SR2-win32-x86_64\hs_err_pid8500.log
#
# Compiler replay data is saved as:
# C:\MyDev\eclipse-jee-luna-SR2-win32-x86_64\replay_pid8500.log

3,解决方案

暂无,待定。

Eclipse中启动Tomcat报错:[There is insufficient memory for the Java Runtime Environment to continue.]的解决方案的更多相关文章

  1. tomcat启动报错There is insufficient memory for the Java Runtime Environment to continue

    tomcat启动报错后显示以下错误 ## There is insufficient memory for the Java Runtime Environment to continue.# Nat ...

  2. 【JVM】linux上tomcat中部署的web服务,时好时坏,莫名其妙宕机,报错:There is insufficient memory for the Java Runtime Environment to continue.

    =========================================================================================== 环境: linu ...

  3. Eclipse中启动tomcat报错:A child container failed during start

    我真的很崩溃,先是workspace崩了,费了好久重建的workspace,然后建立了一个小demo项目,tomcat中启动却报错,挑选其中比较重要的2条信息如下: A child container ...

  4. kafka启动报错Cannot allocate memory;There is insufficient memory for the Java Runtime Environment to continue.

    kafka启动过程报错,配置没有问题,这就懵了!! Java HotSpot(TM) 64-Bit Server VM warning: INFO: os::commit_memory(0x00000 ...

  5. eclipse中启动tomcat报错 java.lang.ClassNotFoundException

    之前启动还好好的,某次启动tomcat就莫名其妙的报了这个java.lang.ClassNotFoundException的错.   检查maven依赖包,发现这个类是存在的. 然后一通clean操作 ...

  6. Eclipse中启动tomcat报错java.lang.OutOfMemoryError: PermGen space的解决方法

    有的项目引用了太多的jar包,或者反射生成了太多的类,异或有太多的常量池,就有可能会报java.lang.OutOfMemoryError: PermGen space的错误, 我们知道可以通过jvm ...

  7. 【转】Eclipse下启动tomcat报错:/bin/bootstrap.jar which is referenced by the classpath, does not exist.

    转载地址:http://blog.csdn.net/jnqqls/article/details/8946964 1.错误: 在Eclipse下启动tomcat的时候,报错为:Eclipse下启动to ...

  8. 在eclipse中启动Tomcat报端口被占用的错误

    安装配置好Tomcat之后,在浏览器中输入localhost,能正取打开页面.然后在eclipse中建立项目,创建Servlet之后,启动Tomcat,报端口被占用的错误.如图: 原因:原来已经启动了 ...

  9. eclipse本地启动tomcat报错集锦

    1.eclipse本地添加tomcat服务器    打开Eclipse,单击“window”菜单,选择下方的“Preferences”: 找到Server下方的Runtime Environment, ...

随机推荐

  1. Android 基础知识

    system/app   与   system/priv-app Android4.4系统在system目录下新增了priv-app目录,在该目录下的apk一般都是系统核心应用如Launcher.sy ...

  2. 报Error creating bean with name 'dataSource' defined in class path resource 报错解决办法

    在学习spring boot 的数据库操作的时候,报了一串错误 对于初学spring boot的我来说,英语水平低,看不懂报错的信息,给我造成了很大的麻烦,花了我一天的时间,经过不懈的努力后终于让我找 ...

  3. 一个FORK的面试题(转)

    https://coolshell.cn/articles/7965.html https://coolshell.cn/articles/945.html

  4. 怎样将PDF文件转换成Excel表格

    PDF文件怎样转换成Excel表格呢?因为很多的数据信息现在都是通过PDF文件进行传输的,所以很多时候,信息的接受者都需要将这些PDF文件所传输的数据信息转换成Excel表格来进行整理,但是我们应该怎 ...

  5. Thymeleaf常用th标签

    https://www.jianshu.com/p/f9ebd23e8da4 关键字 功能介绍 案例 th:id 替换id <input th:id="'xxx' + ${collec ...

  6. 面向面试编程代码片段之GC

    x 代码 using System; using System.Threading; public static class Program{ public static void Main(){ T ...

  7. tomcat体系结构

    总体架构解析 Server: 一个StandardServer类实例就表示一个Server容器,TOMCAT启动的时候首先会启动一个Server,一个Server包括多个Service Service ...

  8. SQL开发——SQL语法

    文档资料参考: 参考:http://www.w3school.com.cn/sql/sql_syntax.asp 参考:http://wiki.jikexueyuan.com/project/sql/ ...

  9. VUE 参数共享问题

    **标黄 export default { data () { return { msg: "这是一个变量", xx:"", } }, mounted : fu ...

  10. CF451E Devu and Flowers 数论

    正解:容斥+Lucas定理+组合数学 解题报告: 传送门! 先mk个我不会的母函数的做法,,, 首先这个题的母函数是不难想到的,,,就$\left (  1+x_{1}^{1}+x_{1}^{2}+. ...