在两台机子上同时操作下面的步骤


首先安装MySQL,从官网下载相对应版本的RPM包

  • mysql-community-client-5.7.23-1.el7.x86_64.rpm
  • mysql-community-common-5.7.23-1.el7.x86_64.rpm
  • mysql-community-libs-5.7.23-1.el7.x86_64.rpm
  • mysql-community-libs-compat-5.7.23-1.el7.x86_64.rpm (*解决与XtraBackup安装时,my.cnf冲突问题)
  • mysql-community-server-5.7.23-1.el7.x86_64.rpm

一口气把他们全都安上,省的报依赖错误

rpm -ivh mysql-community-client-5.7.23-1.el7.x86_64.rpm mysql-community-common-5.7.23-1.el7.x86_64.rpm mysql-community-libs-5.7.23-1.el7.x86_64.rpm mysql-community-libs-compat-5.7.23-1.el7.x86_64.rpm mysql-community-server-5.7.23-1.el7.x86_64.rpm

初始化MySQL

先修改 /var/lib/mysql/ 文件夹的权限,因为是用root权限安装的,需要修改为mysql的权限。

chown -R mysql.mysql /var/lib/mysql/

初始化MySQL

mysqld --initialize

从mysqld.log中获取初始密码,得到红色部分的密码

[root@localhost srv]# cat /var/log/mysqld.log | grep 'y password'
2018-08-23T05:54:39.866279Z 1 [Note] A temporary password is generated for root@localhost: (WRwAWtoj14+

登录mysql,修改密码

[root@localhost srv]# mysql -uroot -p'(WRwAWtoj14+'
mysql: [Warning] Using a password on the command line interface can be insecure.
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.7.23 Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved. Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners. Type 'help;' or '\h' for help. Type '\c' to clear the current input statement. mysql> alter user root@localhost identified by 'root';
Query OK, 0 rows affected (0.01 sec) mysql> exit
Bye

至此,MySQL安装完毕


安装XtraBackup

按照官网的安装示例安装即可:https://www.percona.com/doc/percona-xtrabackup/2.4/installation/yum_repo.html

1、安装Percona yum 仓库

yum install http://www.percona.com/downloads/percona-release/redhat/0.1-6/percona-release-0.1-6.noarch.rpm

2、安装XtraBackup 24

yum install percona-xtrabackup-24 -y

会以依赖安装(就是因为依赖总是离线安不上,才用的yum):

作为依赖被安装:
libev.x86_64 0:4.15-7.el7 perl-DBD-MySQL.x86_64 0:4.023-6.el7 perl-Digest.noarch 0:1.17-245.el7
 perl-Digest-MD5.x86_64 0:2.52-3.el7 rsync.x86_64 0:3.1.2-4.el7

至此,两个软件安装完毕


上面安装中的一些坑(已经帮助跳过去了):

1、MySQL无法启动,cli下报如下错误

[root@localhost srv]# service mysqld start
Redirecting to /bin/systemctl start mysqld.service
Job for mysqld.service failed because the control process exited with error code. See "systemctl status mysqld.service" and "journalctl -xe" for details.

/var/log/mysqld.log中报如下错误

2018-08-23T06:08:24.018182Z 0 [ERROR] InnoDB: The innodb_system data file 'ibdata1' must be writable
2018-08-23T06:08:24.018188Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2018-08-23T06:08:24.620670Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2018-08-23T06:08:24.620698Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2018-08-23T06:08:24.620703Z 0 [ERROR] Failed to initialize builtin plugins.
2018-08-23T06:08:24.620706Z 0 [ERROR] Aborting

解决方法看上面的MySQL初始化部分

2、XtraBackup安装冲突

file /etc/my.cnf from install of Percona-Server-shared-56-5.6.41-rel84.1.el7.x86_64 conflicts with file from package mysql-community-server-5.7.23-1.el7.x86_64

先安装 mysql-community-libs-compat-5.7.23-1.el7.x86_64.rpm 即可

CentOS7 下 MySQL 5.7.23 & XtraBackup 24 做数据备份(1)——安装软件的更多相关文章

  1. Centos7 下mysql大小写敏感问题

    在Centos7 下mysql大小写敏感问题,会导致程序运行时找不到对应的表. 解决办法: 第一步:编辑/etc/my.cnf文件,在[mysqld]节下 添加 lower_case_table_na ...

  2. Linux - centos7 下 MySQL(mariadb) 和 主从复制

    目录 Linux - centos7 下 MySQL(mariadb) 和 主从复制 MySQL(mariadb) 安装MySQL(mariadb) 配置数据库的中文支持 在远程用 mysql客户端去 ...

  3. Centos7 下mysql 密码重置

    Centos7 下mysql 密码重置 先停止mysql服务 mysqld_safe --skip-grant-tables & mysql mysql> use mysql;mysql ...

  4. 【mysql】centos7下mysql的安装以及基本操作

    centos7使用的MariaDB,替代了早期版本默认的MySQL.MariaDB是MySQL的一个分支,由开源社区维护,采用GPL授权许可,且MariaDB完全贱人MySQL. 检查centos7下 ...

  5. linux centos7下mysql安装--韩国庆

    首先我先给大家介绍下MariaDB和mysql的区别. 上图,“MySQL之父”的骨灰级程序员Monty,但是mysql被Oracle收购后,Monty又开始去发展另一条数据库的道路,并且以Monty ...

  6. windows、ubuntu、centos7下mysql 的安装与使用

    一.windows 及ubuntu下安装 windows可以傻瓜式安装,另一种空闲了下来写,也不麻烦 ubuntu: apt-get install mysql 强烈推荐使用ubuntu从这儿就很方便 ...

  7. docker 下mysql 和postgresql 数据库的搭建以及数据文件的迁移和备份

    service docker start - docker 启动 service docker stop - docker 关闭 1.docker 镜像创建—使用的默认镜像有数据卷 docker pu ...

  8. CentOS7下Mysql 5.6.30安装与配置

    环境:centos 7 x64 先下载mysql安装包 打开 http://dev.mysql.com/downloads/mysql/  选择 linux - Generic 再选择 下载完毕后,得 ...

  9. centos7下mysql双主+keepalived

    一.keepalived简介 keepalived是vrrp协议的实现,原生设计目的是为了高可用ipvs服务,keepalived能够配置文件中的定义生成ipvs规则,并能够对各RS的健康状态进行检测 ...

随机推荐

  1. poj 1696 极角排序(解题报告)

    #include<iostream> #include<cmath> #include<algorithm> using namespace std; double ...

  2. hdu2669Romantic (扩展欧几里德)

    Problem Description The Sky is Sprite. The Birds is Fly in the Sky. The Wind is Wonderful. Blew Thro ...

  3. Operating System:管程相关概念

    管程 (Moniters,也称为监视器)一.管程的概念是一种程序结构,结构内的多个子程序(对象或模块)形成的多个工作线程互斥访问共享资源.这些共享资源一般是硬件设备或一群变量.管程实现了在一个时间点, ...

  4. 开放式 Web 应用程序安全性项目 OWASP

    开放式 Web 应用程序安全性项目 OWASP Open Web Application Security Project (OWASP) OWASP 基金会是谁? Open Web Applicat ...

  5. leetcode bug & 9. Palindrome Number

    leetcode bug & 9. Palindrome Number bug shit bug "use strict"; /** * * @author xgqfrms ...

  6. website & blogs & about me & contact

    website & blogs & about me & contact demos https://davidwalsh.name/about-david-walsh htt ...

  7. Netty & websockets

    Netty & websockets Netty is a non-blocking I/O client-server framework for the development of Ja ...

  8. D3 tree map

    D3 tree map D3 矩形树图 https://www.zhihu.com/question/55529379 https://zhuanlan.zhihu.com/p/57873460 ht ...

  9. nodejs 查看进程表

    psaux tasklist system-tasks const { exec } = require("child_process"); const isWindows = p ...

  10. 双十一NGK官方快讯!