首先vsftp同步文件,并没有好的解决方案,网上有一些软件是可以定时同步文件的,我是用的是linux上的一款工具Rsync

首先先了解一下Rsync与scp的区别:点我

1.安装Rsync

两种安装方式:1:源代码编译安装,2:yum安装,因为我的虚拟机可以连接外网,所以我是使用yum安装,两台都要安装

[root@master /]# yum install rsync

安装完成后,输入命令 rsync ,如图说明安装成功

2.修改主从服务器配置文件

[root@master /]# vim /etc/rsyncd.conf 

将如下内容复制或替换进去

#工作中指定用户(可以不指定为0)

uid = 

gid = 

#相当于黑洞.出错定位

use chroot = no

#有多少个客户端同时传文件

max connections = 

#超时时间

timeout = 

#进程号文件

pid file = /var/run/rsyncd.pid

#日志文件

lock file = /var/run/rsync.lock

#日志文件

log file = /var/log/rsyncd.log

#模块开始

#模块名称随便起(可以是多个)

[home]

#需要备份的目录

path = /home

#表示出现错误忽略错误

ignore errors

#表示网络权限可写(本地控制真正可写)

read only = false

#这里设置IP或让不让同步

list = false

#指定允许的网段(即主ftp服务器)

hosts allow = 192.168.81.3

#拒绝链接的地址,一下表示没有拒绝的链接。

hosts deny = 0.0.0.0/

#不要动的东西(默认情况)

#虚拟用户

auth users = rsync_backup

#虚拟用户的密码文件

secrets file = /etc/rsync.password

其中标红的部分一定要注意:

第一个标红的部分表示:模块名称,之后使用rsync传输文件要用到

第二个标红的部分表示:模块根路径,这个路径一定要存在否则会报错 错误为:@ERROR: chdir failed

第三个标红的部分表示:允许哪些地址来使用rsync请求,多个地址之间使用逗号分隔

第四个标红的部分表示:密码文件

3.备份服务器配置虚拟用户的密码文件

[root@slave /]# echo "rsync_backup:123456" >/etc/rsync.password

[root@slave /]# cat /etc/rsync.password

rsync_backup: #注:rsync_backup为虚拟用户,123456为这个虚拟用户的密码

[root@inotify-slave /]# chmod  /etc/rsync.password #为密码文件提权,增加安全性

4、主服务器配置虚拟用户密码

[root@master ~]# echo "" >/etc/rsync.password

[root@master ~]# cat /etc/rsync.password

 #注意:这里只要写密码即可,切记。

[root@master ~]# chmod  /etc/rsync.password

5、准备工作

1.启动Rsync服务端(即备用服务器)

[root@master /]# rsync --daemon --config=/etc/rsyncd.conf

先说明一下,这种启动方式很麻烦,之后关闭重启需要 使用kill -9 关闭进程,然后再删除进程文件,才能重启,后面会使用脚本来启动rsync

2.如前面的配置文件所述(第二个标红处),在备份服务器建立【第二个标红处】上的路径,也就是说 ,我需要建立 /home 目录

3.在主服务器上建立任意文件夹,文件

6:测试

命令:

[root@master /]# rsync -avz /home/pic rsync_backup@192.168.81.4::home --password-file=/etc/rsync.password

命令的含义是 将主服务器/home/pic 目录下的文件,文件夹同步到从服务器上的 home模块中 注意标青色的部分,对照,上面的标红的第一部分,好了,如果出现如下所示,表示同步成功,便可以去看从服务器中的文件了

7.编写同步脚本脚本(主服务器)

[root@master /]# vim /usr/local/bin/rsync_push.sh
#!/bin/bash
rsync -avz /home/pic rsync_backup@192.168.81.4::home --password-file=/etc/rsync.password

赋予脚本可执行权限

[root@master bin]# chmod a+x /usr/local/bin/rsync_push.sh

将脚本加入crontab(主服务器)

[root@master etc]# cd /etc/
[root@master /]# crontab -e

加入如下代码:

*/1 * * * * /usr/local/bin/rsync_push.sh

以上代码表示,每分钟执行一次rsync同步脚本 ,(具体执行时间设定,参照这里) 

输入命令查看crontab脚本

[root@master etc]# crontab -l

8.使用脚本启动关闭rsync

[root@slave1 pic]# vim /etc/init.d/rsync 

将如下内容复制粘贴

#!/bin/bash 

#this script for start|stop rsync daemon service
#date:// status1=$(ps -ef | egrep "rsync --daemon.*rsyncd.conf" | grep -v 'grep')
pidfile="/var/run/rsyncd.pid"
start_rsync="rsync --daemon --config=/etc/rsyncd.conf" function rsyncstart() { if [ "${status1}X" == "X" ];then rm -f $pidfile ${start_rsync} status2=$(ps -ef | egrep "rsync --daemon.*rsyncd.conf" | grep -v 'grep') if [ "${status2}X" != "X" ];then echo "rsync service start.......OK" fi else echo "rsync service is running !" fi
} function rsyncstop() { if [ "${status1}X" != "X" ];then kill - $(cat $pidfile) status2=$(ps -ef | egrep "rsync --daemon.*rsyncd.conf" | grep -v 'grep') if [ "${statusw2}X" == "X" ];then echo "rsync service stop.......OK"
fi
else echo "rsync service is not running !" fi
} function rsyncstatus() { if [ "${status1}X" != "X" ];then echo "rsync service is running !" else echo "rsync service is not running !" fi } function rsyncrestart() { if [ "${status1}X" == "X" ];then echo "rsync service is not running..." rsyncstart
else rsyncstop rsyncstart fi
} case $ in "start")
rsyncstart
;; "stop")
rsyncstop
;; "status")
rsyncstatus
;; "restart")
rsyncrestart
;; *)
echo
echo "Usage: $0 start|stop|restart|status"
echo
esac

给脚本设置可执行权限:

[root@slave1 pic]# chmod a+x /etc/init.d/rsync

启动命令:

[root@master /]# service rsync start

停止命令

[root@master /]# service rsync stop

vsftp服务器同步文件的更多相关文章

  1. linux下实现多台服务器同步文件(inotify-tools+rsync实时同步文件安装和配置)

    inotify-tools+rsync实时同步文件安装和配置 注:转载https://www.linuxidc.com/Linux/2012-06/63624.htm

  2. Centos7 rsync+inotify两台服务器同步文件(单向)

    注:本篇介绍的是单向同步,即A文件同步到B,但B的文件不同步到A,双向同步的在下一篇文章中. rsync与inotify不再赘述,直接进入实战. 0.背景 两台服务器IP地址分别为: 源服务器:192 ...

  3. 详解:基于WEB API实现批量文件由一个服务器同步快速传输到其它多个服务器功能

    文件同步传输工具比较多,传输的方式也比较多,比如:FTP.共享.HTTP等,我这里要讲的就是基于HTTP协议的WEB API实现批量文件由一个服务器同步快速传输到其它多个服务器这样的一个工具(简称:一 ...

  4. cwRsync window下的跨服务器的文件同步

    cwRsync 是window下的文件同步软件,可以跨服务器运行,第一次运行的时候是全部备份同步,之后的同步采用的是增量同步 这个软件分为服务端和客户端. 服务器是需要同步的文件源, 客户端相当于是备 ...

  5. 用 rsync 同步本地和服务器的文件

    参考 DigitalOcean 安装 For Debian/Ubuntu: sudo apt-get install rsync For OpenSUSE/Fedora: sudo yum insta ...

  6. centos6.5 rsync+inotify实现服务器之间文件实时同步

    1. rsync的优点与不足 与传统的cp.tar备份方式相比,rsync具有安全性高.备份迅速.支持增量备份等优点,通过rsync可以解决对实时性要求不高的数据备份需求,例如定期的备份文件服务器数据 ...

  7. rsync+sersync+inotify实现服务器间文件同步之一

    rsync+sersync+inotify实现服务器间文件同步之一:rsync安装配置 2013年12月14日 ⁄ Linux管理, 服务器集群技术 ⁄ 共 4925字 ⁄ rsync+sersync ...

  8. centos shell编程4【分发系统】 服务器标准化 mkpasswd 生成密码的工具 expect讲解 expect传递参数 expect自动同步文件 expect指定host和要同步的文件 expect文件分发系统 expect自动发送密钥脚本 Linux脚本执行方式 第三十八节课

    centos shell编程4[分发系统] 服务器标准化  mkpasswd 生成密码的工具  expect讲解   expect传递参数   expect自动同步文件  expect指定host和要 ...

  9. Linux服务器间文件实时同步的实现

    使用场景 现有服务器A和服务器B,如果服务器A的指定目录(例如 /home/paul/rsync/ )中的内容发生变更(增删改和属性变更),实时将这些变更同步到服务器B的目标目录中(例如 /home/ ...

随机推荐

  1. 【第二十章】 springboot + consul(1)

    consul的具体安装与操作查看博客的consul系列. 一.启动consul (1个server+1个client,方便起见,client使用本机):查看:http://www.cnblogs.co ...

  2. 3、CommonChunkPlugin提取公共js-以提取一个jquery为例

    cnpm install css-loader --save-dev    //css-loader 是将css打包进js cnpm install style-loader --save-dev   ...

  3. C#学习笔记(五):while循环和for循环

    while循环 while循环和for循环,可以相互替换,范围和效能一样,理解事物的逻辑不一样 while循环用于条件不确定的逻辑 for循环用于计算次数的逻辑 for循环 快捷写法,按两下TAB i ...

  4. java List中相同的数据合并到一起

    值好最后一天岗,写个小程序 List<Map<Object,Object>> mapList = new ArrayList<Map<Object,Object&g ...

  5. codeforces 251 div2 C. Devu and Partitioning of the Array 模拟

    C. Devu and Partitioning of the Array time limit per test 1 second memory limit per test 256 megabyt ...

  6. jekins,报错 stderr: Could not create directory '/usr/share/tomcat7/.ssh'. Failed to add the host to the list of

    public key是在~/.ssh/id_rsa.pub,而private key是~/.ssh/id_rsa 设置的时候,Jenkins需要的是private key

  7. MongoDB(课时24 全文索引)

    3.6.3 全文索引 在一些信息管理平台上经常需要进行信息模糊查询,最早的时候是利用了某个字段上实现的模糊查询,但这个时候返回的信息并不会很准确,因为只能够查A字段或B字段,而在MongoDB里面实现 ...

  8. WZY社区

    WZY社区是我自己做的一个网站,后面会详细更新,敬请关注!

  9. Codeforces 834C - The Meaningless Game

    834C - The Meaningless Game 数学. 思路1:判断a•b能不能化成v3且a%v==0且b%v==0.v可以直接用pow求(或者用cbrt),也可以二分求:还可以用map映射预 ...

  10. 各种容器与服务器的区别与联系 Servlet容器 WEB容器 Java EE容器 应用服务器 WEB服务器 Java EE服务器

    转自:https://blog.csdn.net/tjiyu/article/details/53148174 各种容器与服务器的区别与联系 Servlet容器 WEB容器 Java EE容器 应用服 ...