原创 欢迎转载,届时请注明出处

报错场景

  今天,刚开始启动win server的远程连接服务(remote desktop services)时 该服务可以正常启动,然后选择了  “计算机-->属性-->远程设置-->远程-->远程桌面-->允许运行任意版本远程桌面….-->应用-->确定”。一切都正常的。

然后,我就手贱,在”计算机-->属性-->远程设置-->远程-->远程桌面-->选择用户”选择了一个用户,最后发现启动远程连接服务(remote desktop services)时就报了一下错误1079,如图。

而启动 remote desktop services usermode port redirector服务时报错1068,如图。

解决过程

  1. 阅读了官方文档后,尝试了文档上的几种方法,方法如下图所示。结果启动远程连接服务(remote desktop services)还是报 场景中的错误。

  2. 后来仔细想来,我之前的操作过程,设置了”计算机-->属性-->远程设置-->远程-->远程桌面-->选择用户”。然后我就删除了选择的用户账号,然后再启动,还是报错1079.

  3. 最后,将“计算机-->属性-->远程设置-->远程-->远程桌面”设置为”不允许连接到这台计算机”,然后按照官方文档中的方法设置远程连接服务(remote desktop services)登陆账号为”NT AUTHORITY\NetworkService”, 再启动就正常了,返回来再设置“计算机-->属性-->远程设置-->远程-->远程桌面”为” 允许运行任意版本远程桌面….”.在cmd中执行”netstat –an | findstr 3389”检查远程端口果然为Linsten状态。Ok,可以在远端使用mstsc远程连接了。

总结

  如果有的网友一开始“计算机-->属性-->远程设置-->远程-->远程桌面”就是”不允许连接到这台计算机”的,可以直接使用官方文档中的方法---将登陆用户账号设为”NT AUTHORITY\NetworkService”或者”NT AUTHORITY\LocalService”,然后启动远程连接服务(remote desktop services)应该就没有问题的了。而我在这里描写下自己尝试的过程更多的也是提醒自己。

Windows server 2008启动remote dosktop services服务报错1079的更多相关文章

  1. windows server 2008 安装MySQL 8.0 遇到报错 1055 - Expression #1 of ORDER BY clause is not in GROUP BY

    mysql安装参考教程:https://blog.csdn.net/qq_37350706/article/details/81707862 安装完毕后 执行sql语句 SELECT * FROM c ...

  2. 如何在Windows Server 2008 R2下搭建FTP服务

    在Windows Server 2008 R2下搭建FTP服务,供客户端读取和上传文件 百度经验:jingyan.baidu.com 工具/原料 Windows Server 2008 R2 百度经验 ...

  3. Sql Server 2008卸载后再次安装一直报错

    sql server 2008卸载之后再次安装一直报错问题. 第一:由于上一次的卸载不干净,可参照百度完全卸载sql server2008 的方式 1. 用WindowsInstaller删除所有与S ...

  4. 在Windows Server 2008 R2上安装IIS服务

    一.Windows Server 2008 R2 介绍 1.Windows Server 2008 R2 基本概念 2.Windows Server 2008 R2 家族系列 二.VMware虚拟机安 ...

  5. 如何解决在Windows Server 2008 R2 上安装证书服务重启后出现 CertificationAuthority 91错误事件

    很久都没写什么博客了,前一段时间学习2008 R2时,在自己的电脑上同时安装AD 和证书 往往会出现一个CertificationAuthority错误,如下: 产生问题的主要原因是: 证书服务器与D ...

  6. Windows Server 2008 R2 修改远程桌面服务RDP默认端口及相应的防火墙配置

    修改以下两个注册表项当中的默认端口3389为自定义端口: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wd ...

  7. linux 启动weblogic的某服务报错

    问题如标题所示, 错误信息主要包括: weblogic.store.PersistentStoreException: [Store:280073]The file store"WLS_DI ...

  8. 启动elk中elasticsearch服务报错which: no java in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin)

    解决办法: vi /etc/sysconfig/elasticsearch JAVA_HOME=/usr/local/java sudo systemctl restart elasticsearch ...

  9. deepin下启动自己的springcloud服务报错

    java.nio.file.AccessDeniedException: /home/msan/logs/csp/sentinel-record.log.2021-01-04.0.2.lck at s ...

随机推荐

  1. 获取当前函数名 __FUNCTION__ 的使用<转>

    vs项目中见过这种获取 当前函数名的调用.觉得挺方便的就记录一下. ============================================================== 转载地 ...

  2. 转化RGB颜色为CMYK颜色

    procedure RGBTOCMYK(R : byte; G : byte; B : byte; var C : byte; var M : byte; var Y : byte; var K : ...

  3. rook issues

    ceph-volumeattacher: failed rbd single_major check, assuming it's unsupported: failed to check for r ...

  4. CHEMISTS DISCOVER A SAFE, GREEN METHOD TO PROCESS RED PHOSPHORUS

                   When it comes to making phosphorus compounds, chemists have traditionally relied on w ...

  5. 76. Minimum Window Substring (String, Map)

    Given a string S and a string T, find the minimum window in S which will contain all the characters ...

  6. Zend Studio使用综述

    1.如何将zend studio 9的默认GBK编码设置为其它编码,例如UTF-8?  选 择window菜单->Preferences->General->Workspace,在界 ...

  7. 判断单选框选中不成功,$("#xx").attr("checked")undefined

    判断单选框选中状态,各种都不行,受到https://www.cnblogs.com/yxwkf/p/4853014.html 的启发,相关引用: 原来.在jquery1.6版本号便对此做出了改动: [ ...

  8. libevent 简单学习

    //NetworkManager.h #ifndef _NET_WORK_MANAGER_ #define _NET_WORK_MANAGER_ #include "event2/util. ...

  9. Python爬虫进阶三之Scrapy框架安装配置

    初级的爬虫我们利用urllib和urllib2库以及正则表达式就可以完成了,不过还有更加强大的工具,爬虫框架Scrapy,这安装过程也是煞费苦心哪,在此整理如下. Windows 平台: 我的系统是 ...

  10. web02

    高内聚,低耦合 写what 不写how 我们只关心他是什么,得到什么,我们并不关心怎么去得到的 ,那个细节去怎么得的, 都应该在这个层面上屏蔽掉,要关心的时候在点进去,这样就一层层的结构良好的代码 d ...