Xampp的获得和安装都十分简单,你仅仅要到下面网址:

http://www.apachefriends.org/zh_cn/xampp.html 下载xampp就可以。我安装的是windows版本号的Installer安装包。仅仅要依据它的安装提示一路安装下去就能够了,十分方便快捷。

只是,安装文件夹最好选择C盘之外的其他磁盘,据某些网友的经验,在Windonws7或Vista中。假设选择C盘安装。因为权限原因,会出现创建一些文件失败的问题。假设你已经据有最高权限,能够直接装在C盘。

一般在windows XP或windows 7中,刚安装完xampp时,apacheserver是启动不了的。

这个原因有非常多,以下我来一一细说。

  • 没有安装VC9的环境

要推断是否是这一问题十分简单,仅仅要单独执行C:\xampp\apache\bin\httpd.exe时(这个是我的安装路径),提示“系统无法执行指定的程序”(这个是用命令行执行后的提示)。假设是直接双击httpd.exe,则会提示环境配置错误。

解决的方法:直接下载vcredist_x86.exe。

下面是在php.net看到的提示信息:

VC9 Versions are compiled with the Visual Studio 2008 compiler and have improvements in performance and stability. The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed

依照链接下载了Microsoft Visual C++ 2008 Redistributable Package (x86),就是那个vcredist_x86.exe。一个执行时环境,使用户可以在未安装 Visual C++ 2008 的计算机上执行使用 Visual C++ 开发的应用程序。装好后启动Apache。一切正常。

  • port被其他程序占用

有时,并非安装完VC9环境就能够直接执行Apache,当中一个重要的原因。便是Apacheserver所使用的port被其他程序占用了。经典代表:迅雷。

解决的方法:

1.80port冲突,解决方法:

打开文件夹C:\xampp\apache\conf(我的安装文件夹为C:\xampp)下的httpd.conf文件,将Listen 80和 ServerName localhost:80中的80改为8081或其他值(尽量不要使用0-1023port,这个是系统保留port),要保持一致。

2.监听port443冲突,解决方法:

打开文件夹C:\xampp\apache\conf\extra (我的安装文件夹为C:\xampp)下的httpd-ssl.conf文件,将Listen 443这句凝视掉:# Listen 443或将443改为4433或其他值(尽量不要使用0-1023)。

3.Apache启动后又立即停止。一种情况是,Apache已经正常启动,仅仅是Xampp的控制面板没有显示而已。你能够通过在浏览器中输入http://localhost:8081。假设能直接进入Apacheserver的控制页面就是没有问题的了。

还有一种情况,原因可能是因为安装了oracle10g。与当中的perl5lib变量发生了冲突,解决方法有3种:

(1) 打开文件夹C:\xampp\apache\conf(我的安装文件夹为C:\xampp)下的httpd.conf文件,

将Include "conf/extra/httpd-perl.conf"凝视掉:# Include "conf/extra/httpd-perl.conf"。

(2) 打开文件夹C:\xampp\apache\conf\extra (我的安装文件夹为C:\xampp)下的httpd-perl.conf文件。找到LoadModule perl_module modules/mod_perl.so,在以下一行添加PerlSwitches –T,保存文件就可以。

(3) 改动环境变量:在环境变量path中添加C:\xampp\perl\lib; C:\xampp\perl\site\lib;就可以。

前两种方法的任一种都能解决我遇到的apache启动后又立即停止的问题,第3种方法我遇到的是没显示,但已经执行。至于还有一种情况可能对某些网友实用,所以也把它写了出来,以供參考。

其他方法:

以下的解决方法也是网友在实际中用到的。只是本人并不推荐。

原因在于。能够更改server配置。就尽量不要动操作系统的环境和配置。要不然,以后其他软件出问题,你也不知道是不是这个系统设置惹的祸。

当然,假设你对你的操作系统足够熟悉就另当别论。

而如今我仅仅是写出来。供大家參考,或许因为你的原因特殊。正好解决你的问题。

1 关闭占用80port的进程。

在“执行”中输入cmd命令,打开dos窗体。输入命令:netstat –abn –>D:\port.txt或命令netstat –ano|findstr 80命令。打到占用80端口的进程,然后打任务管理器窗体。关闭该进程。

此方法治标不治笨,执行比較麻烦,不推荐使用。

2 改动网络设置

(1) 网上邻居——本地连接——属性——internet协议(TCP/IP)——属性——高级——wins标签——去掉“启用LMHOSTS查询(L)”前的勾。

(2) 控制面板——Windows防火墙——“高级”标签——本地连接——设置——“服务”标签——勾选“安全webserver(HTTPS)。

这样的方法有些奇怪,说不清为什么。假设实在找不到办法了。能够一试。

关于XAMPP安装后APACH无法启动的问题的更多相关文章

  1. TerraGate软件安装后,不能启动的解决办法

    在服务端安装Skyline的TerraGate软件的时候,大家可能会遇到过这样的问题,“TerraGate软件安装后,不能启动”,很多时候,这个问题是因为TerraGate设 置的端口号已经被占用造成 ...

  2. 完美解决phpstudy安装后mysql无法启动(无需删除原数据库,无需更改任何配置,无需更改端口)直接共存

    PHPstudy与原Mysql兼容解决 一.前言 今天学习php,当然是要先安装好运行环境了,phpstyudy是一个运行php的集成环境, 一键安装对新手很友好,与时作为一个新手,便跟着教程安装了p ...

  3. ubuntu 14.04 Clion2016.2 安装激活与安装后添加快捷启动方式

    参考链接:http://www.cnblogs.com/conw/p/5938113.html 下载clion for linux : http://www.jetbrains.com/clion/d ...

  4. xampp 安装后无法启动apache 的解决方法

    1,安装xampp 后,apache 无法启动,当时的报错已经没有证据了,大概的翻译就是端口 被block(锁定)的意思 2,通过 查找端口被占用,找到被占用程序,进行杀掉进程,或者卸载软件,参考网址 ...

  5. XAMPP安装后启动Apache的Busy解决方法

    启动apache后,一直提示80 busy 使用netstat -ano查看,并无端口占用,真是奇怪. 百度之后发现有可能是启动后,ssl端口占用导致. XAMPP默认会加载一个SSL模块,它要占用一 ...

  6. xampp安装后启动apache出现端口占用问题

    apache默认监听电脑80端口,当端口被占用时,xampp无法正常启动apache.我们需要将端口解除占用再启动. xampp报错: Problem detected!19:36:24 [Apach ...

  7. XAMPP 安装时 MySQL 无法启动,且提示端口占用。

    今天安装XAMPP时遇到了几个坑,忙活了一上午才搞定,写下来分享给同样遇坑的盆友们. MySQL 点击start 提示端口3306被占用,我改了端口号,又改了注册表,将注册表地址改为xampp中mys ...

  8. windows media server 组件安装后流媒体服务器启动失败

    做好的web应用,去客户现场部署的时候发现流媒体服务器不能启动.(现场服务器系统为windows server2008 R2) 自己测试的时候搭建环境没什么问题.从来没有遇到安装windows med ...

  9. Tomcat学习笔记 - 错误日志 - Tomcat安装版安装后第二次启动后闪退(转)-- javac不是内部或外部命令 -- 配置java环境教程

    如果安装成功并且安装完成第一次启动是成功的,第二次就闪退的话,原因之一是没有配置java的环境.在网上找的配制方法有很多错误,测试javac命令时候会提示不是内部或外部命令,找到一个正确的教程.如下, ...

随机推荐

  1. iotop---监控磁盘I/O 使用状况

    iotop命令是一个用来监视磁盘I/O使用状况的top类工具.iotop具有与top相似的UI,其中包括PID.用户.I/O.进程等相关信息.Linux下的IO统计工具如iostat,nmon等大多数 ...

  2. shell清除日志小脚本

    #!/bin/bash #清除日志脚本 LOG_DIR=/var/log ROOT_UID=0 #用户id为0的 ,即为root if [ "$UID" -ne "$RO ...

  3. 解决MAC下PHP连接MYSQL错误Warning: mysql_connect(): No such file or directory in conn.php

    今天在mac上用php去连接mysql数据库,出现了 mac PHP Warning:  mysql_connect(): [2002] No such file... 详细例如以下所看到的: Dir ...

  4. CentOS 配置防火墙操作实例(启、停、开、闭port)

    CentOS 配置防火墙操作实例(启.停.开.闭port): 注:防火墙的基本操作命令: 查询防火墙状态: [root@localhost ~]# service   iptables status& ...

  5. POJ 3070 Fibonacci 矩阵高速求法

    就是Fibonacci的矩阵算法.只是添加一点就是由于数字非常大,所以须要取10000模,计算矩阵的时候取模就能够了. 本题数据不强,只是数值本来就限制整数,故此能够0ms秒了. 以下程序十分清晰了, ...

  6. POJ 1152 An Easy Problem! (取模运算性质)

    题目链接:POJ 1152 An Easy Problem! 题意:求一个N进制的数R.保证R能被(N-1)整除时最小的N. 第一反应是暴力.N的大小0到62.发现当中将N进制话成10进制时,数据会溢 ...

  7. Spring MVC数据转换

    样例:把一个字符串封装而一个对象. 如:username:password格式的数据ZhangSan:1234.我们把这个数据封装成一个User对象.以下分别使用属性编辑器与转换器来实现. 1.自己定 ...

  8. fs路径位置与widget路径转换

    var fs = api.require('fs'); fs.exist({ path: 'fs://res/yltmusic.mp4' }, function(ret, err) { if (!re ...

  9. ZOJ 3435 Ideal Puzzle Bobble 莫比乌斯反演

    http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4119 依然是三维空间内求(1,1,1)~(a,b,c)能看到的整点数,平移一下 ...

  10. linux ifconfig找不到

    提示命令不存在 原因: 系统默认的环境变量设置不对 而,ifconfig恰恰就在/sbin里面. 下cat /etc/profile, 可以发现没有关于/sbin的环境变量. Linux,习惯用ged ...