tomcat监控,自动重启shell脚本如下,取名 monitor_tomcat.sh:

#!/bin/sh

# func:自动监控tomcat脚本并且执行重启操作

# 获取tomcat进程ID(其中[grep -w '.....']中的.....需要替换为实际部署的tomcat文件夹名,如下)
TomcatID=$(ps -ef |grep tomcat |grep -w '/usr/local/tomcat/apache-tomcat-8.5.31'|grep -v 'grep'|awk '{print $2}')
# 获取同一个tomcat重复启动个数
TomcatCount=$( ps -ef |grep tomcat |grep -w '/usr/local/tomcat_autoupdate'|grep -v 'grep'|awk '{print $2}' |wc -l) # tomcat启动程序(这里注意tomcat实际安装的路径)
StartTomcat=/usr/local/tomcat/apache-tomcat-8.5./bin/startup.sh
TomcatCache=/usr/local/tomcat/apache-tomcat-8.5./work #定义要监控的页面地址
WebUrl=http://localhost:8080/test2 #日志输出
GetPageInfo=/tmp/tomcat_oip_back_visit.info
TomcatMonitorLog=/tmp/tomcat_oip_back_monitor.log Monitor()
{
echo "[info]开始监控tomcat...[$(date +'%F %H:%M:%S')]"
if [[ $TomcatCount -gt ]];then #这里判断Tomcat进程是否有重复启动,有重复启动则全部干掉
ps -ef |grep tomcat |grep -w '/usr/local/tomcat_autoupdate'|grep -v 'grep'|awk '{print $2}' | xargs kill -
echo "同一tomcat开启开启 $TomcatCount 个进程,统统kill掉"
sleep
else
if [ $TomcatID ];then #这里判断Tomcat进程是否存在
echo "[info]当前tomcat进程ID为:$TomcatID,继续检测页面..."
# 检测是否启动成功(成功的话页面会返回状态""),100秒无响应就不等待了
TomcatServiceCode=$(curl -s -o $GetPageInfo -m --connect-timeout $WebUrl -w %{http_code})
if [ $TomcatServiceCode -eq ];then
echo "[info]页面返回码为$TomcatServiceCode,tomcat启动成功,测试页面正常"
else
echo "[error]tomcat页面出错,请注意...状态码为$TomcatServiceCode,错误日志已输出到$GetPageInfo"
echo "[error]页面访问出错,开始重启tomcat"
kill - $TomcatID # 杀掉原tomcat进程
sleep
rm -rf $TomcatCache # 清理tomcat缓存
$StartTomcat
fi
else
echo "[error]tomcat进程不存在!tomcat开始自动重启..."
echo "[info]$StartTomcat,请稍候..."
rm -rf $TomcatCache
$StartTomcat
fi
fi
echo "--------------------------"
}
Monitor>>$TomcatMonitorLog

2、赋予monitor_tomcat.sh可执行权限:

chmod  monitor_tomcat.sh

3、手动执行一下monitor_tomcat.sh看是否能启动指定位置的tomcat

./monitor_tomcat.sh

4、脚本解释说明

ps  -e  //显示所有进程

ps -f   //按树状显示

grep tomcat  //只取含有tomcat的行

grep -w 'apache-tomcat-5.5.23'        //-w选项搜索一个单词,并且避免搜索到词中的部分字串。 搜索含有apache-tomcat-5.5.23的行

grep -v 'grep'    //去掉含有grep的行

awk '{print $2}'  //用空格切分 取第二列

ps -ef |grep tomcat |grep -w 'apache-tomcat-5.5.23'|grep -v 'grep'|awk '{print $2}'   //获取tomcat的进程id 

但是仅仅是 tomcat进程存在是不够的,需要访问下  站点页面看看 是否访问正常  正常状态为200  通过curl 

curl -s -o $GetPageInfo -m  --connect-timeout  $WebUrl -w %{http_code}   //访问页面并保存页面内容返回状态码
-s --silent //静默模式,就是不显示错误和进度
-o $GetPageInfo //将文件保存到本地并命名为$GetPageInfo
-m //表示获取网页的最长时间(数据传输的最大允许时间)
-m //表示如果10秒内无法完成获取网页源码的操作,则放弃
--connect-timeout //连接超时时间
--connect-timeout //表示如果10秒内无法连接,则放弃
$WebUrl //就是我们要访问的页面路径变量
-w //curl的-w参数我们可以自定义curl的输出,%{http_code}代表http状态码 如果状态码为200则 tomcat正常,否则 kill 杀掉tomcat 进程, 访问tomcat的启动脚本 start.sh 启动tomcat

5、添加进crontab中

输入命令 :

crontab -e

进入编辑界面(操作类似vim),编辑为每5分钟执行一次脚本进行tomcat检测

*/ * * * * /usr/local/my_crontab/monitor_tomcat.sh

6、批量删除进程:

| xargs kill -

将前面的结果作为参数传入,一并kill掉

7、统一前面结果的字符串个数

|wc -l

参考:https://blog.csdn.net/zhang41228/article/details/79860030

https://www.cnblogs.com/cocoat/p/6017283.html

https://blog.csdn.net/lzz313/article/details/9389211

tomcat监控,自动重启shell脚本的更多相关文章

  1. nginx奔溃自动重启Shell脚本

    # vi /usr/local/nginx/sbin/nginx_restart.sh 贴入一下代码: #!/bin/bash #www.xmsolink.com #Monitor nginx ser ...

  2. 检测进程不存在自动重启shell脚本

    #!/bin/bash WORKDIR="/usr/local/gse/gseagent" [[ -d $WORKDIR ]] && { if ! ps aux|g ...

  3. 如何设置tomcat定时自动重启

    ,今天笔者就跟大家分享一下如何设置tomcat定时自动重启. 第一:把Tomcat6安装成windows 2003服务. 1.首先检查tomcat\bin目录下是否有service.bat文件,如图: ...

  4. centos7 开机自动执行shell脚本

    centos7 开机自动执行shell脚本 90十80 关注 2018.12.23 09:37 字数 309 阅读 485评论 0喜欢 0 自己新建一个脚本,如centnet-service.sh 经 ...

  5. JFinal中文件上传后会默认放置到WebContent的upload包下,但是tomcat会自动重启,当我们再次打开upload文件夹查看我们刚刚上传的文件时,发现上传的文件已经没有了。

    JFinal中文件上传后会默认放置到WebContent的upload包下,但是tomcat会自动重启,当我们再次打开upload文件夹查看我们刚刚上传的文件时,发现上传的文件已经没有了.因为tomc ...

  6. 实用脚本----Linux下Jdk和Tomcat自动安装shell脚本总结

    系统环境为:ubuntu 14.04 一.JDK 自动安装脚本 jdk自动安装bash shell脚本,截止今天(2014/10/15)亲测可用: sudo su #切换到root权限 mkdir / ...

  7. linux下实现tomcat定时自动重启

    tomcat自带的脚本中没有提供直接restart的模式,但是有start和shutdown两种模式.要实现restart模式,实际上只需要判断是否已经启动tomcat,若已经启动则限制性shutdo ...

  8. MySQL自动备份shell脚本

    在数据库的日常维护工作中,除了保证业务的正常运行以外,就是要对数据库进行备份,以免造成数据库的丢失,从而给企业带来重大经济损失.通常备份可以按照备份时数据库状态分为热备和冷备,按照备份数据库文件的大小 ...

  9. 使用redis4.0.1和redis-cluster搭建集群并编写重启shell脚本

    1.删除机器上原有的redis2.8 关闭redis-server killall -9 redis-server 查找redis文件所在目录 which redis 删除相关文件 rm -rf re ...

随机推荐

  1. 随笔 javascript-抽象工厂模式

    随笔   javascript-抽象工厂模式 抽象工厂模式笔记   1.抽象工厂模式创建多个抽象类,创建出的结果是一个类簇(这里是抽象类的集合)   2.抽象工厂中传入的父类是否是抽象工厂方法创建的抽 ...

  2. 前端开发 - HTML - 总结

    html head标签 title 显示网站的标题 meta 提供有关页面的原信息 link 链接css资源文件.网站图标 style 定义内部样式表 script 链接脚本js文件 body标签 块 ...

  3. zzuli1783: 简单的求和---求因子和

    1783: 简单的求和 Description 定义f(i)代表i的所有因子和(包括1和i),给定一个l,r.求f(l)+f(l+1)+...+f(r). Input 第一行输入一个t(t<10 ...

  4. Sublime Text 中文

    1.打开Sublime Text 2.Ctrl+Shift+P,输入Package Control: Install Package回车 3.输入LocalizedMenu,回车 4.点击菜单help ...

  5. DtypeWarning: Columns (1,5,7,16,......) have mixed types. Specify dtype option on import or set low_memory=False.

    DtypeWarning: Columns (1,5,7,16,......) have mixed types. Specify dtype option on import or set low_ ...

  6. Incorrect key file for table ' '; try to repair it

    场景:为有150W的数据表增加字段时,报错 解决:在my.ini配置临时目录configure tmpdir. Where MySQL Stores Temporary Files

  7. R中遇到的部分问题

    在Rstdio使用的是3.5.1的64位R版本中遇到问题:The Perl script 'WriteXLS.pl' failed to run successfully. 首先使用 Sys.whic ...

  8. OOM问题分析

    一.背景 在实际的开发中,性能问题的分析一直是运维团队的痛点,无论是缓慢内存溢出还是迅速的内存爆炸,对系统和业务的破坏都是快速而巨大的,此贴分享下简单的分析内存问题的经验. 二.相关名词 分代:根据对 ...

  9. 推荐系统第5周--- 基于内容的推荐,隐语义模型LFM

    基于内容的推荐

  10. Flask之wtforms源码分析

    一.wtforms源码流程 1.实例化流程分析 # 源码流程 1. 执行type的 __call__ 方法,读取字段到静态字段 cls._unbound_fields 中: meta类读取到cls._ ...