springboo+nginx测试负载均衡
1:之前只是用nginx调用了boot_8044这一个服务,这次新建一个boot_8055服务,并在linux上启动;
两个boot我都是放在 /myprojects 目录下的(自定义,能启动就行)

2:切换到 /myprojects/nginx 目录下,修改nginx.conf中的某些配置,增加服务器组 upstream

保存修改后,重启一下nginx服务;
3:再次在windows下访问linux的nginx服务
访问nginx时可以看到浏览器发出了两个servlet 请求

而在两个boot页面中显示boot_8044收到一个请求,boot_8055收到一个请求

如有需要可以看看boot源码;
此时nginx就同时代理了boot_8044、boot_8055两个服务的请求,由于没有配置权重等,默认轮询;
下面可以来玩玩nginx的权重 等相关配置了;
4:为 upstream 中的各个boot 分别按需添加相关属性
1)weight : 权重,值越大,分配的概率越大,默认为1;注意weight=1才是正确写法,weight = 1多了空格,启动nginx或报错;

分配概率=单weight/总weight,如8044的概率为:1/1+2 = 1/3 ;
2)max_fails:最大失败次数,当某服务请求失败达到设定的次数之后,在fail_timeout设定的时间内将不再为该服务分配请求;
如果设置为0,Nginx会将这台Server置为永久无效状态,然后将请求发给定义了proxy_next_upstream, fastcgi_next_upstream, uwsgi_next_upstream, scgi_next_upstream, and memcached_next_upstream指令来处理这次错误的请求。
3)fail_timeout:单位秒,默认值为10;当某服务处理请求失败达到max_fails的设定后会触发改配置;

4)backup:备机,当其他服务都down掉(不可用)时,会把请求交给此机处理;

如图,我把8055设置成备机后,只剩8044还能正常工作,8044down掉后会唤醒8055,可自行测试;
5)down:标识某服务不可用,不再处理任何请求

如图,8044设置为down之后,不再处理请求,8055down掉nginx的请求将再无法处理;
6)max_conns:给某服务设置的最大连接数,当达到上限时nginx不再分配请求给改server,默认值为0,代表不限制;版本大于1.5.9才可使用;
7)ip_hash:使来自同一客户端的请求始终分发在同一server上,除非此server不可用(down掉);
ip_hash会为每个客户端分配一个具体hash值,用来找到上一次访问的server;
客户端的ip_hash值为ipv4的前三个8位字节或ipv6的的地址;

好处:可以保证浏览器端的登录状态

如图,我在源码中采用了session登录,使用ip_hash可以正确返回登录状态,而若我不适用ip_hash则无法判定用户的登录状态(能访问是因为我在源码中没加登录判断);
所以之前看不到具体的用户名就是这个原因导致;
坏处:当用户处于登录成功状态时(假设正在由8055处理所有请求),8055突然down掉了,用户就被迫下线了(可自行修改源码测试~);


8)slow_start:慢启动,默认为0,禁用此指令;作用是设置server从权重为0恢复到标准值权重的时间,或不健康的服务器恢复健康的时间,
或者服务器在一段时间被认为不可用后变得可用时间;不可与hash和ip_hash一起使用;
这个估计是bug吗?该指令在1.8.1中居然不可用~~~望解答

nginx这个东西还是有很多坑啊,需多多注意~~~~
springboo+nginx测试负载均衡的更多相关文章
- nginx作为负载均衡服务器——测试
i. 需求 nginx作为负载均衡服务器,用户请求先到达nginx,再由nginx根据负载配置将请求转发至 tomcat服务器. nginx负载均衡服务器:192.168.101.3 tomcat1服 ...
- nginx+tomcat负载均衡
最近练习nginx+tomcat负载均衡.根据一些资料整理了大体思路,最终实现了1个nginx+2个tomcat负载均衡. 安装JDK 1>进入安装目录,给所有用户添加可执行的权限 #chmod ...
- windows配置nginx实现负载均衡集群
windows配置nginx实现负载均衡集群2014-08-20 09:44:40 来源:www.abcde.cn 评论:0 点击:617 网上大部分关于nginx负载均衡集群的教程都是lin ...
- Nginx作为负载均衡服务器(Windows环境)
一个最简单的负载均衡测试,不涉及到session复制,只是将请求分配到不同的服务器上去而已. 1.创建一个简单的web应用.只有一个index.jsp页面,,内容如下. <%@ page lan ...
- [转载] nginx的负载均衡
原文:http://www.srhang.me/blog/2014/08/27/nginx-loabbalance/ Nginx负载均衡 一.特点 1.1 应用情况 Nginx做为一个强大的Web服务 ...
- Nginx之负载均衡
转自:http://www.360doc.com/content/13/1114/12/7694408_329125489.shtml 注,大家可以看到,由于我们网站是发展初期,nginx只代理了后端 ...
- nginx做负载均衡配置文件
nginx做负载均衡是在反向代理的基础上做的,代码如下: ## Basic reverse proxy server ## ## Apache backend for www.baidu.com ## ...
- linux+nginx+tomcat负载均衡,实现session同步
linux+nginx+tomcat负载均衡,实现session同步 花了一个上午的时间研究nginx+tomcat的负载均衡测试,集群环境搭建比较顺利,但是session同步的问题折腾了几个小时才搞 ...
- nginx四层负载均衡配置
nginx四层负载均衡配置代理Mysql集群 环境如下: ip 192.168.6.203 Nginx ip 192.168.6.*(多台) Mysql 步骤一 查看Nginx是否安装stream模块 ...
随机推荐
- codeforces850E Random Elections
题目链接:codeforces 850E 翻译:luogu 读题是第一要务(大选这么随便真的好吗) 其实答案问你的就是在所有选民心中支持的人的所有情况中,能让一个人连赢两场的情况数是多少 我们假设\( ...
- python学习日记(初识递归与算法)
递归函数 定义 递归的定义——在一个函数里再调用这个函数本身 递归的最大深度——997,即栈溢出. 使用递归函数需要注意防止栈溢出.在计算机中,函数调用是通过栈(stack)这种数据结构实现的,每当进 ...
- spring-webmvc-DispatcherServlet
Spring Web MVC is the original web framework built on the Servlet API and has been included in the S ...
- wqs二分
今天模拟赛有一道林克卡特树,完全没有思路 赛后想了一想,不就是求\(k+1\)条不相交的链,使其权值之和最大嘛,傻了. 有一个最裸的\(DP\),设\(f[i][j][k]\)表示在以\(i\)为根的 ...
- 分享自己总结的PMP项目管理20个G的资料,本人去年过的pmp认证,过了5A
版权归作者所有,任何形式转载请联系作者. 我在去年6月拿到的pmp证书,5A的,现在来分享下自己的资料. 这些资料是从我开始学习,到问了很多朋友.老人,到后来报班学习,再到之后做项目管理中总结的很多经 ...
- PMP是什么,PMP最难的是哪些内容?
目前在国内很多人还不了解PMP是什么,甚至不知道PMP认证的内容是哪些,考来有什么用,今天我这边就普及一下. PMP认证是美国项目管理协会发起的一项针对项目管理专业人士资格认证.取得认证需要学习项目管 ...
- JMeter的介绍和简单使用
Apache官网(https://jmeter.apache.org/)对JMeter的解释: Apache JMeter™ Apache JMeter™应用程序是开源软件, 为负载功能和性能测试 ...
- STL迭代器iterator
一:迭代器原理 迭代器是一个“可遍历STL容器内全部或部分元素”的对象. 迭代器指出容器中的一个特定位置. 迭代器就如同一个指针. 迭代器提供对一个容器中的对象的访问方法,并且可以定义了容器中对象的范 ...
- vue路由信息对象
一个路由信息对象表示当前激活的路由的状态信息,每次成功的导航后都会产生一个新的对象. path字符串,对应当前路由的路径 params对象,包含动态路由参数 query对象,URL查询参数 hash字 ...
- react项目后台及上线步骤
应同学要求,本人将react项目创建后台及上线流程书写如下: 前端部分 略…… 后台部分 (注:这里的后台是用的nodejs搭建的,使用的是express框架+ejs模板) 首先通过express快速 ...