原文链接:https://blog.csdn.net/bao19901210/article/details/51917641

二进制安装

1.添加mysql组和mysql用户,用于设置mysql安装目录文件所有者和所属组。

 ①groupadd mysql

 ②useradd -r -g mysql mysql

 * useradd -r参数表示mysql用户是系统用户,不可用于登录系统。

 * useradd -g参数表示把mysql用户添加到mysql用户组中。

2.将二进制文件解压到指定的安装目录,我们这里指定为 /Ultrapower/test/,也可以是通用的/usr/local

 ①解压二进制文件, tar -zxvf /Ultrapower/test/mysql-5.7.13-linux-glibc2.5-i686.tar.gz 

 ②mv mysql-5.7.13-linux-glibc2.5-i686 mysql   更改mysql目录名称

 ③cd mysql 进入mysql文件夹,也就是mysql所在的目录,

 ④更改mysql目录所属的组和用户。更改权限

    chown -R mysql .

    chgrp -R mysql .

3.初始化 MySQL 配置表 

 执行mysql_install_db脚本,对mysql中的data目录进行初始化并创建一些系统表格。

 bin/mysql_install_db --user=mysql

 报错:

 2016-07-15 14:50:14 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize
 2016-07-15 14:50:14 [ERROR]   The data directory needs to be specified.  需要指定data目录,注意mysql服务进程mysqld运行时会访问data目录,所以必须由启动mysqld进程的用户(就是我们之前设置的mysql用户)执行这个脚本,  或者用root  执行,但是加上参数--user=mysql。  上文还有警告信息,说mysql_install_db 命令已经是弃用的,建议切换到mysqld --initialize命令  注:  mysql5.7和之前版本不同,很多资料上都是这个命令:../scripts/mysql_install_db --user=mysql,而mysql5.7的mysql_install_db命令是在bin目录下  的并且建议  用 mysqld --initialize命令  mysql5.7之前版本初始化配置表命令:  script/mysql_install_db --user=mysql --basedir=/Ultrapower/test/mysql --datadir=/Ultrapower/test/mysql/data/  --user  启动mysql的用户  --basedir  mysql安装目录  --datadir  mysql数据仓库目录  ①初始化表配置正确执行步骤:   [root@rhel5-32 mysql]# mkdir data
[root@rhel5-32 mysql]# bin/mysqld --initialize --user=mysql --basedir=/Ultrapower/test/mysql --datadir=/Ultrapower/test/mysql/data
2016-07-15T09:39:38.166396Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-07-15T09:39:38.166941Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
2016-07-15T09:39:38.166976Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
2016-07-15T09:39:39.486697Z 0 [Warning] InnoDB: New log files created, LSN=45790
2016-07-15T09:39:39.699652Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
2016-07-15T09:39:39.767191Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 0d154f38-4a70-11e6-8670-005056913e3a.
2016-07-15T09:39:39.771851Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2016-07-15T09:39:39.773073Z 1 [Note] A temporary password is generated for root@localhost: i7YCy.:jv6yr
       注意最后一行,这也是和之有版本不同的地方,它给了root一个初始密码,后面要登录的时候要用到这个密码。    ②将mysql/目录下除了data/目录的所有文件,改回root用户所有,mysql用户只需作为mysql/data/目录下所有文件的所有者。   [root@rhel5-32 mysql]# chown -R root .
[root@rhel5-32 mysql]# chown -R mysql data ③复制配置文件     [root@rhel5-32 mysql]# cp support-files/my-default.cnf /etc/my.cnf
           ④mysql5.7配置文件需要修改my.cnf关键配置, mysql5.7之前默认配置文件中是有配置项的,不用手动修改   [mysqld]
basedir = /Ultrapower/test/mysql
datadir = /Ultrapower/test/mysql/data
port = 3306
socket = /Ultrapower/test/mysql/tmp/mysql.sock sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES
   注意,tmp目录不存在,请创建之。否则会出错     创建后要赋予mysql权限,chown -R mysql:mysql tmp   如果mysql.sock指定到/tmp以外的目录,需要在my.cnf中添加[client]并且指定socket位置,  否则登录mysql时会报错:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)  应该是,默认会找tmp目录下的sock文件           4. 将mysqld服务加入开机自启动项。  将{mysql}/ support-files/mysql.server 拷贝为/etc/init.d/mysql并设置运行权限,这样就可以使用service mysql命令启动/停止服务,  否则就只能使用{mysql}/bin/mysqld_safe &命令来启动服务  还需要把mysql.server中basedir的相关路径,改为自定义的路径,默认路径是/usr/local/mysql   #cp mysql.server /etc/init.d/mysql
#chmod +x /etc/init.d/mysql
 把mysql注册为开机启动的服务   #chkconfig --add mysql
     查看是否添加成功 [root@rhel5-32 mysql]# chkconfig --list mysql
mysqld 0:关闭 1:关闭 2:启用 3:启用 4:启用 5:启用 6:关闭
  5.mysql服务的开启和关闭 #/etc/init.d/mysql start 或者 service mysql start 或者 bin/mysqld_safe&
#/etc/init.d/mysql stop 或者 service mysql stop 或者 bin/mysqladmin -uroot -p
 注:在bin/mysqld_safe&这个启动脚本里已默认设置--user=mysql;在脚本末尾加&表示设置此进程为后台进程,区别就是在控制台输入bg,即可将当前进  程转入后台,  当前shell  可进行其他操作。  bin/mysqladmin -uroot -p  (注意此时的root是指mysql的root用户)   需要把mysqll加入到环境变量中,或者为mysql建立软链接 否则运行mysql命令会出现   -bash: mysql:command not found 不加环境变量,就要使用bin/mysql -uroot -p 或者bin/mysqladmin -uroot -p  命令来登录mysql服务   建立软链接: ln -s /Ultrapower/test/mysql/bin/mysql  /usr/local/bin ln -s /Ultrapower/test/mysql/bin/mysqladmin  /usr/local/bin ln -s /Ultrapower/test/mysql/bin/mysqld_safe  /usr/local/bin   6.加入环境变量  修改/etc/profile文件使其永久性生效,并对所有系统用户生效,在文件末尾加上如下两行代码
 PATH=$PATH:/Ultrapower/test/mysql:/Ultrapower/test/mysql/bin
 export PATH
 最后:执行 命令source /etc/profile或 执行点命令 ./profile使其修改生效,执行完可通过echo $PATH命令查看是否添加成功。   7.登录mysql服务  执行:mysql -uroot -p生成的密码  连上后,在做任何操作前,mysql要求要改掉root的密码后才能进行操作。  ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement.  需要执行:alter user 'root'@'localhost' identified by 'xxxxxxx'; mysql安装过程遇到的错误:   启动Mysql bin/mysqld_safe --user=mysql &   [root@rhel5-32 mysql]# bin/mysqld_safe &
[1] 13863
[root@rhel5-32 mysql]# bin/mysqld_safe: line 541: /Ultrapowewr/test/mysql/data/mysqld_safe.pid: 没有那个文件或目录
awk: (FILENAME=- FNR=1) warning: error writing standard output (断开的管道)
2016-07-15T07:57:05.782967Z mysqld_safe Logging to '/Ultrapowewr/test/mysql/data/rhel5-32.err'.
touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
chmod: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
chown: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
2016-07-15T07:57:05.877234Z mysqld_safe Starting mysqld daemon with databases from /Ultrapowewr/test/mysql/data
bin/mysqld_safe: line 135: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录
bin/mysqld_safe: line 169: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录
touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
chown: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
chmod: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录
2016-07-15T07:57:05.923131Z mysqld_safe mysqld from pid file /Ultrapowewr/test/mysql/data/rhel5-32.pid ended
bin/mysqld_safe: line 135: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录   [root@rhel5-32 mysql]# service mysql restart
MySQL server PID file could not be found!                  [失败]
/etc/init.d/mysql: line 276: cd: /Ultrapowewr/test/mysql: 没有那个文件或目录
Starting MySQLCouldn't find MySQL server (/Ultrapowewr/test[失败]/bin/mysqld_safe) 这错误是因为,在/etc/my.cnf中配置basedir路径出错导致的 ************************************************************************************************************************************************* 执行 mysql -uroot -p 出错:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111)   查看 less data/rhel5-32.err  发现日志输出: 2016-07-15T08:13:31.786920Z 0 [Note] /Ultrapower/test/mysql/bin/mysqld: ready for connections.
Version: '5.7.13'  socket: '/temp/mysql.sock'  port: 3306  MySQL Community Server (GPL)   查看/etc/my.cnf中,socket配置: # These are commonly set, remove the # and set as required.
basedir = /Ultrapower/test/mysql
datadir = /Ultrapower/test/mysql/data
port = 3306
# server_id = .....
socket = /tmp/mysql.sock   socket文件目录为/temp/mysql.sock和错误提示不一样, #由上可知my.cnf中定义的为/tmp目录下,而错误提示为/temp/mysql.sock/目录下
#也就是说mysqld已经声称了正确的sock文件,但客户端连接还是从初始目录去找sock文件 应该是因为,没有temp目录,mysql不会自动创建,找不到所致 ************************************************************************************************************************************************* 错误:The server quit without updating PID file [失败]local/mysql/data/rhel5-32.pi 启动mysql服务时报如上错误,查看mysql日志发现   2016-07-26T02:07:28.134232Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2016-07-26T02:07:28.172866Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2016-07-26T02:07:28.172990Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2016-07-26T02:07:28.244892Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2016-07-26T02:07:28.252257Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2016-07-26T02:07:28.252344Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2016-07-26T02:07:28.253779Z 0 [Note] InnoDB: Waiting for purge to start
2016-07-26T02:07:28.305124Z 0 [Note] InnoDB: 5.7.13 started; log sequence number 2523957
2016-07-26T02:07:28.306232Z 0 [Note] InnoDB: Loading buffer pool(s) from /usr/local/mysql/data/ib_buffer_pool
2016-07-26T02:07:28.307231Z 0 [Note] Plugin 'FEDERATED' is disabled.
2016-07-26T02:07:28.315654Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2016-07-26T02:07:28.315736Z 0 [Note] Server hostname (bind-address): '*'; port: 3306
2016-07-26T02:07:28.315825Z 0 [Note] IPv6 is available.
2016-07-26T02:07:28.315860Z 0 [Note] - '::' resolves to '::';
2016-07-26T02:07:28.316013Z 0 [Note] Server socket created on IP: '::'.
2016-07-26T02:07:28.316099Z 0 [ERROR] Could not create unix socket lock file /usr/local/mysql/tmp/mysql.sock.lock.
2016-07-26T02:07:28.316115Z 0 [ERROR] Unable to setup unix socket lock file.
2016-07-26T02:07:28.316128Z 0 [ERROR] Aborting 不能创建mysql.sock.lock文件,可能是tmp目录权限不足或者目录不存在的问题   执行 chown -R mysql:mysql tmp,然后启动mysql服务,启动成功 ************************************************************************************************************************************************* 登录mysql,mysql -uroot -pi7YCy.:jv6yr 如出现ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO),是因为不允许密码为空 如出现ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES),可能密码错误 ,终极办法停止mysql服务,删除data目录,重新初始化表数据,受权data目录给Mysql用户,用重新生成的临时密码登录。 ---------------------
作者:夜舞倾城
来源:CSDN
原文:https://blog.csdn.net/bao19901210/article/details/51917641
版权声明:本文为博主原创文章,转载请附上博文链接!

安装时遇到的错误:https://blog.csdn.net/qq_34266639/article/details/80668533

使用mysql -uroot -p连接数据库时,出现

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/usr/local/mysql/run/mysql.sock' (2)
通过 find / -name mysql.sock
可以找到/tmp/mysql.sock,但是没有找到
/usr/local/mysql/run/mysql.sock
先用 mysql -uroot -p -S /tmp/mysql.sock
强制指定使用/tmp/mysql.sock尝试连接,报错 ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111)
如下图: 检查错误日志: grep 'Error' /usr/local/mysql/log/mysql_error.log 没有任何输出,自己再仔细查看错误日志,发现全是Note和Warning,并且这些记录和警告与连接无关,后来查了一下,mysql.sock是在mysql启动时生成的一个文件,检查服务状态,并没有启动,重启一下mysql就可以了。 /etc/init.d/mysql.server status
/etc/init.d/mysql.server restart 总结: 1、遇到问题一定要沉着冷静。 2、有错误先查看错误日志和错误信息,通过错误信息和错误日志定位问题。 3、服务相关的问题先检查服务状态,可能是服务没有启动,重启服务就可以解决。 4、遇到文件找不到的问题先用find / -name file_name 找一下,可能这个文件不在这个目录下,或者没有在这个目录下生成这个文件,有的时候是权限问题,没有权限生成文件,修改权限或者在root用户下touch /path/to/file/file_name手动创建一个文件。 5、在安装MySQL的时候记得一定要更改所有者。 chown -R root:mysql .
chown -R mysql:mysql data
因为连接数据库的时候使用的是mysql组的mysql用户,可能会因为权限问题导致没有办法获取到key。
---------------------
作者:MiaFu
来源:CSDN
原文:https://blog.csdn.net/qq_34266639/article/details/80668533
版权声明:本文为博主原创文章,转载请附上博文链接!

查看tomcat是否安装成功

命令

rpm -q mysql 

结果

二进制安装
1.添加mysql组和mysql用户,用于设置mysql安装目录文件所有者和所属组。
 ①groupadd mysql
 ②useradd -r -g mysql mysql
 * useradd -r参数表示mysql用户是系统用户,不可用于登录系统。
 * useradd -g参数表示把mysql用户添加到mysql用户组中。
2.将二进制文件解压到指定的安装目录,我们这里指定为 /Ultrapower/test/,也可以是通用的/usr/local
 ①解压二进制文件, tar -zxvf /Ultrapower/test/mysql-5.7.13-linux-glibc2.5-i686.tar.gz 
 ②mv mysql-5.7.13-linux-glibc2.5-i686 mysql   更改mysql目录名称
 ③cd mysql 进入mysql文件夹,也就是mysql所在的目录,
 ④更改mysql目录所属的组和用户。更改权限
    chown -R mysql .
    chgrp -R mysql .
3.初始化 MySQL 配置表 
 执行mysql_install_db脚本,对mysql中的data目录进行初始化并创建一些系统表格。
 bin/mysql_install_db --user=mysql
 报错:
 2016-07-15 14:50:14 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize 2016-07-15 14:50:14 [ERROR]   The data directory needs to be specified.
 需要指定data目录,注意mysql服务进程mysqld运行时会访问data目录,所以必须由启动mysqld进程的用户(就是我们之前设置的mysql用户)执行这个脚本,  或者用root  执行,但是加上参数--user=mysql。
 上文还有警告信息,说mysql_install_db 命令已经是弃用的,建议切换到mysqld --initialize命令
 注:
 mysql5.7和之前版本不同,很多资料上都是这个命令:../scripts/mysql_install_db --user=mysql,而mysql5.7的mysql_install_db命令是在bin目录下  的并且建议  用 mysqld --initialize命令
 mysql5.7之前版本初始化配置表命令:
 script/mysql_install_db --user=mysql --basedir=/Ultrapower/test/mysql --datadir=/Ultrapower/test/mysql/data/
 --user  启动mysql的用户
 --basedir  mysql安装目录
 --datadir  mysql数据仓库目录
 ①初始化表配置正确执行步骤:
 
[root@rhel5-32 mysql]# mkdir data[root@rhel5-32 mysql]# bin/mysqld --initialize --user=mysql --basedir=/Ultrapower/test/mysql --datadir=/Ultrapower/test/mysql/data2016-07-15T09:39:38.166396Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).2016-07-15T09:39:38.166941Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.2016-07-15T09:39:38.166976Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.2016-07-15T09:39:39.486697Z 0 [Warning] InnoDB: New log files created, LSN=457902016-07-15T09:39:39.699652Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.2016-07-15T09:39:39.767191Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 0d154f38-4a70-11e6-8670-005056913e3a.2016-07-15T09:39:39.771851Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.2016-07-15T09:39:39.773073Z 1 [Note] A temporary password is generated for root@localhost: i7YCy.:jv6yr 
 
 
 注意最后一行,这也是和之有版本不同的地方,它给了root一个初始密码,后面要登录的时候要用到这个密码。
 
 ②将mysql/目录下除了data/目录的所有文件,改回root用户所有,mysql用户只需作为mysql/data/目录下所有文件的所有者。
 
[root@rhel5-32 mysql]# chown -R root .[root@rhel5-32 mysql]# chown -R mysql data
③复制配置文件
 
 
[root@rhel5-32 mysql]# cp support-files/my-default.cnf /etc/my.cnf 
 
 
 
 
 ④mysql5.7配置文件需要修改my.cnf关键配置, mysql5.7之前默认配置文件中是有配置项的,不用手动修改
 
[mysqld]basedir = /Ultrapower/test/mysqldatadir = /Ultrapower/test/mysql/dataport = 3306socket = /Ultrapower/test/mysql/tmp/mysql.sock sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 
 注意,tmp目录不存在,请创建之。否则会出错     创建后要赋予mysql权限,chown -R mysql:mysql tmp 
 如果mysql.sock指定到/tmp以外的目录,需要在my.cnf中添加[client]并且指定socket位置,
 否则登录mysql时会报错:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
 应该是,默认会找tmp目录下的sock文件
 
 
 
 
 
4. 将mysqld服务加入开机自启动项。
 将{mysql}/ support-files/mysql.server 拷贝为/etc/init.d/mysql并设置运行权限,这样就可以使用service mysql命令启动/停止服务,
 否则就只能使用{mysql}/bin/mysqld_safe &命令来启动服务
 还需要把mysql.server中basedir的相关路径,改为自定义的路径,默认路径是/usr/local/mysql
 
#cp mysql.server /etc/init.d/mysql#chmod +x /etc/init.d/mysql 把mysql注册为开机启动的服务
 
#chkconfig --add mysql 
 
 查看是否添加成功
[root@rhel5-32 mysql]# chkconfig --list mysqlmysqld          0:关闭  1:关闭  2:启用  3:启用  4:启用  5:启用  6:关闭 
5.mysql服务的开启和关闭
#/etc/init.d/mysql start   或者   service mysql start  或者  bin/mysqld_safe&#/etc/init.d/mysql stop    或者   service mysql stop   或者  bin/mysqladmin -uroot -p 注:在bin/mysqld_safe&这个启动脚本里已默认设置--user=mysql;在脚本末尾加&表示设置此进程为后台进程,区别就是在控制台输入bg,即可将当前进  程转入后台,  当前shell  可进行其他操作。
 bin/mysqladmin -uroot -p  (注意此时的root是指mysql的root用户)
 
需要把mysqll加入到环境变量中,或者为mysql建立软链接
否则运行mysql命令会出现   -bash: mysql:command not found
不加环境变量,就要使用bin/mysql -uroot -p 或者bin/mysqladmin -uroot -p  命令来登录mysql服务
 
建立软链接:
ln -s /Ultrapower/test/mysql/bin/mysql  /usr/local/bin
ln -s /Ultrapower/test/mysql/bin/mysqladmin  /usr/local/bin
ln -s /Ultrapower/test/mysql/bin/mysqld_safe  /usr/local/bin
 
6.加入环境变量
 修改/etc/profile文件使其永久性生效,并对所有系统用户生效,在文件末尾加上如下两行代码 PATH=$PATH:/Ultrapower/test/mysql:/Ultrapower/test/mysql/bin export PATH 最后:执行 命令source /etc/profile或 执行点命令 ./profile使其修改生效,执行完可通过echo $PATH命令查看是否添加成功。
 
7.登录mysql服务
 执行:mysql -uroot -p生成的密码
 连上后,在做任何操作前,mysql要求要改掉root的密码后才能进行操作。
 ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement.
 需要执行:alter user 'root'@'localhost' identified by 'xxxxxxx';
mysql安装过程遇到的错误:
 
启动Mysql
bin/mysqld_safe --user=mysql &  
[root@rhel5-32 mysql]# bin/mysqld_safe &[1] 13863[root@rhel5-32 mysql]# bin/mysqld_safe: line 541: /Ultrapowewr/test/mysql/data/mysqld_safe.pid: 没有那个文件或目录awk: (FILENAME=- FNR=1) warning: error writing standard output (断开的管道)2016-07-15T07:57:05.782967Z mysqld_safe Logging to '/Ultrapowewr/test/mysql/data/rhel5-32.err'.touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录chmod: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录chown: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录2016-07-15T07:57:05.877234Z mysqld_safe Starting mysqld daemon with databases from /Ultrapowewr/test/mysql/databin/mysqld_safe: line 135: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录bin/mysqld_safe: line 169: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录touch: 无法触碰 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录chown: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录chmod: 无法访问 “/Ultrapowewr/test/mysql/data/rhel5-32.err”: 没有那个文件或目录2016-07-15T07:57:05.923131Z mysqld_safe mysqld from pid file /Ultrapowewr/test/mysql/data/rhel5-32.pid endedbin/mysqld_safe: line 135: /Ultrapowewr/test/mysql/data/rhel5-32.err: 没有那个文件或目录
 
[root@rhel5-32 mysql]# service mysql restartMySQL server PID file could not be found!                  [失败]/etc/init.d/mysql: line 276: cd: /Ultrapowewr/test/mysql: 没有那个文件或目录Starting MySQLCouldn't find MySQL server (/Ultrapowewr/test[失败]/bin/mysqld_safe)
这错误是因为,在/etc/my.cnf中配置basedir路径出错导致的
*************************************************************************************************************************************************
执行 mysql -uroot -p
出错:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111)
 
查看 less data/rhel5-32.err 
发现日志输出:
2016-07-15T08:13:31.786920Z 0 [Note] /Ultrapower/test/mysql/bin/mysqld: ready for connections.Version: '5.7.13'  socket: '/temp/mysql.sock'  port: 3306  MySQL Community Server (GPL)
 
查看/etc/my.cnf中,socket配置:
# These are commonly set, remove the # and set as required.basedir = /Ultrapower/test/mysqldatadir = /Ultrapower/test/mysql/dataport = 3306# server_id = .....socket = /tmp/mysql.sock
 
socket文件目录为/temp/mysql.sock和错误提示不一样,
#由上可知my.cnf中定义的为/tmp目录下,而错误提示为/temp/mysql.sock/目录下#也就是说mysqld已经声称了正确的sock文件,但客户端连接还是从初始目录去找sock文件
应该是因为,没有temp目录,mysql不会自动创建,找不到所致
*************************************************************************************************************************************************
错误:The server quit without updating PID file [失败]local/mysql/data/rhel5-32.pi
启动mysql服务时报如上错误,查看mysql日志发现
 
2016-07-26T02:07:28.134232Z 0 [Note] InnoDB: Highest supported file format is Barracuda.2016-07-26T02:07:28.172866Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables2016-07-26T02:07:28.172990Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...2016-07-26T02:07:28.244892Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.2016-07-26T02:07:28.252257Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.2016-07-26T02:07:28.252344Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.2016-07-26T02:07:28.253779Z 0 [Note] InnoDB: Waiting for purge to start2016-07-26T02:07:28.305124Z 0 [Note] InnoDB: 5.7.13 started; log sequence number 25239572016-07-26T02:07:28.306232Z 0 [Note] InnoDB: Loading buffer pool(s) from /usr/local/mysql/data/ib_buffer_pool2016-07-26T02:07:28.307231Z 0 [Note] Plugin 'FEDERATED' is disabled.2016-07-26T02:07:28.315654Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key2016-07-26T02:07:28.315736Z 0 [Note] Server hostname (bind-address): '*'; port: 33062016-07-26T02:07:28.315825Z 0 [Note] IPv6 is available.2016-07-26T02:07:28.315860Z 0 [Note]   - '::' resolves to '::';2016-07-26T02:07:28.316013Z 0 [Note] Server socket created on IP: '::'.2016-07-26T02:07:28.316099Z 0 [ERROR] Could not create unix socket lock file /usr/local/mysql/tmp/mysql.sock.lock.2016-07-26T02:07:28.316115Z 0 [ERROR] Unable to setup unix socket lock file.2016-07-26T02:07:28.316128Z 0 [ERROR] Aborting
不能创建mysql.sock.lock文件,可能是tmp目录权限不足或者目录不存在的问题
 
执行 chown -R mysql:mysql tmp,然后启动mysql服务,启动成功
*************************************************************************************************************************************************
登录mysql,mysql -uroot -pi7YCy.:jv6yr
如出现ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO),是因为不允许密码为空
如出现ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES),可能密码错误
,终极办法停止mysql服务,删除data目录,重新初始化表数据,受权data目录给Mysql用户,用重新生成的临时密码登录。

--------------------- 作者:夜舞倾城 来源:CSDN 原文:https://blog.csdn.net/bao19901210/article/details/51917641 版权声明:本文为博主原创文章,转载请附上博文链接!

安装mysql报错的更多相关文章

  1. 运行安装mysql 报错 [root@localhost mysql-mult]# ./scripts/mysql_install_db  --defaults-file=conf/3306my.cnf FATAL ERROR: please install the following Perl modules before executing ./scripts/mysql_install_

    运行安装mysql 报错 [root@localhost mysql-mult]# ./scripts/mysql_install_db  --defaults-file=conf/3306my.cn ...

  2. ubuntu安装mysql报错

    ubuntu换源后安装mysql报错: 原因:版本高,不兼容,只需要还原apt下载源,然后 sudo apt-get install mysql-server即可正常安装mysql

  3. win7下安装MYSQL报错:"MYSQL 服务无法启动"的3534问题

    上午在win7下安装MYSQL,只到“net start mysql”这一步报错:3534的错误: 于是在百度中搜索关键字“mysql服务无法启动3534”. 参考以下两个链接中的方法,解决了3534 ...

  4. 安装mysql报错:Can't find messagefile '/usr/share/mysql/english/errmsg.sys'和/usr/bin/mysqladmin: error while loading shared libraries: libmysqlclient.so.16: cannot open shared object file: No such file or

    使用yum安装mysql服务端: [root@centos ~]# yum -y install mysql-server Loaded plugins: fastestmirror, securit ...

  5. centos6.5安装mysql报错

    安装完mysql后,mysql服务无法打开. 报错 查看mysql日志 执行命令:less /var/log/mysqld.log  发现是权限不够,不能创建pid文件.因此改变权限,再次启动服务 问 ...

  6. CentOS 5 64bit 编译安装MySQL报错

    报错情况:   在执行./configure时出现configure: error: No curses/termcap library found 解决方法: ./configure时加上参数--w ...

  7. mac 安装mysql 报错“ERROR 2002 (HY000): Can not connect to local MySQL server through socket '/tmp/mysql.sock' (2)” 解决办法

    首先安装 homebrew 再 brew install mysql 之后连接 mysql 无论是登录还是修改初始密码都会报如下的错误 ERROR 2002 (HY000): Can not conn ...

  8. 安装Mysql报错**此用户已存在!**

    我是安装了两个installer下载器,将其中一个删除运行另一个就会报这个错. 解决办法:将删除的那个installer从回收站还原.

  9. 安装mysql报错2503

    安装MySQL-5.5.27报这个错误: The installer has encountered an unexpected error installing this package.This ...

随机推荐

  1. Linux忽略大小写的查找技巧(转)

    1.vim 中的查找 Linux 下 vim搜索文件内容时加上 \c 参数可以忽略搜索字符的大小写. 比如用vim 搜索文件中的 China 时 可用 :/china\c 2. find 查找 Lin ...

  2. js文字颜色闪烁

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...

  3. IPSec 专题----转自华为文档

    参考链接:https://support.huawei.com/enterprise/zh/doc/EDOC1000122878?section=j004 IPSec 特性全景 1.介绍 由于IP报文 ...

  4. C++隐式推导-auto关键词

    总述 C++中有一个关键字,它不进行显式声明,而进行隐式推导,auto可以在声明变量时根据变量初始值的类型自动为此变量选择匹配的类型.C++语言类似的关键字还有decltype. 如何评价 C++ 1 ...

  5. 翻译:《实用的Python编程》README

    欢迎光临 大约 25 年前,当我第一次学习 Python 时,发现 Python 竟然可以被高效地应用到各种混乱的工作项目上,我立即被震惊了.15 年前,我自己也将这种乐趣教授给别人.教学的结果就是本 ...

  6. A. Little Pony and Expected Maximum

    Twilight Sparkle was playing Ludo with her friends Rainbow Dash, Apple Jack and Flutter Shy. But she ...

  7. Codeforces Round #680 (Div. 2, based on Moscow Team Olympiad) C. Division (数学)

    题意:有两个数\(p\)和\(q\),找到一个最大的数\(x\),使得\(p\ mod\ x=0\)并且\(x\ mod\ q\ne 0\). 题解:首先,如果\(p\ mod\ q\ne0\),那么 ...

  8. AtCoder Beginner Contest 173 D - Chat in a Circle (贪心)

    题意:有一个空环和\(n\)个点,每次可以选择一个点放在空环上,并且获得周围两个点中最小的那个的权值,问能获得的最大的权值是多少? 题解:我们每次都优先放最大的进去,注意每次放的时候都要将这个点放在当 ...

  9. MySQL 回表查询 & 索引覆盖优化

    回表查询 先通过普通索引的值定位聚簇索引值,再通过聚簇索引的值定位行记录数据 建表示例 mysql> create table user( -> id int(10) auto_incre ...

  10. ArcGIS处理栅格数据(二)

    五.栅格数据的配准 1.有参考图层 ① 在ArcMap里面添加需要配准的栅格数据集和参考数据集. ② 在ArcMap里面添加"地理配准"工具条. 添加成功后如下图所示: ③ 将需要 ...