前端开发集成环境-XAMPP

  在前端开发中,经常需要进行请求的调试等都需要一个服务器环境,这时类似wamp、XAMPP就是我们最后的选择,集成apache、php、mysql等一应俱全,不需要去单独配置,美滋滋。。之前的工作中,一直使用的是wamp,很傻瓜式的使用,安装完成后就直接在c盘的www文件夹中开发,也一直很够用,图形化界面比较友好,直达最近的项目中,配置一个项目需要php5.0以上,mysql的版本也太低,这时候就尴尬了,找了好多地方都没能成功升级,所以只能放弃,这时同事跟我推荐了XAMPP,那就用来试试;

  1、首先卸载类似wamp集成环境的软件

    主要防止一些默认端口冲突,当然厉害的也可以自己修改端口号。

  2、安装

    傻瓜式安装,一路下来,选择自己的安装目录

  3、启动

    

    这时候出现图上红字提示,说明端口被占用,可以使用命令行 netstat -ano  查看端口使用情况,当然我们直接修改XAMPP中apache的默认端口和SSL端口

  4、端口修改

    

    点击apache中的config按钮,打开①httpd.conf,将文件中的80改为你要设置的默认端口号,比如8080,共3处,  打开②httpd-ssl.conf将默认的443全部改为4433或你喜欢的,总共4处,修改后保存,并启动Apache,

      出现端口号,且显示绿色就为启动成功;

    如果mysql无法启动,则可以修改默认端口号,打开下图文件,修改默认端口3306,(改为其他端口)

    

  5、修改localhost默认路径

    

    打开apache→config→httpd.conf,找到

    DocumentRoot "D:\wamp\ETshop\dist\Webroot"
    <Directory "D:\wamp\ETshop\dist\Webroot">

    修改成你希望的指定路径;

  6、多虚拟目录域名设置

    不想频繁的修改localhost默认指向,希望能输入不同的域名转向不同的目录结构怎么办??

    ①、修改本地hosts,设置你的虚拟域名

      打开 C:\Windows\System32\drivers\etc  中的hosts文件,添加127.0.0.1绑定域名到本地,如下:

      

    ②、确认 httpd-vhosts.conf 是否启用

      打开文件 httpd.conf(目录位于C:\xampp\apache\conf)具体看你的安装目录

      找到 Include conf/extra/httpd-vhosts.conf 行,如果前面带#号,需要把#号去掉。#号代表注释

    ③、设置虚拟目录

      打开文件 httpd-vhosts.conf (目录 C:\xampp\apache\conf\extra)具体看你的安装目录

      新增虚拟目录,指定域名和目录之间的关系

      其中 ServerName 指定虚拟目录

         DocumentRoot 是虚拟目录指定的目录

      注意:虚拟目录是通过 hosts文件中指定。也就是步骤一的操作。

      

    ④、一般情况下,这么设置就行了(记得重新启动Apache),但是在我这么设置的时候发生了两种错误情况:

      Ⅰ 、输入虚拟域名时出现 Access forbidden! error403错误,服务器不允许访问文件;

        

        经过一番查找,在 http://blog.sina.com.cn/s/blog_4ed32a4001017zo2.html 找到解决办法:

        打开Apache config httpd.conf文件,查找<Directory /> 将原本

        

      Ⅱ、在一些完善的项目中,把虚拟域名指定向该项目文件夹时,出现Internal Server Error”错误;

        后来找了一些资料,误打误撞的修复了,主要原因是项目中含有.htaccess的重定向文件,默认的删除之后就能正常打开虚拟域名,不是很懂PHP所以无法解释这个原因;

      2017.03.22补充:

        关于上面提到的.htaccess文件导致的Internal Server Error”错误,解决办法:

          打开httpd.conf文件(方法同上),在之前我们修改的 <Directory/>中添加 AllowOverride All  形成如下:

          

          详细的问题讲解请查看 如何让apache支持.htaccess 解决Internal Server Error The server …错误

  总结:XAMPP相对于wamp可能更简洁一点,但是没有wamp图形工具那么容易上手,但对于前端来说,能基本的使用就达到要求了,以上是本人的安装很实用过程,大多数的问题也都是网上查看大牛博客的,在这只为记录自己踩过的坑;

      

XAMPP安装与多虚拟目录地址设置的更多相关文章

  1. Tomcat虚拟目录的设置

    在学习JSP/Servlet的过程中,配置Tomcat的虚拟目录可能是我们遇到的第一个比较麻烦的问题,说是麻烦是针对我们初学者而言,对于高手那都不是问题.反正我是弄了一天才配置好,发现网上给出的很多配 ...

  2. WAMP虚拟目录的设置

    1.打开Apache的配置文件httpd.conf,并去掉#Include conf/extra/httpd-vhosts.conf前面的#!! 2.打开Apache的apache/conf/extr ...

  3. wamp 虚拟目录的设置(转载)

    现在先来配置虚拟主机:1.先打开apache的配置文件httpd.conf,并去掉#Include conf/extra/httpd-vhosts.conf前面的#!!2.打开apache的apach ...

  4. Tomcat 映射虚拟目录和程序热部署

    虚拟目录的设置 方法一:在${tomcat安装目录}/conf/Catalina/localhost目录下创建一个xml文件,任意文件名都可以,但是此文件名是web应用发布后的虚拟目录: 比如创建一个 ...

  5. iis虚拟目录实现分布式文件服务器

    前提:假定有2台服务器:服务器a和服务器b,则服务器a和b须在同一局域网内 服务器设定:a为web服务器,b为文件服务器.这里服务器环境是:Windows Server 2008 R2 大致步骤如下: ...

  6. Tomcat:配置虚拟目录或主目录

    为了在访问web服务的时候,不需要输入项目名,直接"/"就可以访问的话,需要设置虚拟目录或在ROOT下直接放项目 1.采用虚拟目录的方式 在Host中添加  <Context ...

  7. Tomcat创建虚拟目录和程序热部署

    虚拟目录的设置 方法一:在${tomcat安装目录}/conf/Catalina/localhost目录下添加与web应用同名的xml配置文件,这里站点名称为test为例子. test.xml内容:& ...

  8. apache 配置虚拟目录

    #注释掉apache默认的网站目录地址 #DocumentRoot "c:/Rrogram Files/Apache/htdocs" #配置一个虚拟目录 <ifModule ...

  9. IIS7添加虚拟目录映射另一台服务器的共享文件夹

    现状: 一台Windows Server2008 Web服务器 A,一台Windows Server2003 文件服务器 B,需要在A中IIS添加对B的Web访问 方法: 1.A中添加和B相同的账号, ...

随机推荐

  1. iBatis之Iterator的使用

    一:前言 现在这个项目使用的是iBatis,我刚刚开始的时候说是用MyBatis,因为我以前用过,觉得还是比较好用的啊,而且不像iBatis样,查什么一个字段不能多也不能少,觉得好无语啊. 二:内容 ...

  2. 动态规划:LCS

    先上状态转移方程,还是很容易看明白的 例题是Codevs的1862,这个题不是实现了方程就可以了的,还要完成一个事情那就是计数,数一数到底有多少个最长公共子序列 #include<cstdio& ...

  3. Liberty中应用的contextroot

    参考:http://www-01.ibm.com/support/knowledgecenter/api/content/SSEQTP_8.5.5/com.ibm.websphere.wlp.doc/ ...

  4. 【git】git提交忽略不必要的文件或文件夹

    对于经常使用Git的朋友来说,.gitignore配置一定不会陌生.废话不说多了,接下来就来说说这个.gitignore的使用. 首先要强调一点,这个文件的完整文件名就是".gitignor ...

  5. Cpython解释器支持的线程

    因为Python解释器帮你自动定期进行内存回收,你可以理解为python解释器里有一个独立的线程,每过一段时间它起wake up做一次全局轮询看看哪些内存数据是可以被清空的,此时你自己的程序 里的线程 ...

  6. servlet+forward和direct区别

    Servlet:是用于 java 编写的服务器端程序,其使用 java servlet API,当客户机发送请求到服务器时,服务器可以将请求信息发送给 servlet,并让 servlet 建立起服务 ...

  7. nginx1.11.9 apt即源码编译各平台测试

    测试系统:ubuntu16.04 server,debian8.7 netinstall,centos7 mini. 系统配置:使用virtualbox安装,内存1G,cpu单核,物理CPU  i5- ...

  8. [ Openstack ] Openstack-Mitaka 高可用之 memcache

    目录 Openstack-Mitaka 高可用之 概述    Openstack-Mitaka 高可用之 环境初始化    Openstack-Mitaka 高可用之 Mariadb-Galera集群 ...

  9. hdu 1507(二分图匹配)

    Uncle Tom's Inherited Land* Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (J ...

  10. 使用Pygame制作微信打飞机游戏PC版

    前一阵子看了一篇文章:青少年如何使用Python开始游戏开发 .看完照葫芦画瓢写了一个,觉得挺好玩儿,相当于简单学了下Pygame库.这篇文章是个12岁小孩儿写的,国外小孩儿真心NB,想我12岁的时候 ...