Centos 7.5安装 Mysql5.7.24
1. 下载 MySQL
本文采用的Linux为是腾讯云 标准型S2 (1 核 1 GB) Centos 7.5 64位
1.1 官网下载地址:
1.2 选择64位的

1.3 说明
该文档仅供参考,更多详细文档请查看官方文档
https://dev.mysql.com/doc/refman/5.7/en/binary-installation.html
2. 上传文件并解压到安装目录
2.1 使用xftp上传到指定目录 我的目录为
/app/tool
2.2 解压
tar zxf mysql-5.7.24-linux-glibc2.12-x86_64.tar.gz
2.3 重命名
mv mysql-5.7.24-linux-glibc2.12-x86_64 mysql
2.4 复制到指定目录
cp -r mysql /usr/local/
2.5 解压目录结构

3. 添加用户组,用专门管理mysql,提高安全
3.1 新建组
groupadd mysql
3.2 新建用户
useradd -r -g mysql mysql
4. 修改mysql目录权限
4.1 进入mysql根目录
cd /usr/local/mysql/
4.2 修改拥有者为mysql用户
chown -R mysql:mysql ./
5. 配置mysql服务
5.1 将mysql/support-files下的mysql.server 复制到 /etc/init.d/下并自定义为mysql
cp /usr/local/mysql/support-files/mysql.server /etc/init.d/mysql
5.2 修改该服务
vi /etc/init.d/mysql
5.3 修改的内容
basedir=/usr/local/mysql
datadir=/usr/local/mysql/data
6. 配置mysql的配置文件
在其他版本的mysql 里面 support-files下有默认的配置文件,而5.7.24这个版本没有,需要自己准备,下面提供一份简单基本配置
在/etc/ 下新建my.cnf ,有些可能会提示已经存在,因为默认装的数据库配置文件也在,直接覆盖就行
6.1 进入etc目录
cd /etc
6.2 删除my.cnf
rm -rf my.cnf
6.3 新建my.cnf
vi my.cnf
6.4 编辑的内容
# *** DO NOT EDIT THIS FILE. It's a template which will be copied to the
# *** default location during install, and will be replaced if you
# *** upgrade to a newer version of MySQL.
[client]
port = 3306
default-character-set=utf8
[mysqld]
# 一般配置选项
basedir = /usr/local/mysql
datadir = /usr/local/mysql/data
port = 3306
character-set-server=utf8
default_storage_engine = InnoDB
sql_mode=STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
7. 初始化数据库
7.1 进入mysql/bin目录下
cd /usr/local/mysql/bin/
7.2 执行初始化
./mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
7.3 遇到错误
./mysqld: error while loading shared libraries: libnuma.so.1: cannot open shared object file: No such file or directory
7.4 执行以下命令
yum -y install numactl.x86_64
7.5 再执行初始化
./mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
7.6 遇到错误
./mysqld: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
7.7 执行以下命令
yum -y install libaio
7.8 再执行初始化
./mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
7.9 执行完毕后会自动生成默认的密码在执行记录中,注意复制出来

8. 启动mysql服务
8.1 执行启动命令
service mysql start
8.2启动成功会提示 ok
9. 登录及远程配置
9.1 登录
进入mysql/bin目录下执行
./mysql -uroot -p
9.2 输入密码
Enter password:输入默认的临时密码
9.3 修改密码
set password=password('新密码');
9.4 设置远程访问
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY '访问密码';
flush privileges;
9.5 开放端口
9.5.1 开启端口
firewall-cmd --zone=public --add-port=3306/tcp --permanent
9.5.2 重载防火墙
firewall-cmd --reload
10. 设置开机启动和环境变量(可以忽略)
10.1 开机启动
10.1.1 查看自启服务列表
chkconfig --list
10.1.2 添加mysql服务到自启服务
chkconfig --add mysql
10.1.3 设置自启
chkconfig mysql on
10.2 环境变量
10.2.1 为了不用在mysql/bin目录下才能连接mysql 将mysql/bin目录设置到环境变量中
vi /etc/profile
10.2.2 修改的内容
# mysql environment
export MYSQL_HOME=/usr/local/mysql
export PATH=$PATH:$MYSQL_HOME/bin
10.2.3 更新环境变量
source /etc/profile
11. The end
Centos 7.5安装 Mysql5.7.24的更多相关文章
- [转]阿里云CentOS 7.1使用yum安装MySql5.6.24
阿里云CentOS 7.1使用yum安装MySql5.6.24 作者:vfhky | 时间:2015-06-25 09:43 | 分类:web 在前面两篇文章<2015博客升级记(四):Cent ...
- Windows Server 2012安装mysql5.7.24记录
系统环境: 一.下载mysql5.7.24安装包 地址:https://dev.mysql.com/downloads/mysql/5.7.html#downloads 下载解压到相应的目录,我的路径 ...
- Centos 6.4 安装mysql-5.6.14-linux-glibc2.5-i686.tar.gz
创建用户和组 创建链接 授权own和grp给mysql-5.5.8-linux2.6-i686文件夹,就是下面的BASE_DIR 执行的mysql_install_db的时候后面带参数 ./scrip ...
- Centos 7.6 安装Mysql5.7(离线)
Centos 7.6 安装Mysql5.7(离线) 标签(空格分隔): mysql 安装包下载 https://dev.mysql.com/downloads/mysql/ [image.png-14 ...
- 转:在CentOS 7.3使用yum安装 MySql5.6.24
按照CentOS 6.5的方法在CentOS 7上安装会失败,需要按照下文进行安装. 1.安装rpm包 Linux系统自带的repo是不会自动更新每个软件的最新版本(基本都是比较靠后的稳定版),所以无 ...
- Linux下安装mysql-5.7.24
Mysql数据库的安装对于开发者来说,是我们必然会面对的问题,它的安装过程其实并不复杂,并且网络上的安装教程也非常多,但是对于新手来说,各种不同形式的安装教程,又给新手们带来了要选择哪种方式进行安装的 ...
- centos下编译安装mysql5.5/5.6
2013年11月16日 19:39:13 centos 6 mysql 5.5.28 我只说些我出错的地方: cmake后删除的方法是 xargs rm < install_manifest.t ...
- CentOS7编译安装MySQL5.7.24
目录 安装依赖 安装boost 编译安装MySQL 配置 登录MySQL,修改密码 安装依赖 (1)cmake是新版MySQL的编译工具 sudo yum install gcc gcc-c++ pc ...
- centos下编译安装mysql5.5/5.6/5.7
2018-12-28 14:38:46 星期五 centos 系统在mysql官网, 按照教程去配置yum源, 然后安装, 不用自己找依赖了: https://dev.mysql.com/doc/my ...
随机推荐
- Implement strStr() 字符串匹配
Implement strStr(). Returns the index of the first occurrence of needle in haystack, or -1 if needle ...
- SGU 103 Traffic Lights【最短路】
题目链接: http://acm.hust.edu.cn/vjudge/problem/visitOriginUrl.action?id=16530 题意: 给定每个点最初的颜色,最初颜色持续时间,以 ...
- 选择阿里云数据库HBase版十大理由
根据Gartner的预计,全球非关系型数据库(NoSQL)在2020~2022预计保持在30%左右高速增长,远高于数据库整体市场. 阿里云数据库HBase版也是踏着技术发展的节奏,伴随着NoSQL和大 ...
- How To Move Or Rebuild A Lob Partition
How To Move Or Rebuild A Lob Partition [ID 761388.1] 改动时间 29-JUN-2010 类型 HOWTO 状 ...
- LOJ6079「2017 山东一轮集训 Day7」养猫
养ImmortalCO k可重区间问题 的增强版:有上下界! 直接都选择s[i],然后再把一些调整到e[i] 考虑通过最大流的“最大”,使得至少每k个有me个e, 通过最大流的“上界”,限制每k个最多 ...
- 【BZOJ1227】[SDOI2009]虔诚的墓主人
E. 虔诚的墓主人 题目描述 小W 是一片新造公墓的管理人.公墓可以看成一块N×M 的矩形,矩形的每个格点,要么种着一棵常青树,要么是一块还没有归属的墓地.当地的居民都是非常虔诚的基督徒,他们愿意提前 ...
- [luogu P2617] Dynamic Rankings 带修主席树
带修改的主席树,其实这种,已经不能算作主席树了,因为这个没有维护可持久化的... 主席树直接带修改的话,由于这种数据结构是可持久化的,那么要相应改动,这个节点以后所有的主席树,这样单次修改,就达到n* ...
- 严重: Servlet.service() for servlet [jsp] threw exception java.lang.NullPointerException
五月 04, 2018 11:53:24 上午 org.apache.catalina.core.ApplicationDispatcher invoke 严重: Servlet.service() ...
- 命名实体识别视频51cto
https://edu.51cto.com/center/course/lesson/index?id=402918 https://edu.51cto.com/course/18466.html
- Python--day29--logging模块(日志模块)
重要程度六颗星,比如一个小窗口的广告如果因为你没有日志的问题导致点击量没有记录下来,几十分钟那就会损失几十万了,这责任谁负得起. 希望离开一个公司是因为有了更好的去处而不是因为各种各样的原因被开掉,那 ...