【声名】本实例中采用Linux CentOS 7系统

                                 CentOS Linux release 7.6.1810 (Core)

1.安装LAMP环境:

[root@localhost /]# yum install -y httpd mariadb-server mariadb php php-mysql php-gd libjpeg* php-ldap php-odbc php-pear php-xml php-xmlrpc php-mhash

查看软件版本:

[root@localhost /]# rpm -qa httpd php mariadb

2.重启数据库和http并添加到开启启动项:

[root@localhost /]# systemctl restart mariadb.service
[root@localhost /]# systemctl enable mariadb.service
Created symlink from /etc/systemd/system/multi-user.target.wants/mariadb.service to /usr/lib/systemd/system/mariadb.service.
[root@localhost /]# systemctl restart httpd
[root@localhost /]# systemctl enable httpd
Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /usr/lib/systemd/system/httpd.service.

3.出现报错信息:参考https://www.cnblogs.com/python-wen/p/12360070.html

按照网上的方法:yum  clean  all    yum  makecache    yum  update  -y     三部曲之后,仍然无法解决这样的报错。

【解决方法】

将系统ISO光盘挂载一下!

创建一个挂载目录:

[root@localhost yum.repos.d]# mkdir /media/cdrom

挂载操作:

[root@localhost yum.repos.d]# mount /dev/cdrom /media/cdrom/
mount: /dev/sr0 写保护,将以只读方式挂载

[root@localhost yum.repos.d]# echo "/dev/cdrom /media/cdrom iso9660 defaults 0 0" >> /etc/fstab

4.安装zabbix:这里选择zabbix4.2版本(https://www.zabbix.com/cn/download?)

  (1)注意这里使用官方的源会报错:所以使用国内的阿里云zabbix镜像源:https://mirrors.aliyun.com/zabbix/zabbix

[root@zabbix-controller ~]#  rpm -Uvh https://mirrors.aliyun.com/zabbix/zabbix/4.2/rhel/7/x86_64/zabbix-release-4.2-1.el7.noarch.rpm

  (2)[root@zabbix-controller ~]# yum clean all

3.安装zabbix server,web前端和agent:

  此处极易出现上面提到的报错信息,所以要多试几次,多试几种方法去解决问题。

[root@zabbix-controller ~]# yum -y install zabbix-server-mysql zabbix-web-mysql zabbix-agent

4.进入数据库,创建zabbix数据库:

  进入数据库后,因为是第一次启动(默认空密码),所以直接回车后就进入数据库了。

MariaDB [(none)]> create database zabbix character set utf8 collate utf8_bin;   #设置好字符集
Query OK, 1 row affected (0.07 sec)

MariaDB [(none)]> grant all privileges on zabbix.* to zabbix@localhost identified by 'password';   #注意这个password密码是zabbix数据库的密码
Query OK, 0 rows affected (0.12 sec)

MariaDB [(none)]> quit

5.导入初始架构和数据,系统将提示您输入新创建的密码(刚刚设置的密码password):

[root@localhost ~]# zcat /usr/share/doc/zabbix-server-mysql*/create.sql.gz | mysql -uzabbix -p zabbix
Enter password: password

6.修改zabbix服务器端配置文件 /etc/zabbix/zabbix_server.conf

  找到这一行,将DBPassword取消注释,在“=”号后面输入你创建的zabbix密码,我这里是zabbix。

7.重启zabbix和http:

  [root@localhost ~]# systemctl restart zabbix-server zabbix-agent httpd

8.进入zabbix的web界面,在浏览器内输入:http://server_ip/zabbix

  (1)这里我的server_ip为192.168.10.2,所以在浏览器地址栏输入:http://192.168.10.2/zabbix。进入这个界面后点击“next step”

  (2)按照流程往下走,发现有一项参数未通过,经检查,发现是因为 时区没有设置:

  (3)修改/etc/php.ini文件,找到错误的项 date.timezone,取消注释,增加时区,然后保存,重启服务,刷新浏览器页面(注意要重启服务!):

  

  修改/etc/httpd/conf.d/zabbix.conf文件:

  (4)重启zabbix和http服务,刷新浏览器页面后,发现全部参数已经变为ok:[root@localhost ~]# systemctl restart zabbix-server zabbix-agent httpd

  

  (5)这里的password输入password,即是刚刚在数据库里面创建zabbix数据库的密码,然后一直下一步即可完成设置。

  (6)看到此界面,说明zabbix已经成功安装:默认用户名是Admin  密码是zabbix

zabbix4.2安装配置指南的更多相关文章

  1. [转载]SharePoint 2013测试环境安装配置指南

    软件版本 Windows Server 2012 标准版 SQL Server 2012 标准版 SharePoint Server 2013 企业版 Office Web Apps 2013 备注: ...

  2. 【转】服务器证书安装配置指南(Weblogic)

    服务器证书安装配置指南(Weblogic) 详情请点击: http://verisign.itrus.com.cn/html/fuwuyuzhichi/fuwuqizhengshuanzhuangpe ...

  3. 大数据应用日志采集之Scribe 安装配置指南

    大数据应用日志采集之Scribe 安装配置指南 大数据应用日志采集之Scribe 安装配置指南 1.概述 Scribe是Facebook开源的日志收集系统,在Facebook内部已经得到大量的应用.它 ...

  4. 【转】Syncthing – 数据同步利器---自己的网盘,详细安装配置指南,内网使用,发现服务器配置

    Syncthing – 数据同步利器---自己的网盘,详细安装配置指南,内网使用,发现服务器配置 原贴:https://www.cnblogs.com/jackadam/p/8568833.html ...

  5. 高可用,完全分布式Hadoop集群HDFS和MapReduce安装配置指南

    原文:http://my.oschina.net/wstone/blog/365010#OSC_h3_13 (WJW)高可用,完全分布式Hadoop集群HDFS和MapReduce安装配置指南 [X] ...

  6. Gitolite v3安装配置指南

    使用gitolite对git仓储进行权限配置 gitolite在近期做了很多代码改动,升级到了v3版本,而我使用的是v3.5.2.在<Git权威指南>中所提及的是v2版本,有很多东西已经不 ...

  7. 【云计算】ubuntu下docker安装配置指南

    Docker Engine安装配置 以下描述仅Docker在Ubuntu Precise 12.04 (LTS).Ubuntu Trusty 14.04 (LTS).Ubuntu Wily 15.10 ...

  8. linux下安装Apache(https) 服务器证书安装配置指南

    一.  安装准备 1.    安装Openssl 要使Apache支持SSL,需要首先安装Openssl支持.推荐下载安装openssl-0.9.8k.tar.gz   下载Openssl:http: ...

  9. HADOOP2.2.0安装配置指南

    一.     集群环境搭建 这里我们搭建一个由三台机器组成的集群: Ip地址 用户名/密码 主机名 集群中角色 操作系统版本 192.168.0.1 hadoop/hadoop Hadoop-mast ...

随机推荐

  1. Milestone

    为什么开博客?     事情要从一只蝙蝠说起...       准备用博客做什么?     记录自己在开发中遇到的issue以及解决的思路:记录一些读书笔记以便温故:练习如何制造仪式感,ect.   ...

  2. HTML/JavaScript实现地图以鼠标为圆心缩放和移动

    代码如下 <!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF- ...

  3. CSS 实现一个自适应的正方形

      传统方法正方形用固定的形式写 直接长=宽写固定的值如下   .box{   width: 200px;   height: 200px;   background: pink;   color: ...

  4. scala-匹配序列和元组

    scala的模式匹配极其强大,其中有一种用法是用case语句匹配序列和元组. 放码过来: def parse(x: Any): String = x match { case List(0, _, _ ...

  5. 一些java基础知识的备忘

    接口和抽象类的区别是什么? 接口的方法默认是 public,所有方法在接口中不能有实现(Java 8 开始接口方法可以有默认实现),而抽象类可以有非抽象的方法. 接口中除了static.final变量 ...

  6. 《深入理解java虚拟机》读书笔记一——第二章

    第二章 Java内存区域与内存溢出异常 1.运行时数据区域 程序计数器: 当前线程所执行的字节码的行号指示器,用于存放下一条需要运行的指令. 运行速度最快位于处理器内部. 线程私有. 虚拟机栈: 描述 ...

  7. anki

    anki需要一个舞台来容纳所有的不同领域的经历 虽然难以避免臃肿的局面.

  8. SpringBoot学习- 7、问题Could not autowire. No beans of 'xxxx' type found处理

    SpringBoot学习足迹 这个问题网上有好多同学都提到这个问题,代码可以运行,但是就是有红线,强迫症不能忍 自己试验下 1.增加一个final编译一下,再删掉就不会出红线了 public clas ...

  9. 解决sql server2008数据库安装之后,web程序80端口被占用问题(终极方案)

    解决sql server2008数据库安装之后,web程序80端口被占用问题(终极方案) 前言:原来电脑上的Apache一直使用正常,在安装sql server2008后,突然发现Apache无法启动 ...

  10. Importing data in R 1

    目录 Importing data in R 学习笔记1 flat files:CSV txt文件 packages:readr read_csv() read_tsv read_delim() da ...