最近用xampp搭建了开源商城项目iwebshop,刚搭建完没问题,可是周一来因为服务器重启了,我再启动xampp,显示组件都启动ok了,但是用linux命令查看相关组件的进程时,发现实际没启动起来,在网上找了好久解决办法,按照下列步骤终于解决了。(因为xampp已经安装,所以忽略1-3条)

以下内容来源:http://www.cnblogs.com/stay-sober/p/4159614.html

安装xampp

1./opt目录下放xampp-Linux-1.8.3-3-installer.run、bugfree.zip

2.[root@centos1 opt]# chmod 775 xampp-linux-1.8.3-3-installer.run #赋权 
3.[root@centos1 opt]# sudo ./xampp-linux-1.8.3-3-installer.run #安装xampp

4.启动xampp

[root@centos1 /]# sudo ./opt/lampp/lampp start 
Starting XAMPP for Linux 1.8.3-3... 
XAMPP: Starting Apache...already running. 
XAMPP: Starting MySQL...ok. 
XAMPP: Starting ProFTPD...ok. 
[root@centos1 /]#

配置mysql服务

[root@centos1 ~]# find / -name mysql.server 
/opt/lampp/share/mysql/mysql.server 
/opt/lampp/bin/mysql.server   ##mysql启动文件

[root@centos1 ~]# ln -s /opt/lampp/bin/mysql.server /etc/rc.d/init.d/mysql   ##软连接(理解为快捷键) 
[root@centos1 ~]# vi /etc/rc.d/init.d/mysql   ##大概看了一眼

[root@centos1 ~]# chkconfig --add mysql   ##增加mysql的系统服务 
[root@centos1 ~]# chkconfig --list mysql    ##列出mysql服务的设置情况 
mysql              0:关闭    1:关闭    2:启用    3:启用    4:启用    5:启用    6:关闭

[root@centos1 ~]# service mysql restart 
Shutting down MySQL.. SUCCESS! 
Starting MySQL.. SUCCESS!

[root@centos1 ~]# service mysql status 
SUCCESS! MySQL running (3237)

[root@centos1 init.d]# ps -aux|grep mysql 
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ 
root      3318  0.0  0.2   3044  1340 pts/0    S    12:17   0:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/centos1.pid 
mysql     3679  0.0 19.0 330620 97344 pts/0    Sl   12:17   0:01 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --plugin-dir=/opt/lampp/lib/mysql/plugin/ --user=mysql --log-error=/opt/lampp/var/mysql/centos1.err --pid-file=/opt/lampp/var/mysql/centos1.pid --socket=/opt/lampp/var/mysql/mysql.sock --port=3306 
root      4217  0.0  0.1   5980   756 pts/0    S+   12:41   0:00 grep mysql


如果使用过程中提示

[root@centos1 var]# mysql -uroot -p
-bash: mysql: command not found

解决:[root@centos1 bin]# ln -s /opt/lampp/bin/mysql /usr/bin

就可以了

配置apache服务   

[root@centos1 ~]# find / -name apachectl 
/opt/lampp/bin/apachectl

[root@centos1 ~]# ln -s /opt/lampp/bin/apachectl /etc/rc.d/init.d/apache

[root@centos1 ~]# vi /etc/rc.d/init.d/apache ##加入#chkconfig:2345 85 15

#说明:2345表示在2345这四种启动级别里面加载这个服务,85表示启动(开机时)顺序号,15表示关闭(关机时)顺序号.

[root@centos1 init.d]# chkconfig --add apache 
[root@centos1 init.d]# chkconfig --list apache 
apache             0:关闭    1:关闭    2:启用    3:启用    4:启用    5:启用    6:关闭

[root@centos1 ~]# service apache status 
/etc/init.d/apache: line 96: lynx: command not found

[root@centos1 ~]# yum install lynx

[root@centos1 ~]# service apache restart 
httpd not running, trying to start

[root@centos1 init.d]# ps -aux|grep httpd 
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ 
root      4203  1.0  3.5  58252 18016 ?        Ss   12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4204  0.0  2.7  55552 13932 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4205  0.0  3.0  58252 15720 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4206  0.2  3.0  58252 15720 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4207  0.0  3.0  58252 15720 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4208  0.0  3.0  58252 15720 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
daemon    4209  0.2  3.0  58252 15720 ?        S    12:35   0:00 /opt/lampp/bin/httpd -k restart 
root      4211  0.0  0.1   5980   752 pts/0    S+   12:35   0:00 grep httpd 
[root@centos1 init.d]#



[root@centos1 init.d]# ll 
总用量 148 
lrwxrwxrwx  1 root root    24 12月 12 11:29 apache -> /opt/lampp/bin/apachectl 
-rwxr-xr-x. 1 root root  3378 6月  22 2012 auditd 
-r-xr-xr-x. 1 root root  1340 2月  22 2013 blk-availability 
-rwxr-xr-x. 1 root root  2793 7月  19 2011 crond 
-rw-r--r--. 1 root root 18216 1月   9 2013 functions 
-rwxr-xr-x. 1 root root  5829 1月   9 2013 halt 
-rwxr-xr-x  1 root root  2001 10月 16 22:46 htcacheclean 
-rwxr-xr-x  1 root root  3371 10月 16 22:46 httpd 
-rwxr-xr-x. 1 root root  9515 2月  22 2013 ip6tables 
-rwxr-xr-x. 1 root root  9409 2月  22 2013 iptables 
-rwxr-xr-x. 1 root root   652 1月   9 2013 killall 
-r-xr-xr-x. 1 root root  2134 2月  22 2013 lvm2-lvmetad 
-r-xr-xr-x. 1 root root  2665 2月  22 2013 lvm2-monitor 
-rwxr-xr-x. 1 root root  2200 9月  14 2012 messagebus 
lrwxrwxrwx  1 root root    27 12月 12 11:43 mysql -> /opt/lampp/bin/mysql.server

[root@centos1 tmp]# ps -aux|grep httpd 
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ 
root      5320  0.1  4.2  62536 21544 ?        Ss   07:46   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5353  0.0  2.9  61080 15316 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5354  0.0  3.3  62536 16916 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5355  0.0  3.3  62536 16928 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5356  0.0  3.3  62536 16916 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5357  0.0  3.3  62536 16916 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
daemon    5358  0.0  3.3  62536 16916 ?        S    07:48   0:00 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log -DSSL -DPHP 
root      5362  0.0  0.1   5976   740 pts/0    S+   07:49   0:00 grep httpd

[root@centos1 init.d]# find / -name apachectl 
/usr/sbin/apachectl 
/opt/lampp/bin/apachectl 
[root@centos1 init.d]# /opt/lampp/bin/apachectl -k start 
httpd (pid 5468) already running 
[root@centos1 init.d]# /opt/lampp/bin/apachectl -k stop 
[root@centos1 init.d]# /opt/lampp/bin/apachectl -k start          
        
[root@centos1 init.d]# service apache start 
[root@centos1 init.d]# netstat -anp|grep :80 
tcp        0      0 :::80                       :::*                        LISTEN      5959/httpd

xampp搭建开源项目iwebshop后,服务器重启后再启动xampp显示组件都启动ok,但是实际启动失败解决办法的更多相关文章

  1. PHPWAMP自启异常,服务器重启后Apache等服务不会自动重启的原因分析

    在使用“PHPWAMP自动任务”时,不少学生遇到如下问题: “phpwamp绿色集成环境重启动电脑(服务器)后,不会自动启动网站服务” (如果是其他环境或是自己搭建时遇到此问题,也是可以用此法解决) ...

  2. Linux服务器重启后eureka报错

    在Linux服务器重启后,首次启动应用时查看eureka注册中心,报错 EMERGENCY! EUREKA MAY BE INCORRECTLY CLAIMING INSTANCES ARE UP W ...

  3. 服务器重启后如何开启由docker部署的redmine

    1. 服务器重启后,需要重新开启docker服务 systemctl start docker 2. 查看全部container,包括exited的容器,找出redmine所对应的NAMES标签名称 ...

  4. 服务器断电后 redis重启后启动不起来

    服务器断电后 redis 重启后启动不起来 原因:db持久化失败 1. 先查询redis的进程 ps -ef|grep redis 2. 查询redis的缓存文件在哪 whereis dump.rdb ...

  5. Linux服务器重启后启动Oracle服务

    目录 1. 启动Oracle服务 2. 启动Oracle监听服务 © 版权声明:本文为博主原创文章,转载请注明出处 1. 启动Oracle服务 重启Linux服务器后,Oracle服务还需要手动启动. ...

  6. rsyslog 服务器重启后 发现不能接受到外部日志 只能接受本地日志 关闭防火墙即可

    rsyslog 服务器重启后 发现不能接受到外部日志 只能接受本地日志  关闭防火墙即可 1 关闭防火墙: # systemctl stop firewalld 2 将SELINUX设置为disabl ...

  7. .NET平台开源项目速览(5)深入使用与扩展SharpConfig组件

    上个月在文章:这些.NET开源项目你知道吗?让.NET开源来得更加猛烈些吧  和 .NET平台开源项目速览(1)SharpConfig配置文件读写组件 中都提到了SharpConfig组件,简单轻量级 ...

  8. .NET平台开源项目速览(2)Compare .NET Objects对象比较组件

    .NET平台开源项目速览今天介绍一款小巧强大的对象比较组件.可以更详细的获取2个对象的差别,并记录具体差别,比较过程和要求可以灵活配置. .NET开源目录:[目录]本博客其他.NET开源项目文章目录 ...

  9. 服务器重启后SQL Server Agent由于"The EventLog service has not been started" 启动失败

    案例环境: 操作系统   : Microsoft Windows Server 2003 Standard Edtion SP2 数据库版本 : SQL Server 2005 Standard Ed ...

随机推荐

  1. java并发编程JUC第十篇:CyclicBarrier线程同步

    在之前的文章中已经为大家介绍了java并发编程的工具:BlockingQueue接口.ArrayBlockingQueue.DelayQueue.LinkedBlockingQueue.Priorit ...

  2. 17 DOS攻击防范

    #!/bin/bash source /etc/profile HOST_IP="172.16.1.122" DROP_IP_FILE="/tmp/drop_ip.log ...

  3. 28、python3.7(windows)将ORACLE11gR2中的数据取出写入excel表

    28.1.下载python的离线扩展模块: 1.windows下python的离线扩展模块下载地址为: https://www.lfd.uci.edu/~gohlke/pythonlibs/ 提示: ...

  4. 22.17、heartbeat和drbd整合

    1.要确保master-db和slave-db的drbd服务和heartbeat服务都已经停止了: 2.heartbeate设置: 修改master-db和slave-db的'/etc/ha.d/ha ...

  5. 5、SpringBoot整合之SpringBoot整合MybatisPlus

    SpringBoot整合MybatisPlus 目录(可点击直接跳转,但还是建议按照顺序观看,四部分具有一定的关联性): 实现基础的增删改查 实现自动填充功能 实现逻辑删除 实现分页 首先给出四部分完 ...

  6. 个人使用uploadify插件遇到的一些问题

    当uploadify上传插件遇到的好几个问题 现在开始自我反省,留下脚印希望能够帮助其他遇到同样问题的朋友. 我遇到的第一个是, 在firefox不能执行uploadify事件onUploadSucc ...

  7. POJ 3304 Segments 叉积

    题意: 找出一条直线,让给出的n条线段在这条直线的投影至少有一个重合的点 转化一下,以重合的点作垂线,那么这条直线一定经过那n条线段.现在就是求找到一条直线,让这条直线经过所有线段 分析: 假设存在这 ...

  8. CRM系统对管理客户的帮助

    我们可以把客户关系看做是一种长期的投资,在资源有限的基础上,把人力财力物力放到那些能够持续创造价值的客户身上,从而为企业带来源源不断的收益.通过进行客户关系管理,能够让企业与客户之间建立沟通的渠道,形 ...

  9. 基于Linux的校园网破解思路和方法

    #思路: ##1. 当校园网断开,只需要重新拨号即可 ##2. 校园网使用两台电脑同时登录时不会立即下线,其中有一段时间间隔 #步骤: ##1. 通过抓包对拨号产生的数据包进行分析,使得可以通过代码来 ...

  10. 案例分享:Qt西门子机床人机界面以及数据看板定制(西门子通讯,mysql数据库,生产信息,参数信息,信息化看板,权限控制,播放器,二维图表,参数调试界面)

    若该文为原创文章,转载请注明原文出处本文章博客地址:https://blog.csdn.net/qq21497936/article/details/118685521 长期持续带来更多项目与技术分享 ...