Mysql5.7登录错误1045和1130的解决方法,亲测有用,希望能帮助到你们。
Mysql
(针对Mysql5.7版本,其他版本可能略有不同)
错误:1045
解决方法:
以管理员身份运行cmd(win8系统:win+x 键 ,再按 A键 ),进入Mysql安装目录下的bin目录下(如下图所示,根据自己的情况修改目录)
@:下面还要再打开cmd窗口,为方便区别,此窗口记为‘’ cmd-A ‘’窗口运行
net stop mysql,停止Mysql服务运行
mysqld -nt --skip-grant-tables,使得在登录时可以跳过登录密码以上三步正常运行后该cmd窗口应该处于静止不动,光标闪烁的状态
打开另一个管理员的cmd窗口 @:此窗口记为‘’ cmd-B‘’窗口
运行
mysql -uroot -p回车,出现Enter password:直接回车,成功进入了mysql可以运行以下命令来修改密码:
use mysql使用mysql数据库update user set authentication_string=password('mysqladmin') where user='root';更新root的密码为mysqladmin,显示Query OK则修改成功。
解释:更新 user表 使 authenticatio_string(密码)字段 = mysqladmin(password('') 是以密码保护的形式存储,在数据库看不见密码原文) 修改的是,user(字段)=root(值)的哪一行。- 以上两步就可以修改密码成功。若你的mysql不是用authentication_string字段来存储密码。可以用以下方法来找到存储密码的字段。
show tables;查看当前数据库下的所有表desc user查看user表的结构,在这一步你可以查看user表的字段,密码字段就在这里,不是mysql5.7版本的可以在“desc user”的结果下,自己判断哪个是密码字段select host,user,authentication_string from user;查看三列关于user表的信息,若你的密码字段不是authentication_string,可自行替换成你表中的密码字段名。update user set authentication_string='mysqladmin' where user='root';不推荐,这种方式就是将密码明文不经过加密直接显示在数据库中。
经过以上6步后,已经成功的修改了数据库登录密码。接下来是再次尝试登录。
关闭‘’cmd-A‘’窗口 (输入了skip-grant-tables的cmd)
关闭任务管理器中的进程
mysql.exe(任务管理器->详细信息->进程->找到mysql.exe(大约占150M内存)->关闭)在‘’cmd-B‘’窗口中输入
net start mysql输入
mysql -uroot -p,敲入新的用户名、密码 即可登录成功
若还是不能登录,或出现错误1130。则是权限问题 (或 host问题),以下为权限为题的解决方法:
错误:1130
解决方法:
按以上方法跳过验证进入数据库
在
mysql>中执行flush privileges刷新权限(不执行这步.会出现在skip-grant-tables模式下不能授权的问题)执行
grant all privileges on *.* to root@'localhost' identified by "mysqladmin";为root用户授权关闭
cmd和mysql.exe进程,启动mysql服务net start mysql,重新登录mysql -uroot -p即可成功
若还是不能解决,或有其他问题。可以评论留言,我会尽快回复。
Mysql5.7登录错误1045和1130的解决方法,亲测有用,希望能帮助到你们。的更多相关文章
- SQL Server 2008登录错误:无法连接到(local)解决方法
在一些朋友安装完SQL Server 2008之后大多会遇到连接出错的问题比如:SQL Server 2008登录错误:无法连接到(local)等等相关问题,本文将详细介绍解决方法,需要的朋友可以参考 ...
- Linux下切换root用户提示Authentication failure错误的解决方法(亲测有效)
第一种情况可能是root密码输入错误造成的,再仔细检查一遍是否输入错误 第二种是刚安装完,没有设置root用户密码导致的,我的就是最小化安装,就会出现这种小问题 解决办法:sudo passwd 然后 ...
- mysql 1053错误,无法启动的解决方法
mysql 1053错误,无法启动的解决方法 windows2003服务器中,服务器重启后Mysql却没有启动,手动启动服务时提示1053错误. 尝试了以下方法,终于解决. 1.在DOS命令行使用 第 ...
- Linux下登录Oracle命令行时删除键^H解决方法
Linux下登录Oracle命令行时删除键^H解决方法 在linux服务器下登录oracle的控制台,如果输入错误,想用删除键删除时却不能删除,输出的是^H的字符. 方法 用如下的命令可以使删除键生效 ...
- http://localhost/certsrv 错误找不到页面解决方法
http://localhost/certsrv 错误找不到页面解决方法 最近公司需要后台启动安全证书,可安装了“Active Directory证书服务” 后,http://localhost/ce ...
- MySQL主从失败 错误Got fatal error 1236解决方法
--MySQL主从失败 错误Got fatal error 1236解决方法 ----------------------------------------------------2014/05/1 ...
- vmware 传输(vmdb)错误-32:pipe:read failed 解决方法
摘自: http://www.myzhenai.com.cn/post/1088.html 传输(vmdb)错误-32:pipe:read failed 解决方法 原创内容,转载请注明出处:htt ...
- CentOS忘记密码修改方案以及centos卡在开机登录界面,命令失效的解决方法
CentOS忘记密码修改方案 应用场景 linux管理员忘记root密码,需要进行找回操作. 注意事项:本文基于CentOS7.2环境进行操作的,由于CentOS的版本之间是有差异的,继续之前请先确定 ...
- 【转】通过Navicat for MySQL远程连接的时候报错mysql 1130的解决方法
错误代码是1130,ERROR 1130: Host xxx.xxx.xxx.xxx is not allowed to connect to this MySQL server 是无法给远程连接的用 ...
随机推荐
- 活字格企业 Web 应用生成器新手上路指南
活字格是一款企业 Web 应用生成器,使用了类 Excel 的设计界面,通过简单的拖拽操作,就能快速制作出一个 Web 信息管理系统.在整个使用过程中无需专业软件知识,没有任何技术门槛,能轻松实现各行 ...
- 一步一步 Pwn RouterOS之调试环境搭建&&漏洞分析&&poc
前言 本文由 本人 首发于 先知安全技术社区: https://xianzhi.aliyun.com/forum/user/5274 本文分析 Vault 7 中泄露的 RouterOs 漏洞.漏洞影 ...
- 签署您的应用--手动签署 APK
签署您的应用 本文内容 证书和密钥库 签署您的调试构建 调试证书的有效期 管理您的密钥 使用 Google Play 应用签名 自行管理您的密钥和密钥库 签署 APK 生成密钥和密钥库 手动签署 AP ...
- [转载]python——事件驱动的简明讲解
本文转载自http://www.cnblogs.com/thinkroom/p/6729480.html 作者:码匠信龙 方便自己今后查阅存档 关键词:编程范式,事件驱动,回调函数,观察者模式 --- ...
- eclipse安装lua
单击Eclipse->Help->Install New Software… 在Work with中输入网址 Kepler - http://download.eclipse.org/re ...
- 传递命令行参数示例代码 (C 和 Python)
C语言 在 C 语言中, 使用 main 函数的输入参数 argc 和 argv 传入命令行参数. argc 为 int 类型, 表示传入命令行参数的个数 (argument count); argv ...
- leetCode题解之Self Dividing Numbers
1.题目描述 2.题目分析 简单题目,只要挨个判断该数是不是满足条件即可. 3.代码 vector<int> selfDividingNumbers(int left, int right ...
- wopihost
项目介绍 基于wopi协议开发的WopiHost, 支持word, excel,ppt(仅支持预览)等文档的预览和编辑. 运行环境 需要安装Office online 2016才可以使用,基于jdk ...
- 转 Ubuntu Linux 环境变量PATH设置
Ubuntu Linux系统环境变量配置文件: /etc/profile : 在登录时,操作系统定制用户环境时使用的第一个文件 ,此文件为系统的每个用户设置环境信息,当用户第一次登录时,该文件被执行. ...
- 关于Tomcat端口出现的问题
=Several ports (8005, 8080, 8009) required by Tomcat v7.0 Server at localhost are already in use. Th ...