目的: 将 Tomcat与 IIS整合在一起,共用 80端口。让 iis可以解析 *.asp、 *.aspx、 *.jsp、 servlet和 *.do文件;

第一步:准备工作。

在你的 Tomcat下面创建一个新的目录 IIS。

拷贝 bin"isapi_redirector2.dll 到你的 $Tomcat_Home"bin中。

拷贝 bin"isapi_redirector2.dll 到你的 $Tomcat_Home"IIS中。

拷贝 conf"workers2.properties 到你的 $Tomcat_Home"conf中 (确认 8009端口没有被占用)

拷贝 conf"jk2.properties 到你的 $Tomcat_Home"conf中

修改 REG"jakarta.reg 的内容,将 c:""tomcat5.5全部修改为你的 Tomcat的安装目录,(建议目录中不要有空格)。tomcat6.0也是同样

双击 IIS.reg文件,将内容导入注册表中。

第二步:配置 IIS

在你要的网站上建立虚拟目录 jakarta(一定要为这个),并指向第一步中的 IIS目录,记得加上可执行的权限。

添加筛选器 jakarta:进入站点属性的“ ISAPI筛选器”标签页。创建一个新的筛选器 jakarta。具体步骤如下:点击添加按钮,在筛选器名称中输入 jakarta,可执行文件选择 isapi_redirector2.dll。单击确定按钮。重启站点,看筛选器上箭头是否为绿色向上,如果是则初步成功。

此时可以在浏览器中通过 [url]http://localhost/[/url]访问 IIS。

启动 Tomcat, (由于 workers2.properties文件中已经为你配置好了 Tomcat的默认的两个应用 jsp-examples和 servlets-examples)此时可以通过 [url]http://localhost/jsp-examples/[/url]和 [url]http://localhost/servlets-examples/[/url]来访问 Tomcat下面的这两个应用。

注意地址要写全,不要丢掉” /”。

如果访问其他 Tomcat下面的应用,

只须在 $Tomcat_Home"conf"workers2.properties文件中,增加类似的 [uri:/servlets-examples/*]即可。

例如如果我们通过 [url]http://localhost:8080/job/[/url]可以访问 Tomcat下面的 job应用,那么我们可以在 workers2.properties中,添加 [uri:/job/*]即可。

windows2003 iis6需要添加web服务扩展
文件选择isapi_redirector2.dll,并设置成允许

注意点:如果安装过程中出现问题,请重新彻底地删除您添加的所有文件。

by sofot

softotto@126.com

http://www.blogjava.net/b47248054   《《《《《《《《《《《-附件在这里

http://blog.csdn.net/b47248054

分享到:

整合iis+tomcat的更多相关文章

  1. IIS Tomcat共享80端口

    为什么有这种需求, 原因是这样的, 公司有一个Java的web项目,在另一台服务器A上,最近老板一时兴起,想把他合并到这台稳定点的服务器B上,服务器B上使用IIS来寄宿asp.net 网站, 怎么办呢 ...

  2. IIS tomcat共用80端口解决一个IP多个域名:使用Nginx反向代理方式使两者兼容

    环境: windows server 2003,IIS6服务器,Tomcat7服务器 域名有几个: 以下是使用IIS的域名: http://www.formuch.com/ http://www.fo ...

  3. 整合apache+tomcat+keepalived实现高可用tomcat集群

    Apache是一个强大的Web服务器在处理静态页面.处理大量网络客户请求.支持服务的种类以及可配置方面都有优势,高速并且强壮.但是没有JSP/Servlet的解析能力.整合Apache和Tomcat可 ...

  4. ssh整合启动tomcat报java.lang.ClassNotFoundException: org.apache.commons.lang.xwork.StringUtils

    今天搭建了一个ssh项目环境,整合后,访问项目首页,登录不进去,控制台报错,后来调试代码后,在获取数据库数据后,返回到action时,又进入了action导致死循环,其实这里是两个问题,控制台报错如下 ...

  5. IIS+Tomcat功能iis端口2

    之前写过IIS桥接Tomcat是通过isapi_redirect.dll,组件方式实现共用端口的,但是在Windows2012服务器 iis8.0版本中,配置完成后没有效果,比较抓狂,分析发现如下信息 ...

  6. 主流服务器apache,iis,tomcat,jboss,resion,weblogic,websphere的区别

    在互联网高速发展的今天,不同种类的网站大量涌现,每个人都在享受着网络服务带来的便利.而创建自己的个性化网站的门槛不断降低.从事网站架构,这种当年的绝对“”高科技“”绝活.也从it人员的专利“”沦落“” ...

  7. (转)IIS tomcat共用80端口解决一个IP多个域名:使用Nginx反向代理方式使两者兼容

    from :http://www.cnblogs.com/wuyou/p/3455619.html 环境: windows server 2003,IIS6服务器,Tomcat7服务器 域名有几个: ...

  8. 润乾报表整合到Tomcat服务器的部署过程

    转载自:http://www.cnblogs.com/avivaye/archive/2012/11/16/2773681.html 使用第三方的报表设计器/服务器来快速的开发报表. 润乾服务器是使用 ...

  9. SSH整合后tomcat启动报错SEVERE: Exception starting filter struts2 java.lang.NoClassDefFoundError: org/objectweb/asm/ClassVisitor

    错误信息:  SEVERE: Exception starting filter struts2 java.lang.NoClassDefFoundError: org/objectweb/asm/C ...

随机推荐

  1. How Tomcat Works(十八)

    在前面的文章中,如果我们要启动tomcat容器,我们需要使用Bootstrap类来实例化连接器.servlet容器.Wrapper实例和其他组件,然后调用各个对象的set方法将它们关联起来:这种配置应 ...

  2. mongodb高级操作及在Java企业级开发中的应用

    Java连接mongoDB Java连接MongoDB需要驱动包,个人所用包为mongo-2.10.0.jar.可以在网上下载最新版本. package org.dennisit.mongodb.st ...

  3. ASP.NET MVC- 解决HTML转码

    在MVC里从Controller发送一段带有HTML的文字到View视图时,MVC是会将这段代码进行转码的. 一.使用MvcHtmlString转HTML转码 如果想不让这段文字进行转码,以HTML的 ...

  4. Windows7部署WordPress傻瓜式教程(IIS7.5+MySQL+PHP+WordPress)

    http://www.cnblogs.com/vengen/archive/2010/01/01/WordPressInstall.html

  5. jquery网页字体变大小

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...

  6. WM_QUIT,WM_CLOSE,WM_DESTROY 消息出现顺序及调用方式

    http://bbs.ednchina.com/BLOG_ARTICLE_3005455.HTM VC中WM_CLOSE.WM_DESTROY.WM_QUIT消息出现顺序及调用方式 wxleasyla ...

  7. Codeforces Round #310 (Div. 2) B. Case of Fake Numbers 水题

    B. Case of Fake Numbers Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://codeforces.com/contest/5 ...

  8. C#中正则表达式进行忽略大小写的字符串替换

    在C#里要进行忽略大小写的字符串替换,用string的Replace是很难做到的,即使花了天大的力气做到了,效率仍然是很低的,正确的方法应该是使用正则表达式. 要使用正则表达式,首先需要引用命名空间: ...

  9. TP复习13

    ## ThinkPHP 3.1.2 模板的使用技巧#讲师:赵桐正微博:http://weibo.com/zhaotongzheng 本节课大纲:一.模板包含 <include file=&quo ...

  10. apache2.2 虚拟主机配置

    一.改动httpd.conf 打开appserv的安装文件夹,找到httpd.conf文件,分别去掉以下两行文字前面的#号. #LoadModule vhost_alias_module module ...