Apache配置文件讲解
持续作用扩展自
HTTP/1.0
和
HTTP/1.1
的长连接特性。提供了长效的
HTTP
会话,用以在同
一个
TCP
连接中进行多次请求。
在某些情况下,
这样的方式会对包含大量图片的
HTML
文件
起到
50%
的加速作用。对于使用
HTTP/1.0
的客户端来说,只有客户端设置使用的时候才会
使用持续作用连接。而对于
HTTP/1.1
的客户端来说,如果没有进行特殊指定,长连接将是
默认的连接方式。
l MaxKeppAliveRequests
一个长连接中允许的请求数量。
【说明】
该参数限制了当启用
KeepAlive
时,每次连接允许的请求数量。如果将此值设为
0
,将不限
制请求的数量。这里建议最好将此值设为一个比较大的值,以确保最优的服务器性能。
l KeppAliveTimeOut
持续作用中服务器在两次请求之间的等待时间。
【说明】
Apache
在关闭本次连接前等待下一次请求的时间,即在这段时间内该连接没有接收到请求
就会关闭此连接。一旦收到一个请求,超时值将会被设置为
KeppAliveTimeOut
的值。
注意:
对于高负荷的服务器来说,
如果把该参数的值设置的较大可能会导致一些性能方面的
问题,因为
KeppAliveTimeOut
的值会影响释放空闲进程、线程时间的数量,如果该值大,
那么在一定时间区间内释放出来的空闲进程、
线程的数量会少于该值小的,
所以会降低服务
器处理请求的能力,从而影响整个系统的吞吐量。
l Listen
服务器监听
IP
地址和端口。
【说明】
Listen
参数是指
Apache
服务器在指定的
IP
地址和端口上进行监听;
默认情况下
Apache
会在
所有
IP
地址上监听。
Listen
是一个必须设置的指令。
如果在配置文件中找不到这个指令,
服
务器将无法启动。
Listen
参数还可以指定服务器在哪个端口或地址和端口的组合上进行监听请求。如果只指定
一个端口,
服务器将在所有地址上监听该端口。
如果指定了地址和端口的组合,
服务器将按
照指定地址和指定的端口进行监听。
使用多个
Listen
参数可以指定多个不同的监听端口和
/
或地址端口组合。
例如,想要服务器接受
80
和
8080
端口上的请求,可以这样设置:
Listen 80
Listen 8080
为了让服务器在两个确定的地址端口组合上接受请求,可以这样设置:
Listen 192.64.182.1:80
Listen 192.64.182.5:8080
注意:多个
Listen
指令指定了同一个地址和端口的组合后,会导致
"Address
already
in
use"
错误。
2
.
系统路径管理类参数
l ServerRoot
服务器的安装基础目录。
【说明】
该参数设置了服务器所在的目录。一般来说它将包含
conf/
和
logs/
子目录。其它配置文件的
相对路径都基于此目录
(
比如
Include
或
LoadModule)
。
例如:
ServerRoot /etc/httpd
l DocumentRoot
组成网络上可见的主文档树的根目录。
【说明】
此参数设置了
httpd
服务的目录。在没有配置类似
Alias
这种参数的情况下,服务器会将请
求中的
URL
附加到
DocumentRoot
后面以构成指向文档的路径。比如说:
DocumentRoot /etc/httpd/www/web
于是对
http://www.ccb.com.cn/index.html
的访问就会指向
/etc/httpd/www/web/index.html
。
如果参数中不是绝对路径,则被假定为是相对于
ServerRoot
Apache配置文件讲解的更多相关文章
- Apache配置文件服务器
配置Apache文件服务器: apache配置文件服务器httpd.conf中这两个模块必须不被注释LoadModule autoindex_module modules/mod_autoindex. ...
- (原创)LAMP搭建之二:apache配置文件详解(中英文对照版)
LAMP搭建之二:apache配置文件详解(中英文对照版) # This is the main Apache server configuration file. It contains the # ...
- Apache配置文件中的deny和allow的使用
Apache配置文件中的deny和allow的使用 由于产品的需要,最近在配置apache的负载均衡功能,但是在配置虚拟主机的访问权限的时候我们遇到了一些问题.主要问题是deny和allow的执行顺序 ...
- Apache配置文件httpd.conf内容翻译
本文已经废弃,现在apache2不依靠httpd.conf来配置. Ubuntu下默认的配置文件是/etc/apache2/sites-available/default 可以修改上面文件来修改a ...
- SpringBoot2.x配置文件讲解
SpringBoot2.x配置文件讲解 简介:SpringBoot2.x常见的配置文件 xml.yml.properties的区别和使用 xml.properties.json.yaml 1.常见的配 ...
- MAC下通过改apache配置文件切换php多版本的方法
网上关于php版本切换的文章有很多,但测试发现有很多都不行,所以不如自己想办法实现了,所以下面这篇文章主要给大家介绍了在MAC系统下通过改apache配置文件的方法来使php多版本切换的相关资料,需要 ...
- Apache 配置文件详解
0x01 禁止目录列表访问 () 备份httpd.conf配置文件,修改内容: <Directory "/web"> Options FollowSymLinks Al ...
- Linux服务器---apache配置文件
Apache配置文件 Apache的配置文件默认路径是“/etc/httpd/conf/httpd.conf”,编辑该文件就可以修改Apache的配置 1.设置网页主目录,参数DocumentRoot ...
- ssh 配置文件讲解大全 ssh调试模式 sftp scp strace进行调试 特权分离
ssh 配置文件讲解大全 ssh调试模式 sftp scp strace进行调试 特权分离 http://blog.chinaunix.net/uid-16728139-id-3265394.h ...
随机推荐
- git-credential-winstore.exe": No such file or directory
$ git push -u origin master\"D:/GitExtensions/GitCredentialWinStore/git-credential-winstore.exe ...
- imx6 uboot saveenv fail
uboot设置环境变量之后,不能保存在EMMC中,出现错误. MX6SDL SABRESD U-Boot > saveenv Saving Environment to SPI Flash... ...
- 6. support vector machine
1. 了解SVM 1. Logistic regression 与SVM超平面 给定一些数据点,它们分别属于两个不同的类,现在要找到一个线性分类器把这些数据分成两类.如果用x表示数据点,用y表示类别( ...
- Ubuntu16.04配置phpmyadmin
原文 如何安装phpmyadmin-Mysql 数据库管理 使用界面管理器:系统->系统管理->新立得软件包管理器->搜索 phpmyadmin->右键标记安装.或直接使用一条 ...
- VS2010 LINK1123:failure during conversion to COFF:file invalid or corrupt
今天用Visual Studio 2010编译一个C工程时突然遇到下面这个编译错误.fatal error LINK1123:failure during conversion to COFF:fil ...
- noi 1.5 45:金币
描述 国王将金币作为工资,发放给忠诚的骑士.第一天,骑士收到一枚金币:之后两天(第二天和第三天)里,每天收到两枚金币:之后三天(第四.五.六天)里,每天收到三枚金币:之后四天(第七.八.九.十天)里, ...
- Leetcode: Sentence Screen Fitting
Given a rows x cols screen and a sentence represented by a list of words, find how many times the gi ...
- com.caucho.hessian.io.HessianProtocolException: is unknown code 解决方案
问题: Cannot access Hessian remote service at [http://....../remote/syllabusService]; nested exception ...
- 纯html、css3、js的时钟
之前在网上看了一些使用js写的时钟,但感觉实现的方法有点麻烦,所以就自己重新写了一个例子,样子有点丑,但方法比较简单,大家就凑合看吧 其中采用的主要方法是原生js里面的Data(时期)对象,以及它的. ...
- aspcms,2.x以上版本,保护栏目不可删除处理方法
aspcms,2.x以上版本,保护栏目不可删除处理方法.首先找到\admin\_content\_Sort\AspCms_SortFun.asp这个文件.然后将if isnul(id) then a ...