【MySQL案件】mysql登录-S失败
1.1.1. mysql登录mysql时间,-S参数失效
【环境的叙述性说明】
mysql5.5.14
【问题叙述性说明】
配置多个实例
|
实例1 |
实例2 |
|
|
datadir |
/home/mysql_3306 |
/home/mysql_3307 |
|
basedir |
/usr |
/usr |
|
socket |
/home/mysql_3306/mysq.sock |
/home/mysql_3307/mysq.sock |
登录实例2的时候,却连接到了实例1:
mysql -S /home/mysql_3307/mysql.sock
> show variables like '%sock%';
+---------------+-----------------------------+
| Variable_name | Value |
+---------------+-----------------------------+
| socket | /home/mysql_3306/mysql.sock |
+---------------+-----------------------------+
【问题原因】
mysql命令中的-S參数是用来指定unix_socket,可是此时mysql非常明显没有使用socket。
查看/etc/my.cnf配置文件。发现[client]域配置例如以下:
[client]
host = 127.0.0.1
尝试改动host=localhost 和凝视掉host。再次尝试登录mysql:
mysql -S /home/mysql_3307/mysql.sock
> show variables like '%sock%';
+---------------+-----------------------------+
| Variable_name | Value |
+---------------+-----------------------------+
| socket | /home/mysql_3307/mysql.sock |
+---------------+-----------------------------+
此时,正常登录上了指定的实例。
再次測试登录mysql:
mysql -S /home/mysql_3306/mysql.sock -h 127.0.0.1-P 3307
> show variables like '%sock%';
+---------------+-----------------------------+
| Variable_name | Value |
+---------------+-----------------------------+
| socket | /home/mysql_3307/mysql.sock |
+---------------+-----------------------------+
mysql登录的时候指定的socket是3306port的,host是127.0.0.1,port是3307。登录后。连接的是3307port的实例。
mysql -S /home/mysql_3307/mysql.sock -h127.0.0.1
> show variables like '%sock%';
+---------------+-----------------------------+
| Variable_name | Value |
+---------------+-----------------------------+
| socket | /home/mysql_3306/mysql.sock |
+---------------+-----------------------------+
mysql登录的时候指定的socket是3307port的。host是127.0.0.1,port没有指定,登录后,连接的是3306port的实例。
综上,mysqlclient连接mysql数据库的时候,假设同一时候指定了socket和host的时候,mysql会採使用TCP/IP协议日志。此时socket它将被忽略。默认情况下访问3306port。
版权声明:本文博客原创文章,博客,未经同意,不得转载。
【MySQL案件】mysql登录-S失败的更多相关文章
- express框架+jade+bootstrap+mysql开发用户注册登录项目
完整的项目代码(github):https://github.com/suqinhui/express-demo express是基于Node.js平台的web应用开发框架,用express框架开发w ...
- [Centos 7]MYSQL 安装及登录问题
1. Centos 7 上安装mysql 8 rpm -qa |grep -i mysql //看自己系统有没有装mysql wget https://dev.mysql.com/get/mysql8 ...
- node+mysql+express实现登录/注册/修改密码/删除用户 接口
实现用户的注册.登录.修改密码.删除用户操作 用到的数据库:nodecms:表:user 目录结构: db目录下存放数据库操作语句: userSQL.js 用户有关的操作语句 router目录 接口路 ...
- CentOS 配置MySQL允许远程登录
Mysql为了安全性,在默认情况下用户只允许在本地登录,可是在有此情况下,还是需要使用用户进行远程连接,因此为了使其可以远程需要进行如下操作: 一.允许root用户在任何地方进行远程登录,并具有所有库 ...
- MySQL命令行登录的例子
环境:MySQL Sever 5.1 + MySQL命令行工具 问题:MySQL命令行登录 解决: 命令 行登录语法: mysql –u用户名 [–h主机名或者IP地址] –p密码 说明:用户名是你登 ...
- Win7下mysql root账户登录提示:ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)解决方案
ERROR 1045 (28000): Ac-- password: YES)这个意思是密码不正确,那就修改密码: 如果你是服务器是 windows xp/2000/2003/nt 都可以使用这个方法 ...
- MySQL数据库2 - 登录MySQL及数据库管理
一. 登录数据库 1.使用命令窗口登录MySQL 启动Mysql服务 -> 打开命令窗口 -> 输入登录密码 具体步骤:开始菜单 - 控制面板 - 管理工具 - 服务 - Mysql56( ...
- [CentOS 0010] CentOS 配置mysql允许远程登录
Mysql为了安全性,在默认情况下用户只允许在本地登录,可是在有此情况下,还是需要使用用户进行远程连接,因此为了使其可以远程需要进行如下操作: 一.允许root用户在任何地方进行远程登录,并具有所有库 ...
- mysql用户修改登录密码及开启远程登录
一.修改用户登录密码: mysql> show databases;ERROR 1820 (HY000): You must SET PASSWORD before executing this ...
随机推荐
- lunux命令笔记
文件查看命令 ls / -lh ls list / 路径 -l 具体 -lh 具体的人性化显示 -ld 显示文件夹 -i 显示i节点 mkdir /tmp/mulu/mulu2 /tmp/ma/mb ...
- 弹出式菜单PopMenu
MainActivity.java public class MainActivity extends Activity implements OnClickListener{ private Pop ...
- C++基于该模型模板包括节目外实例
一个."经典模式"失败 我们学过C++的人都知道.在C++中组织代码的经典模型是:将函数或类的声明和定义部分分开在不同的文件之中 , 即一般将声明放在一个.h的头文件里而定义在 ...
- ASP.NET自定义控件组件开发 第五章 模板控件开发
原文:ASP.NET自定义控件组件开发 第五章 模板控件开发 第五章 模板控件开发 系列文章链接: ASP.NET自定义控件组件开发 第一章 待续 ASP.NET自定义控件组件开发 第一章 第二篇 接 ...
- Android使用开源项目Xutils实现多线程下载文件
#1.下载utils项目 https://github.com/wyouflf/xUtils #2布局文件里实现UI <LinearLayout xmlns:android="http ...
- proxool数据库连接池配置
proxool.xml构造 <?xml version="1.0" encoding="UTF-8"?> <something-else-en ...
- C该结构变化 struct typedef
这几天看代码,看到若干类型的结构,例如下列结构声明: struct book{ string name; int price; int num; }; 此种结构定义结构变量的格式例如以下: ...
- HDU 别easy在一系列的
别easy在一系列的 Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Su ...
- SQL Server高可用——日志传送(4-2)——部署
原文:SQL Server高可用--日志传送(4-2)--部署 前文再续,书接上一回.本章演示一下日志传送的具体过程 准备工作: 由于时间关系,已经装好了3台虚拟机,且同在一个域里面: SQL01:主 ...
- UVA 239 - Tempus et mobilius. Time and motion(更换周期)
UVA 239 - Tempus et mobilius. Time and motion 题目链接 题意:这题题意也是吊得飞起,看了老半天,大概是这样: 有一个放球的队列.和3个轨道(说白了就是栈) ...