部署项目的时候,重启tomcat,死活起不来,很郁闷,网上巴拉了半天,结合自己的情况,找到了原因;

错误日志信息:

2018-12-13 13:52:26,992 [main] INFO  org.apache.catalina.core.AprLifecycleListener- The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
2018-12-13 13:52:27,052 [main] WARN org.apache.tomcat.util.digester.Digester- [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'maxSpareThreads' to '512' did not find a matching property.
2018-12-13 13:52:27,394 [main] INFO org.apache.coyote.http11.Http11NioProtocol- Initializing ProtocolHandler ["http-nio-2015"]
2018-12-13 13:52:27,685 [main] INFO org.apache.tomcat.util.net.NioSelectorPool- Using a shared selector for servlet write/read
2018-12-13 13:52:27,688 [main] INFO org.apache.coyote.http11.Http11Protocol- Initializing ProtocolHandler ["http-bio-9094"]
2018-12-13 13:52:27,695 [main] INFO org.apache.catalina.startup.Catalina- Initialization processed in 976 ms
2018-12-13 13:52:27,732 [main] INFO org.apache.catalina.core.StandardService- Starting service Catalina
2018-12-13 13:52:27,732 [main] INFO org.apache.catalina.core.StandardEngine- Starting Servlet Engine: ONIP SOABean OpenAS V300R002C50SPC100
2018-12-13 13:52:27,796 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Error starting static Resources
java.lang.IllegalArgumentException: Document base /home/duiba/apache-tomcat/webapps/../webapps/manager does not exist or is not a readable directory
at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:138)
at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4912)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5092)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1517)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1508)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
2018-12-13 13:52:27,800 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Error in resourceStart()
2018-12-13 13:52:27,822 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Error getConfigured
2018-12-13 13:52:27,823 [localhost-startStop-1] ERROR org.apache.catalina.core.StandardContext- Context [/manager] startup failed due to previous errors
2018-12-13 13:52:27,923 [localhost-startStop-1] INFO org.apache.catalina.loader.WebappClassLoader- validateJarFile(/home/duiba/apache-tomcat/webapps/duiba/WEB-INF/lib/servlet-api-1.0.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class

  分析原因:原来是因为我自己的原因,为了把原来的东西个删除干净,我把tomcat自带的manager目录也给删除了,这就尴尬了,启动的时候就一直有这个错误的日志信息在打印(事实上,这个错误并不影响程序的运行),但是日志一直有Error还是不好的,我就把其他模块的manager给复制了一份,并传到了改服务器上,然后重新启动服务,启动成功了!感觉下次要小心了,不能乱删东西啊!

Linux下启动tomcat报错RROR org.apache.catalina.core.StandardContext- Error starting static Resources java.lang.IllegalArgumentException: Document base /home/duiba/apache-tomcat/webapps/../webapps/manager do的更多相关文章

  1. tomcat启动报错:java.lang.IllegalArgumentException: Document base D:\apache-tomcat-6.0.45\webapps\activiti-explorer does not exist or is not a readable directory

    java.lang.IllegalArgumentException: Document base D:\apache-tomcat-6.0.45\webapps\erp does not exist ...

  2. tomcat报错java.lang.IllegalArgumentException: Document base XXXXX does not exist or is not a readable directory

    启动tomcat的时候报如下错误: java.lang.IllegalArgumentException: Document base F:\java\tools\tomcat\me-webapps\ ...

  3. Tomcat的错误 之 java.lang.IllegalArgumentException: Document base * does not exist

    Tomcat的异常 之 java.lang.IllegalArgumentException: Document base 有些刚开始使用的Tomcat的朋友会出现的问题,明明已经将某个web应用从t ...

  4. Jenkins - Linux下启动Jenkins报错hudson.WebAppMain#contextDestroyed: Shutting down a Jenkins instance that was still starting up

    报错截图 在Linux下直接运行jenkins.war报错,导致启动失败 报错原因 运行端口已被其他进程占用 解决方法 换个启动端口就可以啦!

  5. 解决kylin报错:Failed to create dictionary on <db>.<table>, Caused by: java.lang.IllegalArgumentException: Too high cardinality is not suitable for dictionary

    报错信息: 2017-05-13 15:14:30,035 DEBUG [pool-9-thread-10] dict.DictionaryGenerator:94 : Dictionary clas ...

  6. linux下启动jekins报错

    进入默认安装目录,执行java -jar jekins.war 启动使用端口号: java -jar jenkins.war --httpPort=8085,即启动完成 这个有个弊端,关闭后下次还得这 ...

  7. Linux下启动eclipse报错

    A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be avail   Java RunTime Environm ...

  8. Tomcat启动时报错:“ Error starting static Resources”问题解决

    部署测试环境的时候,需要用到Tomcat.故在Linux上部署了Tomcat,并将开发提供的工程包部署到Tomcat的webapps目录下,启动Tomcat,部署成功.第二天修改工程配置文件时,发现w ...

  9. 在MyEclipse中运行tomcat报错 严重: Error starting static Resources

    严重: Error starting static Resourcesjava.lang.IllegalArgumentException: Document base E:\apache-tomca ...

随机推荐

  1. swift - view的指定位置切圆角

    1. extension UIView{ func addCorner(conrners: UIRectCorner , radius: CGFloat) { let maskPath = UIBez ...

  2. swift - 使用系统app导航

    import UIKit //1.导入框架 import MapKit class ViewController: UIViewController { lazy var geoCoder : CLG ...

  3. http协议的学习

    TPC/IP协议是传输层协议,主要解决数据如何在网络中传输,而HTTP是应用层协议,主要解决如何包装数据.

  4. linux查看目录下所有文件内容中是否包含某个字符串

    转发自:http://blog.csdn.net/yimingsilence/article/details/76071949 查找目录下的所有文件中是否含有某个字符串 find .|xargs gr ...

  5. Mysql数据库(一)

    一 什么是数据库 一般来说,所有的数据都要存储在硬盘中,为了方便对这些数据的管理因此就出现了例如MySQL SQLserver oracle等数据库管理软件. 数据库中的数据按一定的数据模型组织.描述 ...

  6. 关于thymeleaf的if多条件判断

    <ul class="nav nav-second-level"> <li th:each="cmenu : ${menu.children}" ...

  7. day7 回顾

    1,is == == 比较的是值. is 内存地址.对于int str 来说:存在小数据池的概念.为什么存在小数据池? 节省内存. int -5 ~ 256 str 全部字母,数字与单个字母想乘 数字 ...

  8. Activity(活动)

  9. POJ2728 Desert King

    一道生成树+\(0/1\)分数规划 原题链接 设每条边的距离为\(dis[x]\),两点高度差为\(h[x]\),该图的生成树为\(T\),则题目实际求的就是\(\dfrac{\sum\limits_ ...

  10. snort学习笔记

    Snort有三种工作模式:嗅探器.数据包记录器.网络入侵检测系统(ids). 嗅探器模式仅仅是从网络上读取数据包并作为连续不断的流显示在终端上. 数据包记录器模式把数据包记录到硬盘上. 网络入侵检测模 ...