记录一次“异常bug”,具体信息如下。主要是记录一下处理过程,可能口水话比较多,如果想看结果,直接往后拉即可。

最后一行

起初,运维同事找到我,跟我说程序出问题了,系统升级,一直连不上nacos。

我看了日志信息之后,刚开始还是没有在意的。毕竟是nacos报错,报错还那么明显:java.net.ConnectException: Connection refused (Connection refused)

我信心满满告诉他,是nacos没起起来,或者是配置文件有问题。这不是代码的问题。(这里带有一点点侥幸心理)

我很快就被打脸了。其他服务都能起起来,唯独我们同事写的这个模块出了bug?就是连不上nacos。此时让他们重启nacos,肯定是不现实的,毕竟nacos是没问题的。重启这个报错的模块也试过了,但是模块就是一直在重连nacos,并且最终连不上去。

于是我把nacos的加载顺序重新捋一遍。在docker中起服务,首先是加载docker的环境变量,然后替代掉程序中的bootstrap.yml。这里猜测是启动命令的问题。

配置的读取过程

1.当docker容器启动时,获取到容器的环境变量(通常是服务名,nacos地址,nacos命名空间,nacos组,需要的配置文件)。

2.jar启动时,会使用容器的环境变量会作为相关参数。(原理可以查询关键词: spring jar 参数)

3.springboot启动时会注入相关的参数,从而获取到nacos的配置信息,并将nacos做为配置中心,从nacos上读取相关配置。

4.springboot 读到相关配置,其中一个配置是将nacos做为注册中心,将服务注册到nacos上。 (本次异常的发生点)

于是我有去问运维同事容器的启动命令。(因为docker中的环境变量,已经在启动命令中做了映射了,所有我们只用看运维同事的启动命令即可)

exec java -jar island-serviceconfig.jar --server-addr=sc-nacos:8848 --namespace=public --group=service-cool --config-common=island-common.yaml --config-service=island-serviceconfig.yaml

看着启动命令,我又陷入了沉思,这是怎么操作,一定毛病也没有。就这样,尝试了好几遍。一个下午就没有了。

后面我仔细回味报错信息。这不可能,nacos难道有版本错误?很快被我否定,这次升级系统,重新拉了代码。之前都是好好的,运维那边的nacos版本是没有改动过的。

于是我上去仓库看代码。代码也没有问题,近期没有人修改过。这很郁闷呐。

最后迫不得已,去看了nacos的源码,最后找到了一点点信息,nacos是在我们没有配置nacos地址的时候,才会去加载localhost:8848这个地址。

那么问题来了,明明我们配置了nacos地址,为什么还是会去加载localhost:8848?这又回到了原点。又开始怀疑是运维同事的执行命令出了问题,但是确实是没有问题的。

我慢慢静下心来。也许是我一开始的出发点就出问题了。我一直以为是运维同事部署出了问题,思维停留在运维那边,丝毫没有怀疑是配置问题的问题。

最终快下班了和另一个同事讨论,我刚开口描述完问题,他就说了一句:卧槽,我搞了三天。

果然,之前不是好着的,而是有这位同事一直在“擦屁股”,但是git上面的配置问题,他又没有进行更新。导致运维每次拉取代码,都会出现这个问题。具体问题如下

乍一看这配置没啥问题,我之前检查配置文件也是,每次看下去都没有问题,洽洽是我的以为,导致这个问题没能及时被发现。这就是一个缩进的问题。

正确的配置如下:

最后,感受一波吐槽,其实最初运维的同事也发现这个缩进有问题,所有他手动改了很多,也反馈了,但是估计开发都很忙,就没有修改git上的配置文件。导致埋下了一颗大雷。好在写代码的同事已经离职(手动狗头保命)

总结:遇到bug不要慌,好好和运维同事做沟通,每个部门都有自己的规范和要求,像简单的运行命令出了问题,这个还是很好排查的。切记切记,不要有甩锅心理,不要有甩锅心理,不要有甩锅心理。

这次很明显,运维同事就是被我们开发摆了一道,这也是开发这边没有注意的问题,或者说,这是不应该出现的问题,属于比较低等的问题。饶是如此,我们也要重视起来,否则一个小小的雷,埋久了,他也是会发酵的,威力越来越大。

nacos Connection refused (Connection refused)的更多相关文章

  1. supervisord supervisorctl 问题supervisor.sock refused connection

    如果supervisord挂了的话,提示supervisor.sock refused connection. ,重新启动命令为supervisord 常用命令: supervisord -c /et ...

  2. 异常-CDH的service无法启动并抛出异常-org.apache.avro.AvroRemoteException: java.net.ConnectException: Connection refused (Connection refused)

    1 详细异常 org.apache.avro.AvroRemoteException: java.net.ConnectException: Connection refused (Connectio ...

  3. exception is feign.RetryableException: Connection refused (Connection refused) executing GET http://......

    2018-03-23 10:00:58.430 ERROR 31889 --- [nio-4321-exec-7] o.a.c.c.C.[.[.[/].[dispatcherServlet] : Se ...

  4. public class feign.RetryableException feign.RetryableException: Connection refused (Connection refused) executing POST http://common-wx/wx/auth/client/token/v1

    一.异常出现的场景 Spring Cloud内部两个服务A和B,A调用B时,抛出该异常.提示连接拒绝 public class feign.RetryableException feign.Retry ...

  5. supervisorctl unix:///var/run/supervisor.sock refused connection

    运行supervisorct 报如下错误 supervisorctl unix:///var/run/supervisor.sock refused connection 查看supervisord. ...

  6. Exception in thread "main" redis.clients.jedis.exceptions.JedisConnectionException: java.net.ConnectException: Connection refused (Connection refused)

    一.linux中配置redis,使用java连接测试时报错: Exception in thread "main" redis.clients.jedis.exceptions.J ...

  7. 启动storm之后浏览器访问报错,org.apache.thrift7.transport.TTransportException: java.net.ConnectException: Connection refused (Connection refused)

    原因是zookeeper没有启动 Internal Server Error org.apache.thrift7.transport.TTransportException: java.net.Co ...

  8. Cannot open channel to 3 at election address :3888 java.net.ConnectException: Connection refused (Connection refused)

    关于Linux中搭建分布式时可能遇到的问题 这个问题来自于今天安装zookeeper时踩的一个大坑,害的我花了一天时间.在搭建zookeeper的分布式时,往往要进行这样的配置: server.1=h ...

  9. solr集群Server refused connection at: http://127.0.0.1:6060/solr/ego 注册zookeepr自动使用内网ip

    引导:适用于各种注册服务,zookeeper和被注册的服务器不在同一ip上,产生的注册了127.0.0.1本地ip地址 在使用solr集群操作的时候,报了如下的错误 org.apache.solr.c ...

随机推荐

  1. jsp中basa标签的使用

    <base href="http://${pageContext.request.serverName}:${pageContext.request.serverPort}${page ...

  2. zabbix 发现 vmvare esxi6.7 虚拟主机

    1:服务端配置确认 确保 #vi /etc/zabbiz/zabbix-server/zabbix_server.conf ## 确认其中有 StartVMwareCollectors项目 值 > ...

  3. 魔镜魔镜,今天有雨吗?——GitHub 热点速览 v.21.25

    作者:HelloGitHub-小鱼干 上周智能驾驶项目的作者曾经做过一个透明小电视机,同透明电视机类似 MagicMirror 也是一个神奇的智能项目,使用它进行模块定制开发,你将拥有一块非常酷炫的智 ...

  4. Acwing Arithmetic Learning:数据结构(2)

    目录 数据结构(2)acwing 1.trie树 2.并查集(近乎O(1)) 3.堆 数据结构(2)acwing 1.trie树 快速存储和查找字符串的集合 结构特征: 例题:Trie字符串统计 ? ...

  5. Netty 框架学习 —— 基于 Netty 的 HTTP/HTTPS 应用程序

    通过 SSL/TLS 保护应用程序 SSL 和 TLS 安全协议层叠在其他协议之上,用以实现数据安全.为了支持 SSL/TLS,Java 提供了 javax.net.ssl 包,它的 SSLConte ...

  6. SQL Prompt快捷键

    1. DF DELETE FROM  2. ssf SELECT * FROM  3. be BEGIN  END 4. ij INNER JOIN  5. ap ALTER PROCEDURE  6 ...

  7. Kubernetes自动伸缩pod-HPA

    在运维中,虽然能预先知道负载何时会飙升,或者如果负载的变化是较长时间内逐渐发生的,手动扩容也是可以接受的,但指望靠人工干预来处理突发而不可预测的流量增长,仍然不够理想. 幸运的是,Kubernetes ...

  8. Kubernetes的认证机制

    1.了解认证机制 API服务器可以配置一到多个认证的插件(授权插件同样也可以).API服务器接收到的请求会经过一个认证插件的列表,列表中的每个插件都可以检查这个请求和尝试确定谁在发送这个请求.列表中的 ...

  9. Vue前端基础学习

    vue-cli vue-cli 官方提供的一个脚手架(预先定义好的目录结构及基础代码,咱们在创建Maven项目的时可以选择创建一个骨架项目,这个骨架项目就是脚手架),用于快速生成一个vue项目模板 主 ...

  10. Vue3全家桶升级指南二ref、toRef、toRefs的区别

    ref是对原始数据的拷贝,当修改ref数据时,模板中的视图会发生改变,但是原始数据并不会改变. toRef是对原始数据的引用,修改toRef数据时,原始数据也会发生改变,但是视图并不会更新. 在vue ...