使用NBU进行oracle异机恢复
windows平台的异机恢复,目录不同
1.异机环境准备
安装oracle介质
安装nbu客户端
在异机主机的host文件中添加nbu server主机和原主机信息
2.恢复spfile文件
C:\>oradim -new -sid ybb
SQL> startup nomount
C:\> rman target /
RMAN> set dbid= 884218943
RMAN> run {
allocate channel ch02 type 'sbt_tape'
parms="ENV=(NB_ORA_CLIENT=olddb,NB_ORA_SERV=netbackup)";
restore spfile from 'c-884218943-20160628-03';
release channel ch02;
} 分配的通道: ch02
通道 ch02: SID=130 设备类型=SBT_TAPE
通道ch02: Veritas NetBackup for Oracle - Release 7.6 (20141027) 启动 restore 于 19-7月 -16 通道 ch02: 正在从 AUTOBACKUP c-884218943-20160628-03 还原 spfile
通道 ch02: 从 AUTOBACKUP 还原 SPFILE 已完成
完成 restore 于 19-7月 -16 释放的通道: ch02
3.恢复控制文件
RMAN> run {
2> allocate channel ch03 type 'sbt_tape'
3> parms="ENV=(NB_ORA_CLIENT=olddb,NB_ORA_SERV=netbackup)";
4> restore controlfile from 'c-884218943-20160629-03';
5> release channel ch03;
6> }
分配的通道: ch03
通道 ch03: SID=63 设备类型=SBT_TAPE
通道ch03: Veritas NetBackup for Oracle - Release 7.6 (20141027)
启动 restore 于 19-7月 -16
通道 ch03: 正在还原控制文件
通道 ch03: 还原完成, 用时: 00:00:07
输出文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\CONTROL01.CTL
输出文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\CONTROL02.CTL
完成 restore 于 19-7月 -16
释放的通道: ch03
4.将数据库置于mount状态
RMAN> sql 'alter database mount';
5.恢复数据文件
RMAN> run{
2> allocate channel ch01 type 'sbt_tape';
3> SEND 'NB_ORA_SERV=netbackup,NB_ORA_CLIENT=olddb';
4> set newname for datafile 'D:\app\Administrator\oradata\ybb\SYSTEM01.DBF' to 'C:\app\Administrator\oradata\ybb\SYSTEM01.DBF';
5> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\SYSAUX01.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\SYSAUX01.DBF';
6> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\UNDOTBS01.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\UNDOTBS01.DBF';
7> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\USERS01.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\USERS01.DBF';
8> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA01.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA01.DBF';
9> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA02.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA02.DBF';
10> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA03.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA03.DBF';
11> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX01.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX01.DBF';
12> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX02.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX02.DBF';
13> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX03.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX03.DBF';
14> set newname for datafile 'D:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA0101.DBF' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA0101.DBF';
15> restore database;
16> switch datafile all;
17> recover database until scn 272947828;
18> release channel ch01;
19> }
分配的通道: ch01
通道 ch01: SID=63 设备类型=SBT_TAPE
通道ch01: Veritas NetBackup for Oracle - Release 7.6 (20141027)
向通道发命令: ch01
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
正在执行命令: SET NEWNAME
启动 restore 于 20-7月 -16
通道 ch01: 正在开始还原数据文件备份集
通道 ch01: 正在指定从备份集还原的数据文件
通道 ch01: 将数据文件 00001 还原到 C:\app\Administrator\oradata\ybb\SYSTEM01.DBF
通道 ch01: 将数据文件 00002 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\SYSAUX01.DBF
通道 ch01: 将数据文件 00003 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\UNDOTBS01.DBF
通道 ch01: 将数据文件 00004 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\USERS01.DBF
通道 ch01: 将数据文件 00005 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA01.DBF
通道 ch01: 将数据文件 00006 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA02.DBF
通道 ch01: 将数据文件 00007 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA03.DBF
通道 ch01: 将数据文件 00008 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX01.DBF
通道 ch01: 将数据文件 00009 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX02.DBF
通道 ch01: 将数据文件 00010 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX03.DBF
通道 ch01: 将数据文件 00011 还原到 C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA0101.DBF
通道 ch01: 正在读取备份片段 bk_dybb_u95r99ttg_s3365_p1_t915732400
通道 ch01: 段句柄 = bk_dybb_u95r99ttg_s3365_p1_t915732400 标记 = TAG20160628T180639
通道 ch01: 已还原备份片段 1
通道 ch01: 还原完成, 用时: 00:04:56
完成 restore 于 20-7月 -16
数据文件 1 已转换成数据文件副本
输入数据文件副本 RECID=15 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\SYSTEM01.DBF
数据文件 2 已转换成数据文件副本
输入数据文件副本 RECID=16 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\SYSAUX01.DBF
数据文件 3 已转换成数据文件副本
输入数据文件副本 RECID=17 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\UNDOTBS01.DBF
数据文件 4 已转换成数据文件副本
输入数据文件副本 RECID=18 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\USERS01.DBF
数据文件 5 已转换成数据文件副本
输入数据文件副本 RECID=19 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA01.DBF
数据文件 6 已转换成数据文件副本
输入数据文件副本 RECID=20 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA02.DBF
数据文件 7 已转换成数据文件副本
输入数据文件副本 RECID=21 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA03.DBF
数据文件 8 已转换成数据文件副本
输入数据文件副本 RECID=22 STAMP=917694346 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX01.DBF
数据文件 9 已转换成数据文件副本
输入数据文件副本 RECID=23 STAMP=917694347 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX02.DBF
数据文件 10 已转换成数据文件副本
输入数据文件副本 RECID=24 STAMP=917694347 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_INDEX03.DBF
数据文件 11 已转换成数据文件副本
输入数据文件副本 RECID=25 STAMP=917694347 文件名=C:\APP\ADMINISTRATOR\ORADATA\ybb\NNC_DATA0101.DBF
启动 recover 于 20-7月 -16
正在开始介质的恢复
通道 ch01: 正在开始将归档日志还原到默认目标
通道 ch01: 正在还原归档日志
归档日志线程=1 序列=25090
通道 ch01: 正在读取备份片段 arch_dybb_u97r99ue8_s3367_p1_t915732936
通道 ch01: 段句柄 = arch_dybb_u97r99ue8_s3367_p1_t915732936 标记 = TAG20160628T181535
通道 ch01: 已还原备份片段 1
通道 ch01: 还原完成, 用时: 00:00:25
归档日志文件名=C:\APP\ADMINISTRATOR\PRODUCT\11.2.0\DBHOME_1\RDBMS\ARC0000025090_0818501732.0001 线程=1 序列=25090
介质恢复完成, 用时: 00:00:00
完成 recover 于 20-7月 -16
释放的通道: ch01
6.打开数据库
RMAN> alter database open resetlogs; RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: alter db 命令 (在 07/20/2016 11:08:53 上) 失败
ORA-00344: 无法重新创建联机日志 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO01A.LOG' ORA-27040: 文件创建错误, 无法创建文件
OSD-04002: 无法打开文件
O/S-Error: (OS 21) 设备未就绪。
7.针对上一步出现的错误,重命名redo日志
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO01A.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO01A.LOG';
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO01B.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO01B.LOG';
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO02A.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO02A.LOG';
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO02B.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO02B.LOG';
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO03A.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO03A.LOG';
SQL> alter database rename file 'D:\APP\ADMINISTRATOR\ORADATA\ybb\REDO03B.LOG' to 'C:\APP\ADMINISTRATOR\ORADATA\ybb\REDO03B.LOG';
8.重新打开数据库
RMAN> alter database open resetlogs; 数据库已打开 RMAN>
使用NBU进行oracle异机恢复的更多相关文章
- rman恢复方案和oracle异机恢复
这篇文章主要介绍了rman恢复方案和oracle异机恢复,需要的朋友可以参考下 注:①恢复的前提是已经做好备份②完全恢复数据库是数据库遇到故障,在恢复时候没有丢失任何已经提交事物数据的恢复不完全恢复数 ...
- ORACLE 异机恢复
有时候需要将大的数据库发布到客户现场或转移机器时,不得不考虑在异机上恢复已经调整.测试好的库. dumpdp 全备的方法虽然易用,但在处理对象.索引.空间的时候异常的出错,比如:见有些公司,建表.索引 ...
- Oracle异机恢复
RMAN异机恢复注意事项:1.RMAN 异机恢复的时候,db_name必须相同. 如果说要想改成其他的实例名,可以在恢复成功后,用nid 命令修改. 实例名的信息会记录到控制文件里,所以如果在恢复的时 ...
- oracle异机恢复测试
(一)问题背景 最近在生产环境中,开发人员误操作,使用truncate将oracle数据库某个表的数据全部删除了,在删除之后,开发人员发现自己闯祸了,于是联系值班的DBA进行紧急数据恢复. 经过分析, ...
- oracle异机恢复参考官方文档
How to use Rman Duplicate on ASM/RAC/OMF/Single Instance (Doc ID 840647.1) How to perform Rman dupli ...
- oracle异机恢复 open resetlogs 报:ORA-00392
参考文档:ALTER DATABASE OPEN RESETLOGS fails with ORA-00392 (Doc ID 1352133.1) 打开一个克隆数据库报以下错误: SQL> a ...
- NBU Rman异机恢复Oracle
前段时间一个亿级分区表,被分割成历史表和业务表,历史表中保留15天以外的数据,每天都会从业务表中的15天外的数据copy到历史表,并删除业务表15天外的数据,逻辑也很简单,但插入历史表的where 条 ...
- 使用不同用户对Oracle数据库进行异机恢复,失败,错误:Backup file not found in NetBackup catalog
最近做某数据库恢复演练,数据库版本是10.2.0.4,恢复控制文件一直报错,报错如下,经过反复折腾,原来恢复机上oracle用户不是oracle导致(我的是oraclev4),查看源库oracle用户 ...
- Hyper-V安装Oracle Linux6_4 Oracle db 12c并使用rman做异机恢复
本文记录在Windows Server 2012 R2上安装Oracle Enterprise Linux 6.4以及使用RMAN进行进行异机恢复的过程. Windows服务器增加Hyper-V功能 ...
随机推荐
- PHP 多个文件上传
关键函数: is_uploaded_file():用于判断指定的文件是否是通过 HTTP POST 上传的,如果是则返回 TRUE.用于防止潜在的攻击者对原本不能通过脚本交互的文件进行非法管理,这可以 ...
- Grand Theft Auto V 图形研究(2)
原文链接 http://www.adriancourreges.com/blog/2015/11/02/gta-v-graphics-study-part-2/ Level of Detail 如 ...
- 【翻译】CEDEC2015 速成Albedo Chart 制作
关于pbr材质和贴图的制作,最近llegorithmic提供了几篇不错的guide https://www.allegorithmic.com/pbr-guide 不过像如何从通过现实场 ...
- 20145235 《Java程序设计》第5周学习总结
教材学习内容总结 8.1语法与继承架构 try和catch语法,如果被try{}的语句出现了catch()的问题就执行catch{}的语句. 错误的对象都继承于java.long.Throwable, ...
- thanksgiving day (eat)
1.try a nibble of your food 2.dig in (开动) 3.ingest in (吞咽) 4.devoured(狼吞虎咽) 5.wolf down your food 6 ...
- ubuntu中一些配置文件含义
/var/log/apache2/mod_jk.log apache2 mod_jk错误日志错误 /conf/server.xml ...
- 【转】一篇很全面的freemarker教程---有空慢慢实践
FreeMarker的模板文件并不比HTML页面复杂多少,FreeMarker模板文件主要由如下4个部分组成: 1,文本:直接输出的部分 2,注释:<#-- ... -->格式部分,不会输 ...
- nrf51822裸机教程-PPI
Programmable Peripheral Interconnect即可编程外设互联 系统,该模块是51822 提供的一个特性. 目的是为了让51822 的外围模块可以不通过处理器而自动相互作用. ...
- HBase学习笔记-高级(一)
HBase1. hbase.id记录了集群的唯一标识:hbase.version记录了文件格式的版本号2. split和.corrupt目录在日志分裂过程中使用,以便保存一些中间结果和损坏的日志在表目 ...
- websocket nodejs
Web领域的实时推送技术,也被称作Realtime技术.这种技术要达到的目的是让用户不需要刷新浏览器就可以获得实时更新.它有着广泛的应用场景,比如在线聊天室.在线客服系统.评论系统.WebIM等. W ...