Webalizer解析nginx基本配置
先前使用了nginx做tomcat程序负载,后来需要解析日志。查看访问量。后来网上查了下,就使用了这个
参考地址: http://daliang1215.iteye.com/blog/618829
.安装webalizer所需的软件包
yum -y install gd-devel.i* .下载Webalizer的源码包 tar -xvjf webalizer-2.21--src.tar.bz2
cd webalizer-2.21-
./configure --with-language=simplfied_chinese ##在lang的目录下面有个webalizer.simplfied_chinesemake文件特别说明这个文件的格式是gb2312的,最好想办法转换成utf-8的,(这里使用Linux命令 file 查看编码,iconv -f GBK -t UTF-8 file1 -o file2) ##如果要指定安装目录 需要在 ./configure 后面加 --prefix=目录 make && make install .复制Webalizer配置文件模板并建立Webalizer统计结果输入目录 cp /usr/local/etc/webalizer.conf.sample /usr/local/etc/webalizer.conf mkdir /var/log/webalizer 4.在/usr/local/etc/webalizer.conf 文件中修改如下参数
##nginx access.log 目录
LogFile /usr/local/nginx/logs/access.log
##web访问目录,日志生成目录
OutputDir /usr/local/nginx/html Incremental yes IncrementalName /var/lib/webalizer/webalizer.current .运行webalizer ##先建立一个软连接
ln -s /usr/local/etc/webalizer.conf /etc/webalizer.conf ##运行
webalizer -c /etc/webalizer.conf ##定时生成日志
crontab -e * * * /usr/local/bin/webalizer -c /etc/webalizer.conf
##意思每天生成日志文件 ## 开启定时任务
service crond start
## 停止
service crond stop ##查看定时任务
crontab -l ##其它问题
configure: error: png library not found.. please install libpng
解决
yum install libpng libpng-devel configure: error: gd library not found.. please install libgd
解决
yum -y install gd gd-devel 如果没有交叉编译器的话需要
yum install gcc-c++ libstdc++-devel
Webalizer解析nginx基本配置的更多相关文章
- nginx解析漏洞,配置不当,目录遍历漏洞环境搭建、漏洞复现
nginx解析漏洞,配置不当,目录遍历漏洞复现 1.Ubuntu14.04安装nginx-php5-fpm 安装了nginx,需要安装以下依赖 sudo apt-get install libpcre ...
- Nginx防盗链、访问控制、解析PHP相关配置及Nginx代理
6月11日任务 12.13 Nginx防盗链12.14 Nginx访问控制12.15 Nginx解析php相关配置12.16 Nginx代理 扩展502问题汇总 http://ask.apelearn ...
- Linux centos VMware Nginx防盗链、Nginx访问控制、Nginx解析php相关配置、Nginx代理
一.Nginx防盗链 配置如下,可以和上面的配置结合起来 location ~* ^.+\.(gif|jpg|png|swf|flv|rar|zip|doc|pdf|gz|bz2|jpeg|bmp|x ...
- nginx.conf 配置解析之文件结构
nginx.conf配置文件结构如下: ...... #主要定义nginx的全局配置 events{ #events(事件)块:主要配置网络连接相关 } http{ #http块:代理缓存和日志定义绝 ...
- 如何在Nginx下配置PHP程序环境
1.nginx与PHP的关系 首先来看nginx与php的关系, FastCGI的关系(而不是像apache那样安装成nginx的模块) FastCGI的意思是, 快速的通用网关接口:CGI Comm ...
- 理解nginx的配置
Nginx配置文件主要分成四部分:main(全局设置).server(主机设置).upstream(上游服务器设置,主要为反向代理.负载均衡相关配置)和 location(URL匹配特定位置后的设置) ...
- 【转】linux 编译安装nginx,配置自启动脚本
linux 编译安装nginx,配置自启动脚本 本文章来给各位同学介绍一篇关于linux 编译安装nginx,配置自启动脚本教程,希望有需要了解的朋友可一起来学习学习哦. 在公司的suse服务器装ng ...
- 《深入理解Nginx》阅读与实践(一):Nginx安装配置与HelloWorld
最近在读陶辉的<深入理解Nginx:模块开发与架构解析>,一是想跟着大牛练练阅读和编写开源代码的能力,二是想学学Nginx优秀的架构设计,三是想找一个点深入下Linux下网络编程的细节.侯 ...
- Nginx安全配置研究
x00 测试环境 ? 1 2 3 操作系统:CentOS6.5 Web服务器:Nginx1.4.6 Php版本:Php5.4.26 0x01 Nginx介绍 nginx本身不能处理PHP,它只是个we ...
随机推荐
- C# 自定义序列化问题
public class overdue { public int overdueTimes { get; set; } /// <summary ...
- teamviewer现在无法捕捉屏幕,这可能是由于快速的用户切换或远程桌面会话已经断开
解决方法: 不用远程连接过去开启teamview,直接在在电脑本机上手动开启teamview就可以了 即:如果是mstsc远程过去开启,则会有这个错误提示,需要让服务器连接显示器,手动去登录 ...
- 第五百八十三天 how can I 坚持
今天去看了个电影,日本动漫,第一次在电影院看日本动漫,<你的名字>,挺经典的.存在爱情吗?什么是爱情,哎.什么是人. 好像有点感冒了呢,说过自己很久没感冒后,往往就会感冒,这到底是怎么回事 ...
- Linux下的段错误(Segmentation fault)
Linux开发中常见段错误问题原因分析 1 使用非法的内存地址(指针),包括使用未经初始化及已经释放的指针.不存在的地址.受系统保护的地址,只读的地址等,这一类也是最常见和最好解决的段错误问题,使用G ...
- 15 个有用的 MySQL/MariaDB 性能调整和优化技巧(转载的一篇好文)
MySQL 是一个强大的开源关系数据库管理系统(简称 RDBMS).它发布于 1995 年(20年前).它采用结构化查询语言(SQL),这可能是数据库内容管理中最流行的选择.最新的 MySQL 版本是 ...
- React学习之一:React初探
一,React简介 React是由Facebook和Instagram开发的一套创建用户界面的JavaScript库.许多人认为React是MVC中的V. React创建的目的是为了:构建数据随时会改 ...
- archlinux pacman 常用选项
pacman -S package_name #安装软件包pacman -R package_name #删除软件包 pacman -Rs package_name #顺便删除软件包相关依赖pacma ...
- js中object类型模拟java中的map
- .net批量插入SqlServer数据库的方法:
using System;using System.Collections.Generic;using System.Configuration;using System.Data;using Sys ...
- ZT 趋势移动安全apk
趋势移动安全 应用截图 应用简介 趋势移动安全( Mobile Security) 是一款专业的Android移动安全软件.利用趋势科技世界领先的云安全技术,保护用户避免被移动恶意程序骚扰,避免个 ...