Not Found类的错误主要是由于网络服务访问出错。所以需要分析是由哪个网络服务访问失败而导致的。

DataAccessSilverlight.PowerDataServiceReference.GetUserByLoginResponse _result = ((DataAccessSilverlight.PowerDataServiceReference.GetUserByLoginResponse)(base.EndInvoke("GetUserByLogin", _args, result)));

  CommunicationException was unhandled by user code

远程服务器返回了错误: NotFound。

Troubleshooting tips:

Get help for this exception

Inner exception: Check the status property of the exception to determine why the request failed

Inner exception: Check the response property of the exception to determine why the request failed

get the general help the inner exception

http://192.168.1.102/RenhuaPower/PowerDataAccessService.asmx粘贴到网址栏,发现

那就说明是服务没有发布成功。但是我之前服务是对的,也没有用。原因尚不明朗,但是,如果把服务删除,再发布,或许会有用。

         频繁更新数据也可能导致not found问题

更新数据是异步的。因为在项目中,一个重点项目对应多个polygon,假设为N,当对一个项目的属性进行更新时,必然会使得该项目的所有polygon都更新一遍,那么如果一个项目的polygon过大,比如N为几十(个),那么就会使得同一个时间更新得过于频繁,从而会出现部分更新操作not found,比如序号为“2-4” 、“10-19” 、“21-22”这几个polygon更新了,而一些则没有更新,就会导致项目不一样。如下图

要解决这个问题,可以考虑将多个polygon合并为一个MultiPolygon

另外,也有可能是服务的地址改变了,而我没有及时更新,也会出现Not Found 的情况。

有一次,是由于<Path>http://localhost:3048/clientbin/cls.xml</Path>配置错误而导致服务请求失败,整个分类查找的配置如下:

 <!--分类查找-->
<Task ID="dg_qtask" SourceType="NewMap" ServiceType="ClassTask">
<Url>http://192.168.1.22:9010/sd_gz_dmdz/wfs?TypeName=GEOSTAR.DMDZ</Url>
<!--要素服务地址-->
<Path>http://localhost:3048/clientbin/cls.xml</Path>
<!--分类配置文件的路径-->
<PageSize></PageSize>
<!--分页大小-->
<Field>Name</Field>
<!--分类查询的字段,可多个字段以逗号分隔-->
</Task>

总结一下,此类错误多是因为网络地址配置错误或者网络服务的配置文件有误,有时候也有可能是调用的服务过程中出错了,比如调用空值等非法操作,导致某些文件无法找到或者网络无法找到,所以提示为“NOT FOUND”。

system.net.webexception远程服务器返回了错误: NotFound。的更多相关文章

  1. Silverlight提示“Load 操作失败。远程服务器返回了错误: NotFound”

    调试时出现“Load 操作失败.远程服务器返回了错误: NotFound”: 一定要注意此错误之前的错误是什么?基本就是用户Cookie的问题,用户没有登录. 有时需要设置成Any CPU 有时重新编 ...

  2. Exchange 2016 创建日程,远程服务器返回错误: (401) 未经授权

    背景:在测试环境中一切正常,使用的是Exchange2013,上生产环境Exchange2016,部署后产生如下错误: Microsoft.Exchange.WebServices.Data.Serv ...

  3. post数据时报错:远程服务器返回错误: (400) 错误的请求。

    网上查了多种方法,有不少说法,报400说是传的数据格式不对,最后的结论确实是数据格式不对. Content_Type为:application/json,配的数据格式有些麻烦,特别数多层,单层还好.例 ...

  4. SharePoint 2013 Workflow Manager 1.0 远程服务器返回错误: (400) 错误的请求。 不支持查询字符串中的 api-version

    环境: Windows Server 2012 R2 Standard SharePoint Server 2013 with sp1 通过Web 平台安装程序 5.0,已安装 Workflow Ma ...

  5. (C#)调用Webservice,提示远程服务器返回错误(500)内部服务器错误

    因为工作需要调用WebService接口,查了下资料,发现添加服务引用可以直接调用websevice 参考地址:https://www.cnblogs.com/peterpc/p/4628441.ht ...

  6. 十五、API请求接口-远程服务器返回错误: (400) 错误的请求错误

    一.远程服务器返回错误: (400) 错误的请求错误 捕获异常查看具体错误 using Newtonsoft.Json; using System; using System.Collections. ...

  7. HttpWebResponse远程服务器返回错误: (500) 内部服务器错误。

    现象 我们编码实现请求一个页面时,请求的代码类似如下代码: HttpWebRequest req = (HttpWebRequest)WebRequest.Create(strUrl); req.Us ...

  8. C#FTP下载文件出现远程服务器返回错误: (500) 语法错误,无法识别命令

    如果下载多个文件的时候,有时候莫名其妙的出现500服务器错误,很有可能是没有设置KeepAlive 属性导致的. 出现应用程序未处理的异常:2015/1/6 11:40:56 异常类型:WebExce ...

  9. HttpWebResponse远程服务器返回错误: (500) 内部服务器错误

    现象 我们编码实现请求一个页面时,请求的代码类似如下代码: HttpWebRequest req = (HttpWebRequest)WebRequest.Create(strUrl);req.Use ...

随机推荐

  1. Shell 字符截取命令 awk

    awk命令# awk '条件1{动作1} 条件2{动作2}….' 文件名一般使用关系表达式作为条件动作:1.格式化输出 2.流程控制语句 处理cut命令无法截取空格的列 例子:截取出磁盘使用率 df ...

  2. python3 字符串str

    字符串使用单引号或双引号表示: 是不可变的,当一个字符串被创建后,它始终不会被改变: 可以被迭代,也可以被切片: +拼接字符串,*重复输出字符串: 格式符%s,%d,%f u'字符串:Unicode格 ...

  3. Luogu P5290 / LOJ3052 【[十二省联考2019]春节十二响】

    联考Day2T2...多亏有这题...让我水了85精准翻盘进了A队... 题目大意: 挺简单的就不说了吧...(这怎么简述啊) 题目思路: 看到题的时候想了半天,不知道怎么搞.把样例画到演草纸上之后又 ...

  4. Asp.Net Output.Write()

    string name="张三" <div> <label>@Output.Write(name)</label> </div> 在 ...

  5. Swarm stack

    什么是 stack ?例如:首先创建 secret. 然后创建 MySQL service,这是 WordPress 依赖的服务. 最后创建 WordPress service. 也就是说,这个应用包 ...

  6. CF1106E Lunar New Year and Red Envelopes

    比赛时看到这题懵逼了,比完赛仔细一想是个很简单的dp = = 由于题目限制,可以发现\(B\)取红包的策略是唯一的,可以用优先队列预处理出\(B\)在第\(i\)秒可以拿到的红包的收益\(w_i\)和 ...

  7. LVS搭建负载均衡(一)NAT模型

    应用场景:LVS配置负载均衡方式之一:nat 测试环境: 测试步骤: 1. 在主机lvs上安装ipvsadm lvs~]# yum install ipvsadm -y lvs~]# ipvsadm ...

  8. MyBatis深入浅出--入门

    mybatis概述 mybatis简介 MyBatis 是支持定制化 SQL.存储过程以及高级映射的优秀的持久层框架. MyBatis 避免了几乎所有的 JDBC 代码和手动设置参数以及获取结果集. ...

  9. sshd启动报错Could not load host key

    ~ # /usr/sbin/sshd Could not load host key: /etc/ssh/ssh_host_rsa_key Could not load host key: /etc/ ...

  10. 利用nginx进行集群部署

    现在一般的服务器都是集群的情况了,所以准备搞集群部署下. nginx用的是第三方的openrestynginx.首先安装nginx,我的系统是UBuntu,安装方法也很简单,见官网. 自己采用了默认安 ...