CentOS 6.5下RPM方式(重新)安装MySQL 5.7.21从头到尾篇
- 强烈推荐参阅这一篇教程 https://www.cnblogs.com/kevingrace/p/8340690.html
- 下面我写的仅供参考
- 今天把Mysql5.1升级到了5.7,浪费了一天为了避免以后重复麻烦,总结一下(红色字体为正常执行顺序):
- 查看该操作系统上是否已经安装了mysql数据库
rpm -qa | grep mysql- 通过 rpm -e 命令 或者 rpm -e –nodeps 命令卸载
rpm -e mysql...// 普通删除模式
rpm -e --nodeps mysql...// 强力删除模式(包括依赖包)
此处mysql…代指第一步查询列表- 如果没有安装,只是有包,则remove
yum -y remove mysql-libs
查看卸载是否成功
rpm -qa | grep mysql- 使用rpm软件包安装mysql
安装依赖包
下载地址为:https://dev.mysql.com/downloads/mysql/5.7.html#downloads
rpm -ivh mysql-community-common-5.7.9-1.el6.x86_64.rpm
rpm -ivh mysql-community-libs-5.7.9-1.el6.x86_64.rpm
安装客户端
rpm -ivh mysql-community-client-5.7.9-1.el6.x86_64.rpm
安装服务端
rpm -ivh mysql-community-server-5.7.9-1.el6.x86_64.rpm- 根据/etc/my.cnf创建相应的文件,并授权
mkdir -p /var/run/mysql
mkdir -p /var/log/mysql
chown -R mysql:mysql /var/log/mysql
chown -R mysql:mysql /var/run/mysql
注:/etc/my.cnf中没有basedir路径,需要添加
basedir=/usr/local/mysql- 初始化数据库
cd /usr/bin
会为root账户生成一个随机的初始密码( 密码位置:/var/log/mysqld.log )
注:使用命令:mysql -u root -p,然后输入密码来登录MySQL
mysqld --initialize --user=mysql
不会为root账户生成一个随机的初始密码
注:使用命令:mysql -u root –skip-password直接登录MySQL
mysqld --initialize-insecure --user=mysql
注:初始化时,mysqld服务会检查数据目录是否存在:
如果数据目录不存在,mysqld则会创建它。
如果数据目录存在,且不是空目录(即包含有文件或子目录),mysqld会显示一条错误信息并中止:
[ERROR] –initialize specified but the data
directory exists. Aborting.
解决方案: 将数据目录重命名后,重新再初始化一次 mv /var/lib/mysql /var/lib/mysql.bak8.- 配置mysql服务开机自动启动
检查自启动项列表中没有mysqld这个,如果没有就添加mysqld:
chkconfig --list mysqld
chkconfig --add mysqld
设置开机启动
chkconfig mysqld on- 启动mysql
启动mysqld服务
service mysqld start
检查mysqld是否已经启动
service mysqld status- 修改mysql用户密码(初始root密码文件在/var/log/mysqld.log)
mysql -uroot-p
mysql>alter user 'root'@'localhost' identified by '123456';- 已root用户身份登录
mysql -uroot -p123456
- 1.请看下面的重点:一般你rpm方式安装成功是没有问题的,问题是安装成功后启动不起来的事。
- 2.你要想执行mysql -uroot -p命令首先你得启动你安装的mysql服务,当你执行启动命令:service mysqld start出现报错信息:
MySQL Daemon failed to start.
Starting mysqld: [FAILED]
- 解决方法:执行下列命令然后再执行service mysqld start启动mysql
rm -fr /var/lib/mysql/*
m /var/lock/subsys/mysqld
killall mysqld
- 3.mysql服务启动后,执行mysql -uroot -p进入修改原始密码:
注:若登录失败就使用命令mysql -u root --skip-password直接登录MySQL,执行下列语句修改密码:MySQL -u root
mysql>SET PASSWORD FOR 'root'@'localhost' = PASSWORD('123456');
该语句若失败, 用UPDATE直接编辑user表
mysql -u root
mysql>use mysql;
mysql>UPDATE user SET Password = PASSWORD('123456') WHERE user = 'root';
mysql>FLUSH PRIVILEGES;
- 若是执行上述修改密码报错
ERROR 1290 (HY000): The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement
这时候我们只要
mysql> flush privileges;
Query OK, 0 rows affected (0.01 sec)
再执行修改密码即可
4 远程连接mysql root账号报错:2003-can’t connect to MYSQL serve
解决方法:授权法
1.登录数据库:mysql -uroot -p(密码|123456)
2.执行:
mysql>GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY '密码' WITH GRANT OPTION;
3.执行flush privileges;命令立即生效改表法:
mysql>use mysql;
mysql>update user set host = ‘%’ where user = ‘root’;
收藏博客|方便查找
CentOS 6.5下RPM方式(重新)安装MySQL 5.7.21从头到尾篇的更多相关文章
- CentOS 6.6 下源码编译安装MySQL 5.7.5
版权声明:转自:http://www.linuxidc.com/Linux/2015-08/121667.htm 说明:CentOS 6.6 下源码编译安装MySQL 5.7.5 1. 安装相关工具# ...
- Centos以rpm方式进行安装MySql
安装过很多次mysql了,却没好好总结过,每次安装完了都忘,下次还要重新Google,这次总结下,自己以后也有的查. 1.安装采用的的rpm包的方式,安装前要先看系统内是否安装了旧版本的MySql和m ...
- CentOS 6 下RPM方式安装MySQL5.6
CentOS 6 下RPM方式安装MySQL5.6 1. 下载Linux对应的RPM包,如:CentOS6.7_64对应的RPM包,如下:[root@mysql ~]# ll总用量 113808-rw ...
- CentOS 6.3下rsync服务器的安装与配置[转]
CentOS 6.3下rsync服务器的安装与配置 一.rsync 简介 Rsync(remote synchronize)是一个远程数据同步工具,可通过LAN/WAN快速同步多台主机间的文件,也 ...
- CentOS 6.4下Squid代理服务器的安装与配置,反向代理
CentOS 6.4下Squid代理服务器的安装与配置 一.简介 代理服务器英文全称是Proxy Server,其功能就是代理网络用户去取得网络信息. Squid是一个缓存Internet 数据的软件 ...
- 【转载】CentOS 6.4下PXE+Kickstart无人值守安装操作系统
[转载]CentOS 6.4下PXE+Kickstart无人值守安装操作系统 转自:CentOS 6.4下PXE+Kickstart无人值守安装操作系统 - David_Tang - 博客园 http ...
- CentOS 6.5下PXE+Kickstart无人值守安装操作系统centos7.3
CentOS 6.5下PXE+Kickstart无人值守安装操作系统centos7.3 一.简介 1.1 什么是PXE PXE(Pre-boot Execution Environment,预启动执行 ...
- CentOS 6.5 下Nginx服务的安装与配置
参考网站: http://www.cnblogs.com/zhuhongbao/archive/2013/06/04/3118061.html http://www.cnblogs.com/jilia ...
- CentOS 6.3下Samba服务器的安装与配置方法(图文详解)
这篇文章主要介绍了CentOS 6.3下Samba服务器的安装与配置方法(图文详解),需要的朋友可以参考下 一.简介 Samba是一个能让Linux系统应用Microsoft网络通讯协议的软件, ...
随机推荐
- Java synchronized解析
多线程三大特性: 可见性.原子性.有序性 synchronize的特性: 1.同一时刻只有一个线程访问临界资源 2.其它未获取到锁执行权的线程必须排队等待 3.保证共享资源的原子性.可见性和有序性 4 ...
- Linux 进程后台运行的几种方式 screen
转载请标明出处:http://blog.csdn.net/zhaoyanjun6/article/details/80580779 本文出自[赵彦军的博客] screen是Linux窗口管理器,用户可 ...
- (其他)用sublime text3编写的html网页用浏览器打开出现中文乱码的原理及解决方法(转)
最近发现Hbuler比较难用,换成sublime text3了,用了以前没用过的软件,就要学习他的操作,刚上手就出了点问题. 解决方法就是sublime text3以utf8 with bom保存. ...
- mysql之系统默认数据库
相关内容: 系统默认数据库information_schema,performance_schema,mysql,test 的意义 首发时间:2018-02-23 17:10 安装mysql完成后, ...
- JS的判断字符/元素是否存在数组列表
python有in操作, 可以很方便的用于判断元素是否存在指定列表. JS的in操作是对象, 用于判断指定的属性在指定对象中是否存在. propNameOrNumber in objectName i ...
- HDFS快速入门
一.简介 HDFS[Hadoop Distributed File System]是Hadoop组件中的分布式存储系统,提供高可靠性.高扩展性和高吞吐率的数据存储服务. 二.存储模型 1.文件线性切割 ...
- LINQ的求和 平均 最大 最小 分组 计数 等等
1.简单形式: var q = from p in db.Products group p by p.CategoryID into g select g; 语句描述:使用Group By按Categ ...
- shell read变量的读入
shell变量的输入: shell变量除了可以直接赋值或脚本传参外,还可以使用read命令从标准输入获取,read为bash内置命令,可以通过help read查看帮助. 语法格式: read [参数 ...
- C语言 汉诺塔问题
//凯鲁嘎吉 - 博客园 http://www.cnblogs.com/kailugaji/ 汉诺塔是由三根杆子A,B,C组成的.A杆上有n个(n>1)穿孔圆盘,盘的尺寸由下到上依次变小.要求按 ...
- java操作elasticsearch实现查询删除和查询所有
后期博客本人都只给出代码,具体的说明在代码中也有注释. 1.查询删除 //查询删除:将查询到的数据进行删除 @Test public void test8() throws UnknownHostEx ...