Oracle rac 监听状态异常远程连接问题解决(TNS-12541 TNS-12560 TNS-00511 Linux Error:111 ORA-12502)
问题1现象
数据导出脚本执行失败,报错如下
ORA-12537

到服务器上查看,报错:
[oracle@test ~]$ lsnrctl status LSNRCTL for Linux: Version 11.2.0.4. - Production on -APR- :: Copyright (c) , , Oracle. All rights reserved. Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=))
TNS-: TNS:no listener
TNS-: TNS:protocol adapter error
TNS-: No listener
Linux Error: : Connection refused
[oracle@test ~]$ lsnrctl start LSNRCTL for Linux: Version 11.2.0.4. - Production on -APR- :: Copyright (c) , , Oracle. All rights reserved. Starting /app/oracle/product/11.2./db_1/bin/tnslsnr: please wait... TNSLSNR for Linux: Version 11.2.0.4. - Production
Log messages written to /app/oracle/diag/tnslsnr/ggfwdb1/listener/alert/log.xml
Error listening on: (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=))
TNS-: TNS:address already in use
TNS-: TNS:protocol adapter error
TNS-: Address already in use
Linux Error: : Address already in use Listener failed to start. See the error message(s) above...
解决:
思路,报错提示地址已经使用,百度查找结果,大多都是hosts文件配置问题,但我的hosts文件正常的
最后真实原因是有其它监听已启用,kill掉重新注册监听
1)ps查看已有的监听并清除
$ ps -ef|grep LISTENER
oracle : pts/ :: grep LISTENER
grid ? :: /grid/11.2./grid_1/bin/tnslsnr LISTENER_SCAN2 -inherit
grid ? :: /grid/11.2./grid_1/bin/tnslsnr LISTENER_SCAN3 -inherit
daemon : ? :: /grid/11.2./grid_1/bin/tnslsnr LISTENER -inherit $ kill -
2)动态注册恢复监听状态
$ sqlplus / as sysdba SQL*Plus: Release 11.2.0.4. Production on Tue Apr :: Copyright (c) , , Oracle. All rights reserved. Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.4. - 64bit Production
With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,
Data Mining and Real Application Testing options SQL> alter system set local_listener=''; System altered. SQL> alter system register; System altered. SQL> exit
查看:
[oracle@ggfwdb1 ~]$ lsnrctl status LSNRCTL for Linux: Version 11.2.0.4. - Production on -APR- :: Copyright (c) , , Oracle. All rights reserved. Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for Linux: Version 11.2.0.4. - Production
Start Date -APR- ::
Uptime days hr. min. sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Log File /app/oracle/diag/tnslsnr/ggfwdb1/listener/alert/log.xml
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=ggfwdb1)(PORT=)))
Services Summary...
Service "+ASM" has instance(s).
Instance "+ASM1", status READY, has handler(s) for this service...
Service "xxxx" has instance(s).
Instance "xxxx", status READY, has handler(s) for this service...
Instance "xxxx", status READY, has handler(s) for this service...
Service "xxxx" has instance(s).
Instance "xxxx", status READY, has handler(s) for this service...
Instance "xxxx", status READY, has handler(s) for this service...
The command completed successfully
问题二现象:
本以为可以连接了,然后执行远程登录测试,出现报错ORA-12502
C:\Users\Administrator>sqlplus user/passwd@hostname.:/sid SQL*Plus: Release 11.2.0.1. Production on 星期二 4月 :: Copyright (c) , , Oracle. All rights reserved. ERROR:
ORA-: TNS: 监听程序没有从客户机收到 CONNECT_DATA
解决:
设置所有节点的LOCAL_LISTENER参数,即可解决。host为vip
SQL> show parameter local_listener; NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
local_listener string
SQL> alter system set local_listener='(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.10.173)(PORT=1521))'; System altered. SQL> show parameter local_listener; NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
local_listener string (ADDRESS=(PROTOCOL=tcp)(HOST=
92.168.10.173)(PORT=))
成功远程登录,问题解决

Oracle rac 监听状态异常远程连接问题解决(TNS-12541 TNS-12560 TNS-00511 Linux Error:111 ORA-12502)的更多相关文章
- ORACLE RAC 监听配置 (listener.ora tnsnames.ora)
Oracle RAC 监听器的配置与单实例稍有不同,但原理和实现方法基本上是相同的.在Oracle中 tns进程用于为指定网络地址上的一个或多个Oracle 实例提供服务注册,并响应来自客户端对该服务 ...
- 转载:oracle11G 已开启监听,但远程连接依旧无监听解决过程
1.连接数据库显示无监听程序,首先查看服务器的oracle监听服务是否开启,服务名称:OracleOraDb11g_home1TNSListener(具体环境中可能不完全一样,但是认准TNSListe ...
- oracle查看监听状态
产看状态命令:lsnrctl status 启动监听:lsnrctl start 关闭监听:lsnrctl stop LSNRCTL for 32-bit Windows: Version 10.2. ...
- oracle11G 已开启监听,但远程连接依旧无监听解决过程
1.连接数据库显示无监听程序,首先查看服务器的oracle监听服务是否开启,服务名称:OracleOraDb11g_home1TNSListener(具体环境中可能不完全一样,但是认准TNSListe ...
- oracle 11g rac修改监听端口(远程监听和本地监听)
转至:https://www.cnblogs.com/yj411511/p/12459533.html 目录 1.修改远程监听端口 1.1 查看远程监听状态 1.2 修改SCAN listener端口 ...
- Oracle 数据库监听无法连接上、监听HANG住、监听无响应、TNS-12560
环境: Windows server 2003 Oracle 11.2.0.1 问题: 一套老数据库在运行了很久后,突然就连接不上了,提示监听异常. 处理: 1.CMD命令行检查监听状态:无监听 2. ...
- Oracle 数据库监听配置和服务
-- 补充说明 如果要远程连接192.168.10.44上的oracle,那么192.168.10.44服务器必须启动TNSListener.(配置文件 listener.ora) PLSQL Dev ...
- RAC监听与tns
监听: 个人理解:本来想通过scan ip来配置tns总数报12545,后来通过vip来配置tns 11g rac的监听在安装时创建,由grid用户管理监听,listener.ora文件在$ORACL ...
- Oracle 数据库监听配置
一.监听器(LISTENER) 监听器是Oracle基于服务器端的一种网络服务,主要用于监听客户端向数据库服务器端提出的连接请求.既然是基于服务器端的服务,那么它也只存在于数据库服务器端,进行监听器的 ...
随机推荐
- day28:hashlib
1,继续上一小节,讲解双下内置方法,双下getitem,setitem,delitem方法,是对象可以像字典一样的来访问属性 # 普通的字典是像下面这样操作的 dic = {'k' : 'v'} di ...
- ide phpStorm管理远程主机
- VScode 中 vue文件template中不能使用tab补齐标签
选择 文件-->首选项-->设置-->搜索 emmet,选择 编辑 setting.json, 添加下列代码: "emmet.includeLanguages" ...
- 测试覆盖率工具EclEmma安装与使用
此文来自于:https://www.cnblogs.com/cnsdhzzl/p/7638883.html EclEmma的简介 一个优秀的开源软件测试工具 eclipse的一个插件 能够对由 Jav ...
- JVM深入:JDK8-废弃永久代(PermGen)迎来元空间(Metaspace)(转)
转载自:https://www.cnblogs.com/yulei126/p/6777323.html 1.背景 2.为什么废弃永久代(PermGen) 3.深入理解元空间(Metaspace) 4. ...
- webapi发布到windows 2012的iis8里 出错
HTTP 错误 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容. 选一个.net版本一致的应用程序池 即可
- mybatisplus ssm配置要点
本以为不难,但也捣鼓了大半天,记录要点如下: 在pom中引入mybatis plus相关包 <!-- mybatis-plus框架包 start --> <dependency> ...
- java生成二维码的几个方法
1: 使用SwetakeQRCode在Java项目中生成二维码 http://swetake.com/qr/ 下载地址 或着http://sourceforge.jp/projects/qrcode/ ...
- VUE2 项目 引入 leaflet.draw全过程
leaflet.draw的参考文档:http://leaflet.github.io/Leaflet.draw/docs/leaflet-draw-latest.html 这个网址不稳定,多刷新几 ...
- PyTorch常用代码段整理合集
PyTorch常用代码段整理合集 转自:知乎 作者:张皓 众所周知,程序猿在写代码时通常会在网上搜索大量资料,其中大部分是代码段.然而,这项工作常常令人心累身疲,耗费大量时间.所以,今天小编转载了知乎 ...