无故出现 mysql dead but subsys locked的有关问题
无故出现 mysql dead but subsys locked的问题
问题描述:
1.mysql安装完成后,使用
service mysqld restart
总是出现stop mysqld service 失败。
2.使用mysql -uroot -p登录出现找不到 /var/lib/mysql/mysql.sock问题。
3.使用service mysqld status出现 mysql dead but subsys locked
解决方法:
大多数mysql都是rpm方式安装的。它会自动寻找/var/lib/mysql/mysql.sock这个文件。
1.首先检查mysql.sock的位置。
通过/etc/my.cnf中的socket的字段。
如果没有/etc/my.cnf这个文件也会提示 Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)。方法是把查找服务器my.cnf的路径,复制到/etc/目录下即可。
如果socket如下所示:
socket=/tmp/mysql.sock
如果无法找到mysql.sock文件或丢失
可以执行
#mysqld_safe
#mysql
2.为mysql.sock增加软连接(相当于windows中的快捷方式)。比如实际的mysql.sock在/tmp/下。
则运行如下命令。
ln -s /tmp/mysql.sock /var/lib/mysql/mysql.sock
3.如果上述两种方法都不生效。那么使用
3.1 service mysqld restart
3.2 service mysqld status
如果出现 mysql dead but subsys locked
4.方法 1
4.1 service mysqld stop (停止服务)
4.2 rm -fr /var/lib/mysql/* (删除/var/lib/mysql下的所有文件)
4.3 rm /var/lock/subsys/mysqld(删除锁定文件)
4.4 killall mysqld (杀死所有mysqld进程)
4.5 service mysql start (启动mysql服务。)
5.方法2
5.1 查看日志文件
cat /var/log/mysqld.log
5.2 停止服务
service mysqld stop
5.3 查看mysql进程
ps -aux|grep -i ^mysql
5.4 结束进程
killall mysql
5.5 删除/var/lib/mysql/*
rm -Rf /var/lib/mysql/*
5.6 查看mysql的全局配置文件
cat /et/my.cnf
5.7 拷贝预配置好的阳历服务器选项文件,/etc/mysql全局配置文件优先级大于服务器选项文件,但这里有更多的选项。
cp /usr/share/doc/mysql-server-?.??.??/my-small.cnf /var/lib/mysql
5.8 重新创建初始数据库
mysql_install_db
5.9 检查和设置服务的运行级别。
chkconfig –level 345 mysqld on
chkconfig –list mysqld
5.10 启动服务
service mysqld restart
5.11 查看日志文件
cat /var/log/mysqld.log
大家注意4或5使用1种即可。
无故出现 mysql dead but subsys locked的有关问题的更多相关文章
- mysql使用出现错误:mysqld dead but subsys locked
现象: 登陆时候出现如下信息 [root@localhost home]# mysql -uroot -p123456mysql: [Warning] Using a password on the ...
- SSH: sshd dead but subsys locked
问题: 查看SSH的状态时,提示错误如下: /etc/init.d/sshd status error: sshd dead but subsys locked 解决方法: sshd -d rm -r ...
- Linux MYSQL:dead but pid file exists
MYSQL dead but pid file exists问题 - CSDN博客https://blog.csdn.net/shilian_h/article/details/38020567 Er ...
- 处理MySQL数据库出现大量Locked的一个案例 (转)
本文转自:http://blog.itpub.net/7607759/viewspace-696781/ 做为一款轻量级数据库软件,MySQL在使用过程中遇到访问速度慢,或者无法响应这类的问题,解决方 ...
- 登录mysql出现/var/lib/mysql/mysql.sock不存在
问题描述: 1.mysql安装完成后,使用 service mysqld start 总是出现 start failed. 2.使用mysql -uroot -p登录出现找不到 /var/lib/my ...
- yum、RPM常用的命令(转)
# yum install xxx 安装xxx软件# yum info xxx 查看xxx软件的信息# yum remove xxx ...
- linux安装php环境,yum安装php环境
用yum来管理安装Apache PHP Mysql的基本安装.1. 安装Apahce, PHP, Mysql, 以及php连接mysql库组件.yum -y install httpd php mys ...
- Linux下修改Mysql的用户(root)的密码
修改的用户都以root为列.一.拥有原来的myql的root的密码: 方法一:在mysql系统外,使用mysqladmin# mysqladmin -u root -p password " ...
- MYSQL的卸载
卸载mysql 1.查找以前是否装有mysql 命令:rpm -qa|grep -i mysql 可以看到mysql的两个包: mysql-4.1.12-3.RHEL4.1 mysqlclient10 ...
随机推荐
- wraps补充
''' wraps: (了解) 是一个修复工具,修复的是被装饰对象的空间. from functools import wraps ''' from functools import wraps de ...
- [转帖]分布式锁-redLock And Redisson
分布式锁-redLock And Redisson 2019-03-01 16:51:48 淹不死的水 阅读数 372更多 分类专栏: 分布式锁 版权声明:本文为博主原创文章,遵循CC 4.0 B ...
- [转帖]Kubernetes v1.17 版本解读 | 云原生生态周报 Vol. 31
Kubernetes v1.17 版本解读 | 云原生生态周报 Vol. 31 https://www.kubernetes.org.cn/6252.html 2019-12-13 11:59 ali ...
- Effective.Java第34-44条(枚举)
34. 使用枚举类型替代整型常量 常量的语义表达不清晰,只能靠前面的名称来区分.枚举具有可读性.更安全.更强大等优势.而且枚举类型对象之间的值比较可以使用==来比较值是否相等的,不是必须使用equa ...
- C#RSA对接JAVA中RSA方式
C#中通过FromXmlString属性加载的是XML形式,而JAVA中用到的是解析后的PEM格式的字符串,总之读取证书中信息无非是转换方式问题 /// <summary> /// c# ...
- Java的常用API
Object类 1.toString方法在我们直接使用输出语句输出对象的时候,其实通过该对象调用了其toString()方法. 2.equals方法方法摘要:类默认继承了Object类,所以可以使用O ...
- APUE之第5章——标准I/O库
一.知识回顾:文件I/O 文件 I/O 是不带缓冲的 I/O(unbuffered I/O),指每个 read 和 write 都调用内核中的一个系统调用. 对于内核而言,所有打开的文件都通过文件描述 ...
- Kafka跨集群迁移方案MirrorMaker原理、使用以及性能调优实践
序言Kakfa MirrorMaker是Kafka 官方提供的跨数据中心的流数据同步方案.其实现原理,其实就是通过从Source Cluster消费消息然后将消息生产到Target Cluster,即 ...
- ABP 临时禁用TenantId IsDelete过滤
由于业务需求,需要查询host的配置,所以要放开权限给租户查询其他租户的数据 直接在业务方法内嵌套 List<string> list = new List<string>() ...
- drf--频率组件
目录 频率组件简介 自定义频率类 内置频率类及局部使用 全局使用 源码分析 SimpleRateThrottle源码分析 频率组件简介 主要是为了限制用户访问的次数,比如某一个接口(发送验证码)同一个 ...